Словарь терминов

 Top Next

А

Аналитические признаки (аналитика) – средство ведения аналитического учета. Аналитические признаки, используемые в программном комплексе "АиТ:\Управление персоналом", делятся на обязательные признаки, заданные программой, и дополнительные признаки, введенные пользователем. Аналитические признаки используются для группировки данных в сформированных отчетах.

Б

База данных – совокупность взаимосвязанных данных, размещаемая на сервере и используемая программными модулями.

В

Выпадающие списки – используются для заполнения полей ввода значениями, установленными программой.

Вид обучения – признак обучения, например, периодическое или стартовое для обязательного обучения. В программе используются стандартные виды обучения, определяемые программой автоматически, и пользовательские виды, задаваемые непосредственно самим пользователем.

Г

Главное меню – размещается в верхней строке основного окна под его заголовком и обеспечивает доступ к основным функциям и возможностям программы.

Д

Дополнительная панель инструментов – панель инструментов, набор кнопок которой зависит от вида открытого окна и операций, выполняемых в нем.

Дополнительные закладки – закладки, которые в персональной карточке отображаются вместо закладки "Дополнительно", они предназначены для показа дополнительных сведений, включенных по усмотрению пользователя, количество закладок неограниченно.

Дополнительные справочники – справочники, которые заполняются по мере необходимости, данные этих справочников используются как дополнительные аналитические признаки для группировки данных в сформированных отчетах

Дочернее окно – окно, размещающееся внутри основного окна.

Должностной ранг – аналитический признак должности для группировки в отчетах.

Должность в подразделении сочетания должности и подразделения, сведения берутся из персональной карточки сотрудника. Является аналогом штатной единицы, однако, даже если режим "Штатное расписание" в программе "АиТ:\Кадровый учет" не используется, то должность и подразделение у сотрудника есть всегда.

Ж

Журнал – представляет собой набор отдельных записей, каждая из которых служит для регистрации и отображения каких-либо изменений в персональных и служебных данных сотрудника с указанием дат их изменения, например, журнал кадровых перемещений

З

Закладка (окон) – страница в многостраничном окне, а также особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку).

К

Курс (учебный курс) – серия учебных занятий по одному предмету.

Ключевые слова – зарезервированные служебные слова программы, имеющие уникальные имена и используемые при разработке шаблонов отчетов.

М

Место проведения обучения – территориальный признак центра обучения.

Модальные окна – работают в монопольном режиме, когда они открыты, запрещен доступ к меню, инструментам и другим открытым окнам.

Н

Направление обучения – аналитический признак (показатель), используется для группировки в отчетах.

Недочерние окна – окна, которые выходят за пределы основного окна, например, окна сообщений об ошибках.

Немодальные окна – позволяют осуществлять доступ к различным функциям программы без своего закрытия.

Номер группы – символьная и\или цифровая маркировка учебной группы.

О

Обязательные справочники – справочники, заполнение которых обязательно для начала работы с программой

Обучение – процесс получения сотрудником знаний в рамках учебного заведения.

Основание обучения – статья законодательства РФ или внутрикорпоративный документ с указанием его номера и даты вступления в силу.

Оценка результатов обучения – цифровое или символьное значение, проставляемое по окончанию курса.

Основная панель инструментов – панель инструментов, содержащая постоянный набор кнопок, не зависящий от вида открытого окна.

Основное окно – окно, открывающееся сразу же после запуска программы и содержащее меню, панель инструментов, открытые дочерние окна программы, а также значки свернутых дочерних окон.

Открытое окно – окно, которое размещается в основном окне программы или на рабочем столе компьютера, если окно является недочерним.

П

Панель инструментов – набор кнопок, обеспечивающий быстрый доступ ко многим режимам и функциям программы.

Папка (каталог) – элемент структуры файловой системы для упорядочения хранения программ и документов на диске и может вмещать как файлы, так и другие вложенные папки (подкаталоги). Папка на экране отображается с помощью значка, имеющего вид канцелярской папки.

Переключатель – одна из зависимых кнопок группы, предназначенная для выбора одного из взаимоисключающих условий.

Периодическое обучение – обучение, которое сотрудник должен обязательно проходить с установленной периодичностью.

План регламентного обучения – представляет собой список сотрудников, подлежащих обучению в выбранном учебном году, с указанием для каждого из них перечня планируемых курсов. Обучение сотрудника может включаться в план как "вручную" пользователем на основе заявок, так и программно на основе списка обязательных курсов. Сводный план может корректироваться и дополняться в течение учебного года.

План учебных групп – список учебных групп за период.

Планируемые сотрудники – сотрудники, в персональную карточку которым добавлена строка, имеющая статус "Включен в план".

Плановый курс – дисциплина, изучаемая в рамках регламентного обучения.

Подразделение – элемент организационной структуры предприятия

Полосы прокрутки – используются для перемещения по тексту вверх/вниз или влево/вправо в окне, в полях списках или в таблицах.

Пользователь – сотрудник компании, работающий с программой "АиТ:\Управление обучением".

Прочее обучение – обучение, не подходящее под определение "Регламентное обучение"

Р

Регламентное обучение – обязательное обучение, проводимое согласно законодательству РФ или корпоративным правилам, подразделяется на два вида: периодическое и стартовое обучение.

Режим работы – совокупность функций и операций, доступных в текущем окне.

Роль – определяет права доступа к функциональным возможностям программных модулей.

С

Стандартные закладки – закладки в кадровой карточке, заголовок закладки, количество колонок, их название и назначение определяется программой автоматически.

Стартовое обучение – обучение, которое сотрудник обязательно должен пройти при вступлении в должность.

У

Учебная группа – сотрудники, обучаемые по одному курсу, объединенные местом и временем обучения.

Учебный год – как правило, совпадает по срокам с календарным годом.

Ф

Форма обучения – способ проведения обучения, например, с отрывом или без отрыва от производства

Формирование учебных групп – объединение обучаемых по конкретному курсу в группу с привязкой к учебному центру и времени обучения.

Файл – поименованная целостная совокупность данных на диске, имеющая набор атрибутов (имя, расширение и др.).

Фильтр – инструмент программы, позволяющий отбирать определенную часть имеющейся информации по заданным условиям для просмотра на экране, выполнения расчетов или формирования отчетов.

Флаг – независимая кнопка, позволяющая выбрать одно из двух альтернативных условий.

Ц

Центр обучения – организация, проводящая обучение по конкретным курсам

Ш

Шаблон – текстовый файл определенной структуры с расширением (*.rep или *.dot). Используется для создания отчетов и выходных документов, содержит ключевые слова и набор элементов, отражающих содержание и внешний вид документа (отчета).


Назначение программы

 Top Previous Next

Программа "АиТ:\Управление обучением" предназначена для автоматизации, учета и контроля этапов обучения сотрудников в учебном заведении или центре обучения.

Программа включает большой комплекс функций, позволяющих наиболее оптимальным способом организовать деятельность менеджеров отдела обучения и автоматизировать процесс обучения сотрудников. Программа обеспечивает автоматизацию процесса организации обучения за счет:

· ведения различных видов обучения: (стандартных и пользовательских). Стандартные виды обучения задаются программой автоматически, пользовательские виды обучения задаются непосредственно самим пользователем;
· использования различных формы обучения сотрудников;
· выбора учебных центров, мест, сроков обучения и т.д.;
· просмотра курсов по одному выбранному направлению;
· формирования плана регламентного (обязательного) обучения для тех должностей, по которым обучение предусмотрено законодательством РФ или внутрикорпоративными правилами. Для каждой такой должности программа разрешает предусмотреть обязательные курсы обучения.
· автоматическое включение в учебный план обучения всех сотрудников, занимающих должности, по которым предусмотрено регламентное (обязательное) обучение;
· формирование списка сотрудников, подлежащих обучению в учебном году, по другим (не регламентным) видам обучения;
· создание списка запланированных и назначенных курсов за учебный год;
· планирование списка учебных групп по каждому из курсов и определение состава слушателей;
· оповещение сотрудников по почте;
· автоматическое отслеживание сроков прохождения периодического и стартового обучения;
· регистрация этапов ведения обучения (заключение договора, оплата обучение, завершение обучения);
· ведение истории обучения сотрудников в учебных группах за предыдущие годы;
· создание набора справочников (назначение, название и набор полей), необходимых для работы с программой;
· использование генератора отчетов для проведения анализа результатов обучения сотрудников.

Программа "АиТ:\Управление обучением" входит в состав комплекса "АиТ:\Управление персоналом" и использует единую для всех программ комплекса базу данных. Она может функционировать только совместно с программами "АиТ:\Кадровый учет" и/или "АиТ:\Зарплата", в которых формируются структура предприятия и карточки сотрудников с их персональными и служебными данными.

Внимание. Программа "АиТ:\Управление обучением" может работать только на MS SQL сервере 2000 и выше (не MSDE), т.к. для ее работы используется Агент SQL Server.


Запуск программы

Запуск программы производится только из операционной среды Windows. Для запуска необходимо дважды щелкнуть на ярлыке (иконке) программы или запустить на выполнение исполняемый файл hrm.exe. Наиболее быстрым и удобным способом является запуск программы с использованием ярлыка.

Чтобы исключить несанкционированный доступ к программе и базе данных, сразу же после запуска программы на экране открывается окно регистрации пользователя (рис. 1). Для идентификации пользователя запрашивается логин и пароль. В целях конфиденциальности при вводе пароля вводимые символы заменяются звездочками.

Рис. 1

В центральной части окна приводится одна или список баз данных, заданных в настроечном файле Ait_kp.ini. База данных, с которой будет работать пользователь в данном сеансе работы программы, должна быть выделена в списке.

В случае успешной регистрации происходит вход в программу, и на экране появляется основное окно программы, содержащее панель инструментов, Главное меню. Внутри основного окна размещается дочернее окно “Список сотрудников”.


Установка прав доступа к программе

Права на работу с программой "АиТ:\Управление обучением" и с другими программами комплекса "АиТ:\Управление персоналом" устанавливаются в программе "АиТ:\Конфигурация" в режиме "Редактирование списка пользователей" на закладке "Общие" (рис. 1).

Права на работу устанавливаются для заданного логина пользователя, слева от которого имеется символ "стрелочка" Strelka. Самыми большими правами на работу с программами обладает системный администратор. Для тех программ, с которыми разрешено работать пользователю, следует установить флаг FlagYes.

Рис. 1

После установки прав на работу с программой, ее имя попадает в выпадающий список поля "Название модуля" на закладке "Роли" (рис. 2), что позволяет назначить роль пользователю, т.е. задать набор возможностей, которыми он будет обладать при работе с программой.

Для назначения роли нужно:

· перейти на закладку "Роли";
· в поле "Название модуля" указать имя программы, для которой она назначается роль, обращаем внимание на тот факт, что никаких ролей не назначено;
· щелкнуть левой кнопкой мыши на левой панели под заголовком поля "Роль";
· нажать на кнопку "Создать" [image] , под полем "Роль" появляется пустая строка;
· в пустую строку из выпадающего списка (рис. 2) ввести имя роли пользователя.

Рис. 2

В том случае, когда пользователю не назначена роль, при запуске программы "АиТ:\Управление обучением" выдается предупреждающее сообщение об ошибке (рис. 3), и программа закрывается.

Рис. 3


Линия консультаций и поддержки

Зарегистрированным пользователям комплекса предоставляются бесплатные услуги линии консультаций по телефону, но не более 15 минут.

Для пользователей, имеющих абонементный договор, предоставляются неограниченные по времени консультации по телефону, факсу, почте и E-mail.

Телефон / Факс: | 8 495 984 82 81
Адрес офиса: | Москва, Б. Почтовая, д. 55/59
E-mail: | ait@aitsoft.ru
Web страница: | http://www.aitsoft.ru


Начало работы с программой

После успешного запуска пользователь получает возможность работать с программой "АиТ:\Управление обучением". Прежде всего, необходимо познакомиться с интерфейсом программы, чтобы получить первоначальное представление о режимах и основных функциях программы. Стандартный пользовательский интерфейс программы включает сервисные средства:

· окна программы;
· Главное меню;
· основная и дополнительная панель инструментов.

В связи с тем, что данная программа может работать только совместно с другими программами комплекса, то структура предприятия и список сотрудников предприятия, который необходим для осуществления задач управления обучением, уже сформированы в программе "АиТ:\Кадровый учет". При открытии программы всегда на экране отображается список сотрудников. Пользователю необходимо также познакомиться со структурой персональных и производственных данных сотрудников. Список сотрудников содержит только самые общие сведения о сотрудниках, табельный номер, фамилию, имя, отчество и занимаемую должность. Более детальные ведения содержатся в карточках сотрудниках, открываемых кнопкой Open из списка сотрудников. Карточка содержит несколько закладок, но редактировать данные можно только на закладке "Список курсов". Эта закладка предназначена для отображения всех курсов, которые запланированы для обучения или закончили сотрудники. Производственная деятельность сотрудника отражена в журнале кадровых перемещений.

Далее пользователь может переходить к непосредственной работе с программой. Основными этапами работы с программой являются:

1. Заполнение справочников – программа содержит набор необходимых справочников, данные из которых используются при планировании и ведении обучения. Пользователь должен внимательно изучить назначение каждого справочника, чтобы правильно его сформировать. Прежде всего, нужно заполнить основные справочники курсов и центров обучения. Для их формирования должны быть заполнены дополнительные справочники видов обучения, форм обучения и мест проведения обучения. Справочник должностей заполнять не требуется, т. к. он формируется в программе "АиТ:\Кадровый учет" или "АиТ:\Зарплата", в нем разрешается редактировать только поле "Ранг". Остальные справочники заполняются в процессе работы по мере необходимости.

2. Формирование плана регламентного обучения – формирования списка курсов для отдельных сотрудников или должностей, обучение по которым является обязательным согласно законодательству РФ или правилам, принятым на текущем предприятии. Регламентное обучение формируется менеджерами отдела обучения предприятия.

3. Внесение в план прочего обучения – формирование учебного плана для сотрудников, направляемых на обучение по заявкам руководителей или непосредственно самих сотрудников.

4. Автоматическое отслеживание сроков периодического обучения.

5. Формирование учебных групп – объединение сотрудников, обучаемых по конкретному курсу, в группу с привязкой к учебному центру (подбор учебного центра) и времени обучения. Формирование учебных групп предусматривает следующие этапы работы:

· создание учебной группы по конкретному курсу с присвоением ей номера;
· создание списка сотрудников, направляемых на обучение в текущем учебном году;
· заполнение карточки учебного курса с указанием курса, номера группы, даты начала занятия, учебного центра, который будет проводить обучение, и других необходимых сведений;
· добавление сотрудников в список, обучаемых в этой группе сотрудников;
· внесение платы за обучение с фиксацией оплаты в карточке учебного курса;
· отметка о завершении обучения, составление протокола по результатам прохождения обучения.

6. Создание архива данных по обучению – позволяет сохранить историю обучения сотрудников за предыдущие годы.

7. Анализ обучения – построение различных аналитических и информационных отчетов.

Более подробные сведения обо всех этапах обучения приведены папке "Планирование и ведение обучения.


Помощь (Справка)

Справочная система (Помощь)

 Top Previous Next

Справочная система (Справка, Помощь) содержит основные сведения и порядок работы с программой "АиТ:\Управление обучением". В затруднительных ситуациях Справочная система (СС) позволяет получить оперативную контекстно-зависимую помощь и может быть открыта одним из трех способов:

· кнопкой Help1 панели инструментов;
· из пункта "Контекстная справка" раздела "?" Главного меню системы;
· горячими клавишами Shift+F1.

Обращение к Справочной системе происходит из любого режима (окна) программы. Для открытия предметного указателя Справочной системы, воспользуйтесь горячими клавишами Ctrl+F1.

Показ разделов Справочной системы происходит в специальном окне, разделенном на две панели. В верхней части окна расположены кнопки, назначение которых описано в конце этого раздела.

Внимание. При первом открытии окно Справочной системы стандартно размещается в верхнем правом углу экрана и его размер задан по умолчанию. Пользователь может установить размер окна и его размещение на экране по своему усмотрению. При последующих открытиях окна настройки, сделанные пользователем сохраняются.

Назначение левой панели окна Справочной системы

На правой панели отображается собственно справочная информация по текущему разделу, открытому программой или выбранному пользователем. Информация, приведенная на левой панели, зависит от выбранной закладки. Если ширина левой панели недостаточна для отображения всех четырех закладок, то справа от набора закладок (рис. 1) появляются кнопки Help2 для перемещения по закладкам.

Рис. 1

На закладке "Содержание" приводится иерархический список папок с включенными в них разделами Справочной системы и отдельных разделов. Папки помечены значком папки Help4 (свернутая папка) или Help5 (раскрытая папка), а разделы – значком документа Help6 . Раскрыть или свернуть папку можно, щелкнув на значке "+" или "-", расположенном слева от названия папки. В раскрытой папке видны все разделы, входящие в нее, и вложенные папки. Щелчок левой кнопки мыши на заголовке выбранного раздела приводит к показу выбранного раздела в правой части окна.

Закладка "Указатель" позволяет перейти к нужной теме по выбранному из списка ключевому слову. В верхней части закладки находится поле для ввода ключевого слова. Причем, если поле ввода под закладками страниц не заполнено, то показывается список ключевых слов, начиная с первой буквы алфавита "А". Открытие раздела производится двойным щелчком левой кнопкой мыши на ключевом слове или в результате его выделения и нажатия на кнопку "Показать". Если ключевое слово относится к нескольким разделам, то предварительно открывается окно "Найденные разделы" со списком разделов.

Если ключевое находится за пределами его видимости, то можно воспользоваться вертикальной полосой прокрутки или ввести его в верхнее поле. Пользователь может ввести ключевое слово (полностью или только несколько первых букв) вручную. Ключевое слово, в котором имеются введенные символы, выделяется и перемещается в самый верх списка.

Закладка "Поиск" обеспечивает переход к нужному разделу по конкретным словам, фразам, имеющимся в тексте Справочной системы, а также по отдельным выражениям с использованием текста и логических операторов AND, OR, NEAR, NOT (рис. 2). Показ списка логических операторов происходит после нажатия на кнопку Help7 .

Рис. 2

После ввода фрагмента текста нажмите на кнопку "Разделы", в результате в нижней части отобразится список разделов, удовлетворяющих заданному выражению. Выбранный в списке раздел показывается в правой части окна.

Закладка "Избранное" предназначена для быстрого показа наиболее часто просматриваемых пользователем разделов. Предварительно нужные разделы должны быть перечислены на этой закладке. Для этого сначала требуется открыть нужный раздел на другой закладке, а затем перейти на эту закладку. Заголовок открытого в данный момент раздела Справочной системы отображается в нижней части закладки в поле "Текущий раздел". После нажатия на кнопку "Добавить" выбранный раздел попадает в список разделов. Исключение ненужного раздела из списка выполняется кнопкой "Удалить".

Назначение правой панели окна Справочной системы

Правая панель служит для непосредственного представления на экране текста выбранного раздела. Перемещаться по тексту раздела можно так же, как и в обычном окне редактирования, а также по словам (ссылкам), выделенным голубым цветом. В окне Справочной системы действуют команды текстового редактора, что позволяет выделить в нем текст, скопировать его или перенести в любой другой документ.

Быстрый переход к другому разделу выполняется по ссылкам внутри темы или по иерархическому списку разделов, ключевых слов, тексту для поиска, отображаемому в левой части окна. При остановке на ключевом слове указатель мыши меняет свой внешний вид со "стрелки" на изображение "руки". Щелчок на таком слове приводит к открытию на экране раздела, в котором содержится более подробная информация о подчеркнутом понятии (термине).

В верхней части окна расположены кнопки, обеспечивающие следующие действия:

· Показать / Скрыть – отображение или скрытие содержания Справочной системы. При показе содержания кнопка называется "Скрыть", при его отсутствии – "Показать". Нажатие на кнопку "Скрыть" делает содержание невидимым, и изменяет название кнопки;
· Назад – переход к последнему просмотренному разделу;
· Вперед – перемещение вперед по списку ранее открытых разделов;
· Домой – переход к первой теме "Словарь терминов" Справочной системы. Перемещение к нужному термину в этом разделе осуществляется нажатием на кнопку с буквой алфавита, совпадающей с первой буквой этого термина. Возврат в начало темы происходит по кнопке "Назад";
· Печать – печать текущего раздела или всей книги, содержащей текущий раздел.
· Параметры – открытие контекстного меню с набором команд.


Настройка прав доступа

Пользователи, работающие с базовой версией программы, имеют полный доступ ко всем функциям программы, и от них не требуется настраивать права доступа.

В версиях "Проф" и "Холдинг" перечень функциональных возможностей при работе с окнами (режимами работы) программы зависит от прав доступа конкретного пользователя программы к этим режимам.

Настройка прав доступа для работы с программным модулем "АиТ:\Управление обучением" в этих версиях осуществляется системным администратором в модуле "АиТ:\Конфигурация" в окне (рис. 1). Вызов окна "Редактирование списка ролей" происходит из пункта "Роли" раздела "Режим" Главного меню.

Прежде всего, необходимо в верхнем поле "Модуль" (рис. 1) указать имя программы "АиТ:\Управление обучением", для которой производится настройка прав доступа. Далее выбрать роль из списка, приведенного в левой части окна. Выбор роли осуществляется щелчком левой кнопки мыши на нужной роли, при этом слева от названия выбранной роли (sa) появляется символ "стрелочка" Strelka , как показано на рис. 1.

Рис. 1

В правой части окна для выбранной роли и программного модуля "АиТ:\Управление обучением" отображается список общих настроек объектов, режимов и функций. Для каждого элемента списка системным администратором указываются права доступа.

Список настроек приводится в первом столбце "Объекты, режимы и функции", формируется автоматически и группируется по разделам, которые могут содержать набор настроек. Имя каждого раздела отображается с левой стороны первого столбца и указывается синим цветом. Второй столбец "Доступ" является редактируемым, значения в него вводится из выпадающего списка, содержащего следующие виды доступа, предоставляемые пользователю:

· полный – полный доступ предполагает возможность работы с выбранным режимом без ограничений, когда доступны все операции с данными. Пользователю разрешается не только просматривать данные, но и изменять их (вводить, удалять, править, печатать, импортировать или экспортировать);
· чтение – разрешен доступ на чтение, что дает возможность только просматривать информацию, но запрещает ее редактировать;
· нет – отсутствует доступ к режиму, т.е. невозможно даже открыть окно или воспользоваться данной функцией программы.


Главное меню

Главное меню обеспечивает доступ к основным функциям и возможностям программы и располагается под строкой заголовка окна. Главное меню имеет иерархическую структуру и включает три уровня меню. Верхний уровень Главное меню включает несколько разделов (например, "Сотрудники", "Отчеты", "Планирование") и всегда показывается под заголовком основного окна программы "АиТ:\Управление обучением".

Рис. 1

Каждый раздел содержит набор пунктов. Отдельные пункты Главного меню продублированы кнопками панели инструментов. В нижней части основного окна программы при выборе пункта меню выводится его назначение.

Для доступа к пунктам щелкните левой кнопкой мыши на требуемом разделе Главного меню. В результате на экране непосредственно под выбранным разделом отображается список всех пунктов этого раздела меню. Второй уровень меню, содержащий список пунктов раздела, по способу отображения называется также выпадающим меню. На рис. 1 показано выпадающее меню для раздела "Справочники".

Выбор одного из пунктов раздела меню осуществляется щелчком левой кнопки мыши на нем и приводит к выполнению определенного действия, для которого он предназначен, например, пункт "Каскад" раздела "Окна" располагает открытые окон в виде стопки. Выполнение большинства команд приводит к открытию нового окна и соответственно переходу в новый режим работы, под которым подразумевается совокупность функций и операций, доступных в данном окне. Свернутое (минимизированное) окно отображается на основном окне программы в виде значка.

Главное меню содержит следующие разделы:

· Сотрудники – включает набор пунктов, обеспечивающих доступ к списку сотрудников и к карточкам сотрудников, содержащим персональные данные и сведения об их обучении, Кроме этого имеются два сервисных пункта для задания фильтра и настройки персональных карточек;
· Отчеты – содержит набор пунктов меню для построения отчетов;
· Планирование – для планирования и ведения процесса обучения сотрудников, работающих на текущем предприятии;
· Справочники – содержит пункты меню для работы со справочниками, позволяя их просматривать и редактировать;
· Окно – управляет расположением на экране графических элементов: окон, панели инструментов, значков;
· Выход – включает один пункт "Выход" (Alt+F4) – автоматическое закрытие всех активных окон, завершение работы и выход из программы
· ? – обеспечивает доступ к Справочной системе (Помощи), в которой описаны основные понятия, возможности и режимы работы с программой.


Раздел "Сотрудники"

Раздел "Сотрудники" Главного меню включает набор пунктов, обеспечивающих доступ к персональным данным сотрудников, в том числе, к сведениям о прохождения их обучения.

Назначение пунктов меню раздела "Сотрудники"

Карточка panal1

Доступ к персональной карточке, в которой отражается персональная и служебная информация о текущем сотруднике, например, сведения о его кадровых перемещениях, об образовании, об оконченных им курсах и другие сведения.

Настройка карточек

Выбор закладок, отображаемых в персональной карточке.

Список сотрудников panal3

Открытие списка сотрудников организации в соответствии с установленным фильтром. Для удобства поиска и выбора конкретного сотрудника список упорядочен по подразделениям предприятия.

Проверка на дату

Проверка на наступление даты событий, описанных в справочнике "Проверка на дату".

Фильтр panal2

Установка и изменение условий для отбора информации по отдельным сотрудникам.


Раздел "Отчеты"

Раздел "Отчеты" Главного меню позволяет сформировать различные виды отчетов для планирования и анализа эффективности проведения обучения сотрудников в центрах обучения.

Назначение пунктов меню раздела "Отчеты"

Отчеты по хранимой процедуре

Отчеты по хранимой процедуре по всему предприятию, по филиалам, по подразделениям.


Раздел "Планирование"

Раздел "Планирование" предназначен для планирования и ведения процесса обучения сотрудников на предприятии.

Обработка заявок

Формирование списка сотрудников, планируемых на обучение в текущем учебном году, создание учебных групп и включение в них сотрудников, отражение всех стадий обучения в карточке учебного курса от включения сотрудника в план обучения и создания группы до завершения обучения, а также создание архива учебных групп, обучение по которым завершено.

Регламентное обучение

Формирование плана регламентного обучения для должностей и для отдельных сотрудников. Обучения для должностей предусмотрено законодательными актами или корпоративными правилами организации.


Раздел "Справочники"

Раздел "Справочники" Главного меню открывает доступ к работе со справочниками, позволяет их просматривать и редактировать:

Курсы

Направления обучения

Виды обучения

Формы обучения

Места проведения обучения

Центры обучения

Должности

Должностные ранги

Оценки результатов обучения

Основания обучения

Проверка на дату


Раздел "Окна"

Управление окнами производится с помощью пунктов (команд) раздела "Окна" Главного меню программы. Данная группа команд позволяет переключаться между открытыми в программе в данный момент окнами и выполнять над ними определенные действия, а также настраивает панель инструментов.

Одно и то же окно не может быть открыто дважды, за исключением окон персональных карточек сотрудников. Переключение между открытыми окнами производится мышью или "горячими” клавишами Ctrl+Tab при условии, что на экране нет открытых модальных окон. Под пунктами раздела "Окна" приводится список открытых в данный момент окон.

Назначение пунктов меню раздела Окна

Каскад

Располагает окна последовательно в виде стопки, с частичным наложением друг на друга таким образом, чтобы на экране всегда был виден заголовок каждого окна и его левая вертикальная сторона. Активное в данный момент окно помещается в самый верх стопки.

Мозаика

Располагает открытые окна рядом так, чтобы можно было видеть их все.

Горизонт

Упорядочивает окна горизонтальной мозаикой.

Панель инструментов

Конфигурирует местоположение панели инструментов на экране. Настройка осуществляется в окне "Настройка панели инструментов".

Упорядочить значки

Располагает все значки открытых, но свернутых (минимизированных) окон в строке в нижней части экрана.

Запомнить положение

Запоминает положение и размеры активного в настоящий момент окна. При последующем открытии это окно появляется в том же месте экрана, в котором находилось в момент закрытия программы.


Раздел "?"

Назначение пунктов меню раздела "?"

Содержание Cправки F1

Показ оглавления Справочной системы программы.

Контекстная справка Shift+F1 Menuhelp

Вызов гипертекстовой контекстной помощи (Help).

Поиск справки по .... Ctrl+F1

Поиск справочных сведений по предметному указателю.

О программе Telephone

Открывается окно со сведениями о программе и ее производителе – компании "АиТ Софт". В окне указывается номер и тип версии (Базовая, Проф, Холдинг), номер и дата сборки, имя базы данных. Для контактов с компанией сообщаются телефоны горячей линии, факс, почтовый и электронный адрес (e-mail), а также адрес официальной страницы (web-адрес) компании в сети Интернет.


Окна

Вся работа с программой выполняется в многооконном режиме, когда одновременно может быть открыто несколько окон. Окно – это часть экрана, предназначенная для отображения каких-либо сведений (текста, электронных форм документов, отчетов и др.), для ввода данных, настройки параметров, осуществления выбора (установки) параметров и поиска информации, а также для вывода сообщений программы.

Сразу же после запуска программы открывается основное окно, имеющее заголовок "АиТ:\Обучение" (рис. 1). Заголовок любого окна отображается в самой верхней строке слева. Под строкой заголовка основного окна, в отличие от других окон, находится Главное меню и основная панель инструментов. Кроме этого в основном окне размещаются все открытые дочерние окна программы, а также значки свернутых дочерних окон.

Рис. 1

В каждый момент времени в программе может быть открыто несколько окон, но работать можно только с одним окном, которое называется активным, или текущим окном. Активным считается окно, в котором находится курсор, в нем можно, просматривать, вводить или редактировать данные. Заголовок активного окна имеет более контрастный цвет по сравнению с другими окнами.

Назначение кнопок управления окном

Заголовок любого окна отображается в его самой верхней строке с левой стороны. В той же строке с правой стороны размещаются кнопки управления окном "Свернуть" Winroll , "Развернуть" Winunfold и/или "Закрыть" WinClose .

Кнопка "Закрыть" предназначена для закрытия окна. Если окно имеет только одну эту кнопку, то его можно также перемещать по экрану, но нельзя изменять его размеры и сворачивать. Для сворачивания окон используется кнопка "Свернуть". Свернутое окно является неактивным и размещается в нижней части основного окна в виде значка, но в любой момент его можно сделать активным и показать на экране его содержимое, щелкнув мышью на первой левой кнопке Winrestore свернутого окна. Окна, у которых активна кнопка "Свернуть", можно также перемещать по экрану и изменять их размеры. Окна на экране могут быть представлены в полноэкранном виде, если у них активна кнопка "Развернуть". Щелчок на ней увеличивает размер окна до полного экрана. Вернуть окно к прежнему размеру можно при помощи кнопки Winrestore , которая появляется только в полноэкранном окне вместо кнопки "Развернуть".

У основного окна активны все три кнопки. Окна, у которых активны все три кнопки, на экране могут быть представлены в полноэкранном или в свернутом виде, их можно закрывать, перемещать и изменять их размеры.

Чтобы изменить размер окна по одному направлению, например, по его высоте (длине) следует установить указатель мыши на горизонтальную (вертикальную) сторону рамки окна, щелкнуть левой кнопкой мыши, и, не отпуская ее, переместить указатель мыши в нужную позицию экрана вверх/вниз (вправо/влево). Вместе с курсором по экрану перемещается и контур окна. Для фиксации размеров окна отпустите кнопку мыши. Для увеличения размеров окна одновременно по двум направлениям расположите указатель мыши на угол окна и выполните те же действия, что и при изменении размера в одном направлении.

Управление взаимным расположением окон относительно друг друга производится из раздела "Окна" Главного меню программы. Данная группа функций позволяет переключаться между открытыми окнами и выполнять над ними определенные действия. Одно и то же окно не может быть открыто дважды. Открытие нового окна приводит к переходу в новый режим работы, под которым подразумевается совокупность функций и операций, доступных в данном окне. Переключение между открытыми окнами производится мышью или “горячими” клавишами Ctrl+Tab.

Виды окон

Все окна программы размещаются в основном окне и могут быть классифицированы по различным критериям.

Открытое окно – окно, которое размещается в основном окне программы или на рабочем столе компьютера, если оно является недочерним. Все открытые окна программы вызываются только из основного окна и закрываются в момент окончания работы с программой. Только одно из открытых дочерних окон может быть активным.

Активное окно – открытое окно, в котором в текущий момент времени установлен курсор, его заголовок окрашивается контрастным цветом.

Свернутое (минимизированное) окно – открытое окно, которое отображается в нижней части основного окна программы в виде значка. На рис. 1 в нижней части основного окна показаны два свернутых окна программы: "Список сотрудников" и "Проверка на дату".

В программе все окна по их местоположению относительно основного окна классифицируются на следующие виды:

· дочерние окна – окна, размещающиеся внутри основного окна;
· недочерние окна – программные окна, которые выходят за пределы основного окна, например, окна сообщений об ошибках.

В зависимости от возможности доступа к другим режимам окна подразделяются на два типа:

· модальные окна – работают в монопольном режиме, когда они открыты, запрещен доступ к меню, инструментам и другим режимам работы (окнам). Типичным представителем модальных окон являются окна, которые вызываются кнопками дополнительной панели инструментов;
· немодальные окна – позволяют осуществлять доступ к различным функциям программы без своего закрытия.

По содержанию окна делятся на диалоги, документы (электронные формы документов) и отчеты.

Отчеты – окна, в которых приводятся результаты построения отчета. Обычно отчеты отображаются в других программах Word, Excel.

Документы – окна, в которых отображаются различного рода документы, используемые при проведении обучения, например, различного рода карточки, и другие документы.

Диалоги (диалоговые окна) – окна, содержащие набор графических элементов, используемых для ввода данных и осуществления выбора (установки) параметров. Диалоги могут размещаться на одной или нескольких страницах (закладках). Многостраничные диалоги имеют набор кнопок (закладок), обычно расположенных в верхней части диалога. Переход на нужную страницу выполняется щелчком мыши на одноименной закладке.

Настройка параметров в диалоге производится путем установки или снятия флагов, выбора переключателей или ввода данных, формирования различных списков. Пользователь может изменить настройки, задаваемые по умолчанию, или оставить их прежними.


Панель инструментов

Панель инструментов содержит кнопки, посредством которых осуществляется быстрый доступ ко многим режимам и функциям программы. В программе имеется две панели инструментов: основная и дополнительная.

В нижней части основного окна программы при выборе пункта меню или кнопки панели инструментов выводится полное наименование выбранного режима. Если, не нажимая, установить на одну из кнопок панели инструментов указатель мыши, рядом с ней появится всплывающая подсказка с кратким наименованием режима.

Основная панель инструментов

Основная панель инструментов (рис. 1) расположена в верхней части основного окна под разделами Главного меню и содержит постоянный набор кнопок, который не зависит от вида открытого окна. При наличии соответствующей настройки кнопки основной панели инструментов отображаются на экране даже, когда все окна программы закрыты.

Рис. 1

Действия инструментальных кнопок основной панели аналогичны одному из пунктов Главного меню, доступ к ним более оперативен. Однако не все пункты меню продублированы кнопками панели инструментов.

Щелчок по кнопке панели инструментов приводит к открытию нового окна и соответственно переходу в новый режим, под которым подразумевается совокупность функций и операций, доступных в данном окне.

В нижней части активного окна программы при выборе кнопки панели инструментов выводится полное наименование выбранного режима. Если, не нажимая, установить указатель мыши на одну из кнопок панели инструментов, рядом с ней появится всплывающая подсказка, характеризующая краткое назначение режима.

Дополнительная панель инструментов

Дополнительная панель инструментов присутствует в большинстве открытых окон (особенно в диалоговых окнах) и содержит переменный набор инструментальных кнопок. Состав кнопок дополнительной панели инструментов определяется автоматически программой и зависит от вида активного окна и операций, доступных в нем. Список наиболее часто используемых кнопок дополнительной панели инструментов с описанием их назначения приведен в отдельной теме. Назначение остальных кнопок, редко используемых в окнах, описано непосредственно в теме, посвященной функционированию этого окна.

По умолчанию кнопки размещены на вертикальной панели с левой стороны окна. Как и кнопки основной панели инструментов, они имеют всплывающую подсказку, поясняющую назначение этой кнопки. При переводе курсора мыши на графическую кнопку возле нее появляется всплывающая подсказка на желтом фоне, дублирующая данные в статусной строке внизу окна.

Внимание. При отсутствии открытых окон кнопки дополнительной панели на экране не отображаются.

Программа предоставляет пользователю возможность настраивать основную и/или дополнительную панель инструментов, изменять ее местоположение, внешний вид, а также отображать ее на экране или скрывать. Установка параметров панели инструментов выполняется в окне "Настройка панели инструментов". Вызов окна происходит с помощью пункта меню "Инструменты" раздела "Окна".


Настройка панели инструментов

Программа предоставляет пользователю возможность настраивать основную и/или дополнительную панель инструментов, изменять ее местоположение, внешний вид (показывать подсказки и названия кнопок), а также скрывать или отображать панель на экране. Установка параметров панели инструментов выполняется в окне "Настройка панели инструментов" (рис. 1). Окно открывается с помощью пункта меню "Инструменты" раздела "Окна".

Рис. 1

Назначение графических элементов окна

Перемещаемая

Установка флага разрешает перемещать основную или дополнительную панель инструментов по экрану главного или дочернего окна. Для перемещения панели инструментов курсор нужно установить на вертикальные или горизонтальные линии Interfacepanelinstall2 панели инструментов, нажать левую кнопку мыши и, не отпуская ее, перемещать панель в нужное место экрана.

Предупреждение. При перемещении панели курсор не должен располагаться на какой-либо кнопке, иначе будет выполнена соответствующая команда.

Расположение

В соответствии с выбранным переключателем основная панель может быть расположена сверху/снизу/справа/слева в основном или дочернем окне.

Спрятать/Показать

Отображает или скрывает основную панель инструментов. Дополнительная панель всегда отображается на экране.

Показывать текст

При установке флага под изображением кнопки показывается ее заголовок.

Показывать подсказки

Если флаг установлен, то при наведении указателя мыши (не нажимая) на кнопку панели инструментов появляется всплывающая подсказка.

Сохранять настройку панели инструментов

Сохраняет при закрытии программы настройку панели инструментов.


Графический интерфейс

В программе используются такие стандартные элементы графического интерфейса Windows, как окна, закладки окон, переключатели, флаги, списки, поля для ввода значений. Каждый из этих элементов выполняет определенную функцию или действие.

Окно – это часть экрана, в которой выполняется вся работа с программой "АиТ:\Управление обучением".

Кнопки (закладки) – особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку) в многостраничном окне. Например, на приведенном ниже рисунке (рис. 1) для окна "Обработка заявок на обучение" показаны три кнопки (закладки): "Планируемые сотрудники", "Учебные группы" и "Архив учебных групп". Переход с закладки на закладку осуществляется щелчком мыши на ее закладке (кнопке).

Рис.1

Блок – набор графических элементов, объединенных по назначению и находящихся внутри рамки, прорисованной белым цветом. Например, на рис. 2 блок "Отбор данных" включает в себя набор переключателей, флаг "Только действующие" и список для выбора подразделений.

Рис.2

Переключатели – представляют собой группу зависимых кнопок (рис. 2), называемых также радио-кнопками, они предназначены для выбора одного из взаимоисключающих условий. Выбор переключателя производится щелчком левой кнопки мыши. В группе переключателей может быть выбран (включен) только один переключатель, который имеет вид кружка с точкой [image] . Остальные переключатели (кнопки) находятся в выключенном состоянии и изображаются на экране кружком без точки [image] .

Флаг – независимая кнопка, состояние флага не зависит от состояния других кнопок. Флаг позволяет выбрать одно из двух альтернативных условий, снабжен заголовком для выбора условия и может находиться в одном из двух состояний:

· включен (установлен) – если условие флага необходимо выполнить. На экране установленный флаг изображается в виде квадрата, внутри которого расположена "галочка" FlagYes . Если флаг используется в таблицах, то он изображается в виде перечеркнутого квадрата [image] ;
· выключен (снят) – если условие флага необходимо отменить. На экране снятый флаг отображается в виде пустого квадрата FlagNo .

Установка и снятие флага производится щелчком мыши или клавишей Пробел, если флаг активен, т.е. заголовок флага обведен пунктирной рамкой (рис. 3).

Рис. 3

Поля списки – поля, содержащие списки различного назначения для выбора необходимых элементов. При больших списках эти поля снабжаются полосой прокрутки. Примером таких полей могут служить списки подразделений (рис. 4) при отборе данных.

Рис. 4

Выпадающие списки – формируются автоматически, их изменить нельзя. Они содержат набор возможных значений, предназначенных для ввода в данное поле. Чтобы показать список для выбора, необходимо щелкнуть мышью по кнопке list (рис. 5), расположенной справа от поля. На рис. 5 показан выпадающий список для ввода значений в поле "Курс". Большие выпадающие списки снабжаются полосами прокрутки. Щелчок по элементу (строке) списка приводит к вставке выбранного значения в поле ввода.

Рис. 5

Поля ввода – применяются для ввода в них значений как непосредственно с клавиатуры, так и с использованием кнопок list выпадающего списка (рис. 5) и кнопок прокрутки [image] (рис. 6). Щелчок на стрелке вверх увеличивает значение, на стрелке вниз – уменьшает. Если это поле предназначено для ввода даты, то можно выделить один из ее фрагментов (день, месяц, год) и с помощью стрелок изменить только его.

Рис. 6

Таблицы – предназначены для визуального просмотра или редактирования списка данных. Каждая строка таблицы (рис. 7) называется записью и содержит информацию об одном элементе списка (объекте или документе). Столбцы таблицы имеют заголовок. Каждая запись (строка) содержит одинаковый набор поименованных полей (столбцов таблицы). Каждое поле в таблице характеризуется своим значением. Например, поле "Имя" в первой строке содержит значение "Валентин".

В таблице (табличном списке) можно выбрать одну или несколько строк. Выбранные строки по умолчанию окрашиваются синим цветом. Выбор строки в таблице выполняется двойным или одинарным щелчком мыши. Возможен выбор нескольких подряд идущих строк при удержании нажатой клавиши Ctrl.

Рис. 7

Полосы прокрутки – позволяют перемещать вверх/вниз и влево/вправо текст, расположенный в окне, в полях списках, в выпадающих списках (рис. 5) или в таблицах (рис. 7). Полосы расположены вдоль вертикальной и горизонтальной границы перечисленных выше графических элементов. Каждая полоса прокрутки содержит по краям стрелки прокрутки и внутри горизонтальный (вертикальный) бегунок для перемещения по тексту или списку. Стрелки прокрутки позволяют перемещаться только на строку вверх (вниз), или вправо (влево). Бегунок применяется для перемещения по тексту, когда он невидим и уходит за вертикальные границы окна, списка или таблицы. Для этого нужно щелкнуть мышью на бегунке и при нажатой правой клавиши мыши перемещать его в нужном направлении.


Стандартный набор кнопок

Дополнительная панель инструментов, в отличие от основной панели содержит переменный набор инструментальных кнопок. Состав кнопок дополнительной панели инструментов определяется автоматически программой и зависит от вида активного окна и действий, доступных в нем.

В данной теме описано назначение кнопок, наиболее часто используемых в окнах программы. Назначение остальных редко используемых кнопок описано непосредственно в теме, посвященной функционированию окна, где она применяется.

Большая группа кнопок из ниже перечисленных применяется для выполнения стандартных операций при работе с данными, представленными в табличном виде. Часть кнопок предназначена непосредственно для работы с окнами (открытие окна, закрытие окна с сохранением данных или без сохранения).

Добавить F3 Added

Добавление новой строки в таблицу, расположенную в окне.

Удалить F8 TabDel

Удаляет выделенную в таблице строку, на которой установлен курсор. Перед удалением сведений обычно открывается окно сообщений, чтобы в случае ошибочного нажатия на кнопку "Удалить" пользователь имел возможность отменить свои действия, нажав на кнопку "Нет".

Внимание. Удаление не производится, если в базе данных имеется ссылка на эту строку.

Открыть PanelRep4

Для выделенной строки в таблице открывает карточку, содержащую более детальные сведения. Это же действие можно выполнить двойным щелчком мыши по строке списка.

Отчет RepForm

Формирует отчет на основании исходных данных, отображенных в окне, и сделанных настроек.

ОК

Выход из справочника с сохранением внесенных в него изменений

Отмена

Выход из справочника без сохранения введенных изменений

Выход

Закрывает текущего окна с сохранением сделанных изменений.


Действия, выполняемые мышью

При работе с мышью следует различать следующие действия: "щелчок", "двойной щелчок", "нажать на кнопку", "перетащить и отпустить" объект.

Щелчок

Для выполнения "щелчка" следует быстро нажать и отпустить левую кнопку мыши.

Двойной щелчок

Для осуществления "двойного щелчка" нужно дважды нажать на левую кнопку мыши с минимальным интервалом между нажатиями.

Нажать на кнопку

Операции "нажать на кнопку" в диалоговом окне означает следующее:

· установить указатель мыши на кнопке;
· нажать левую кнопку мыши и отпустить ее.

В результате будут выполнены действия, для которых предназначена эта кнопка.

Перетащить и отпустить

Метод "перетащить и отпустить" означает следующую последовательность действий:

1. установить указатель мыши на нужный объект, например, на строку;
2. нажать левую кнопку мыши;
3. не отпуская копку, переместить указатель мыши на нужную позицию экрана, при этом одновременно с мышью перемещается и объект (строка);
4. отпустить кнопку мыши.


Общее понятие о справочниках

Работа с программой "АиТ:\Управление обучением" начинается с заполнения справочников служебной информацией, необходимой для планирования и ведения процесса обучения персонала.

В данной программе, как и в других программах комплекса “АиТ:\Управление персоналом” справочник – это средство для просмотра и формирования всевозможной справочной информации об однотипных объектах (курсах обучения, сотрудниках предприятия, подразделениях, должностях и др.). Они служат для удобства работы пользователя и исключения ошибок при вводе одинаковой информации.

Каждый справочник имеет собственное имя, по которому он распознается в программе и базе данных. Данные каждого справочника хранятся в отдельной таблице базы данных программы. Информация в справочниках структурирована, т.е. на экране содержимое справочника отображается в отдельном окне в виде таблицы. Каждая строка (запись) таблицы содержит сведения об одном однотипном объекте, для которого и предназначен данный справочник, и имеет одинаковый набор полей (столбцов таблицы). Все столбцы таблицы снабжены заголовками, характеризующими их назначение.

Вызов справочников для просмотра и редактирования осуществляется с помощью соответствующих пунктов раздела "Справочники" Главного меню. Данные справочников в программе используются в качестве исходных данных для формирования других справочников и выпадающих списков, позволяющих автоматизировать ввод значений в различные поля ввода списков, карточек и документов.

В программе все справочники разделены на две группы:

· обязательные – справочники, заполнение которых обязательно для планирования и ведения обучения;
· дополнительные – справочники заполняются по мере необходимости, данные этих справочников используются как дополнительные аналитические признаки для группировки данных в сформированных отчетах.

Работа со справочниками стандартизирована и осуществляется с помощью кнопок, расположенных на дополнительной панели инструментов.

При работе в сети информация справочников может быть одновременно доступна для просмотра и редактирования нескольким пользователям в зависимости от их прав доступа. Настройка прав доступа в этой версии осуществляется системным администратором в модуле "АиТ:\Конфигурация" в режиме "Редактирование списка ролей", который вызывается с помощью пункта "Роли" раздела "Режим" Главного меню.


Справочник курсов

Справочник курсов заполняется пользователем самостоятельно. Курс является основной единицей учета обучения в программе, поэтому заполнение этого справочника обязательно. В справочнике должны быть перечислены все курсы, по которым проводится обучение на предприятии, и законченные сотрудниками текущей организации самостоятельно без ее участия. Кроме того, в справочнике также должны быть отражены курсы, которые сотрудник закончил, еще до поступления на текущее предприятие, чтобы зафиксировать эти сведения в его персональной карточке.

Вызов справочника курсов (рис. 1) производится из пункта "Курсы" раздела "Справочники".

Рис. 1

Количество отображаемых в списке курсов зависит от настройки справочника. Все курсы можно классифицировать по видам направлений обучения, определенным в справочнике "Направления обучения". Для крупных организаций в целях лучшей обозримости больших списков курсов целесообразно отображать весь список не полностью, а по одному выбранному направлению обучения. Для показа всех курсов нужно в верхнем поле задать значение "Все направления".

Для показа в справочнике отдельно плановых курсов, организованных в рамках обязательного регламентного обучения, нужно установить флаг "Только плановые курсы". Для просмотра всех курсов флаг следует снять.

Заполнение справочника ведется с помощью карточки курса, доступ к которой осуществляется кнопкой "Открыть" Open. Исключение учебного курса из списка осуществляется кнопкой "Удалить" Del после подтверждения пользователем этого действия.

Внимание. Удаление курса производится только при отсутствии на него ссылок.


Карточка курсов обучения

Карточка курса обучения (рис. 1) используется для заполнения обязательного справочника курсов и открывается из справочника кнопкой "Открыть" Open дополнительной панели инструментов.

Рис. 1

В карточке заполняются следующие поля:

· Наименование курса – уникальное (не повторяющееся) текстовое название курса;
· Плановый курс – признак, по которому курс становится доступен в режиме "Регламентное обучение". По умолчанию этот флаг включен;
· Направление обучения – признак, используемый в аналитических отчетах, заполняется из выпадающего списка, созданного на основании данных справочника направлений обучения. Поле целесообразно заполнять для лучшей обозримости списка курсов в справочнике курсов;
· Вид обучения – заполняется из выпадающего списка, сформированного по данным справочника видов обучения;
· Средняя стоимость обучения одного слушателя – рекомендованная стоимость обучения в рублях, затраченная на одного слушателя, поле можно заполняться непосредственно при вводе в справочник нового курса;
· Код – краткий идентификатор курса;
· Описание курса – подробное описание, отражающее суть проводимого обучения.

При первом открытии карточки в момент ее создания она отображается полностью с показом блока "График возможных занятий". После того как карточка курса сформирована и включена в справочник блок "График возможных занятий" не показывается. В том случае, когда для данного курса необходимо указать график возможных занятий следует открыть справочник центров обучения.

График возможных занятий используется при заполнении карточки учебной группы.

Для создания нового графика следует задать учебный год и нажать на кнопку "Добавить", в таблице появляется новая пустая строка, в которую вводятся следующие сведения:

· Дата начала – дата начала обучения;
· Дни, Часы – длительность обучения в календарных днях и суммарное количество учебных часов;
· Человек в группе – рекомендуемое количество человек в группе;
· Цена для 1 чел. – стоимость обучения одного обучаемого.

После заполнения всех обязательных полей карточки (рис. 1) следует нажать на кнопку "ОК", чтобы информация о курсе была введена в справочник курсов.


Справочник центров обучения

Справочник центров обучения является обязательным для заполнения и используется для просмотра информации обо всех организациях (центрах обучения), проводящих обучение по конкретным курсам.

Вызов справочника (рис. 1) производится из пункта "Центры обучения" раздела "Справочники" Главного меню. Быстрый доступ к справочнику центров обучения осуществляется кнопкой "Учебные центры" PanalSchollCentr дополнительной панели инструментов. Справочник формируется после заполнения справочников мест проведения обучения и форм обучения.

Список центров обучения, отображаемых в справочнике (рис. 1) зависит от настройки полей в верхней части справочника. Наиболее полный список центров обучения отображается в справочнике, если в поле "Курсы" введено значение "Все курсы", в поле "Место обучения" – "Все места" в поле "Форма обучения" – "Все формы". Если в поле "Курс" выбран конкретный курс обучения, то в списке центров отображаются центры, в которых проводится обучение по данному курсу.

Рис. 1

В справочнике фиксируются все организации, проводящие инструктажи, обучение и тренинги для сотрудников текущей организации. Справочник заполняется с помощью карточки учебного центра. Для ввода сведений по новому учебному центру следует нажать на кнопку "Добавить" Added.

В карточке учебного центра приводится подробная информация о самом центре (почтовый и электронный адрес, контактный телефон, место проведения занятий и др.), а также отображается список учебных курсов, которые центр обучения может проводить, с указанием их характеристик (даты начала, формы обучения, продолжительности обучения в днях и часах, стоимости обучения одного слушателя).

Кнопка "Открыть" Open открывает карточку выбранного в справочнике учебного центра для просмотра всех курсов, проводимых центром, и ввода новых курсов обучения.

Для удаления текущего центра обучения и сведений о нем из базы данных следует нажать на кнопку "Удалить" Del. Операция удаления возможна при выполнении двух условий:

· подтверждения осуществления этой операции, нажав на кнопку "Да" (рис. 3.4);

Рис. 3.4

· отсутствия сведений о в персональных карточках сотрудника, отсутствие групп или сотрудников, прошедших обучение в текущем центре. Если второе условие не выполняется, программа выдает соответствующее предупреждение (рис. 3.5).

Рис. 3.5.


Карточка учебного центра

Карточка учебного центра открывается из справочника центров обучения кнопкой:

· "Добавить" Added – для ввода сведений по новому центру обучения;
· "Открыть" Open – для просмотра или редактирования сведений по уже введенному в справочник учебному центру.

Карточка предназначена для отображения информации об одном учебном центре и разделена на две части.

В верхней части карточки расположены поля для отображения подробной информации о самом центре (названии центра, почтовом и электронном адресах, о контактном телефоне, месте проведения занятий.) Все эти поля заполняются вручную, кроме поля "Место обучения", значение в которое вводится из выпадающего списка, сформированного на основании справочника мест проведения обучения.

Внешний вид нижней части карточки зависит от выбранной закладки. На закладке "Учебные курсы" (рис. 1) отображается список курсов, проводимых текущим центром обучения. Пользователь может редактировать список курсов с помощью кнопок "Добавить" Added и "Удалить" Del . Кнопка "Открыть" Open открывает карточку курса, где можно задать график возможных занятий.

Рис. 1

После нажатия на кнопку "Добавить" в таблице появляется новая пустая строка, в которую вводятся следующие сведения:

· Наименование курса – наименование курса;
· Форма обучения – форма обучения;
· Дата начала – дата начала обучения;
· Дни, Часы – длительность обучения в календарных днях и суммарное количество учебных часов;
· Человек в группе – рекомендуемое количество человек в группе;
· Цена для 1 чел. – стоимость обучения одного обучаемого.

Поля "Наименование курса" и "Форма обучения" заполняются из выпадающих списков, которые формируются на основании данных справочников курсов и форм обучения. Остальные поля заполняются вручную.


Справочник оценок результатов обучения

Механизм оценки эффективности обучения позволяет провести сравнительную оценку качества работы того или иного учебного центра и выбрать наиболее оптимальный из них. Описание оценок проведенного обучения приводится в справочнике оценок результатов обучения (рис. 1).

Рис. 1

Справочник открывается из пункта "Оценки результатов обучения" раздела "Справочники" и заполняется пользователем программы стандартным способом. В первый столбец "Оценка" можно ввести цифровое или символьное значение, характеризующее получаемые слушателем знания. Эти значения используются для оценки, выставляемой слушателям по окончанию курса.

Целесообразно ввести весь спектр оценок качества результатов обучения от минимальной оценки до максимальной оценки. Количество используемых оценок в справочнике не ограниченно. По результатам полученных за обучение оценок можно выбрать наиболее оптимальный учебный центр для последующего обучения сотрудников. Более точная оценка будет получена, если использовать несколько факторов: качество преподавания, стоимость обучения и уровень организации курсов.

Данные справочника используются также для оценки обучения сотрудников. Если сотрудник получил за обучение оценку "Неудовлетворительно", то он считается не прошедшим обучение, и для получения свидетельства об окончании курсов должен пересдать выпускной экзамен по данному курсу.


Справочник оснований обучения

Справочник содержит перечень оснований, по которым сотрудники могут быть включены в план обучения. В качестве основания может быть указана статья законодательства РФ для регламентного обучения или внутрикорпоративный документ для прочих видов обучения с указанием его номера и даты вступления в силу.

Справочник оснований обучения (рис. 1) формируется стандартным способом, используя кнопки дополнительной панели инструментов.

Рис. 1

Сведения, введенные в справочник, используются при заполнении карточки с параметрами обучения сотрудников для указания причины, по которой сотрудник включается в план обучения.


Справочник направлений обучения

В крупных организациях с большой численностью персонала и с разнообразными видами обучения список курсов становится трудно обозримым. Для удобства работы с большим количеством курсов целесообразно их классифицировать по видам направления обучения, чтобы иметь возможность просматривать курсы по одному выбранному направлению. Для реализации такой возможности и используется данный справочник (рис. 1), в котором хранятся используемые в организации направления обучения.

Рис. 1.

Например, можно создать такие направления обучения, как курсы повышения квалификации по специальности, общеобразовательные курсы, курсы, напрямую не связанные со специальностью, но повышающие общий уровень развития персонала (курсы иностранных языков, курсы по информационным технологиям и др.).

Для создания нового направления обучения следует нажать на кнопку "Добавить" Added. Программа также позволять откорректировать вручную ранее введенное направление. Для добавления этого направления в список необходимо перед закрытием справочника направлений нажать на кнопку "ОК" [image]. В результате новое или исправленное направление будет отображаться в выпадающем списке поля "Направление обучения" справочника курсов.


Справочник видов обучения

В справочнике (рис. 1) перечисляются стандартные и пользовательские виды обучения, которые используются на текущем предприятии. Стандартные виды обучения вводятся в справочник программой автоматически, их нельзя ни отредактировать, ни удалить.

К стандартным видам обучения, относящимся к регламентному типу обучения, относятся:

· периодическое – обучение, которое сотрудник должен обязательно проходить с установленной периодичностью;
· стартовое – обучение, которое сотрудник обязательно должен пройти при вступлении в должность.

Рис. 1

Остальные виды обучения, могут добавляться в справочник непосредственно пользователем стандартным способом, используя кнопки дополнительной панели инструментов.

Пользовательские виды обучения, например, переподготовка, повышение квалификации и др. вводятся в справочник непосредственно самим пользователем программы.


Справочник форм обучения

Справочник используется для описания форм обучения, которые применяются в учебных центрах, и заполняется по мере необходимости. Разные учебные центры могут проводить обучение по одному и тому же курсу, используя разные формы обучения.

Программа позволяет использовать различные формы обучения сотрудников (групповые, индивидуальные, электронные, в рабочее или вне рабочее время и т.п.). Рекомендуемая для конкретного сотрудника форма обучения зависит от его особенностей и результатов предшествующего обучения. Выбор формы обучения производится на основании всех имеющихся форм обучения, внесенных пользователями в данный справочник (рис. 1).

Рис. 1

Каждая форма обучения характеризуется своим наименованием. Заполнение справочника производится стандартным способом с использованием кнопок дополнительной панели инструментов. Для сохранения введенной формы обучения в справочнике нажмите на кнопку [image].


Справочник мест проведения обучения

Справочник мест проведения обучения (рис. 1) используется для описания территориального расположения центров обучения.

Географическое местоположение курсов обучения, в частности, их удаленность от места работы обучающихся сотрудников, является одной их характеристик, учитываемых при выборе учебных центров обучения.

В текущей версии программы данный справочник используется для заполнения адресов мест центров обучения, в которых проводилось обучение сотрудников.

Пополнение данных справочника происходит в процессе работы с программой с использованием кнопок дополнительной панели инструментов.

Рис. 1


Справочник должностей

Справочник заполнять не требуется, т. к. он формируется в программе "АиТ: Кадровый учет" или "АиТ: Зарплата". В связи с этим программа не может функционировать изолированно, а только совместно с программой "АиТ: Кадровый учет" или "АиТ: Зарплата".

Данные справочника хранятся в общей для всех программ базе данных комплекса "АиТ: Управление персоналом". Справочник содержит список имеющихся в текущей организации должностей (рис. 1), поэтому в данной программе запрещается добавлять новые строки в справочник или удалять существующие строки.

Рис. 1

Основные поля справочника в программе "АиТ:\Управление обучением" доступны только для просмотра. Редактировать разрешается только поле "Ранг", которое может быть использовано для создания аналитических отчетов. Ввод данных в поле осуществляется из выпадающего списка, сформированного на основании данных справочника рангов.


Справочник должностных рангов

Справочник должностных рангов (рис. 1) предназначен для создания перечня рангов, привязываемых к должности. Должностной ранг характеризуется приоритет занимаемой должности и определяет местоположение должности в структуре организации. Должностной ранг используется как аналитический признак для группировки должностей в отчетах.

Наличие рангов позволяет построить систему обучения для каждого ранга должности отдельно, назначив им определенный набор курсов. При таком подходе достигается однородность учебных групп по квалификации обучаемых сотрудников.

Рис. 1

Каждый ранг характеризуется своим уникальным номером и наименованием. Добавление нового ранга в справочник осуществляется кнопкой Added. В справочнике появляется новая строка, в которую вводятся числовое значения номера ранга и его наименование.

При необходимости, список рангов можно отредактировать вручную, изменив его наименование. Удаление неиспользуемого ранга из справочника выполняется кнопкой Del, при этом удаляемый ранг должен быть выделен.


Справочник проверок на дату

Справочник "Проверка на дату" (рис. 1) используется для составления условий, по которым будет проводиться оповещение пользователя о наступлении той или иной даты (например, истечение периода регламентного обучения).

Справочник "Проверка на дату" позволяет выдавать пользователю список сотрудников, для которых в базе данных наступили некоторые события, связанные с датами (например, в персональной карточке появилась строка о назначенном регламентном обучении).

Оповещение о наступлении дат производится при запуске программы или принудительно при выборе пункта меню "Проверка на дату" раздела "Сотрудники".

Рис. 1

Автоматическое добавление строк с запланированным обучением осуществляется средствами SQL сервера. Производится ежедневная проверка периода обучения, если условие выполняется , то в персональную карточку сотрудника добавляется строка со статусом "Включен в план". Список вновь запланированных сотрудников формируется посредством режима "Проверка на дату" или при помощи дополнительных отчетов.


Список сотрудников

Список сотрудников (рис. 1), работающих на текущем предприятии, открывается в момент запуска программы одновременно с основным окном. Кроме этого, окно “Список сотрудников” вызывается кнопкой panal3 панели инструментов либо из одноименного пункта раздела "Сотрудники" Главного меню.

Рис. 1

Окно “Список сотрудников” разделено на две панели. На левой панели отображается структура предприятия с показом филиалов и подразделений. Для каждого подразделения, выделенного в дереве структуры зеленым цветом, указывается название и код.

На правой панели можно отобразить полный или частичный список сотрудников. Для показа полного списка всех сотрудников предприятия необходимо в дереве структуры выбрать название предприятия (верхняя строка со значком Perslist2 ). В конце списка отображается общее число сотрудников предприятия, включая уволенных, а также число работающих. Список всех сотрудников упорядочен по подразделениям, а внутри каждого подразделения – по порядку табельных номеров. Изменение порядка сортировки осуществляется двойным щелчком мыши на заголовке колонки, по значениям которой нужно отсортировать список. Для каждого сотрудника в списке указывается табельный номер, Ф.И.О., занимаемая должность.

При выборе филиала или подразделения в списке отображаются только сотрудники выбранного филиала (и подчиненных ему подразделений) или подразделения. В этом случае в конце списка приводится количество сотрудников в выбранном филиале или подразделении.

Фамилии сотрудников предприятия в зависимости от их статуса в списке помечены разным цветом: синим – штатные сотрудники (принятые на должность в рамках штатного расписания), черным – внештатные, серым – уволенные (имеющие в карточке дату увольнения). В списке сотрудников текст в колонках "Должность" и "Табельный номер" для сотрудников, временно принятых на работу, отмечается оттенком красного цвета:

· ярко-красным цветом – если срок временной работы уже истек;
· темно-красным цветом – если срок временной работы еще не закончился.

Сотрудники, являющиеся внутренними совместителями, отображаются в списке более одного раза. На каждое место работы сотрудника по внутреннему совместительству создается отдельная кадровая карточка с другим табельным номером. С целью обеспечения наглядности просмотра списка табельный номер внутреннего совместителя выделен желтым цветом, внешнего совместителя – зеленым цветом.

Для поиска сотрудника в списке используются два поля, расположенные под списком сотрудников. Для поиска сотрудника по фамилии (табельному номеру) необходимо ввести одну или несколько начальных букв (цифр) в поле "Поиск", при этом курсор автоматически переместится на строку с данными выбранного сотрудника. Поиск сотрудников можно также выполнять по названию подразделения. Для этого в поле "Найти по подразделению" из выпадающего списка вводится нужное подразделение, курсор автоматически позиционирует на строке с данными первого сотрудника этого подразделения.

Внимание. Поиск в списке осуществляется, начиная с текущей строки.

Для выполнения действий со списком сотрудников используются кнопки, расположенные на дополнительной панели инструментов.

Сортировка по фамилиям panal3

Упорядочивание списка сотрудников в алфавитном порядке, независимо от подразделения, в котором он числится. В этом случае список сотрудников дополнен столбцом "Подразделение". Такая возможность может быть полезна при поиске сотрудника, для которого подразделение неизвестно.

Обновить Refresh

Обновление сведений в списке сотрудников, т.е. отображения списка в соответствии с произошедшими изменениями в ФИО, подразделении или должности сотрудника, а также при проведении приказа о приеме на работу либо перемещении. Данная операция необходима, т.к. в случае изменений указанных данных при открытом окне списка не происходит их автоматического обновления.

Открыть Open

Открытие персональной карточки выделенного в списке сотрудника. Это же действие можно выполнить двойным щелчком мыши по фамилии сотрудника. Содержание карточки и состав закладок зависит от настройки персональной карточки.

Выход Door

Закрытие окна с сохранением введенной информации. Чтобы закрыть окно без сохранения данных, нажмите на кнопку [image] в левом верхнем углу окна.


Настройка персональных карточек

Персональные и производственные данные сотрудника, отображаемые в персональной карточке, доступны только для просмотра и формируются в кадровой карточке сотрудника в программе "АиТ:\Кадровый учет", за исключением закладки "Список курсов". Эта закладка в отличие от остальных шести закладок всегда отображается в персональной карточке в силу важности сведений, приводимых на ней.

В соответствии с терминологией программного комплекса "АиТ:\Управление персоналом" закладки в кадровых карточках могут быть трех видов: стандартные, дополнительные и настраиваемые. Заголовки в стандартных закладках назначаются автоматически, поэтому они одинаковы для всех пользователей, заголовки остальных закладок определяются самим пользователем.

Персональная карточка может содержать следующий набор закладок:

· Список курсов – формируется непосредственно в программе "АиТ:\Управление обучением", содержит список всех курсов, законченных сотрудником или только планируемых для его обучения;
· Образование – стандартная закладка, содержит сведения о полученном сотрудником образовании и о специальных формах пройденного им обучения.
· Дополнительно – стандартная закладка, открывает доступ к дополнительным закладкам, для показа дополнительных сведений, определенных пользователем по своему усмотрению;
· настраиваемые закладки – формируются на основании созданных пользователем настраиваемых таблиц в программе "АиТ:\Кадровый учет". Для каждой настраиваемой закладки должна быть создана собственная настраиваемая таблица. Количество настраиваемых закладок (таблиц) ограничивается самой программой и не может быть больше четырех. В качестве названия этих закладок используется название соответствующей настраиваемой таблицы, заданное самостоятельно пользователем, поэтому, естественно, названия этих закладок для различных пользователей отличаются. Однако если пользователь не задал имя таблицы в программе "АиТ:\Кадровый учет", то имя закладки задается по умолчанию "Таб. 1", "Таб. 2" и т.д. Количество столбцов, отображаемых на этих закладках, и их названия задаются пользователем в настраиваемой таблице. Данные, содержащиеся на закладках, являются уникальными и определяются самим пользователем.

Итак, персональная карточка может содержать не более семи закладок ("Список курсов", "Образование", "Дополнительно" и четыре настраиваемые закладки). Однако фактическое количество закладок, отображаемых в персональной карточке, зависит от настроек пользователя.

Выбор закладок, которые будут отображаться в персональной карточке, производится в окне "Настройка персональной карточки (рис. 1). Доступ к окну осуществляется из пункта "Настройка карточек" раздела "Сотрудники". Те закладки, слева от названия которых установлен флаг, будут отображаться в персональной карточке.

Рис. 1

Количество заголовков закладок, приведенных в окне (рис. 1) зависит от настроек, установленных в модуле "АиТ:\Конфигурация" в окне "Редактирование списка полей" (рис. 2). Если пользователь задал полный доступ к двум основным и четырем дополнительным закладкам (настраиваемым таблицам), то в окне "Настройка персональной карточки" должны показываться заголовки шести закладок.

В рассматриваемом случае на рис. 2 установлен полный доступ к двум закладкам и двум настраиваемым таблицам, поэтому в окне "Настройка персональной карточки" (рис. 1) показаны только четыре закладки. Те закладки, слева от названия которых установлен флаг, будут отображаться в персональной карточке. Т.к. установлено четыре флага, то в персональной карточке будут отображаться все четыре закладки, приведенные в окне (рис. 1).

Рис. 2


Персональная карточка

Персональная карточка содержит необходимые персональные и производственные данные сотрудника, а также историю его обучения на предприятии. Карточка (рис. 1) открывается из списка сотрудников двойным щелчком мыши по строке с фамилией сотрудника или кнопкой "Открыть" Open.

В верхней части карточки указываются персонифицированные сведения о сотруднике, такие как фамилия, имя, отчество, табельный номер, занимаемая должность, подразделение, в котором он работает в настоящее время, даты рождения, приема на предприятие и увольнения. Эти сведения предназначены только для просмотра, редактировать их в этой программе запрещено.

Рис. 1

В средней части карточки расположены кнопки (закладки) для перехода на нужную закладку. В каждый момент времени только одна закладка является текущей (активной), данные которой отображаются на экране. Сведения, приведенные в верхней части карточки, не изменяются при смене текущей закладки. Переход на нужную закладку выполняется щелчком мыши по одноименной кнопке (закладке).

Содержание закладок

Программа позволяет отображать в персональной карточке не все закладки, а только выбранные пользователем в окне Настройка персональных карточек".

Если пользователь в этом окне не выбрал никаких закладок, то в персональной карточке будет видна только одна закладка "Список курсов", которая всегда отображается в персональной карточке и не зависит от выбора пользователя.

Обращаем внимание пользователей на тот факт, что сведения, отображаемые на остальных закладках, берутся с одноименных закладок кадровой карточки программы "АиТ:\Кадровый учет". Данные на этих закладках используются только для просмотра, редактировать их запрещено.

Закладка "Список курсов"

На этой закладке приводится список всех курсов (рис. 1), законченных сотрудником или только планируемых для его обучения. Список курсов формируется непосредственно в данной программе "АиТ:\Управление обучением". В списке курсов только один курс может быть текущим, он отмечается символом "стрелочка" StrelkaBlack. Список можно упорядочить по дате обучения, для этого следует дважды щелкнуть левой кнопкой на заголовке столбца "Дата".

Информация о курсах обучения сотрудника, которые он еще не закончил, может быть отредактирована. Для этих целей используются следующие кнопки дополнительной панели инструментов:

· "Добавить" Added – открывает карточку обучения, которая используется для ввода в персональную карточку информации о ранее пройденном обучении;
· "Включить в группу" EducationAssign – кнопка доступна, если на этой закладке имеется курс, по которому сотрудник включен в текущий план на обучение. Кнопка позволяет включить сотрудника в группу для обучения и открывает список групп для выбранного курса обучения;
· "Удалить" Del – используется для удаления текущего курса из списка. При этом сотрудник автоматически удаляется из списка учебных групп, если он был включен в группу, или списка планируемых сотрудников по текущему курсу;
· "Журнал перемещений" PersJur – обеспечивает доступ к данным по кадровым перемещениям сотрудника, приведенным в журнале кадровых перемещений.

Закладка "Образование"

Стандартная закладка "Образование" содержит две таблицы (рис. 2), ее название и структура определяются автоматически. В верхней таблице “Основное образование” может быть указано несколько видов образования, полученных сотрудником (например, среднее и высшее). Если в таблице перечислено несколько видов образования, одно из них обязательно должно быть задано как основное (профилирующее) в первой колонке "!".

Рис. 2

В нижней таблице “Дополнительные формы обучения” в качестве дополнительных форм обучения могут быть указаны различного рода курсы, сертификация, стажировка и т.д.

Закладки "Дополнительно"

Закладка "Дополнительно" содержит список дополнительных таблиц (рис. 3), созданных квалифицированным пользователем в программе "АиТ:\Кадровый учет".

Рис. 3

Такие таблицы могут содержать неограниченное количество записей (строк) на каждого сотрудника и, таким образом, служить для документирования изменений любых его персональных характеристик. Для просмотра сведений, приведенных в таблице, следует выделить ее (на рис. 3 это таблица "группировка персонала") и нажать на кнопку "Открыть" Open. В результате на экране вместо закладки "Дополнительно" отображается выбранная дополнительная закладка "группы" (рис. 4), имя закладки задается в настройках дополнительных таблиц в программе "АиТ:\Кадровый учет". А кнопка "Открыть" переименовывается в кнопку "Закрыть" Close.

Рис. 4

Для возврата на закладку "Дополнительно" следует нажать на кнопку "Закрыть" дополнительной панели инструментов.

Настраиваемые закладки

Заголовки настраиваемых закладок, их структура и состав данных определятся непосредственно самими пользователями программы "АиТ:\Кадровый учет". Теоретически настраиваемых закладок может быть четыре, на рис. 1 и 4 показаны две настраиваемые закладки "Медстраховка" и "Научные степени".

Закладка "Медстраховка" содержит сведения об имеющихся у сотрудника медицинских страховках с указанием даты их получения и медицинской страховой компании.

На закладке "Научные степени" вводятся сведения о присуждении сотруднику ученой степени с указанием названия научной степени и даты ее присвоения.


Карточка обучения

Карточка обучения (рис. 1) позволяет ввести в персональную карточку информацию о ранее пройденном обучении за прошлые годы по тем сотрудникам, для которых формирование учебного плана и списков учебных групп является нецелесообразным. Кроме этого, в карточку можно также внести информацию о самостоятельном обучении сотрудника, не включенном в план обучения.

Карточка обучения открывается из персональной карточки кнопкой "Добавить" Added .

Рис. 1

В карточку необходимо ввести данные:

· Учебный год – год, в котором пройдено обучение;
· Номер группы – поле не активно, т.к., таким образом, добавляется обучение за прошлые годы только по каждому сотруднику в отдельности;
· Наименование курса – выбирается из выпадающего списка, сформированного по данным справочника курсов;
· Центр обучения – выбирается из выпадающего списка (ранее заполненный справочник). Для выбора доступны только те центры, в которых добавлен данный курс;
· Место обучения – по умолчанию проставляется место нахождения центра обучения из справочника центров обучения, но его можно изменить, выбрав значение из выпадающего списка;
· Форма обучения - по умолчанию подтягивается из справочника "Учебных центров", но может быть выбрано из выпадающего списка;
· Дата начала – по умолчанию проставляется системная дата, но может быть отредактирована;
· Окончания – заполняется пользователем;
· Основание – при необходимости выбирается из справочника;
· Направившее подразделение – по умолчанию берется подразделение из персональной карточки, но может быть выбрано и из справочника;
· Уровень образования, Квалификация, Специальность, Приоритет – аналитические поля, пока не задействованные в механизме учета, по желанию могут быть заполнены пользователем посредством ввода с клавиатуры;
· Вид обучения – выбирается из выпадающего списка для обязательного обучения (периодическое/стартовое), для дополнительного обучения оставляется пустым;
· Документ – номер документа (диплома), удостоверяющего прохождение обучения. Проставляется посредством ввода с клавиатуры;
· От – дата документа, удостоверяющего прохождение обучения;
· Состояние – автоматически присваивается значение "Завершено", т. к. в персональную карточку вводится информация о ранее пройденном обучении.

Чтобы добавить данные в персональную карточку, нажмите на кнопку "ОК". При таком способе ввода информации фиксируется только факт прохождения обучения, номер группы не учитывается.


Включить в группу

Непосредственно включить в группу можно только сотрудника, который уже включен в план для обучения по заданному курсу. Для таких сотрудников в персональной карточке на закладке "Список курсов" в строке с данными по этому курсу обучения в столбце "Состояние" задано значение "Включен в план" (рис. 1), поэтому кнопка "Включить в группу" EducationAssign доступна. Для сотрудников, не включенных в план, кнопка не активна.

Рис. 1

После нажатия на кнопку "Включить в группу" открывается окно (рис. 2) со списком групп для обучения по заданному курсу. По каждой группе приводятся необходимые сведения даты начала и конца обучения, названия центра, места и формы обучения, а также стоимость обучения, позволяющие объективно оценить возможности обучения в группе. В окне (рис. 2) нужно выбрать группу и нажать на кнопку "ОК".

Рис. 2

В результате на экране появляется карточка обучения сотрудника с заполненными данными, в которую вносятся реквизиты выбранной группы, а также подразделение, направившее сотрудника на обучение.

В том случае, если превышена рекомендуемая численность группы, появляется соответствующее предупреждение (рис. 3). Чтобы включить сотрудника в группу, нужно нажать на кнопку "Да". В этом случае в персональной карточке сотрудника (рис. 1) в строке с выбранным курсом "Прикладная психология. НЛП" в столбце "Состояние" появится надпись "Включен в группу". Если в окне (рис. 3) была нажата кнопка "Нет", сотрудник не будет включен в группу и в столбце "Состояние" значение останется прежним "Включен в план".

Рис. 3


Журнал кадровых перемещений

Журнал кадровых перемещений (рис. 1) открывается из персональной карточки кнопкой "Журнал перемещений" PersJur дополнительной панели инструментов. Журнал создается в программе "АиТ:\Кадровый учет", в нем фиксируются все кадровые перемещения сотрудника с момента его приема на работу по настоящее время (до даты его увольнения с предприятия) с указанием даты перемещения, подразделения, должности, оклада, номера и даты приказа. В программе "АиТ:\Управление обучением" журнал кадровых перемещений используется только для просмотра, и редактировать его запрещается.

Рис. 1


Проверка на дату

В программе предусмотрен специальный режим, позволяющий осуществить проверку наступления события на заданную дату. Однако воспользоваться такой возможностью можно только после ввода в справочник "Проверка на дату" описания событий с указанием условий и дат их наступления.

Проверка наступления события на дату выполняется в окне (рис. 1), его вызов осуществляется из пункта "Проверка на дату" раздела "Сотрудники" Главного меню. В том случае, если в текущий календарный день отсутствуют сотрудники, удовлетворяющие условиям наступления событий, выдается предупреждающее сообщение, иначе – на экране появляется окно "Проверка на наступление даты".

Рис. 1

Это же окно "Проверка на наступление даты" (рис. 1) также будет открываться при каждом последующем входе в программу "АиТ:\Управление обучением" в том случае, если какие-либо даты удовлетворяют событию, приведенному в справочнике "Проверка на дату".

В окне "Проверка на наступление даты" отображается список сотрудников, для которых наступило событие, указанное в верхней части окна, а в колонке "Дата" приводится точная дата наступления этого события. Для каждого сотрудника указывается фамилия, инициалы, табельный номер, должность и подразделение, в котором он работает.

Приведенный список сотрудников можно распечатать или сохранить в виде отчета на текущем компьютере. Для этого нужно нажать на кнопку export и в окне (рис. 2) выбрать способ получения отчета:

· текстовый отчет – создается отчет для печати, на экране он не открывается, но показывается полное имя файла, в котором будет храниться отчет (рис. 4), и путь к нему;
· tab-separeted text – на диске создается текстовый файл, который можно будет открыть с помощью программы Word или Excel;
· Excel – отчет строится в формате *.xls с помощью программы Excel и сразу же и открывается на экране.

Рис. 2

Для построения отчета нажмите на кнопку "ОК". На экране сначала отображается бегущая строка с показом процента выполнения отчета (рис. 3).

Рис. 3

Если был выбран первый или второй способ, то после создания отчета показывается его местоположение в файловой системе компьютера (рис. 4). При выборе третьего способа построенный отчет отображается на экране компьютера.

Рис. 4

Рис. 1

Это же окно "Проверка на наступление даты" (рис. 1) также будет появляться при каждом последующем входе в программу "АиТ:\Управление обучением" в том случае, если какие-либо даты удовлетворяют описанию, приведенному в справочнике "Проверка на дату".

В окне "Проверка на наступление даты" приводится список сотрудников с перечислением названий событий и точных дат их наступления.


Фильтр

Фильтр позволяет отображать список сотрудников предприятия по одному или нескольким заданным условиям (критериям отбора).

Фильтр – это логическое выражение, записанное в виде одного или совокупности условий отбора данных, соединенных логическими "связками" (логическими операциями И, ИЛИ). Каждое условие (критерий) отбора описывается отдельной строкой и характеризуется названием параметра, по которому будет производиться отбор, и условием сравнения.

Установка фильтра, по которому выполняется отбор данных, производится в окне "Фильтр" (рис.1). Вызов окна происходит из пункта "Фильтр" раздела "Сотрудники" Главного меню программы или с помощью кнопки "Фильтр" Filtr основной панели инструментов.

В каждый момент работы программы фильтр может находиться в двух состояниях: установлен или снят (отбор сотрудников отсутствует). Наличие установленного в данный момент работы программы фильтра можно определить по внешнему виду кнопки “Фильтр” панели инструментов. При установке фильтра кнопка изображается на желтом фоне Filtr , при снятии фильтра – на сером фоне Panel9 .

Рис. 1

Закладка "Для пользователя"

Первая закладка (рис.1) позволяет установить или переустановить фильтр для списка сотрудников в табельном листе или отчетов, снять его, а также посмотреть установленный в текущий момент фильтр или список созданных фильтров.

В программе имеется возможность запоминать составленные фильтры под определяемыми пользователем именами и вызывать их впоследствии. Список уже составленных фильтров отображается на левой панели "Наименование" закладки. Для идентификации фильтров целесообразно озаглавливать фильтры таким образом, чтобы в них отражалось смысловое действие фильтра. Число строк (фильтров) в списке не ограничено. Добавлять, удалять и копировать фильтр под другим именем можно с помощью соответствующих кнопок дополнительной панели инструментов. Установленный в момент открытия закладки фильтр окрашивается в соответствующей строке списка голубым цветом.

В правой части закладки (рис. 1) расположены колонки для непосредственного формирования выражения фильтра, имя которого выделено в левой части окна:

· Название – указывается имя переменной, по которой происходит отбор сотрудников. Выбор переменной осуществляется из выпадающего списка, который открывается щелчком мыши. Список переменных в списке ограничен и зафиксирован в самой программе. В основном, в качестве переменных используются данные персональной карточки сотрудника.
· Условие – задается условие, которое может принимать одно из перечисленных значений: = (равно), <> (не равно), > (больше), >= (больше или равно), < (меньше), <= (меньше или равно), включает, пусто, не пусто, один из. Условие выбирается из выпадающего списка щелчком мыши. Условие "один из" позволяет выбрать несколько значений для отбора.
· Значение – в данное поле вводится значение переменной, по которому происходит отбор данных. Значение переменной можно вводить непосредственно с клавиатуры вручную (например, фамилия, подразделение и т.п.) или выбирать из списка значений (рис. 2), формируемого программой. Если для переменной (например, перечисления – Да/Нет), существует список фиксированных значений, то он открывается щелчком правой кнопки мыши.

Рис. 2

При выборе условия "включает" в поле "Значение" необходимо указать строку для поиска включения в следующем виде: %текст для поиска% или _текст для поиска_, где символ % заменяет несколько предшествующих / последующих символов, а символ _ (подчеркивание) – один символ.

· Расшифровка – поле недоступно для редактирования и заполняется автоматически одновременно с полем "Значение", когда значение в поле "Значение" заполняется из выпадающего списка, формируемого по данным справочника. В этом случае в поле "Значение" будет указан код по справочнику, а в поле "Расшифровка" – соответствующее ему наименование.
· ( ) – в этих колонках указываются скобки в тех случаях, когда необходимо определить логическую последовательность обработки условий фильтра.
· Связка – поле заполняется, когда формируемый фильтр содержит одновременно несколько условий, которые должны быть объединены логическими операциями (связками). Связка “И” означает, что оба условия должны выполняться одновременно, например, ОКЛАД>1.000.000 И ПОДРАЗДЕЛЕНИЕ =“0001”. Связка “ИЛИ” означает, что должно выполняться хотя бы одно из заданных условий, например, ФАМИЛИЯ=“Петров” ИЛИ ФАМИЛИЯ = “Иванов”.

Внимание. Если между условиями не установлена связка, то выполняется только первое из них, а следующее условие за отсутствующей связкой будет проигнорировано.

Действие фильтра распространяется на все режимы программы, кроме формирования сводов (простых и аналитических).

Если установленный фильтр предназначен для формирования выходных документов, то в первую строку файла этого документа заносится выражение, описывающее условие установленного фильтра, например:

Выбрано по условию: Табельный номер = 0001 и Номер подразделения <> 9999

Установка выбранного в списке фильтра происходит по нажатию кнопки "Поставить фильтр" Filtr дополнительной панели инструментов. Снятие условия фильтра – по нажатию кнопки "Снять фильтр" Panel9 . Если в момент формирования фильтра создаваемому логическому условию не отвечает ни один из сотрудников предприятия или если под действие этого условие подпадают все сотрудники, выдается предупреждение и фильтр не устанавливается.

Информация для продвинутых пользователей программы

Список полей и таблиц, по которым может быть установлен фильтр, зафиксирован в базе данных. Поэтому для расширения этого списка достаточно выполнить соответствующий скрипт на базе данных с помощью модуля "АиТ:/Конфигурация" или любого внешнего средства исполнения sql-запросов. За подробностями обращайтесь в отдел консультаций компании "АиТ софт".

Закладка "Для администратора SQL"

Вторая закладка окна "Фильтр" (рис. 3) позволяет задавать условие отбора данных на основании sql-запросов.

Рис. 3

Эта возможность полезна системным администраторам, консультантам и опытным пользователям. Такого рода запросы позволяют делать выборки более сложного характера, для которых требуется знание языка SQL и структуры базы данных программного комплекса "АиТ:\Управление персоналом".

Условия отбора, введенные на второй закладке окна "Фильтр", по кнопке [image] могут быть сохранены в виде файлов SQL запросов *.sql в папке \aitclient\hrm\Form рабочего каталога программы. При необходимости сохранные в файле условия отбора могут быть вновь загружены с помощью кнопки "Загрузить" [image] дополнительной панели инструментов. При этом сначала открывается стандартное окно Windows для выбора имени файла с SQL запросом. После выбора файла на экране появляется дополнительное окно (рис. 4) для ввода названия фильтра. После его закрытия кнопкой [image] на закладке (рис. 3) в столбце "Наименование" добавляется новая строка с указанным именем, а в правой части закладки отображается условие отбора, записанное в выбранном файле.

Рис. 4

Закрытие окна "Фильтр" (рис. 1) с сохранением введенной информации осуществляется кнопкой "Выход" TabDoor , без сохранения – кнопкой "Закрыть" [image] , расположенной в правом верхнем углу окна.


Этапы процесса обучения

Учебный процесс характеризуется различными этапами планирования и ведения обучения. Каждый этап фиксируется в базе данных и отражается в соответствующих режимах программы. Начинается процесс обучения с формирование плана регламентного обучения, т.е. формирования списка курсов, обязательных для должностей или отдельных сотрудников. Сотрудники направляются на курсы обучения менеджером по обучению согласно заявкам или профессиональной необходимости, а также автоматически согласно настройке регламентного обучения. Статус нахождения сотрудника на определенном этапе процесса планирования или выполнения обучения отражается в карточке обучения, карточке учебной группы и в персональной карточке сотрудника.

Итак, процесс обучения включает следующие этапы:

· формирование плана регламентного (обязательного) обучения – осуществляется в режиме "Регламентное обучение" для должности и сотрудников;
· составление списка планируемых на обучение сотрудников – сотрудники включаются в план обучения по каждому курсу тремя различными способами (автоматически, принудительно, в режиме "Обработка заявок на обучение" на закладке "Планируемые сотрудники" ). Для каждого включенного в план сотрудника формируется карточка обучения, а в его персональной карточке на закладке "Список курсов" добавляется строка с этими сведения, а в поле "Состояние" указывается "Включен в план";
· фиксация ранее пройденного обучения – производится в карточке обучения, открываемой из персональной карточки. Этот этап используется для тех видов обучения, которые сотрудники закончили до приема на текущее предприятие;
· заключение договора с учебным центром – сведения о заключении договора указываются в карточке учебной группы.
· формирование группы – по каждому курсу обучения в течение учебного года может создаваться несколько групп. Создание новой группы происходит в режиме "Обработка заявок на обучение" на закладке "Учебные группы". Реквизиты учебной группы фиксируются в карточке учебной группы;
· составление списка группы – список обучаемых в группе сотрудников формируется в режиме "Обработка заявок на обучение" на закладке "Учебные группы". Состав учебной группы комплектуется только на основания списка планируемых сотрудников, сформированного для конкретного курса, разрешенного в текущем учебном году;
· оплата за обучение – после проведения оплаты факт оплаты предприятием денежных средств за обучение в учебном центре по данному курсу фиксируется в карточке учебной группы;
· завершение обучения – на этом этапе состояние процесса обучения отмечается как "Завершено" в трех карточках и составляется протокол по результатам прохождения обучения. Номер и дата протокола фиксируются в карточке учебной группы. В карточках обучения сотрудников, входящих в состав группы, проставляется оценка качества проведения обучения, указывается документ об окончании курса и дата его получения. Эти же сведения передаются в персональную карточку и в режим "Обработка заявок на обучение";
· архивация данных – позволяет сохранить сведения по обучению в базе данных, при необходимости просмотреть на экране историю обучения сотрудников за все годы обучения;
· анализ эффективности обучения – осуществляется на основании сформированных отчетов на различных этапах обучения.


Типы и виды обучения

Обучение, поддерживаемое в данной программе, делится на следующие типы:

1. Регламентное (обязательное) обучение – проводится в соответствии с законодательством РФ или внутрикорпоративными правилами и может назначаться:

· для должности – единицей для учета такого обучения является должность, привязанная к подразделению (рабочему месту);
· для сотрудников – обучение, проводимое для одного или нескольких сотрудников.

Регламентное обучение для должности подразделяется на два вида:

· периодическое – обучение, которое сотрудник проходит регулярно с установленным периодом;
· стартовое – обучение, которое сотрудник должен пройти не позже установленного срока с момента вступления в эту должность.

Для сотрудников может быть назначено только периодическое обучение.

2. Ранее проведенное обучение – обучение, полученное до приема на текущее предприятие. Для ввода в персональную карточку сведений о ранее проведенном обучении используется карточка обучения.

3. Самостоятельное обучение – обучение, полученное по собственной инициативе пользователя, независимо от руководства предприятия.

4. Прочие типы обучения – обучение, проводимое по заявкам руководителей или самих сотрудников, необходимое для профессиональной деятельности сотрудников. К этому типу относятся пользовательские виды обучения, например, переподготовка, повышение квалификации и др., которые вводятся в справочник видов обучения непосредственно самим пользователем программы.


Формирование плана регламентного обучения

Регламентное (обязательное) обучение проводится в соответствии с законодательством РФ или внутрикорпоративными правилами и может назначаться:

· для должности, привязанной к подразделению (рабочему месту);
· для одного или нескольких сотрудников.

Для отслеживания сроков прохождения регламентного обучения необходимо сформировать план регламентного обучения с указанием периодов проведения обучения.

План регламентного обучения составляется в отдельном режиме (рис. 1). В левой части окна представлена структура предприятия с показом всех филиалов и подразделений. В правой части окна для всего предприятия или для выбранной структурной единицы (филиала или подразделения) отображается план регламентного обучения в табличном виде. Для каждой структурной единицы приводится список должностей, для которых проводится регламентное обучение, с указанием курса, периода и вида обучения.

Для его открытия окна (рис. 1) следует выбрать пункт "Регламентное обучение" в разделе "Планирование". При этом всегда открывается план регламентного обучения для должности и включен переключатель "Должности", для перехода к плану регламентного обучения для сотрудников следует установить переключатель "Сотрудники" в нижней части окна.

Рис. 1

Назначение регламентного обучения для должности

Единицей для учета регламентного (обязательного) обучения является должность, привязанная к подразделению. Для должности регламентное обучение может быть двух видов:

· Стартовое – это обучение, которое сотрудник должен пройти не позже установленного срока с момента вступления в эту должность;
· Периодическое – обучение, которое сотрудник проходит регулярно с установленным периодом.

Для формирования плана регламентного обучения в окне (рис. 1) необходимо для каждой должности, по которой предусмотрено регламентное обучение, указать курс, вид и период обучения, т.е. выполнить следующие действия:

· в блоке "Фильтр", расположенном в нижней части окна (рис. 1), установить переключатель "Должности";
· нажать на кнопку "Добавить" Added дополнительной панели инструментов. Открывается окно "Добавление регламентного обучения";
· в окне задать необходимые данные (должность, подразделения, курс и др.) и нажать на кнопку "ОК";
· в окне (рис. 1) будет добавлено столько строк, сколько заданных должностей имеется в выбранных подразделениях в окне "Добавление регламентного обучения".


Назначение регламентного обучения для должности

Настройка параметров для добавления курсов периодического и стартового обучения в план регламентного обучения для заданной должности выполняется в окне "Добавление регламентного обучения" (рис. 5.3). Для его открытия следует выполнить следующие действия:

· в блоке "Фильтр", расположенном в нижней части окна "Регламентное обучение", установить переключатель "Должности";
· нажать на кнопку "Добавить" Added дополнительной панели инструментов.

Рис. 5.3

В открывшемся окне (рис. 5.3) нужно задать параметры для добавления строк в план регламентного обучения:

· должность, для которой предусмотрено обязательное обучение, регламентируемое законодательством РФ или внутрикорпоративными правилами;
· структурные единицы, для которых в план нужно добавить курсы для выбранной должности. Структурные единицы можно задавать:
▪ по выбранным предприятиям;
▪ по филиалам (1 или 2 уровня);
▪ по подразделениям.
· курс и период (мес.) для периодического обучения;
· курс и контрольный период (мес.) для стартового обучения.

Для сохранения установленных параметров нажмите на кнопку "ОК". После закрытия окна в план регламентного обучения добавляются строки в выбранные структурные единицы, в которых имеется заданная должность. Для ввода других курсов в план регламентного обучения необходимо снова открыть окно (рис. 5.3) и повторить описанные выше действия.


Назначение регламентного обучения для сотрудника

План регламентного обучения может быть сформирован не только для должности, привязанной к подразделению, но и для отдельных сотрудников. Для составления или просмотра плана регламентного обучения сотрудников необходимо выбрать пункт "Регламентное обучение" в разделе "Планирование" и в окне "Регламентное обучение" (рис. 1) установить флаг "Сотрудники".

Рис. 1

Для сотрудников может быть назначено только периодическое обучение, а не стартовое. Для добавления одного или группы сотрудников в план регламентного обучения нужно:

· нажать на кнопку "Добавить" Added дополнительной панели инструментов. Открывается окно "Выбор сотрудников" (рис. 2);
· в окне (рис. 2) выделить одного сотрудника или нескольких сотрудников;
· в верхней части окна в выпадающем списке выбрать курс и проставить вручную период, задающий интервал проведения обучения;

Рис. 2

· нажать на кнопку "ОК", в результате окно (рис. 2) закрывается и выполняется проверка на правильный ввод данных. Например, если изменился период проведения обучения, то открывается дополнительное окно (рис. 3). Если все данные были введены правильно, то дополнительное окно не открывается, а в план регламентного обучения (рис. 1) добавляется столько строк, сколько было выбрано сотрудников для обучения;

Рис. 3

· в окне (рис. 3) для указанного сотрудника можно изменить период обучения, либо оставить период прежним, выбрав переключатель "Пропустить, не добавлять". В этом случае для указанного сотрудника в план (рис. 1) новая строка не добавляется. Однако если был выбран переключатель "Заменить период прохождения обучения", то для этого сотрудника в плане период будет изменен. Чтобы дополнительное окно (рис. 3) больше не открывалось, нужно установить флаг "Применить выбранную операцию для всех добавляемых строк". Для всех остальных сотрудников будет выполнена операция, выбранная для текущего сотрудника.


Удаление курсов из плана регламентного обучения

При наличии полного доступа на работу с режимом "Регламентное обучение" (рис. 1) пользователь может редактировать план регламентного обучения, т.е. добавлять новые курсы для должности и сотрудников, а также удалять курсы, уже включенные в план.

Рис. 1

Существуют два способа удаления курсов обучения из плана регламентного обучения. Первый способ используется для удаления курсов для должности и сотрудников, а второй способ – только для должности.

В первом способе необходимо в плане регламентного обучения для должности (установлен флаг "Должности", см. рис. 1) и для сотрудников (установлен флаг "Сотрудники"), выделить контрастным цветом строки, предназначенные для удаления, и нажать на кнопку "Удалить" [image] или на клавишу F8.

Выделенные строки удаляются из плана только после подтверждения пользователя на выполнение этой операции, т.е. после нажатия на кнопку "Да" (рис. 2).

Рис. 2

Во втором способе в плане регламентного обучения (рис. 5.4) для должности ничего не нужно выделять, а просто – нажать на кнопку "Удалить" [image]. На экране появляется окно "Удаление регламентного обучения" (рис. 3).

Рис. 3

Настройка параметров в этом окне выполняется так же, как и в окне "Добавление регламентного обучения", т. к. набор графических элементов в обоих окнах совпадает. В окне следует указать должность, подразделения, курс, период и и нажать на кнопку "ОК". После этого курсы, заданные в окне (рис. 2 )для выбранной должности, будут удалены из плана (рис. 1) из всех указанных структурных единиц, в которых имеется эта должность.


Включение сотрудников в учебный план

Согласно сформированному плану регламентного обучения включение сотрудников, планируемых на обучение, в учебный план текущего года осуществляется тремя различными способами:

· автоматически – средствами SQL сервера. Обновление информации производится ежедневно, в назначенное администратором время. Если должность и подразделение сотрудника совпадают с должностью и подразделением в плане регламентного обучения, то по истечении периода ему назначается регламентный курс;
· принудительно – этот способ применяется в тех случаях, когда сотрудник, нуждающийся в периодическом обучении, по какой-либо причине не был включен в учебный план. Принудительное назначение регламентного обучения возможно только для периодических (не стартовых) курсов. Для этого в режиме "Регламентное обучение" нужно выделить нужную строку и нажать на кнопку "Назначить сотрудникам" EducationAssign на дополнительной панели инструментов. В открывшемся окне проставить предполагаемую дату начала курса;
· в режиме "Обработка заявок на обучение" – на закладке "Планируемые сотрудники" этого режима можно ввести сотрудников в учебный план. Более подробно процесс включения сотрудников в учебный план по обучению описан в теме "Формирование списка планируемых сотрудников".

Независимо от способа формирования, сотрудники, запланированные на обучение в текущем учебном году, перечисляются на закладке "Планируемые сотрудники" окна "Обработка заявок на обучение", а также в персональную карточку этих сотрудников на закладку "Список курсов" добавляется строка со статусом "Включен в план".


Принудительное формирование списка сотрудников, планируемых на обучение

Формирование списка планируемых сотрудников, подлежащих обучению в выбранном учебном году, производится тремя различными способами. Независимо от способа сотрудники, планируемые на обучение в текущем году, попадают на закладку "Планируемые сотрудники" окна "Обработка заявок на обучение".

Принудительное включение сотрудников в список применяется в тех случаях, когда сотрудник, нуждающийся в периодическом обучении, по какой-либо причине не был добавлен в учебный план. Принудительное назначение регламентного обучения возможно только для периодических (не стартовых) курсов.

Для принудительного формирования списка планируемых сотрудников следует:

· выбрать пункт "Регламентное обучение" в разделе "Планирование" для открытия окна "Регламентное обучение" (рис. 1);

Рис. 1

· установить флаг "Должности", если в список попадают сотрудники, занимающие заданную должность в выбранных подразделениях;
· выделить нужную строку или строки с заданной должностью. Выделение строки производится двойным щелчком левой кнопки мыши;
· нажать на кнопку "Назначить сотрудникам" EducationAssign дополнительной панели инструментов
· в открывшемся модальном окне (рис. 2) проставить предполагаемую дату начала регламентного обучения и нажать на кнопку "ОК".

Рис. 2

· после успешного назначения курсов сотрудникам (рис. 3) в персональных карточках сотрудников на закладке "Список курсов" и в режиме "Обработка заявок на обучение" (рис. 6) в столбце "Состояние" указывается "Включен в план". Кроме этого формируется карточка обучения сотрудника, которую можно просмотреть из персональной карточки, нажав на кнопку "Карточка" Open.

Рис. 3

· в том случае, если в списке (рис. 1) были выделены сотрудники, повторно направленные на обучение в указанное время, для каждого такого сотрудника открывается окно (рис. 4), в котором указывается сотрудник и причина его ошибочного включения в список;

Рис. 4

· для того чтобы исправить возникшую недопустимую ситуацию, пользователю предлагается выбрать нужное действие:
1. перенести срок начала обучения, выбрав переключатель "Изменить дату начала";
2. отказаться от направления сотрудника на обучение, т. к. возможно сотрудник был включен в список ошибочно.

Если установить флаг "Применить выбранную операцию для всех добавляемых строк", то окно (рис. 4) больше открываться не будет.

· в том случае, если сотрудник уже включен в группу, то также открывается аналогичное окно (рис. 5) с сообщением, что добавление новой записи невозможно. Поэтому все действия запрещены, и переключатели неактивны.

Рис. 5

В тех случаях, когда выбранным сотрудникам не были назначены курсы, программа автоматически создает протокол с перечислением сотрудников, а путь к нему указывается в окне (рис. 6).

Рис. 6

В результате проделанных действий сотрудники, занимающие выбранные должности, за исключением тех, которые по требованию пользователя программы не были направлены на обучения, будут включены в список сотрудников, отображаемый на закладке "Планируемые сотрудники" для заданного курса (рис. 7). Все эти сотрудники включаются в список со статусом "вкл. в план". На следующем этапе на основании этого списка формируются учебные группы по заданному курсу.

Рис. 7


Формирование списка планируемых сотрудников

Закладка "Планируемые сотрудники" (рис. 1) окна "Обработка заявок на обучение" предназначена для формирования списка сотрудников, подлежащих обучению в выбранном учебном году, с указанием для каждого из них курса обучения. Список сотрудников может корректироваться в течение учебного года, однако, информация об уже проведенном обучении не подлежит исправлению. Для открытия окна следует в разделе "Планирование" Главного меню выбрать пункт "Заявка на обучение".

Сотрудник может включаться в план обучения как непосредственно менеджером отдела обучения, так и на основании заявок, поданных самим сотрудником или его руководителем. Для каждого запланированного сотрудника в списке приводятся следующие персонифицированные сведения: фамилия, имя и отчество с указанием его табельного номера, должности и подразделения. Кроме этого, приводится информация, относящаяся к учебному процессу: дата начала обучения, номер группы, форма обучения и статус сотрудника.

Учебный процесс характеризуется различными стадиями планирования или выполнения обучения. Статус нахождения сотрудника на определенной стадии планирования или выполнения обучения отражается в поле "Состояние", которое заполняется программой автоматически и может принимать следующие значения:

· вкл. в план – принята заявка на обучение, но еще не назначена дата и место обучения;
· вкл. в группу – сотрудник включен в одну из учебных групп, известно в каком учебном центре и в какие сроки будет проводиться обучение;
· завершено – обучение закончено. Такое значение поле "Состояние" получает после присвоения учебной группе признака "Закончено".

Рис. 1

Добавление сотрудников план обучения происходит кнопкой "Добавить" Added, при этом открывается дополнительное окно "Выбор сотрудников" (рис. 2) для выбора сотрудников.

Рис. 2

После выделения нужных сотрудников в списке следует нажать на кнопку "ОК" и указать дату, с которой планируется начать обучение (рис. 3).

Рис. 3

В том случае, если выбранный сотрудник уже включен в учебный план по выбранному курсу или по другому курсу, совпадающему по дате проведения обучения, выдается предупреждающее сообщение, например, такое, как приведено на рис. 4. Пользователь может изменить дату, и тогда сотрудник будет включен в список планируемых сотрудников.

Рис. 4

Те выделенные сотрудники, для которых все требования выполнены правильно, будут включены в список планируемых сотрудников со статусом "вкл. в план".

Если одноименный курс уже имеется в плане обучения сотрудника текущего учебного года, то он добавляется в список при условии, что сотрудник уже включен в группу или уже закончил обучения. В остальных случаях повторное включение не выполняется. В этом случае фамилия сотрудника отображается в списке на закладке "Планируемые сотрудники" формы "Список учебных групп" более одного раза.


Формирование учебных групп

Формирование учебных групп в новом учебном году для каждого курса обучения происходит заново. Для создания новой группы или просмотра сформированных ранее учебных групп используется закладка "Учебные группы" окна "Обработка заявок на обучение" (рис. 1).

Рис. 1

Вызов окна осуществляется из пункта "Заявка на обучение" раздела "Планирование". Закладка "Учебные группы" содержит две таблицы, количество строк и содержание которых зависит от настроек полей в верхней части окна. В верхней таблице приводится перечень учебных групп по выбранному курсу и году обучения. Для выбранной в верхней таблице группы в нижней таблице отображается список лиц, обучающихся в данной группе. Если список сотрудников, обучаемых в данной группе, не сформирован, нижняя таблица пустая.

Создание новой группы

Для создания новой группы по выбранному курсу нужно сначала заполнить карточку учебной группы, а затем сформировать список обучающихся в ней сотрудников. Формирования списка групп выполняется непосредственно пользователем программы.

Итак, для создания новой группы необходимо:

· в верхней части окна из выпадающего списка выбрать курс, по которому будет формироваться группа;
· щелкнуть мышью в верхней таблице окна, где приводится список групп;
· нажать на кнопку "Добавить" Added дополнительной панели инструментов для открытия карточки новой учебной группы. В карточке заполнить необходимую информацию и нажать на кнопку "ОК";
· по выбранному курсу в списке учебных групп будет добавлена новая строка с реквизитами, указанными в карточке учебной группы;
· далее для вновь созданной группы составляется список обучающихся в ней сотрудников.


Карточка учебной группы

Для каждой вновь создаваемой группы создается ее карточка учебной группы. Карточка формируется после того, как выбраны центр и место обучения, согласованы дата начала, длительность и стоимость обучения, а также заключен договор с центром.

Карточка предназначена для ввода сведений о новой учебной группе. После создания группы в карточку учебной группы по мере наступления какого-либо события, связанного с обучением в группе, вносятся сведения, отражающие это событие. Т. е. в карточке фиксируются такие этапы прохождения учебного процесса, как заключение договора, его оплата и завершение обучения.

Доступ к карточке происходит с закладки "Учебные группы" окна "Обработка заявок на обучение" кнопкой:

· "Добавить" Added дополнительной панели инструментов – в момент создания новой группы;
· "Открыть" Open дополнительной панели инструментов – для просмотра уже существующей карточки (рис. 1) и внесения изменений статуса группы.

Рис. 1

Заполнение карточки при создании новой группы

В карточке нужно заполнить следующие поля:

· Учебный год – год, в котором совершается обучение, при открытии карточки поле уже заполнено;
· Номер группы – порядковый номер группы, для их идентификации по номеру;
· Центр обучения – организация, которая обеспечивает процесс обучения сотрудников в группе, значение в поле вставляется из выпадающего списка, содержащего перечень только тех центров обучения, которые проводят занятия по данному курсу. Список составляется на основании карточек учебного центра;
· Место обучения, форма обучения – заполняется автоматически после выбора центра обучения, если эти сведения указаны в карточке учебного центра;
· Форма обучения – заполняется автоматически после выбора центра обучения, но можно вставить конкретную форму обучения из выпадающего списка предлагаемых форм, открываемого кнопкой [image] ;
· Дата начала – по умолчанию ставится системная дата, но ее можно отредактировать;
· Окончания – дата окончания занятий;
· Дни, Часы, Рекомендуемая численность, Стоимость – вводятся автоматически на основании данных карточки учебного центра. Если эти данные не введены, то после нажатия на кнопку [image] (см. рис. 1) появляется сообщение (рис. 2), и поля заполняются вручную.

Рис. 2

Если график занятий существует, то открывается окно (рис. 3) с реквизитами групп для заполнения сведений в карточке (рис. 1). Стоимость обучения указывается в расчете на одного обучающегося;

Рис. 3

· Состояние – стадия процесса обучения (заключен договор с учебным центром, произведена оплата за обучение или обучение завершено). В зависимости от стадии обучения в карточке устанавливается соответствующий флаг. При формировании карточки устанавливается флаг "Договор". При необходимости для бухгалтерской отчетности также указать сведения по договору: дату и номер договора. В результате в списке учебных групп в поле "Состояние" проставится значение "Договор".

После того как сформировали группу, реальная численность ее равна нулю. В карточке учебной группы численность указывается только после формирования списка обучающихся в группе сотрудников .

После проверки правильности введенных данных можно нажать на кнопку "ОК". Окно с карточкой закрывается и происходит возврат в режим "Обработка заявок на обучение", из которого карточка была вызвана.


Корректировка списка сотрудников в учебной группе

Формирование состава учебной группы осуществляется на закладке "Учебные группы" окна "Обработка заявок на обучение" (рис. 1). Для открытия окна следует в разделе "Планирование" Главного меню выбрать пункт "Заявка на обучение".

Для отображения списка сотрудников, обучающихся в группе по заданному курсу, предназначена нижняя таблица закладки. В каждой строчке таблицы указывается фамилия, имя и отчество сотрудника, его табельный номер и занимаемая должность, а также подразделение, в котором он работает. Список может быть отфильтрован по формам обучения и по рангам должностей.

Рис. 1

Для включения сотрудников в группу следует в верхней таблице выделить группу, а затем установить курсор в нижней части окна и нажать на кнопку "Добавить" Added дополнительной панели инструментов. Если для выбранного курса на закладке "Планируемые сотрудники" отсутствуют сотрудники, предназначенные для обучения по этому курсу, появляется сообщение программы, приведенное на рис .2.

Рис. 2

Если для заданного курса существуют планируемые сотрудники, то открывается дополнительное окно (рис. 3) со списком сотрудников для выбора сотрудников в состав группы.

Рис. 3

В окне (рис. 3) следует выделить нужных сотрудников и нажать на кнопку "ОК". В результате окно (рис. 3) закрывается, и открывается карточка для ввода параметров обучения сотрудников. Все поля карточки практически заполнены, нужно заполнить поля "Основание", "Направившее подразделение", Вид обучения". На этой стадии в нижней части карточки указывается состояние "Включен в группу". После нажатия на кнопку "ОК" карточка "Параметры обучения сотрудников" и окно "Выбор сотрудников" закрываются, а текущим становится окно "Обработка заявок на обучение".

В окне (рис. 1) на закладке "Учебные группы" в нижней таблице будут перечислены сотрудники, которые были выделены в окне "Выбор сотрудников" (рис. 3). Одновременно формируются карточки обучения на каждого сотрудника, включенного в учебную группу.

До тех пор пока не будет произведена оплата за обучения сотрудников в группе, список обучающихся в группе можно корректировать. Добавление сотрудников производится описанным выше способом.

Для исключения сотрудника из списка следует щелкнуть левой кнопкой мыши на строку, в которой указаны сведения об удаляемой сотруднике, и нажать на кнопку Del дополнительной панели инструментов. Перед удалением сотрудника открывается окно (рис. 4) для подтверждения выполняемого действия. После нажатия на кнопку "Да" сотрудник Серафимов (рис. 3) будет удален из группы.

Рис. 4

Внимание. Из списка всегда удаляется текущий сотрудник, слева от фамилии которого расположен знак Strelka (стрелочка).


Параметры обучения сотрудников

Карточка для ввода параметров обучения сотрудников (рис. 1) открывается кнопкой "ОК" из окна "Выбор сотрудников", в котором перечисляются сотрудники для формирования списка обучающихся сотрудников по заданному курсу. Формирование списка производится на закладке "Учебные группы" режима "Обработка заявок на обучение".

Рис. 1

Карточка (рис. 1) открывается уже заполненными полями, расположенными в ее верхней части. В этих полях проставляются данные, ранее введенные в карточке учебной группы, ввод в эти поля запрещен.

В карточке "Параметры обучения сотрудников" можно заполнить поля:

· Основание – указать причину, на основании которой сотрудник включается в план обучения по выбранному курсу. Ввод в это поля так же, как и в остальные поля происходит из выпадающего списка. Для его открытия следует щелкнуть левой кнопкой мыши на поле (см. рис. 2). В списке нужно щелкнуть левой кнопкой мыши на нужное значение (на рис. 2 – Производственная необходимость), и оно отображается в поле "Основание". Список включает сведения из справочника оснований обучения.

Рис. 2

· Направившее подразделение – указывается подразделение, которое направляет сотрудника на обучение.
· Вид обучения – значение выбирается из выпадающего списка, сформированного по данным справочника видов обучения.

Для сохранения введенных данных и закрытия карточки (рис. 1) нажмите на кнопку "ОК". На этом процесс формирования новой группы заканчивается и активным становится окно "Обработка заявок на обучение". Для просмотра списка обучающихся сотрудников во вновь созданной группе нужно в верхней части закладки "Учебные группы" установить курсор на этой группе. Список сотрудников, выделенных в окне "Выбор сотрудников", будет отображаться в нижней таблице закладки "Учебные группы" окна "Обработка заявок на обучение".


Карточка обучения

В карточке обучения фиксируется вся информация о ходе процессе обучения от его начала до завершения. Карточка обучения сотрудника формируется после включения сотрудника в список планируемых сотрудников, формируемых на обучение в текущем учебном году. На этом этапе в карточке указывается только наименование курса, предполагаемая дата начала обучения и состояние процесса обучения (включен в план). Доступ к карточке происходит из персональной карточки кнопкой "Открыть" Open .

После создания группы сотрудника можно включить в группу, на этом этапе происходит автоматическое заполнения полей карточки (рис. 1), содержащих реквизиты группы, а в нижней части карточки указывается "Состояние: включен в группу". На этом этапе и после завершения обучения карточку можно открыть двойным щелчком левой кнопки мыши на строке с данными сотрудника в нижней части закладки "Учебные группы" окна "Обработка заявок на обучение".

Рис. 1

После завершения обучения нужно открыть карточку обучения сотрудника и заполнить поля "Оценка", "Документ" и "от" (дата документа), которые на этом этапе становятся доступными. При этом в нижней части карточки (рис. 2) в поле "Состояние" отражается состояние процесса обучения "Завершено".

Рис. 2

Все изменения, произведенные в карточке обучения, отражаются в персональной карточке на закладке "Список курсов".


Ранее пройденное обучение

Информацию о ранее пройденном и завершенном обучении за прошлые годы можно ввести непосредственно в персональную карточку сотрудника.

Однако если необходимо внести данные о ранее пройденном обучении согласно протоколу, то для этого нужно создать группу для курса, который закончил сотрудник и включить его в состав этой группы.

1. Для создания группы необходимо:

· выбрать пункт "Заявка на обучение" раздела "Планирование", в открывшемся окне "Обработка заявок на обучение" перейти на закладку "Учебные группы";
· в поле "Учебный год" указать год, в котором учился сотрудник, а в поле "Курс" ввести наименование законченного курса;
· нажать на кнопку "Добавить" Added;
· заполнить поля карточки учебной группы (рис. 1). Заполнение основных полей карточки описаны в теме "Карточка учебной группы". В блоке "Состояние" следует выбрать переключатель "Завершено". В результате становится видимым флаг "Ранее пройденный курс", который нужно установить, и активными поля "Протокол №" и "от" для ввода номера и даты протокола.

Рис. 1

2. Перейти на закладку "Планируемые сотрудники" и ввести сотрудника в состав сотрудников, планируемых на обучение.

3. Перейти на закладку "Учебные группы" и включить сотрудника в состав созданной группы.

4. В результате все введенные данные попадут в персональную карточку сотрудника на закладку "Список курсов" (рис. 2), а в поле "Протокол" отразятся данные, введенные в аналогичное поле карточки учебной группы (рис. 1).

Рис.2


Завершение процесса обучения

В карточке учебной группы фиксируются такие стадии прохождения учебного процесса, заключение договора, оплата и завершение обучения. Учет завершения обучения осуществляется путем установки переключателя "Завершено" в карточке учебной группы (рис. 1). В этом случае становятся доступными поля "Протокол" и "от" для ввода номера и даты протокола.

Рис. 1

После закрытия карточки в списке учебных групп на закладке "Учебные группы" (рис. 2) в поле "Состояние" проставится значение "Завершено", а в поле "Протокол" – номер и дата составления протокола.

Рис. 2

Также следует внести необходимые сведения в карточки обучения в карточки обучения всех сотрудников, обучающихся по данному курсу. Для этого из окна "Обработка заявок на обучение" (рис. 2) нужно открыть все карточки обучения (рис. 3) и указать оценку качества проведения обучения, документ об окончании курса и дату его получения. Заметим, что после завершения обучения в карточке обучения сотрудника становятся доступными поля "Оценка", "Документ" и "от" (дата документа). Состояние процесса обучения отмечается как "Завершено".

Рис. 3


Архив учебных групп

В программе предусмотрен механизм для создания долговременного архива, позволяющий сохранить историю обучению сотрудников в учебных группах в предыдущие годы. Такой механизм позволяет не только хранить в базе данных сведения об уже законченном обучении, но и предоставляет возможность просмотреть на экране историю обучения сотрудников за все годы на закладке "Архив учебных групп" (рис. 1).

Историю обучения можно просмотреть по заданному курсу за конкретный год, указанный пользователем, в соответствии с установленным критерием отбора по форме обучения и рангу. Наиболее полные сведения отображаются, если выбраны значения "Все формы" и "Все ранги". Архив предоставляет пользователю возможность проверить и, если потребуется, уточнить данные обучения, которые могут быть использованы, пример, для повышения сотрудника в должности или в окладе.

Рис. 1

Создания архива данных

Для создания архива учебной группы нужно перейти на закладку "Учебные группы", установить курсор на нужной группе и нажать на кнопку "Закрыть группу" [image] дополнительной панели инструментов. На экране появляется сообщение (рис. 2) для подтверждения указанного действия. После нажатия на кнопку "Да" данные по выбранной учебной группе удаляются с закладки "Учебные группы" и переносятся на закладку "Архив учебных групп" (рис. 1).

Рис. 2

Восстановление группы из архива

В случае необходимости группу можно восстановить из архива. Для этого на закладке "Архив учебных групп" (рис. 1) ее следует сделать текущей, т.е. щелкнуть левой кнопкой мыши на строке с этой группой. В результате этих действий в первой колонке появится символ "стрелочка" Strelka. Затем нужно нажать на кнопку "Открыть группу" GroupOpen дополнительной панели инструментов, далее в окне (рис. 3) выбрать кнопку "Да", после чего сведения по группе удаляются с закладки "Архив учебных групп" и перемещаются на закладку "Учебные группы".

Рис. 3


Документы и отчеты

Для оценки эффективности работы учебного центра и принятия правильных управленческих решений, руководителям требуются различные статистические и аналитические отчеты. Основная группа отчетов, наиболее часто используемая пользователями, создается специалистами "АиТ Софт" и поставляется в дистрибутиве программы. Однако специалистами "АиТ Софт" могут быть разработаны индивидуальные отчеты по ТЗ заказчика. Отчеты создаются на основе хранимых процедур MS SQL сервера, поэтому квалифицированные пользователи имеют возможность создавать различные отчеты в соответствии с потребностями своего предприятия.

Отчеты настраиваются и формируются из режима "Отчеты по хранимой процедуре", открываемого из пункта "По хранимой процедуре" раздела "Отчеты". Все сформированные отчеты хранятся в рабочей папке \aitclient\hrm\TXT.


Подключение отчетов

Формирование отчетов происходит в окне "Отчеты по хранимой процедуре" (рис. 1), которое вызывается из пункта "Отчеты по хранимой процедуре" раздела "Отчеты" Главного меню.

Рис. 1

Каждый новый отчет должен быть добавлен в список, приведенный в правой части окна. Операция добавления отчета в список, называется подключением отчета.

Операция подключения должна выполняться и для тех отчетов, шаблоны которых изменились. Имена новых шаблонов необходимо указать в списке вместо старых шаблонов.

Для подключения нового отчета необходимо выполнить следующие действия.

· нажать на кнопку "Добавить" Added для ввода новой строки в таблицу;
· в первом столбце "Название" с клавиатуры ввести имя нового отчета;
· в столбце "Шаблон документа" задать имя файла шаблона отчета *.rep вручную или с помощью стандартного диалога, чтобы исключить ошибки в имени файла. Для этого дважды щелкните левой кнопкой мыши на текущей строке в поле "Шаблон документа". Открывается стандартное окно Windows "Выбор файла", в котором тип файлов-шаблонов rep задается по умолчанию. В этом окне следует выбрать файл из рабочей папки \aitclient\hrm\Form и нажать на кнопку "Открыть". После этого имя выбранного файла появляется в поле "Шаблон документа";
· в столбце "Форма" введите имя файла шаблона с расширением *.xls. Выбор файла производится так же, как описано выше.


Настройка отчетов по хранимой процедуре

Настройка подключенных отчетов производится в окне "Отчеты по хранимой процедуре" (рис. 1), которое вызывается из пункта "Отчеты по хранимой процедуре" раздела "Отчеты" Главного меню.

Рис. 1

Окно разделено на две части. В левой части располагаются переключатели для выбора структурных единиц предприятия, по которым будет происходить отбор данных, попадающих в состав готового отчета. В отчет будут включены данные за период отчета, заданный датами начала и конца периода в нижней части окна.

В правой части окна отображается список подключенных отчетов с указанием наименования отчета, шаблона документа *.rep и формы представления отчета *.xls.

По одной и той же хранимой процедуре может быть построено несколько отчетов, отличающихся набором данных, определяемых сделанными настройками отчета.

Формирование отчета

Для построения отчета нужно:

· в левой половине окна нужно задать условия отбора сотрудников по подразделениям и период, за который будет формироваться отчет;
· в правой половине окна выделить нужный отчет в списке;
· установить флаг FlagYes в колонке DocumPocedureColumn справа от названия отчета для увеличения скорости создания отчета в формате Excel;
· нажать на кнопку "Отчет" PersReport на дополнительной панели инструментов;
· начинается процесс формирования отчета с отображением процента выполнения;
· если файл отчета уже существует, то программа предлагает перезаписать. После нажатия на кнопку "Да" начинается построение отчета;
· сформированный отчет отображается в программе Ms Excel.


Шаблоны отчетов

Отчеты в программе "АиТ:\Управление обучением" формируются на основе файлов-шаблонов, которые представляют собой обычные текстовые файлы. По существу, шаблоны – это модель для создания конкретного отчета (документа), включающая набор элементов, отражающих его структуру и содержание. Шаблоны позволяют автоматизировать процесс формирования отчетов в программе.

Готовые шаблоны, разрабатываемые программистами ООО "АиТ Софт", поставляются в дистрибутиве программы и размещаются в рабочей папке \aitclient\hrm\form программы. Шаблоны могут также создаваться непосредственно и самими пользователями. Для каждого отчета требуется создать свои индивидуальные шаблоны в формате:

· xls – файл может содержать заголовок таблицы и ее столбцов, а также содержит слова-закладки, начинающиеся с символа !. Например,
ФИО | Должность | Подразделение | Курс | Состояние | Дата начала | Дата окончания
!ФИО | !ДОЛ | !ОТД | !КУРС | !СТАТУС | КУРСНАЧ | !КУРСКОН
· rep – файл содержит соответствия между закладками и ключевыми словами, возвращающими значения.

Структура шаблона отчета в формате rep

Файл шаблона состоит из нескольких частей, перечисленных в строго определенном порядке. Каждая часть содержит набор строк, характеризуется своим назначением, местоположением на шаблоне и набором ключевых слов. Ключевое слово – это зарезервированное служебное слово языка программирования, встроенное в программу и имеющее уникальное имя. В шаблоне используются ключевые слова двух видов, отличающиеся по назначению.

Ключевые слова первого вида начинается с символа # (решетка) и используется для разделения различных частей шаблона друг от друга, например, #НАЧАЛО_ШАПКИ и #КОНЕЦ_ШАПКИ. Второй вид ключевых слов используется для подстановки данных конкретного документа, их имена заключены в квадратные скобки "[ ]". При формировании отчета вместо этих ключевых слов вставляется соответствующие значения из базы данных.

В общем случае шаблон может включать следующие составные части, расположенные обязательно в указанном порядке:

· Расчетная (формульная) часть – содержится в шаблоне между строкой #НАЧАЛО_ФОРМУЛ и строкой #КОНЕЦ_ФОРМУЛ, используется для описания формул. Кроме этого, в документах (отчетах), создаваемых по хранимым процедурам в расчетной (формульной) части указывается непустое имя хранимой процедуры и имя таблицы в базе данных. Также формульная часть может содержать блок [ПАРАМЕТРЫ] с дополнительными настройками (не более 20) для формирования отчета. Например,

#НАЧАЛО_ФОРМУЛ

procedure_name=sp_hrm_not_teach

tmp_table_name=hrm_not_teach

tmp_table_name2=hrm_not_teach_2

F01=1

......

[ПАРАМЕТРЫ]

param1=Количество дней

#КОНЕЦ_ФОРМУЛ

· Шапка – заголовок таблицы, содержится в шаблоне между строкой #НАЧАЛО_ШАПКИ и строкой #КОНЕЦ_ШАПКИ, может содержать ключевые слова.
· Цикл (тело документа) – описание повторяющейся части документа. Тело документа в файле шаблона расположено между строкой #НАЧАЛО_ЦИКЛА и строкой #КОНЕЦ_ЦИКЛА. В отчете эта часть будет повторяться столько раз, сколько сотрудников будет перечислено в документе.
· Подвал – нижняя часть шаблона, может содержать ключевые слова, в шаблоне между строкой #НАЧАЛО_ПОДВАЛА и строкой #КОНЕЦ_ПОДВАЛА. Подвал может быть необходим, например, для того, чтобы формировать итоговые данные.

Шаблон может также содержать комментарии, т.е. поясняющий текст, содержащий одну или несколько строк, начинающихся со знаков "//". В выходной документ такие строки не переносятся. Комментарий может располагаться в любом месте файла-шаблона. Количество таких строк в шаблоне не ограничено.


Общие сведения по хранимой процедуре

Программа предоставляет опытным пользователям широкие возможности по созданию отчетов, удовлетворяющих всевозможным запросам и индивидуальным потребностям пользователей, используя инструмент хранимых процедур.

Хранимая процедура – это набор предложений языка SQL, который выполняется (компилируется) один раз и хранится на сервере базы данных. Хранимая процедура создает в рабочей базе данных дополнительную таблицу и заполняет ее данными по выбранным параметрам. Состав подбираемых данных задается при составлении самой хранимой процедуры.

Дополнительная таблица, в отличие от основных таблиц базы данных, используется программным комплексом только для формирования отчета типа "хранимая процедура".

Для получения отчета по хранимой процедуре необходимо:

· разработать скрипт, на основании которого на сервере рабочей базы данных формируется хранимая процедура;
· откомпилировать скрипт с хранимой процедурой;
· разработать rep-шаблон и xls-шаблон документа, которые хранятся в папке \aitclient\hrm\Form.

Отчет, основанный на хранимой процедуре, позволяет отобразить даже такие данные, которые невозможно получить с помощью других видов отчетов. Операции по подготовке данных для построения отчета (документа) должны выполняться квалифицированными программистами или специалистами компании разработчика программы. Отображаемые в отчете данные зависят от кода (исходного текста) хранимой процедуры, написанной на языке SQL. Файл с кодом хранимой процедуры должен храниться в папке \aitclient\Config\.

Внимание. При создании исходного кода хранимых процедур целесообразно обращаться за консультацией к специалистам ООО "АиТ софт", т.к. некорректно сформированные хранимые процедуры могут привести к потере данных в базе данных.

Компиляция скрипта с хранимой процедурой

После компиляции хранимую процедуру можно было многократно использовать для построения отчета с различной настройкой. Причем компиляция выполняется системным администратором только один раз в модуле "АиТ:\Конфигурация".

Для этого в модуле "АиТ:\Конфигурация" системный администратор для рабочей базы данных должен выполнить следующие действия:

· открыть режим "Исполняемый SQL код" из пункта "I-sql" раздела "Режим" Главного меню программы;
· нажать на верхнюю кнопку SglOpen , открывается стандартное окно "Найти" для выбора файла;
· выбрать нужный файл с расширением sql и нажать на кнопку "Открыть". В результате окно "Найти" закрывается, а код хранимой процедуры отображается в окне "Исполняемый SQL код" (рис. 1);
· запустить файл на выполнение, нажав на кнопку "Исполнить скрипт" SglExec . В нижней части окна появляется надпись "Исполнить скрипт";
· после выполнения скрипта на закладке "Результаты выполнения" появляется сообщение "Выполнение завершено" с указанием затраченного времени на выполнение операции.

Рис. 1


Создание групп для отчетов

При большом количестве отчетов в списке отчетов в окне "Отчеты по хранимой процедуре" (рис. 1) можно отображать не все отчеты, а только отчеты для выбранной группы. В выпадающем списке поля "Группа отчетов" показывается список групп отчетов, введенных пользователем в окне "Группы отчетов по хранимой процедуре" (рис. 2).

Рис. 1

Для формирования списка групп отчетов необходимо:

· в окне (рис. 1) нажать на кнопку "Группировка отчетов" PersJur;
· в открывшемся окне (рис. 2) нажать на кнопку "Добавить" Added для добавления новой строки в список отчетов;
· в новой строке нужно указать название новой группы;
· для сохранения введенных данных, воспользуйтесь кнопкой [image] .

Рис. 2

Аналогичным способом добавляется название других групп. Добавленные группы отчетов попадают в выпадающие списки полей "Группа отчетов" и позволяют отнести каждый отчет из списка (рис. 1) к конкретной группе.


Отчеты по хранимой процедуре

 Top Previous

Отчеты помогают менеджерам по обучению облегчить их производственную деятельность. В данной теме приведены примеры построения некоторых отчетов и описано их назначение. Сформированный отчет отображается в программе Ms Excel. В соответствии с настройкой каждый отчет можно получить как по всему предприятию, так и по выбранным структурным единицам. Кроме этого, данные в отчетах приводятся за период, выбранный пользователем.

1. Отчет о пройденном обучении

Отчет строится в табличном виде. В первых трех столбцах таблицы указывается табельный номер, фамилия, имя и отчество сотрудников, а также занимаемая ими должность. В заголовках остальных столбцов указываются названия курсов, законченных сотрудниками за период, указанный в настройках отчета. В отчете перечислены не все сотрудники, работающие в выбранных структурных единицах, а только те, которые в выбранный период времени закончили курсы.

Рис. 1

2. Отчет по сотрудникам, не прошедшим обучение

В отчете (рис. 2) приведен список сотрудников, не прошедших обучение за выбранный период времени. Для каждого сотрудника указывается название курса и причина, по которой он не закончил обучение.

3. История обучения сотрудников (hrm_report.rep, hrm_report.xls)

Отчет (рис. 3) позволяет просмотреть все курсы, на которых обучались сотрудники за время работы на предприятии. Отчет строится для сотрудников, у которых дата приема на работу больше даты начала периода.