Словарь терминов

 Top Next

А

Автоведение – режим автоматического заполнения табельных листов.

Автоведомые табельные листы – табельные листы, для которых автоматизированы все типовые операции табельного учета. Они формируются автоматически Мастером ведения табельного учета, но могут создаваться и вручную, и в списке табельных листов отмечаются буквой "А".

Активное окно – открытое окно, в котором в текущий момент времени установлен курсор, его заголовок окрашивается контрастным цветом.

Активные графики – плановые графики, которые используются в программном комплексе "АиТ:\Управление персоналом".

Аналитические признаки (аналитика) – объекты аналитического учета. Аналитические признаки, используемые в программном комплексе "АиТ:\Управление персоналом", делятся на обязательные признаки, заданные автоматически, и дополнительные признаки, введенные пользователем в модуле "АиТ:\Зарплата". Аналитические признаки в данном модуле являются свойствами табельного листа и типа времени.

Б

Базовые табельные листы – определяется в настройках табельного листа, табельный лист с автоведением по умолчанию считается базовым (основным).

Балансировка планового графика – позволяет привести годовую или квартальную выработку по сменным графикам в соответствие с нормой выработки по графику 40-ка, 36-ти и 24-х часовой рабочей недели.

В

Выпадающие списки – список с набором значений, сформированный автоматически и предназначенный для ввода выбранного значения в заданное поле.

Г

Главное меню – размещается в верхней строке основного окна под его заголовком и обеспечивает доступ к основным функциям и возможностям модуля.

График работы – список месяцев года с указанием в каждом количества плановых рабочих дней и часов.

Д

Деактивированные (неактивные) графики – плановые графики, которые не используются в программном комплексе "АиТ:\Управление персоналом" и не отображаются в списке плановых графиков.

Дополнительная панель инструментов – панель инструментов, набор кнопок которой зависит от вида открытого окна и операций, выполняемых в нем.

Дочернее окно – окно, размещающееся внутри основного окна.

Ж

Журналы – позволяют автоматизировать заполнение табельных листов и содержат сведения об одном типе времени пребывания или отсутствия сотрудника на рабочем месте.

З

Закладка – это элемент документа в формате Word, которому присвоено уникальное имя. Размещение ключевых слов в шаблоне осуществляется через механизм закладок (bookmarks), имена которых берутся из списка ключевых слов.

Закладка (окон) – страница в многостраничном окне, а также особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку).

К

Карточка – электронный документ, содержащий сведения о каком-либо субъекте или объекте (сотруднике, предприятии, табельном листе, плановом графике и др.) и имеющий произвольное расположение полей ввода и вывода информации, в отличие от типовых форм отчетности, которые являются электронными аналогами законодательно утвержденных первичных документов. Карточка в модуле открывается из списка карточек (записей).

Калькулируемый тип времени – позволяет вести суммированный учет рабочего времени и отражает разницу между фактически отработанным временем и плановым временем, рассчитанным по заданному нормативному графику, например, пятидневке за учетный период (месяц, квартал, полугодие, год). Этот тип времени не отображается непосредственно в табельном листе. Отклонение от нормативного графика за учетный период показывается в итогах и сводах по табельному листу.

Клиент – компьютер, который в локальной сети или в Интернете получает доступ к общим сетевым ресурсам, предоставляемым другим компьютером, называемым сервером.

Ключевые слова – зарезервированные служебные слова, имеющие уникальные имена и используемые при разработке шаблонов отчетов и документов.

Корректирующий свод – свод, который необходимо сформировать в том случае, когда изменение записей в журнале произошло после передачи данных по своду в модуль "АиТ:\Зарплата".

Л

Логин – системное имя пользователя, запрашиваемое при запуске модуля.

М

Мастер – средство графического интерфейса, которое представляет собой последовательно сменяющие друг друга диалоговые окна для выполнения задачи, которую можно разбить на этапы (шаги), например, Мастер приема сотрудника на работу.

Модальные окна – работают в монопольном режиме, когда они открыты, запрещен доступ к меню, инструментам и другим открытым окнам.

Н

Недочерние окна – окна, которые выходят за пределы основного окна, например, окна сообщений об ошибках.

Немодальные окна – позволяют осуществлять доступ к различным функциям модуля без своего закрытия.

Неосновные табельные листы – используются в сложных случаях ведения табельного учета, например, при приведении двух и более табельных листов с разной аналитикой на одно подразделение (когда сверхурочная работа учитывается в отдельном табельном листе), то один лист считается основным, другой – неосновным.

Нормативный график – плановый график для данного типа времени, на основании которого за учетный период рассчитывается отклонение фактически отработанного времени от планового времени, рассчитанного по нормативному графику. Нормативный график использоваться в качестве нормы рабочего времени для планового графика.

О

Основная панель инструментов – панель инструментов, содержащая постоянный набор кнопок, не зависящий от вида открытого окна.

Основное окно – окно, открывающееся сразу же после запуска модуля и содержащее меню, панель инструментов, открытые дочерние окна, а также значки свернутых дочерних окон.

Основной табельный лист – определяется в настройках табельного листа, по умолчанию табельный лист с автоведением считается базовым (основным).

Открытое окно – окно, которое размещается в основном окне или на рабочем столе компьютера, если окно является недочерним.

Оформления табельных листов – операция занесение в табельные листы плановых графиков сотрудников и записей из журналов.

П

Панель инструментов – набор кнопок, обеспечивающий быстрый доступ ко многим режимам и функциям модуля.

Папка (каталог) – элемент структуры файловой системы для упорядочения хранения программ и документов на диске и может вмещать как файлы, так и другие вложенные папки (подкаталоги). Папка на экране отображается с помощью значка, имеющего вид канцелярской папки.

Переключатель – одна из зависимых кнопок группы, предназначенная для выбора одного из взаимоисключающих условий.

Полосы прокрутки – используются для перемещения по тексту вверх/вниз или влево/вправо в окне, в полях списках или в таблицах.

Плановые графики – стандартные графики работ, служат для задания планового количества рабочих дней и часов по месяцам года.

Простые табельные листы – заполняются вручную без использования режима автоведения. Ручное формирование табельных листов используется в тех случаях, когда требуется сформировать список сотрудников в табельном листе не только с учетом подразделения, но и, например, графика или категории.

Подразделение – элемент организационной структуры предприятия низшего уровня, к которой непосредственно приписаны штатные единицы или сотрудники.

Р

Рабочая папка – папка, в которую установлен модуль, а также вложенные в нее папки.

Рабочий центр – определяется двумя взаимосвязанными атрибутами: производственным объектом (станком, оборудованием, установкой и др.), на котором выполнялась работа по нарядам, и структурной единицей предприятия (цехом, подразделением), где он был установлен. Рабочие центры вводятся и настраиваются в модуле "АиТ:\Учет выполненных работ".

Разложить все журналы – операция перенесение записей из всех журналов в табельные листы.

Режим работы – совокупность функций и операций, доступных в текущем окне.

Роль – определяет набор полномочий и функциональных возможностей, которыми будет обладать пользователь при работе с конкретным модулем.

С

Свод по табельным листам – итоговый документ, содержащий суммарное время в днях и часах в табельном листе за заданный период по всем учитываемым в табеле типам времени.

Сервер (компьютер) – специально выделенный в локальной сети компьютер, предоставляющий общие ресурсы пользователям сети. На сервере устанавливается общая для всех модулей база данных и программа (сервер), управляющая базами данных.

Сервер (программа) – программа, которая обеспечивает управление данными, разделение информации, администрирование и безопасность.

Стартовый день – календарная дата, которой соответствует первый день выбранного шаблона графика.

Т

Табельный лист – карточка (электронный документ), в которой ведется табельный учет группы сотрудников, например, работающих в одном подразделении.

Табельные листы с автоведением – табельные листы, для которых автоматизированы все типовые операции табельного учета, в списке табельных листов они отмечаются буквой "А". Эти табельные листы формируются автоматически Мастером ведения табельного учета, но могут создаваться и вручную,

Тип времени – любой вид рабочего или нерабочего времени сотрудника, подлежащий учету. Заполнение фактически отработанного времени сотрудника, зафиксированного в табельном листе, производится через типы времени. К особым типам времени относится калькулируемый тип времени.

Тип шаблона – характеризуется рабочим циклом (недельный, сменный, вахтовый). Например, рабочим циклом для недельного типа шаблона является неделя.

Ф

Файл – поименованная целостная совокупность данных на диске, имеющая набор атрибутов (имя, расширение и др.).

Фильтр – сервисное средство, позволяющее отбирать определенную часть имеющейся информации по заданным условиям для просмотра на экране, выполнения расчетов или формирования отчетов.

Флаг – независимая кнопка, позволяющая выбрать одно из двух альтернативных условий.

Ш

Шаблон отчета – текстовый файл определенной структуры с расширением rep, dot или xls, который используется для создания отчетов и выходных документов. Файл содержит ключевые слова и набор элементов, отражающих содержание и внешний вид документа или отчета.


Назначение модуля

 Top Previous Next

Модуль "АиТ:\Табельный учет" предназначен для автоматизированного ведения табельного учета, контроля и анализа использования рабочего времени на предприятии. Основной формой ведения табельного учета в модуле является стандартный табельный лист с автоматическим или ручным заполнением данных. Модуль "АиТ:\Табельный учет", наряду с другими модулями входит в состав программного комплекса "АиТ:\Управление персоналом" и функционирует в операционной среде Windows.

Данный модуль не может функционировать автономно, т.к. в нем отсутствуют режимы для формирования карточек сотрудников и структуры предприятия, необходимые для ведения табельного учета на предприятии. Такими возможностями обладают только два модуля "АиТ:\Кадровый учет" и "АиТ:\Зарплата" в комплексе, поэтому данный модуль может функционировать только совместно с ними. В модулях "АиТ:\Кадровый учет" и "АиТ:\Зарплата" на каждого сотрудника создается кадровая карточка, в которой указываются персональные и служебные данные, а также фиксируются кадровые перемещения. Все эти сведения хранятся в единой базе данных и доступны другим модулям.

Модуль "АиТ:\Табельный учет" обладает следующими функциональными возможностями:

· позволяет существенно снизить трудозатраты табельщиков по ведению табельного учета;
· автоматически создает и заполняет табельные листы для заданной организационной структуры предприятия. Средства автоматического заполнения табельных листов позволяют обеспечить высокую скорость ввода данных при подробной детализации;
· автоматизирует типовые операции табельного учета, отслеживает кадровые изменения (прием, увольнение, перевод), оформляет табельные листы в соответствии с плановыми графиками сотрудников, учитывая при этом временные (на период) изменения графика и аналитические признаки;
· формирует шаблоны графиков рабочего времени, позволяющие формировать детальные графики работ, настраивать длительность рабочего цикла, проводить разбивку дней графика на рабочие и нерабочие;
· использует различные виды плановых графиков для сотрудников предприятий, работающих в режиме пяти-, шести- и семидневной рабочей недели, по сменным графикам, в том числе и графикам вахтового типа. Режим плановых графиков позволяет автоматически учитывать праздничные дни, а также различные дополнительные изменения, например, санитарный день, профилактику и пр. В модуле выполняется автоматический расчет плановых дней и часов за выбранный расчетный период;
· использует журналы для автоматизации заполнения табельных листов. В журналах фиксируются типы времени, учитывающие присутствия и любые плановые отсутствия сотрудника на рабочем месте, оформленные документами (например, отпуск, больничный, отзыв из отпуска, командировка и др.). Журналы в модуле заполняются автоматически на основании данных, полученных из модулей "АиТ:\Зарплата" и "АиТ:\Кадровый учет;
· формирует своды – итоговые документы, сформированные по табельным листам. Модуль обеспечивает оперативную передачу итоговых данных (сводов) по табельному времени в модуль "АиТ:\Зарплата" для начисления заработной платы и в модуль "АиТ:\Кадровый учет" для формирования приказов об отпуске в счет отгулов;
· гибкая система настроек, позволяющая учитывать различные аналитические признаки для быстрой и точной обработки информации;
· создает разнообразные отчеты по ведению табельного учета для всестороннего анализа, учета и контроля использования рабочего времени. Отчеты позволяют получить структуру отработанного времени и неявок по подразделениям, всему предприятию или произвольным группам сотрудников с учетом нескольких уровней аналитики. Для облегчения и ускорения работы по созданию отчетов по ведению табельного учета используются режимы Мастеров создания отчетов;
· обеспечивает режим стыковки с системой контроля и управления доступом "Perco-S-15000". Режим предназначен для заполнения электронных табельных листов в модуле "АиТ:\Табельный учет" на основании данных, передаваемых из системы "Perco-S-15000". Режим доступен для пользователей, которые обладают правами на установку специальных настроек для работы с электронными проходными.


Варианты поставки

Программный комплекс "АиТ:\Управление персоналом" позволяет автоматизировать процесс управления персоналом на предприятиях с простой и сложной организационной структурой и практически с любой сферой деятельности (промышленных, образовательных, медицинских и других), а также и в холдингах, имеющих сложную территориальную и организационную структуру, состоящую из нескольких предприятий (филиалов), являющихся самостоятельными юридическими лицами.

Программный комплекс содержит комплект программных модулей, использующих общую базу данных, которая может размещаться на сервере MS SQL Express Edition или MS SQL Server 2005 или выше. Полный комплект поставки включает семь модулей: "АиТ:\Кадровый учет", "АиТ:\Зарплата", "АиТ:\Табельный учет", "АиТ:\Персонифицированный пенсионный учет", "АиТ:\Учет выполненных работ", "АиТ:\Конфигурация", "АиТ:\Управление обучением".

Комплекс "АиТ:\Управление персоналом" реализован по двухзвенной архитектуре клиент-сервер, которая предполагает наличие двух компонентов: клиентскую часть (набор модулей размещается на рабочем месте) и серверную часть (базу данных и средства управления базой). Клиентская часть включает набор модулей и размещается на рабочем месте (пользовательском компьютере, клиенте). База данных располагается на том же компьютере, что и сервер баз данных (программа), который обеспечивает управление данными, разделение информации, администрирование и безопасность.

Комплекс поставляется в аппаратно защищенном от нелегального тиражирования виде. Существует два базовых комплекта поставки:

· локальный – однопользовательский вариант с локальным ключом электронной защиты на 1 рабочее место. В этом случае локальный ключ вставляется в USB порт компьютера пользователя, на котором обязательно установлена клиентская часть и сервер ключа защиты. Допускается установка сервера базы данных (приложения) на этом же компьютере или на другом;
· сетевой – многопользовательский вариант с сетевым ключом защиты на 5, 10, 20, 50 и 100 рабочих мест. Количество рабочих мест, одновременно работающих с базой данных, прописывается в сетевом ключе электронной защиты и определяется количеством лицензий на клиентские места, а также максимальным количеством клиентских мест, допустимых для базы данных. В сетевом варианте комплекс используется на нескольких рабочих местах (клиентах), с которых осуществляется доступ к базе данных, а сама база данных и сервер базы данных (приложение) размещаются на специально выделенном в сети компьютере (сервере), не являющемся рабочим местом.

Программный комплекс "АиТ:\Управление персоналом" поставляется в четырех версиях "Базовая", "Проф", "Холдинг" и "Демо-версия", различающихся функциональными возможностями, и двух модификациях: "SQL Express" и "MS SQL".

Модификации программного комплекса

Начиная с номера версии 7.9, в зависимости от численности сотрудников предприятия база данных может работать под управлением СУБД MS SQL Express или СУБД MS SQL Server и размещаться соответственно на сервере MS SQL Express Edition или MS SQL Server для версии не ниже 2005. В связи с этим различают две модификации комплекса: SQL Express и MS SQL:

· SQL Express (бесплатная версия SQL Server 2005) – используется на предприятиях с численностью сотрудников до 1000 человек. СУБД MS SQL Express входит в дистрибутив программного комплекса;
· MS SQL – предназначается для обработки большого объема данных в крупных предприятиях с большим количеством сотрудников. Для работы комплекса необходимо наличие уже установленного сервера MS SQL Server 2005 и выше. Все операции с базами данных осуществляются стандартными средствами администрирования MS SQL Server 2005.

Версии комплекса

Программный комплекс выпускается в четырех версиях, различающихся по функциональности:

1. "Базовая" версия – с типовыми настройками функционала, установленными автоматически, полный доступ ко всем функциям модулей без настройки. В комплект комплекса в этой версии не входит модуль "АиТ:/Учет выполненных работ".

2. Версия "Проф" – версия с полным набором программных модулей и функциональных возможностей. Гибкая настройка прав доступа и разграничение ролей пользователей к различным функциям во всех модулях программного комплекса "АиТ:\Управление персоналом". Версия является наиболее подходящей для крупных предприятий со специфическими особенностями учетов и обеспечивает настройку прав доступа к отдельным функциональным возможностям и блокам информации.

3. Версия "Холдинг" – предназначена для ведения учета в одной базе нескольких предприятий, являющихся юридическими лицами и входящих в один холдинг, в том числе с разной системой налогообложения. Версия обладает наиболее полным функционалом. Может использоваться только в модификации MS SQL под управлением СУБД MS SQL Server 2005 и выше.

4. Демо-версия – предназначена для демонстрации функциональных возможностей программного комплекса и ознакомительного обучения. В версии предусмотрено ограничение по количеству тестовых записей в базе данных (не более 15).


Установка прав на работу с модулем

Права на работу с модулем "АиТ:\Табельный учет" так же, как и с другими модулями программного комплекса "АиТ:\Управление персоналом" устанавливаются в модуле "АиТ:\Конфигурация" в режиме "Редактирование списка пользователей" на закладке "Общие" (рис. 1). В этом же окне необходимо назначить и роль пользователю, т.е. задать его полномочия и набор возможностей, которыми он будет обладать при работе с модулем. Самыми большими правами на работу с модулями обладает системный администратор.

Чтобы установить права на работу с модулем требуется:

· в окне (рис. 1) сделать текущим пользователя, для которого будут установлены права на работу с модулем, т.е. щелкнуть левой кнопкой мыши на логине, под которым текущий пользователь входит в модуль "АиТ:\Табельный учет". В этом случае слева от выбранного логина появится символ "стрелочка" [image] ;
· установить флаг "Права на работу с АиТ:\Табельный учет".

Рис. 1

После установки прав на работу с модулем, ее имя попадает в выпадающий список поля "Название модуля" на закладке "Роли" (рис. 2), что позволяет назначить роль пользователю.

Для назначения роли нужно:

· перейти на закладку "Роли";
· в поле "Название модуля" указать имя модуля, для которого она назначается роль, обращаем внимание на тот факт, что никаких ролей пользователю еще не назначено;
· щелкнуть левой кнопкой мыши на левой панели под заголовком поля "Роль";
· нажать на кнопку "Создать" TabAdded , под полем "Роль" появляется пустая строка;
· в пустую строку из выпадающего списка (рис. 2) ввести имя роли пользователя.

Рис. 2

В том случае, когда пользователю не назначена роль, при запуске модуля "АиТ:\Табельный учет" выдается предупреждающее сообщение об ошибке (рис. 3), и модуль закрывается.

Рис. 3


Настройка параметров запуска

Для работы с модулем необходимо выполнить ряд настроек, а именно: установить права для работы с ним, создать базу данных, задать логин, пароль и путь к рабочей папке, в которую установлен модуль. База данных создается во время установки серверной части программного комплекса.

Работа с модулем возможна после его успешного запуска. Первое окно модуля, которое открывается после его запуска, предназначено для регистрации пользователя. В нем запрашиваются системное имя (логин) и пароль на вход в модуль, которые необходимо задать еще до его запуска в файле настроек AIT_KP.INI, иначе вход в модуль будет запрещен. Для функционирования модуля в этом файле необходимо также указать ряд других сведений, в частности, имя сервера и базу (базы) данных, используемых модулем.

Первоначально все перечисленные сведения формируются в файле AIT_KP.INI автоматически в момент установки программного комплекса "АиТ:\Управление персоналом", но эти данные доступны для редактирования. Следует заметить, что для каждого программного модуля в их рабочие папки установки добавляются два настроечных файла AIT_KP.INI и AIT.INI. Структура файла AIT_KP.INI одинакова для всех программных модулей. Рассмотрим подробно структуру файла AIT_KP.INI и назначение каждого его раздела.

Пример файла AIT_KP.INI

[Common]

DBMS=MSS (Msoft) SQL Server 6.0

ServerName=ServerProg

[DB]

Title_1=АиТ: Управление персоналом

DB_1=ait_hr

text_path_1=c:\aitclient\tbu\TXT

Title_2=Base2

DB_2=Base2

text_path_2=c:\aitclient\tbu\TXT

[Login]

LastUser=sa

LastDb=1

LastRole=

Назначение разделов файла AIT_KP.INI

Настроечный файл AIT_KP.INI включает три раздела, каждый из которых содержит набор директив. Имя каждого раздела указывается в квадратных скобках, например, [Common]. Каждая директива записывается на отдельной строке.

В первом разделе [Common] необходимо задать имя SQL сервера, на котором размещаются базы данных, с которыми будут работать модули (клиентское место), в частности модуль "АиТ:\Табельный учет". Имя севера, например, ServerProg указывается в директиве ServerName после знака "=".

Второй раздел [DB] предназначен для перечисления имен баз данных, доступных на текущем клиентском месте и размещенных на SQL сервере, имя которого приведено в первом разделе. Для каждой базы данных задается четыре директивы (строки). Первая база имеет порядковый номер 1, который ставится в каждой директиве после знака "_", например, Title_1, вторая база имеет порядковый номер 2 (Title_2) и так далее. В первой директиве указывается наименование базы данных, отображаемое в окне регистрации пользователя, Также директива может содержать и дополнительный поясняющий текст, например, название программного комплекса или конкретного модуля.

Title_1=АиТ: Управление персоналом

Во второй директиве указывается имя базы данных, под которым она зарегистрирована на сервере. В третьей и четвертой директивах заданы пути доступа к папкам с текстовыми файлами.

В третьем разделе [Login] в директиве LastUser можно указать логин пользователя, заданный системным администратором. Если логин задан, то при открытии модуля он отображается в поле "Имя" окна регистрации, иначе поле будет пустое и должно заполняться пользователем вручную.

В директиве LastDb можно проставить номер базы данных в списке. В этом случае при открытии модуля база данных с заданным номером будет выделена. Но разрешается выбрать из списка другую базу данных, которая будет использоваться при работе с модулем в текущем сеансе связи. После окончания работы с модулем в этой директиве будет задан номер базы данных, с которым он работал.

Файл AIT.INI

Файл настроек AIT.ini размещается в рабочей папке установки модуля и имеет такую же структуру, что и файл AIT_KP.INI, т.е. состоит из нескольких разделов, содержащих набор директив.

Для запуска модуля необходимо в первой директиве StartDir первого раздела [Start] указать путь к папке, в которой размещаются файлы модуля, например,

[Start]

StartDir=C:\aitclient\tbu\

Назначения остальных разделов и директив будет рассматриваться в дальнейших темах по мере описания работы с модулем.

Только после правильной настройки этого файла и при наличии логина и пароля можно начинать работу с программным модулем "АиТ:\Табельный учет".


Запуск модуля

Модуль поставляется в аппаратно защищенном от нелегального тиражирования виде. В момент запуска модуля в USB порте компьютера должен стоять электронный ключ из комплекта поставки.

Запуск модуля производится только из операционной среды Windows. Для запуска необходимо дважды щелкнуть на ярлыке (иконке) модуля Basestart или запустить на выполнение исполняемый файл tbu.exe. Наиболее быстрым и удобным способом является запуск модуля с использованием ярлыка, который создается при установке программного комплекса "АиТ:\Управление персоналом".

После запуска модуля открывается окно регистрации пользователя (рис. 1). В центральной части окна приводится одна или список баз данных, заданных в настроечном файле AIT_KP.INI. База данных, с которой будет работать пользователь в данном сеансе работы, должна быть выделена в списке.

Чтобы исключить несанкционированный доступ к модулю и базе данных, в окне регистрации запрашивается логин и пароль пользователя, которые необходимо задать еще до запуска модуля, иначе вход в него будет запрещен. В целях конфиденциальности при вводе пароля вводимые символы заменяются звездочками.

Рис. 1

Для входа в модуль нужно в окне регистрации:

· в поле "Имя" вручную ввести логин пользователя, если он не задан в файле AIT_KP.INI;
· в поле "Пароль" задать пароль, если присвоен пользователю;
· выбрать (выделить) рабочую базу данных, с которой ведется работа в текущем сеансе.

В случае успешной регистрации происходит вход в модуль, начинается инициализация данных и после их окончания открывается основное окно модуля, содержащее панель инструментов, Главное меню и список табельных листов.


Линия консультаций и поддержки

Зарегистрированным пользователям комплекса предоставляются бесплатные услуги линии консультаций по телефону, но не более 15 минут.

Для пользователей, имеющих абонементный договор, предоставляются неограниченные по времени консультации по телефону, факсу, почте и E-mail.

Телефон / Факс: | 8 495 984 82 81
Адрес офиса: | Москва, 105092, Б. Почтовая, д. 55/59
E-mail: | ait@aitsoft.ru
Web страница: | http://www.aitsoft.ru


Начало работы с модулем

Модуль "АиТ:\Табельный учет" поставляется с набором типовых плановых графиков, шаблонов плановых графиков, типов времени и других сведений, имеющихся в базе данных, что позволяет пользователю сразу же начать работу с ним и получить первоначальные навыки ведения табельного учета с помощью этого модуля.

Для ведения табельного учета с помощью данного модуля необходимо познакомиться с его основными понятиями:

· табельный лист – карточка, в которой ведется табельный учет группы сотрудников, например, работающих в одном подразделении. В нем указывается фактическое рабочее время сотрудника, а также причины неявки (больничные, отпуска и т.д.);
· тип времени – любой вид рабочего или нерабочего времени сотрудника, подлежащий учету. Заполнение фактически отработанного времени сотрудника, зафиксированного в табельном листе, производится через типы времени. Тип времени может исчисляться в днях (больничный, отпуск и пр.) или в днях и часах (рабочее время, сверхурочное, ночное и т. д.). Типы времени используются в расчете зарплаты для учета оплачиваемого времени в днях и часах;
· плановые графики – стандартные графики работ, служат для задания планового количества рабочих дней и часов по месяцам года. В плановых графиках определяется плановое количество табельного времени на каждую конкретную календарную дату;
· шаблоны графиков – используются для заполнения плановых графиков. Модуль позволяет автоматически заполнять плановые графики по имеющимся шаблонам. В этом случае шаблон графика указывается в настройках планового графика;
· журналы – представляют собой совокупность записей о каком-либо типе времени (больничный, отпуск и т. д.) с указанием периода длительности. Журналы предназначены для автоматизации заполнения табельных листов. В дистрибутивную поставку комплекса входит несколько настроенных журналов;
· своды – итоговые документы, созданные по данным табельных листов и содержащие суммарное время за месяц или за заданный период времени по типам табельного времени.

Для формирования и заполнения табельных листов необходимо создать и настроить типы времени, шаблоны графиков, плановые графики и журналы. Поэтому сразу же после установки модуля перед созданием табельных листов необходимо выполнить следующие предварительные действия:

· откорректировать список ежегодных праздников в соответствии с законодательством РФ на текущий календарный год, что обеспечивает автоматический перенос праздников, попадающих на выходные дни, в плановых графиках;
· установить текущий год, за который требуется заполнять плановые графики. В поставку программного комплекса включен большой набор плановых графиков, в том числе "Пятидневка (40ч)", "Пятидневка (36ч)", "Шестидневка (40ч)", обеспечивающих заполнение табельных листов в соответствии с требованиями ТК РФ и автоматический перенос праздников, попадающих на выходные дни. Все эти графики отображаются в окне "Список плановых графиков", но не заполнены;
· заполнить плановые графики для текущего календарного года, необходимые для ведения табельного учета. При первом открытии модуля "АиТ:\Табельный учет" в окне "Список плановых графиков" показываются плановые графики, сведения о которых имеются в дистрибутивной базе данных или из модулей "АиТ:\Кадровый учет" или "АиТ:\Зарплата", если пользователь уже работал с ними до приобретения данного модуля.

При совместном функционировании модулей плановые графики следует добавлять только в модуле "АиТ:\Табельный учет", и они автоматически попадают в справочник плановых графиков модуля "АиТ:\Кадровый учет" или "АиТ:\Зарплата";

· откорректировать справочник типов времени, добавив в справочник типы времени, используемые на текущем предприятии, и настроить их свойства;
· настроить аналитические признаки, используемые в модуле "АиТ:\Табельный учет", в окне "Настройка аналитических признаков".

После выполнения предварительных операций можно приступить к созданию и заполнению табельных листов. Текущая работа с модулем предполагает следующие операции:

· установка текущего месяца и года, т. е. месяца и года, за который приводятся данные в табельных листах, в журналах и других документах;
· создание и заполнение журналов по требуемому типу времени (отпуск, больничный лист и др.). Данные в журналы поступают из модуля "АиТ:\Кадровый учет" или "АиТ:\Зарплата" и используются для заполнения табельных листов. Этапы работы с журналами перечислены в теме "Назначение журналов";
· создание простых и автоведомых табельных листов, их заполнение за расчетный период;
· формирование сводов на основании табельных листов и передача их в модуль "АиТ:\Зарплата" для расчета зарплаты или в модуль "АиТ:\Кадровый учет" для формирования приказа об отпуске и получения отпуска за отгулы;
· создание отчетов для всестороннего анализа рабочего времени, учета и контроля использования рабочего и нерабочего времени, получения структуры отработанного времени и неявок по группам сотрудников, подразделениям или предприятию.


Заполнение плановых графиков

Заполнение плановых графиков выполняется в самом начале работы с модулем после приобретения программного комплекса "АиТ:\Управление персоналом" и предусматривает выполнение следующей последовательности действий.

1. Установить текущий календарный год в окне, которое вызывается первой кнопкой Panel1 на основной панели инструментов. Месяц можно установить любой, например, январь, т. к. заполнение графиков выполняется на весь календарный год.

2. Откорректировать список ежегодных праздников в соответствии с законодательством РФ на текущий календарный год.

3. Открыть окно "Список плановых графиков" кнопкой Panel6, выделить все или нужные графики, например, используемые в текущем предприятии, и нажать на кнопку "Пересчет плановых графиков за год" GrafRecalc для заполнения выделенных графиков. Выделение графика выполняется щелчком правой кнопки мыши, выделенный график отображается контрастным цветом.

Внимание. В том, случае, если по каким-либо причинам список плановых графиков пуст, то при самом первом открытии окна появляется сообщение, предупреждающее об этом. После нажатия на кнопку "Пересчет плановых графиков за год" GrafRecalc и завершения операции в списке появятся плановые графики, заданные в модулях "АиТ:\Кадровый учет" или "АиТ:\Зарплата".

4. Проверить, все ли графики заполнены. Для этого последовательно нужно выделить каждый график. Заполненным считается график, у которого на правой панели "Итого" в колонках "Дни" и "Часы" указываются не нулевые значения.

5. Если выделенный график не заполнен, то следует проверить настройки шаблона и планового графика.

5.1. Для настройки шаблона и графиков работы нужно:

· нажать на кнопку Panel5 основной панели инструментов и в списке шаблонов выделить нужный шаблон;
· нажать на кнопку "Открыть" SotrParam дополнительной панели инструментов и в окне "Настройка шаблона проверить правильность заполнения цикла шаблона и типов времени, при необходимости откорректировать настройки шаблона.

5.2. Для настройки графика работы откройте окно "Настройки графика" кнопкой TabParam из списка плановых графиков и проверьте, указано ли в поле "Шаблон" имя шаблона, на основании которого заполняется данный график. Если необходимо, откорректируйте настройки и сохраните их, закрыв окно кнопкой TabDoor. Появляется сообщение "Подождите, пожалуйста, выполняется операция".

6. Открыть окно "Список плановых графиков", выделить последовательно все графики и нажать на кнопку GrafRecalc для перерасчета плановых графиков. Далее в окне "Перерасчет плановых графиков" (рис. 1) нажать на кнопку "Да" для проведения операции.

Рис. 1

Начинается пересчет плановых графиков с указанием процента выполнения операции в бегущей строке (рис. 2).

Рис. 2

После окончания операции (100% выполнения) появляется сообщение "Все прошло успешно".


Помощь (Справка)

Справочная система (Помощь)

 Top Previous Next

Справочная система (Справка, Помощь) содержит основные сведения и порядок работы с модулем "АиТ:\Табельный учет". Обращение к Справочной системе происходит из любого режима (окна) модуля. В затруднительных ситуациях Справочная система (СС) позволяет получить оперативную контекстно-зависимую помощь по работе с конкретным окном, открытым в настоящий момент, нажав на клавишу F1. Справочная система может быть открыта одним из следующих способов:

· кнопкой Help1 панели инструментов;
· клавишей F1;
· из пунктов раздела "?" Главного меню.

Показ разделов Справочной системы происходит в специальном окне, разделенном на две панели (рис. 1). На правой панели отображается собственно справочная информация по текущему разделу, открытому из модуля или выбранному пользователем. При открытии Справочной системы на левой панели отображается ее содержание. В верхней части окна расположены кнопки, назначение которых описано в конце этого раздела.

Рис. 1

Внимание. При первом открытии окно Справочной системы стандартно размещается в верхнем правом углу экрана и его размер задан по умолчанию. Пользователь может установить размер окна и его размещение на экране по своему усмотрению. При последующих открытиях окна настройки, сделанные пользователем сохраняются.

Назначение левой панели окна Справочной системы

Информация, приведенная на левой панели, зависит от выбранной закладки. Если ширина левой панели недостаточна для отображения названий всех четырех закладок, то справа от набора закладок (рис. 2) появляются кнопки Help2 для перемещения по закладкам.

Рис. 2

На закладке "Содержание" приводится иерархический список папок с включенными в них разделами Справочной системы и отдельных разделов. Папки помечены значком папки Help4 (свернутая папка) или Help5 (раскрытая папка), а разделы – значком документа Help6 . Раскрыть или свернуть папку можно, щелкнув на значке "+" или "-", расположенном слева от названия папки. В раскрытой папке видны все разделы, входящие в нее, и вложенные папки. Щелчок левой кнопки мыши на заголовке выбранного раздела приводит к показу выбранного раздела в правой части окна.

Закладка "Указатель" позволяет находить нужную тему по списку ключевых слов, которые перечислены в алфавитном порядке. В верхней части закладки находится поле для ввода ключевого слова. Причем, если поле ввода под закладками страниц не заполнено, то показывается список ключевых слов, начиная с первой буквы алфавита "А". Открытие раздела производится двойным щелчком левой кнопкой мыши на ключевом слове или в результате его выделения и нажатия на кнопку "Показать". Если ключевое слово относится к нескольким разделам, то предварительно открывается окно "Найденные разделы" со списком разделов.

Если ключевое находится за пределами его видимости, то можно воспользоваться вертикальной полосой прокрутки или ввести его в верхнее поле. Пользователь может ввести ключевое слово (полностью или только несколько первых букв) вручную. Ключевое слово, в котором имеются введенные символы, выделяется и перемещается в самый верх списка.

Закладка "Поиск" обеспечивает переход к нужному разделу по конкретным словам, фразам, имеющимся в тексте Справочной системы, а также по отдельным выражениям с использованием текста и логических операторов AND, OR, NEAR, NOT (рис. 1). Показ списка логических операторов происходит после нажатия на кнопку Help7 .

После ввода фрагмента текста нажмите на кнопку "Разделы", в результате в нижней части отобразится список разделов, удовлетворяющих заданному выражению. Выбранный в списке раздел показывается в правой части окна.

Закладка "Избранное" предназначена для быстрого показа наиболее часто просматриваемых пользователем разделов. Предварительно нужные разделы должны быть перечислены на этой закладке. Для этого сначала требуется открыть нужный раздел на другой закладке, а затем перейти на эту закладку. Заголовок открытого в данный момент раздела Справочной системы отображается в нижней части закладки в поле "Текущий раздел". После нажатия на кнопку "Добавить" выбранный раздел попадает в список разделов. Исключение ненужного раздела из списка выполняется кнопкой "Удалить".

Назначение правой панели окна Справочной системы

Правая панель служит для непосредственного представления на экране текста выбранного раздела. Перемещаться по тексту раздела можно так же, как и в обычном окне редактирования, а также по словам (ссылкам), выделенным голубым цветом. В окне Справочной системы действуют команды текстового редактора, что позволяет выделить в нем текст, скопировать его или перенести в любой другой документ.

Быстрый переход к другому разделу выполняется по ссылкам внутри темы или по иерархическому списку разделов, ключевых слов, тексту для поиска, отображаемому в левой части окна. При остановке на ключевом слове указатель мыши меняет свой внешний вид со "стрелки" на изображение "руки". Щелчок на таком слове приводит к открытию на экране раздела, в котором содержится более подробная информация о подчеркнутом понятии (термине).

В верхней части окна расположены кнопки, обеспечивающие следующие действия:

· Показать / Скрыть – отображение или скрытие содержания Справочной системы. При показе содержания кнопка называется "Скрыть", при его отсутствии – "Показать". Нажатие на кнопку "Скрыть" делает содержание невидимым, и изменяет название кнопки;
· Назад – переход к последнему просмотренному разделу;
· Вперед – перемещение вперед по списку ранее открытых разделов;
· Домой – переход к первой теме "Словарь терминов" Справочной системы. Перемещение к нужному термину в этом разделе осуществляется нажатием на кнопку с буквой алфавита, совпадающей с первой буквой этого термина. Возврат в начало темы происходит по кнопке "Назад";
· Печать – печать текущего раздела или всей книги, содержащей текущий раздел.
· Параметры – открытие контекстного меню с набором команд.


Настройка прав доступа

Пользователи, работающие с базовой версией модуля "АиТ:\Табельный учет", имеют полный доступ ко всем его функциям, и от них не требуется настраивать права доступа.

В версиях "Проф" и "Холдинг" перечень функциональных возможностей при работе с окнами (режимами работы) модуля зависит от прав доступа конкретного пользователя к этим режимам.

Настройка прав доступа для работы с режимами и функциями модуля в этих версиях осуществляется системным администратором в модуле "АиТ:\Конфигурация" в окне (рис. 1). Вызов окна "Редактирование списка ролей" происходит из пункта "Роли" раздела "Режим" Главного меню.

Прежде всего, необходимо в верхнем поле "Модуль" (рис. 1) указать имя модуля "АиТ:\Табельный учет", для которого производится настройка прав доступа. Далее выбрать роль из списка, приведенного в левой части окна. Выбор роли осуществляется щелчком левой кнопки мыши на нужной роли, при этом слева от названия выбранной роли (sa) появляется символ "стрелочка" Strelka , как показано на рис. 1.

Рис. 1

В правой части окна для выбранной роли и программного модуля "АиТ:\Табельный учет" отображается список общих настроек объектов, режимов и функций. Для каждого элемента списка системным администратором указываются права доступа.

Список настроек приводится в первом столбце "Объекты, режимы и функции", формируется автоматически и группируется по разделам, которые могут содержать набор настроек. Имя каждого раздела отображается с левой стороны первого столбца и указывается синим цветом. Второй столбец "Доступ" является редактируемым, значения в него вводится из выпадающего списка, содержащего следующие виды доступа, предоставляемые пользователю:

· полный – полный доступ предполагает возможность работы с выбранным режимом без ограничений, когда доступны все операции с данными. Пользователю разрешается не только просматривать данные, но и изменять их (вводить, удалять, править, печатать, импортировать или экспортировать);
· чтение – разрешен доступ на чтение, что дает возможность только просматривать информацию, но запрещает ее редактировать;
· нет – отсутствует доступ к режиму, т.е. невозможно даже открыть окно или воспользоваться данной функцией модуля.


Настройка параметров режимов работы модуля

Пользователи, работающие с базовой версией комплекса, имеют полный доступ ко всем функциям модулей, и от них не требуется настраивать параметры отдельных режимов работы.

В версиях "Проф" и "Холдинг" настройка параметров режимов работы с модулем "АиТ:\Табельный учет" осуществляется системным администратором в модуле "АиТ:\Конфигурация" в окне "Настройки комплекса" (рис. 1). Вызов окна происходит из пункта "Настройки" раздела "Режим" Главного меню.

Рис. 1

Окно "Настройки комплекса" предназначено для общей настройки алгоритмов и функциональных возможностей режимов выбранного программного модуля. Выбор модуля происходит из выпадающего списка самого верхнего поля "Модуль", под которым расположена таблица, содержащая два столбца "Параметр" и "Значение" для отображения списка параметров и их значений. Для просмотра таблицы можно воспользоваться полосой прокрутки. При перемещении по таблице в каждый момент времени видимый фрагмент таблицы содержит имя выбранного программного модуля "АиТ:\Табельный учет", которое отображается на сером фоне над заголовком раздела.

Все параметры в первом столбце формируются автоматически, их редактировать нельзя. Параметры сгруппированы по разделам, каждый из разделов выделяется жирным синим цветом и может содержать от одного до нескольких параметров. Для автоматического перехода к нужному параметру необходимо ввести несколько начальных букв в поле "Поиск". В результате заданный параметр становится текущим, он подчеркивается и отмечается знаком Strelka ("стрелочка") слева от него.

Параметры могут принимать логические значения "Да" или "Нет", которые указываются во втором столбце "Значение" (рис. 1). Для ввода значений используется дополнительное окно "Изменение параметра" (рис. 2). Установка флага соответствует значению "Да", при снятом флаге значение равно "Нет".

Рис. 2


Графический интерфейс

Модуль "АиТ:\Табельный учет" оснащен стандартным графическим интерфейсом пользователя, который обеспечивает доступ к основным функциям и режимам модуля и на экране представлен в виде графических элементов (объектов). Учитывая особую значимость графического интерфейса пользователя для работы с модулем, его описание приводится в отдельной папке.

К стандартному пользовательскому интерфейсу модуля относятся:

· окна модуля;
· Главное меню;
· основная и дополнительная панель инструментов.
· элементы графического интерфейса окон.

Следует заметить, что Главное меню и панели инструментов располагаются только в основном окне модуля. Только одно окно в модуле является основным окном, и в нем размещаются все дочерние окна, в которых происходит основная работа с модулем.

Дочерние окна модуля содержат набор стандартных элементов (объектов) графического интерфейса Windows (полей, флагов, переключателей и других), имеющих стандартный внешний вид и выполняющих стандартные действия. Доступ ко всем видимым элементам графического интерфейса осуществляется с помощью клавиатуры или устройства координатного ввода типа "мышь".

Следует заметить, что работа с использованием мыши является более предпочтительной благодаря своей простоте и оперативности. Для выполнения различных операций с помощью клавиатуры применяются специально предназначенные для этого клавиши, называемые, горячими клавишами. Например, вызов Главного меню осуществляется клавишей горячей клавишей F10.


Основное окно модуля

Основное окно – это часть экрана, в которой выполняется вся работа с модулем "АиТ:\Табельный учет". Основное окно (рис. 1) открывается сразу же после запуска модуля и успешной регистрации пользователя.

В модуле "АиТ:\Табельный учет" только одно окно является основным, и в нем в качестве заголовка указывается название модуля – "АиТ:\Табель", а также месяц и год, за который формируются табельные листы. Окна, размещающиеся внутри основного окна, называются дочерними. После открытия модуля внутри основного окна размещается дочернее окно с заголовком "Список табельных листов".

Рис. 1

Основное окно, в отличие от других дочерних окон, содержит Главное меню, а также две панели инструментов (основную панель и панель операций). В процессе работы в рабочей области основного окна могут размещаться и другие открытые дочерние окна модуля, а также значки свернутых дочерних окон. Обратите внимание дочерние окна, в отличие от основного окна, не содержат меню и панели инструментов, но так же, как и основное окно имеют заголовки. Виды окон и способы управления ими рассмотрены в отдельной теме. Окна модуля содержат набор стандартных графических элементов Windows (полей, флагов, переключателей и других).

Любая операция в окне, например, выбор пункта меню, настройка параметров в любых окнах, ввод данных и т.д. осуществляется с помощью мыши. Поэтому в самом начале работы следует познакомиться с основными действиями, выполняемыми мышью: "щелчок", "двойной щелчок", "нажать на кнопку", "перетащить и отпустить".

Щелчок

Для выполнения "щелчка" следует быстро нажать и отпустить левую кнопку мыши.

Двойной щелчок

Для осуществления "двойного щелчка" нужно дважды нажать на левую кнопку мыши с минимальным интервалом между нажатиями.

Нажать на кнопку

Операции "нажать на кнопку" в окне означает следующее:

· установить указатель мыши на кнопке;
· нажать левую кнопку мыши и отпустить ее.

В результате будут выполнены действия, для которых предназначена эта кнопка.

Перетащить и отпустить

Метод "перетащить и отпустить" означает следующую последовательность действий:

1. установить указатель мыши на нужный объект, например, на строку;
2. нажать левую кнопку мыши;
3. не отпуская кнопку, переместить указатель мыши на нужную позицию экрана, при этом одновременно с мышью перемещается и объект (строка);
4. отпустить кнопку мыши.


Виды окон и способы управления ими

Вся работа с модулем выполняется в многооконном режиме, когда одновременно может быть открыто несколько окон (рис. 1). Окно предназначено для отображения каких-либо сведений в электронном виде, для ввода данных, настройки параметров и поиска информации. Настройка параметров в любых окнах производится путем установки или снятия флагов, выбора переключателей, ввода данных или формирования различных списков. Пользователь может изменить настройки, задаваемые по умолчанию, или оставить их прежними.

Рис. 1

Сразу же после запуска модуля и успешной регистрации пользователя открывается основное окно. Все остальные открытые окна модуля размещаются внутри основного окна и называются дочерними окнами. Дочерние окна, в отличие от основного окна, не содержат Главное меню и кнопки панели инструментов.

После открытия модуля внутри основного окна размещается дочернее окно с заголовком "Список табельных листов". Все окна (основное и дочерние) снабжены заголовком и кнопками управления окнами.

В каждый момент времени в модуле может быть открыто несколько окон, но работать можно только с одним окном, которое называется активным, или текущим окном. Активным считается окно, в котором находится курсор, в нем можно, просматривать, вводить или редактировать данные. Заголовок активного окна имеет более контрастный цвет по сравнению с другими окнами, на рис. 1 – это окно "Список плановых графиков".

Список открытых в данный момент окон показывается под пунктами раздела "Окно" Главного меню. Одно и то же окно не может быть открыто дважды. Для открытия окон в модуле используются пункты Главного меню, кнопки основной и дополнительной панелей инструментов. Открытие нового окна приводит к переходу в новый режим работы, под которым подразумевается совокупность функций и операций, доступных в данном окне. Переключение между открытыми окнами выполняется мышью или “горячими” клавишами Ctrl+Tab.

Назначение кнопок управления окном

Заголовок любого окна отображается в его самой верхней строке с левой стороны. В той же строке с правой стороны размещаются кнопки управления окном "Свернуть" Winroll , "Развернуть" Winunfold и/или "Закрыть" WinClose (рис. 1). У основного окна активны все три кнопки.

Самая правая кнопка "Закрыть" предназначена для закрытия окна. Если окно имеет только одну эту кнопку, то его можно также перемещать по экрану, но нельзя изменять его размеры и сворачивать. Для сворачивания окон используется кнопка "Свернуть". Свернутое окно является неактивным и размещается в нижней части основного окна в виде значка (рис. 2), но в любой момент времени его можно сделать активным и показать на экране его содержимое, щелкнув мышью на первой левой кнопке Winrestore свернутого окна.

Рис. 2

Окна, у которых активна кнопка "Свернуть", можно также перемещать по экрану и изменять их размеры. Окна на экране могут быть представлены в полноэкранном виде, если у них активна кнопка "Развернуть". Щелчок на ней увеличивает размер окна до полного экрана (рис. 3).

Рис. 3

В этом случае заголовок полноэкранного окна отображается после заголовка основного окна в квадратных скобках, а кнопки управления этим окном в той же строке, что и Главное меню, с правой стороны. Вернуть окно к прежнему размеру можно при помощи кнопки "Свернуть в окно" Interfacewin4 , которая появляется только в полноэкранном окне вместо кнопки "Развернуть".

Окна, у которых активны все три кнопки, на экране могут быть представлены в полноэкранном (рис. 2) или в свернутом виде (рис. 3), их можно закрывать, перемещать и изменять их размеры.

Чтобы изменить размер окна по одному направлению, например, по его высоте (длине) следует установить указатель мыши на горизонтальную (вертикальную) сторону рамки окна, щелкнуть левой кнопкой мыши, и, не отпуская ее, переместить указатель мыши в нужную позицию экрана вверх/вниз (вправо/влево). Вместе с курсором по экрану перемещается и контур окна. Для фиксации размеров окна отпустите кнопку мыши. Для увеличения размеров окна одновременно по двум направлениям расположите указатель мыши на угол окна и выполните те же действия, что и при изменении размера в одном направлении.

Управление окнами производится с помощью пунктов раздела "Окно" Главного меню. Данная группа функций позволяет переключаться между открытыми в данный момент окнами и выполнять над ними определенные действия.

Виды окон

Все дочерние окна модуля размещаются в основном окне и могут быть классифицированы по различным критериям. Все открытые в данный момент времени в модуле окна делятся на следующие виды:

· открытое – окно, которое размещается в основном окне модуля или на рабочем столе компьютера, если оно является недочерним. Все открытые окна модуля вызываются только из основного окна и закрываются в момент окончания работы с ним. Только одно из открытых дочерних окон может быть активным;
· активное (текущее) – открытое окно, в котором в текущий момент времени установлен курсор, только в нем можно просматривать, вводить или редактировать данные. Заголовок активного окна имеет более контрастный цвет по сравнению с другими окнами;
· свернутое (минимизированное) – открытое окно, которое отображается в нижней части основного окна модуля в виде значка. На рис. 2 показано три свернутых окна модуля.

В модуле все окна по их местоположению относительно основного окна классифицируются на следующие виды:

· дочерние окна – окна, размещающиеся внутри основного окна;
· недочерние окна – окна, которые выходят за пределы основного окна, например, окно для установки текущего месяца. Недочерние окна отсутствуют в списке открытых окон под пунктами раздела "Окна", они отображаются на панели задач в виде кнопки так же, как и другие запущенные приложения. По умолчанию панель задач находится в нижней части экрана монитора. Чтобы закрыть текущую кнопку на панели задач, щелкните на ней правой кнопкой мыши и выберите команду "Закрыть" или воспользуйтесь клавишами Alt+F4.

В зависимости от возможности доступа к другим режимам окна подразделяются на два типа:

· модальные окна – работают в монопольном режиме, когда они открыты, запрещен доступ к меню, инструментам и другим режимам работы (окнам). Типичным представителем модальных окон являются Мастера для создания отчетов и окна, которые вызываются кнопками дополнительной панели инструментов;
· немодальные окна – позволяют осуществлять доступ к различным функциям модуля без его закрытия.

По количеству страниц (закладок) окна подразделяются на:

Одностраничные – окна, у которых отсутствуют закладки, например, окно со списком табельных листов.

Многостраничные – окна, имеющие набор закладок, например, окно "Типы времени". Переход на нужную закладку выполняется щелчком мыши на одноименной кнопке (закладке), обычно расположенной в верхней части окна.

По содержанию отображаемых данных и внешнему виду окна делятся на следующие виды:

Карточки – электронные документы, используемые в модуле и содержащие сведения о каком-либо субъекте или объекте (табельном листе, типе времени и др.) и имеющие произвольное расположение полей ввода и вывода информации.

Отчеты – окна, в которых приводятся результаты построения отчета. Обычно отчеты отображаются в других программах Word, Excel.

Документы – окна, в которых отображаются различного рода документы, используемые в табельном учете, например, различного рода карточки, журналы и другие документы.

Формы – окна с типовыми формами отчетности, которые являются электронными аналогами законодательно утвержденных первичных документов, в которых отображаются различного рода документы, используемые в табельном учете, например, унифицированные формы Т-13 и Т-12.

Настроечные окна – окна, используемые для настроек, например, окна для общих настроек модуля, журналов, аналитики, отчетов по предприятию

Окна-списки – окна, в которых информация представлена в виде списков в иерархическом или табличном виде. Иерархические списки можно отображать в свернутом (компактном виде) или развернутом виде с показом одной, нескольких или всех вложенных групп данных. Окна с иерархическими списками используются для отображения структуры предприятия. Например, в первом окне Мастера создания отчета по списочной численности приводится структура предприятия для выбора подразделения, по которому создается отчет.


Главное меню

Главное меню обеспечивает доступ к основным функциям и возможностям модуля, имеет иерархическую структуру и включает три уровня меню. Верхний уровень Главного меню состоит из нескольких разделов (например, "Карточка", "Вид", "Режим") и всегда показывается под заголовком основного окна модуля "АиТ:\Табельный учет" (рис. 1).

Рис. 1

Каждый раздел содержит набор пунктов. Отдельные пункты Главного меню продублированы кнопками панели инструментов. В нижней части основного окна при выборе пункта меню выводится его назначение.

Для доступа к пунктам щелкните левой кнопкой мыши на требуемом разделе Главного меню. В результате на экране непосредственно под выбранным разделом отображается список всех пунктов этого раздела меню. Второй уровень меню, содержащий список пунктов раздела, по способу отображения называется также выпадающим меню. На рис. 1 показано выпадающее меню для раздела "Режим".

В свою очередь некоторые пункты меню, справа от которых имеется символ MainMenu2 , могут содержать подпункты, в частности, пункт "Отчеты" включает шесть подпунктов, первым из которых является "Списочная численность". Подпункты и пункты меню, не содержащие подпунктов, называются командами. Под командой понимается последовательность действий, приводящих к определенному результату.

Выбор одного из пунктов раздела меню или подпунктов (команды) осуществляется щелчком левой кнопки мыши на нем и приводит к выполнению определенного действия, для которого он предназначен, например, команда "Каскад" раздела "Окна" располагает открытые окна в виде стопки. Выполнение большинства команд приводит к открытию нового окна.

Главное меню содержит следующие разделы:

· Карточка – включает пункты меню, обеспечивающие доступ к сервисным функциям практически всех типов карточек (электронных документов), используемых в модуле;
· Вид – содержит переменный набор пунктов меню, зависящий от вида открытого окна, а также два постоянных пункта для настройки фильтра и установки текущего месяца;
· Режим – обеспечивает доступ к основным режимам работы модулеяи к их настройкам;
· Автоведение – содержит пункты меню для работы с автоведомыми табельными листами;
· Окно – управление расположением на экране графических элементов: окон, панели инструментов, значков;
· ? – обеспечивает доступ к Справочной системе (Помощи), в которой описаны основные понятия, возможности и режимы работы с модулем.


Раздел "Карточка"

Назначение и количество пунктов раздела "Карточка" Главного меню зависит от вида активного окна (режима). Пункты этого раздела доступны в следующих случаях, когда:

· в активном окне размещается список карточек или записей, открытый при помощи пунктов раздела "Режим";
· в активном окне отображается карточка, открытая в списке карточек при помощи пункта "Открыть" этого раздела;
· на экране все окна закрыты, в списке пунктов раздела присутствует только один пункт "Выход".

Когда на экране открыт список карточек, то раздел "Карточка" включает набор пунктов, обеспечивающий создание, открытие, копирование, удаление карточки или записи, выделенной в списке активного окна.

Если на экране открыта карточка, то состав пунктов изменяется, контекстно зависит от типа карточки, и обеспечивает доступ к сервисным функциям активного окна с карточкой.

Пункты меню этого раздела используются для следующих окон (режимов), открытых на экране:

1. Параметры сотрудников предприятия;

2. Типы времени;

3. Список табельных листов;

4. Табельные листы;

5. Список плановых графиков;

6. Список шаблонов графиков;

7. Своды по табельному листу;

8. Итоги по табельному листу;

9. Журналы;

10.Отчеты;

11.Настройка параметров планового графика.

Список пунктов меню с указанием их назначения и режимов, в которых они используются, приведен в нижеприведенной таблице.

Пункт меню

Кнопка

Назначение

Используется для режима

Создать

TabAdded

Создание новой карточки (записи). В зависимости от типа активного окна создаются табельные листы, типы времени и пр.

1, 2, 3, 5, 6

Открыть

SotrParam

Открытие существующей карточки (записи). В зависимости от типа активного окна открываются табельные листы и пр. (в типах времени отсутствует)

1,3,6

Копировать

GrafCopy

Копирование текущей записи в окне настройки отчетов по предприятию

5

Удалить

TabDel

Удаление записи из списка. В зависимости от типа активного окна удаляются табельные листы, типы времени и пр.

1,2,3,5,6

Сохранить (Ctrl+S)

TabSave

Сохранение данных в текущем окне

3, 4, 6

Выделить все

TabSelect

Выделение всех строк в активном списке

2, 4

Снять выделение

TabSelectNo

Снять выделение со всех строк в активном списке

2, 4

Отобразить все

TabPluc

Показать все строки в табельном листе

4

Скрыть пустые

TabMinuc

Не показывать незаполненные строки табельного листа

4

Поставить фильтр

Filtr

Установка фильтра в активном окне, например, с табельным листом, со списком плановых графиков

4, 5

Снять фильтр

Panel9

Снятие фильтра в активном окне

4, 5

Свод в зарплату

SvodSalary

Формирование свода, передаваемого в модуль "АиТ:\Зарплата".

7

Свод в кадры

SvodPerson

Формирование свода, передаваемого в модуль "АиТ:\Кадровый учет".

7

Пролистать к началу

Переход к первому своду в списке и его открытие

7, 8

Пролистать назад

Переход к предыдущему своду в списке и его открытие

7, 8

Пролистать вперед

Переход к последующему своду в списке и его открытие

7, 8

Пролистать к концу

Переход к последнему своду в списке и его открытие

7, 8

Заполнить (Ctrl+F)

TabWizardAdded

Вызов Мастера заполнения табельного листа (планового графика) табельным временем

4

Параметры (Ctrl+P)

TabParam

Вызов окна настройки параметров текущего табельного листа (планового графика)

3, 4, 5

Расчет (Ctrl+F3)

TabCalk

Пересчет итоговых сумм по табельному листу при изменении каких-либо данных в нем, не закрывая окно "Итоги по табельному листу"

8

Праздники (Ctrl+H)

GrafHoliday

Открытие списка праздничных дней

5

Печать (F4)

Print

Печать отчетов по текущему окну

4, 5, 8

Настройка принтера…

Настройка параметров текущего принтера

4, 5

Мастер расчета

Panel2

Мастер расчета позволяет создавать новые отчеты или табельные листы с автоведением по каждому подразделению.

10

Распространить общие настройки

(Ctrl+F)

Этот пункт появляется в меню только при открытом окне настройки параметров планового графика и распространяет настройки данного окна на весь период действия текущего планового графика. При этом на экране появляется окно с предупреждением, что, если в других месяцах график имел уникальные настройки, то они будут безвозвратно потеряны.

Действие этого пункта эквивалентно установке флага "Одинаковые параметры во всех месяцах" в настройках параметров планового графика.

11

Закрыть окно

TabDoor

Закрыть текущее окно

1,2, 3, 6

Выход (Alt+F4)

Panel14

Автоматическое закрытие всех окон и завершение работы с модулем "АиТ:\Табельный учет"

Все окна


Раздел "Вид"

Состав пунктов раздела "Вид" Главного меню зависит от вида активного окна (режима), открытого на экране, и используется для следующих режимов работы модуля:

1. Параметры сотрудников предприятия;

2. Типы времени;

3. Список табельных листов;

4. Табельные листы;

5. Список плановых графиков;

6. Список шаблонов графиков;

7. Отчеты.

При условии, что все окна на экране закрыты, в разделе "Вид" присутствуют два пункта "Текущий месяц" и "Фильтр".

Название и назначение пунктов меню раздела "Вид", а также кнопок и клавиш, выполняющих те же действия, что и пункт меню, приведено в таблице.

Пункт меню | Кнопка | Назначение | Используется для режима
Текущий месяц (Alt+M) | Panel1 | Открытие окна изменения текущего месяца | Все окна
Список сотрудников (Ctrl + L) | TabSotr | Открытие списка сотрудников для просмотра или изменения состава сотрудников, учитываемых в текущем табельном листе | 3,4
Скопировать список сотрудников |  | Копировать список сотрудников в табеле в текущем месяце на основании данных табельного листа предыдущего месяца. | 3
Отклонения параметров (Ctrl + F2) | TabParamSotr | Открытие окна для ввода отклонений графика и аналитики сотрудников в текущем табельном листе | 3,4
Детализация по дням(Ctrl + T) | TabDetal | Открытие табельного листа и окна детализации плановых графиков | 3,5
Промежуточные итоги(Ctrl + C) | TabItog | Открытие окна итогов по табельному листу или по плановым графикам. В режиме "Уменьшить количество отображаемых кнопок" операция недоступна | 3,4,5
Своды по табельному листу (Ctrl + S) | TabSvod | Открытие окна со списком сводов | 3,4
Балансировка графика(Ctrl + B) | GrafBalans | Открытие окна балансировки плановых графиков | 5
Деактивирование графика | GrafDeactiv | Изменение статуса планового графика с активного состояния, когда график используется в модулях, на неактивное состояние (деактивированное), когда он недоступен в других модулях комплекса | 5
Перерасчет плановых графиков на год | GrafRecalc | Перерасчет плановых графиков на год | 5
Фильтр (Ctrl + F) | Panel9 | Открытие окна для установки фильтра | Все окна


Раздел "Режим"

Раздел "Режим" предназначен для открытия основных режимов работы модуля и их настройки. Состав пунктов этого раздела неизменен и не зависит от вида активного окна, открытого на экране.

Раздел "Режим" обеспечивает доступ к табельным листам, плановым графикам, типам времени, шаблонам графиков, журналам, отчетам и списку сотрудников. В результате открываются списки карточек (записей) соответствующего типа, позволяющие перейти к выбранной карточке. Открытие карточки выполняется с помощью пункта меню "Открыть" раздела "Карточка".

Назначение пунктов меню раздела "Режим"

Пункт меню

Кнопка

Назначение

Настройки

Включает набор подпунктов, обеспечивающих доступ к окнам настроек модуля: Настройки общие, Настройки режимов, Настройки журналов, Настройки аналитики, Настройки отчетов по предприятию, Настройки формы 38.

Типы времени (Alt + V)

Panel4

Открытие окна настройки типов времени

Шаблоны графиков (Alt + D)

Panel5

Открытие списка шаблонов графиков

Плановые графики (Alt + P)

Panel6

Открытие окна со списком плановых графиков

Табельные листы (Alt +T)

Panel7

Открытие окна со списком табельных листов

Параметры сотрудников

Panel3

Открытие окна параметров сотрудников предприятия

Отчеты

Включает набор подпунктов, обеспечивающих вызов окон для получения отчетов, например, расчета списочной и средней численности, формирования отчетов по предприятию и др.

Журналы (Alt + J)

Panel8

Открытие окна для работы с журналами.

Разложить все журналы (Ctrl + Alt + J)

Если пользователь имеет полный доступ к этой функции модуля, то сразу можно раскладывать все журналы, т.е. перенести записи из всех журналов в табельные листы в заданном пользователем порядке.

Внимание. Данный пункт отображается в меню, если в окне "Редактирование списка ролей" модуля "АиТ:\Конфигурация" в разделе "Доступ к режиму Ведение журналов" для функции "Раскладка всех журналов" установлен полный доступ.

Поиск (Alt + F7)

Panel10

Вызов функции поиска данных о сотруднике.

Перечитать данные

Panel11

Обновление данных в процессе работы модуля – импорт данных об отпусках и больничных, об изменениях параметров сотрудников из модулей "АиТ:\Кадровый учет" и "АиТ:\Зарплата". Целесообразно выполнять эту операцию перед оформлением табельных листов и формированием сводов, при этом все все окна модуля должны быть закрыты, иначе операция не выполняется и выдается предупреждающее сообщение. В некоторых случаях для проведения этой операции может потребоваться продолжительное время.


Раздел "Автоведение"

Раздел "Автоведение" включает следующие пункты меню для работы с автоведомыми табельными листами:

· Мастер табельного учета – вызов Мастера табельного учета. Кроме этого, Мастер можно вызвать кнопкой Panel2 основной панели инструментов;
· Откорректировать списки сотрудников – корректировка списков сотрудников в текущем табельном листе или в выделенных табельных листах c автоведением в соответствии с критериями отбора сотрудников в каждом табельном листе (подразделение, категория, график и т.д.);
· Оформить табель – запуск функции оформления табеля для текущего табельного листа или для выделенных табельных листов с автоведением. Операция оформления табельного листа предусматривает заполнение табеля по всем сотрудникам в соответствии с их плановыми графиками с учетом изменений плановых графиков и переходов сотрудников между табельными листами, а также внесение в табельные листы записей из журналов. Записи из журналов вносятся в табельные листы в том же порядке, как и для операции "Разложить все журналы".

Внимание. При создании новых небазовых табельных листов этот пункт неактивен, отображается серым цветом.

· Рассчитать свод – расчет сводов для текущего табельного листа или выделенных в списке табельных листов с автоведением.

Внимание. Последние три пункта меню отображаются в разделе "Автоведение" только при условии, что на экране открыто окно "Список табельных листов". Эти пункты дублируют шаги Мастера табельного учета и позволяют выполнить же операции не со всем списком, а с произвольно выбранными в нем табельными листами.


Раздел "Окно"

Управление окнами производится с помощью пунктов (команд) раздела "Окно" Главного меню. Данная группа команд позволяет переключаться между открытыми в модуле в данный момент окнами и выполнять над ними определенные действия, а также настраивать панель инструментов. Раздел "Окно" включает следующие пункты меню:

Каскад

Располагает окна последовательно в виде стопки, с частичным наложением друг на друга таким образом, чтобы на экране всегда был виден заголовок каждого окна и его левая вертикальная сторона. Активное в данный момент окно помещается в самый верх стопки.

Мозаика

Располагает все открытые дочерние окна в основном окне вертикально без перекрытия, чтобы был виден фрагмент каждого окна.

Горизонт

Располагает в основном окне все открытые дочерние окна горизонтально без перекрытия, чтобы был виден фрагмент каждого окна.

Панель инструментов

Конфигурирует местоположение панели инструментов на экране. Настройка осуществляется в окне "Настройка панели инструментов".

Упорядочить значки

Располагает все значки открытых, но свернутых окон упорядоченно в нижней строке основного окна, если до этого значки в области основного окна размещались в произвольном порядке.

Запомнить положение Panel12

Запоминает положение и размеры активного в настоящий момент окна. При последующем открытии это окно появляется в том же месте экрана, в котором находилось в момент закрытия модуля.

Список открытых окон

Список открытых в данный момент дочерних окон (рис. 1) выводится под пунктами раздела "Окна" Главного меню. Одно и то же окно не может быть открыто дважды. Переключение между открытыми окнами производится мышью, клавишами Ctrl+Tab или с помощью списка открытых окон при условии, что на экране нет открытых модальных окон. Недочерние окна не приводятся в списке открытых окон.

В каждый момент времени только одно окно может быть активным, в списке окон слева от его названия установлен флаг Flag . Щелчок мыши на заголовке окна в списке делает его активным, в списке окон флаг устанавливается слева от названия этого окна и флаг снимается с открытого окна, которое было до этого активным. На рис. 1 активным становится окно "Список табельных листов".

Рис. 1


Раздел "?"

Раздел "?" предназначен для вызова Справочной системы и содержит следующие пункты меню:

Содержание справки

Показ Справочной системы для работы с модулем, открывается окно "Назначение модуля".

Контекстная справка

Вызов гипертекстовой контекстной помощи (Help) для получения контекстно-зависимой справочной информации по работе с конкретным окном, открытым в настоящий момент. Также контекстную помощь можно получить, нажав на клавишу F1 или на кнопку [image] .

Поиск справки

Поиск справочных сведений по ключевым словам, перечисленным на закладке "Указатель" окна Справочной системы модуля.

О программе ...

Доступ к окну со сведениями о модуле и ее производителе. В окне указывается номер и тип версии (Базовая, Проф, Холдинг), номер и дата сборки, имя базы данных. Также сообщаются телефоны горячей линии, факс, почтовый и электронный адрес (e-mail) и адрес официальной страницы (web-адрес) компании "АиТ Софт" в сети Интернет.


Назначение команд всплывающего меню

Для выделения сотрудников в ряде режимов модуля, содержащих списки сотрудников, можно воспользоваться командами всплывающего (контекстного) меню, которое вызывается щелчком правой кнопки мыши. К таким режимам относятся списки сотрудников в табельном листе, журналах, в параметрах сотрудников предприятия.

Всплывающее меню содержит следующие команды:

· Поиск – вызов окна "Поиск сотрудника" для текущего в списке сотрудника;
· Отметить всех – выделить всех сотрудников в текущем списке;
· Снять отметку со всех – снять выделение со всех сотрудников в текущем списке;
· Инвертировать отметку по всем – изменить выделение всех сотрудников на противоположное, т.е. с выбранных сотрудников снимается выделение, а неотмеченные сотрудники становятся выделенными;
· Отметить подразделение – выделить всех сотрудников в текущем подразделении;
· Снять отметку с подразделения – снять выделение со всех сотрудников в текущем подразделении;
· Инвертировать отметку по подразделению – изменить отметку со всех сотрудников текущего подразделения на противоположную. Если сотрудники были выделены, то с них снимается выделение, а если – были не отмечены, то становятся выделенными. Текущим является подразделение, на сотруднике которого установлен курсор, т.е. слева от табельного номера отображается символ Strelka "стрелочка";
· Сохранить выборку – сохранить список выделенных сотрудников как выборку под произвольным именем выборки, которое указывается в дополнительном окне (рис. 1). Для этого в этом окне нужно нажать на кнопку "Добавить" и в появившейся пустой строке задать имя выборки, например, "Табельный лист № ...";
· Восстановить ранее сохраненную выборку – выделить всех сотрудников в текущем списке, попавших в ранее сохраненную выборку. Данная команда открывает дополнительное окно (рис. 2) с перечнем имен сохраненных выборок.

Работа с выборкой

Выборкой называется произвольный список сотрудников предприятия, объединенный под определенным названием. Окно со списком выборок (рис. 1) открывается командой всплывающего меню "Сохранить выборку" или "Восстановить ранее сохраненную выборку".

Рис. 1

В окне (рис. 1) расположен список всех выборок, созданных в программном комплексе "АиТ:\Управление персоналом", если установлен флаг "показать все выборки". При снятом флаге в окне отображаются только выборки, созданные текущим пользователем в этом и других окнах модуля "АиТ:\Табельный учет".

Удаление ненужной выборки из списка выполняется кнопкой "Удалить". Для добавления в список новой выборки нажмите на кнопку "Добавить" и в появившейся пустой строке задайте имя выборки. В результате в этой выборке будет храниться список сотрудников, выделенных в данный момент в табельном листе. Закрытие окна с сохранением выделенной в списке выборки происходит по кнопке "Ок". Закрытие окна без сохранения выборки осуществляется кнопкой "Отмена".

При восстановлении выборки нажатие на кнопку "Ок" приведет к закрытию окна с восстановлением указанной выборки, т.е. в текущем табельном листе будет выделен список сотрудников, который хранился под именем выбранной выборки.


Панель инструментов

Панель инструментов содержит кнопки, посредством которых осуществляется быстрый доступ ко многим режимам и функциям модуля. В модуле имеется две панели инструментов: основная и дополнительная.

В нижней части основного окна модуля при выборе пункта меню или кнопки панели инструментов выводится полное наименование выбранного режима. Если, не нажимая, установить на одну из кнопок панели инструментов указатель мыши, рядом с ней появится всплывающая подсказка с кратким наименованием режима.

Основная панель инструментов

Основная панель инструментов (рис. 1) по умолчанию расположена в верхней части основного окна под разделами Главного меню и содержит постоянный набор кнопок, который не зависит от вида открытого окна. Кнопки основной панели инструментов отображаются на экране даже, когда все дочерние окна закрыты.

Модуль предоставляет пользователю возможность настраивать основную и/или дополнительную панель инструментов, изменять ее местоположение, внешний вид, а также отображать или скрывать название кнопки и подсказку к ней. Установка параметров панели инструментов выполняется в окне "Настройка панели инструментов". Вызов окна происходит с помощью пункта меню "Инструменты" раздела "Окно".

Действия кнопок основной панели аналогичны пунктам меню, но доступ к ним более оперативен. Однако не все пункты меню продублированы кнопками панели инструментов.

Рис. 1

Щелчок по кнопке панели инструментов приводит к открытию нового окна и соответственно переходу в новый режим, под которым понимается совокупность функций и операций, доступных в данном окне.

В нижней части активного окна модуля при выборе кнопки панели инструментов выводится полное наименование выбранного режима. Если, не нажимая, установить указатель мыши на одну из кнопок панели инструментов, рядом с ней появится всплывающая подсказка, характеризующая краткое назначение режима, если в настройках панели инструментов для основной панели установлен флаг "Подсказки".

Дополнительная панель инструментов (панель операций)

Дополнительная панель инструментов показывается в основном окне и содержит переменный набор кнопок, который определяется автоматически, зависит от вида активного дочернего окна и операций, доступных в нем. Список наиболее часто используемых кнопок дополнительной панели инструментов с описанием их назначения приведен в отдельной теме. Назначение остальных кнопок, редко используемых в окнах, описано непосредственно в теме, посвященной функционированию этого окна.

По умолчанию кнопки размещаются на вертикальной панели с левой стороны основного окна. Как и кнопки основной панели инструментов, они имеют всплывающую подсказку, поясняющую назначение этой кнопки. При переводе курсора мыши на графическую кнопку возле нее появляется всплывающая подсказка на желтом фоне, дублирующая данные в статусной строке внизу окна, если в настройках панели инструментов для панели операций установлен флаг "Подсказки".

Внимание. При отсутствии открытых дочерних окон кнопки дополнительной панели инструментов в основном окне не отображаются.


Настройка панели инструментов

Пользователям предоставляется возможность настраивать основную и/или дополнительную панель инструментов, изменять ее местоположение, внешний вид (показывать подсказки и названия кнопок), а также скрывать или отображать панель на экране. Установка параметров панели инструментов выполняется в окне "Настройка панели инструментов" (рис. 1). Окно открывается с помощью пункта меню "Панель инструментов" раздела "Окно".

Рис. 1

Назначение графических элементов окна

Панель

Сначала в блоке "Панель" необходимо выбрать панель инструментов (основную или операций), для которой будет производиться настройка.

Позиция

Панель инструментов в соответствии с выбранным переключателем в блоке "Позиция" может быть расположена слева, сверху, справа или снизу в рабочей области основного окна.

Выбор переключателя "Плавающая" разрешает перемещать по экрану основную или дополнительную панель инструментов, называемую в этом окне панель операций. В этом случае кнопки панели инструментов размещаются на экране в отдельном окне (рис. 2), имеющем заголовок и кнопку "Закрыть" [image] , которая предназначена для закрытия панели инструментов.

Рис. 2

Показывать текст

При установке флага под изображением кнопки показывается ее заголовок.

Показывать подсказки

Если флаг установлен, то при наведении указателя мыши (не нажимая) на кнопку панели инструментов появляется всплывающая подсказка.


Графический интерфейс

В модуле используются такие стандартные элементы графического интерфейса Windows, как окна, закладки окон, переключатели, флаги, списки, поля для ввода значений. Каждый из этих элементов выполняет определенную функцию или действие.

Окно – это часть экрана, в которой выполняется вся работа с модулем "АиТ:\Табельный учет".

Кнопки (закладки) – особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку) в многостраничном окне. Например, на приведенном ниже рисунке (рис. 1) для окна "Параметры сотрудников предприятия" показаны три кнопки (закладки): "Список сотрудников", "Параметры по приказам" и "Параметры нестрогие". Переход с закладки на закладку осуществляется щелчком мыши на ее закладке (кнопке).

Рис. 1

Блок – набор графических элементов, объединенных по назначению и находящихся внутри рамки, прорисованной белым цветом. Например, на рис. 2 блок "За текущий" включает в себя набор переключателей и два поля ввода.

Рис. 2

Переключатели – представляют собой группу зависимых кнопок (рис. 2), называемых также радио-кнопками, они предназначены для выбора одного из взаимоисключающих условий. Выбор переключателя производится щелчком левой кнопки мыши. В группе переключателей может быть выбран (включен) только один переключатель, который имеет вид кружка с точкой [image] . Остальные переключатели (кнопки) находятся в выключенном состоянии и изображаются на экране кружком без точки [image] .

Флаг – независимая кнопка, состояние флага не зависит от состояния других кнопок. Флаг позволяет выбрать одно из двух альтернативных условий, снабжен заголовком для выбора условия и может находиться в одном из двух состояний:

· включен (установлен) – если условие флага необходимо выполнить. На экране установленный флаг изображается в виде квадрата, внутри которого расположена "галочка" FlagYes . Если флаг используется в таблицах, то он изображается в виде перечеркнутого квадрата [image] ;
· выключен (снят) – если условие флага необходимо отменить. На экране снятый флаг отображается в виде пустого квадрата FlagNo .

Установка и снятие флага производится щелчком мыши или клавишей Пробел, если флаг активен, т.е. заголовок флага обведен пунктирной рамкой (рис. 3).

Рис. 3

Поля списки – поля, содержащие списки различного назначения для выбора необходимых элементов. При больших списках эти поля снабжаются полосой прокрутки. Примером таких полей могут служить списки подразделений (рис. 4) при отборе данных.

Рис. 4

Выпадающие списки – формируются автоматически, их изменить нельзя. Они содержат набор возможных значений, предназначенных для ввода в данное поле. Чтобы показать список для выбора, необходимо щелкнуть мышью по кнопке list (рис. 5), расположенной справа от поля. На рис. 5 показан выпадающий список для ввода значений в поле "Категория". Большие выпадающие списки снабжаются полосами прокрутки. Щелчок по элементу (строке) списка приводит к вставке выбранного значения в поле ввода.

Рис. 5

Поля ввода – применяются для ввода в них значений как непосредственно с клавиатуры, так и с использованием кнопок list выпадающего списка и [image] прокрутки. Щелчок на стрелке вверх увеличивает значение, на стрелке вниз – уменьшает. Если это поле предназначено для ввода даты, то можно выделить один из ее фрагментов (день, месяц, год) и с помощью стрелок изменить только его.

Таблицы – предназначены для визуального просмотра или редактирования списка данных. Каждая строка таблицы (рис. 6) называется записью и содержит информацию об одном элементе списка (объекте или документе). Столбцы таблицы имеют заголовок. Каждая запись (строка) содержит одинаковый набор поименованных полей (столбцов таблицы). Каждое поле в таблице характеризуется своим значением. Например, поле "Название" в первой строке содержит значение "Пятидневка (40)".

В таблице (табличном списке) можно выбрать одну или несколько строк. Выбранные строки по умолчанию окрашиваются синим цветом. Выбор строки в таблице выполняется двойным или одинарным щелчком мыши. Возможен выбор нескольких подряд идущих строк при удержании нажатой клавиши Ctrl.

Рис. 6

Полосы прокрутки – позволяют перемещать вверх/вниз и влево/вправо текст, расположенный в окне, в полях списках, в выпадающих списках (рис. 5) или в таблицах (рис. 6). Полосы расположены вдоль вертикальной и горизонтальной границы перечисленных выше графических элементов. Каждая полоса прокрутки содержит по краям стрелки прокрутки и внутри горизонтальный (вертикальный) бегунок для перемещения по тексту или списку. Стрелки прокрутки позволяют перемещаться только на строку вверх (вниз), или вправо (влево). Бегунок применяется для перемещения по тексту, когда он невидим и уходит за вертикальные границы окна, списка или таблицы. Для этого нужно щелкнуть мышью на бегунке и при нажатой правой клавиши мыши перемещать его в нужном направлении.


Стандартный набор кнопок

Дополнительная панель инструментов, в отличие от основной панели содержит переменный набор инструментальных кнопок. Состав кнопок дополнительной панели инструментов определяется автоматически и зависит от вида активного окна и действий, доступных в нем.

В данной теме описано назначение кнопок, наиболее часто используемых в окнах модуля. Назначение остальных редко используемых кнопок приводится непосредственно в теме, посвященной функционированию окна, где кнопка используется.

Большая группа кнопок из ниже перечисленных применяется для выполнения стандартных операций при работе с данными, представленными в табличном виде. Часть кнопок предназначена непосредственно для работы с окнами (открытие окна, закрытие окна с сохранением данных или без сохранения).

Создать TabAdded

Добавление новой строки в табличный список, приведенный в окне.

Копировать GrafCopy

Копирует любую строку в табличном списке. В частности эта кнопка позволяет создавать новые отчеты в окне "Настройка отчетов по предприятию.

Удалить строку TabDel

Удаляет выделенную в списке строку, на которой установлен курсор. Перед удалением сведений обычно открывается окно сообщений, чтобы в случае ошибочного нажатия на кнопку "Удалить" пользователь имел возможность отменить свои действия, нажав на кнопку "Нет".

Внимание. Удаление не производится, если в базе данных имеется ссылка на эту строку.

Открыть PanelRep4

Открывает документ, выделенный в списке. Это же действие можно выполнить двойным щелчком мыши по строке списка.

Мастер расчета Panel2

Позволяет создавать новые отчеты

Отчет RepForm

Формирует отчет на основании исходных данных, отображенных в окне, и сделанных настроек.

Выделить всех [image] и Снять выделение

С помощью этих кнопок можно выделять всех сотрудников в списке и отменять выделение. Выбранные сотрудники отмечаются контрастным цветом. Текущий сотрудник в списке выделен подчеркиванием.

Печать print

Печатает содержимое окно непосредственно на принтер, без формирования файла.

Выход

Закрывает текущего окна без сохранения сделанных изменений.

Сохранить (Ctrl+S) Save

Сохраняет внесенные в окне изменения данных.

.


Установка текущего месяца

Все данные, имеющие привязку к календарю (табельные листы, записи в журналах и прочие), показываются за конкретный, установленный в модуле месяц (год), который называется текущим месяцем (годом). Информация об установленном в модуле текущем месяце и годе отображается в заголовке основного окна программы.

Чтобы увидеть информацию за любой другой месяц, необходимо сменить текущий месяц. Переход на другой месяц производится в окне "Текущий месяц" (рис. 1), которое вызывается кнопкой "Установить текущий месяц" Panel1 основной панели инструментов, клавишами Ctrl+М или выбором одноименного пункта раздела "Вид" Главного меню.

Рис. 1

В поле "Расчетный месяц" отображается установленный в модуле текущий месяц. Для смены текущего месяца необходимо в поле "Изменить расчетный месяц на:" выбрать текущий месяц из выпадающего списка (рис. 2), а также при необходимости установить текущий год. Для вставки изменений в базу данных нажмите на кнопку "Изменить". Выход из окна осуществляется кнопкой "Закрыть" [image] .

Рис. 2

При смене месяца происходит копирование списка сотрудников табельных листов только при переходе в данный месяц в первый раз. При переходе на новый год происходит копирование шаблонов графиков и плановых графиков.


Параметры сотрудников предприятия

Режим "Параметры сотрудников предприятия" позволяет просмотреть основные параметры сотрудников, а также изменить график, категорию и затраты на произвольный период.

Все сведения о сотруднике формируются в модуле "АиТ:\Кадровый учет" или "АиТ:\Зарплата". При приеме на работу на каждого сотрудника создается кадровая карточка, где указывается подразделение, должность, плановый график и некоторые другие параметры.

Окно "Параметры сотрудников предприятия" вызывается из пункта "Параметры сотрудников" раздела "Режим" Главного меню или кнопкой "Основные параметры сотрудников" Panel3 панели инструментов. Окно (рис. 1) содержит три закладки.

Рис. 1

На первой закладке показывается список сотрудников предприятия, упорядоченный по подразделениям, с указанием табельного номера, ФИО, дат приема и увольнения. На второй и третьей закладках отображаются данные на выделенных в списке сотрудников. Выделение сотрудников в списке осуществляется двойным щелчком левой клавиши мыши по фамилии или с помощью пунктов выпадающего меню, открываемого правой кнопкой мыши.

На первой закладке "Список сотрудников" также можно выбрать период, за который необходимо просмотреть или откорректировать записи. Если открыт табельный лист и нажата кнопка "Поставить фильтр по табельному листу" на дополнительной панели инструментов, то на данной закладке отображается список сотрудников соответствующего табельного листа. На закладке предусмотрена возможность сортировать список сотрудников по фамилии, имени и отчеству, что удобно при наличии однофамильцев, работающих на предприятии. Для удобства пользователей табельные номера внутренних совместителей подсвечиваются желтым цветом.

На второй закладке "Параметры по приказам" (рис. 2) отображаются данные о месте работы (подразделении и должности) выбранных сотрудников, номере приказа и даты его действия. Эти данные подбираются из соответствующего кадрового приказа и коррекции в этом модуле не подлежат.

Рис. 2

На закладке "Параметры нестрогие" (рис. 3) отображаются дополнительные сведения о выбранных сотрудниках, такие как график работы, категория, затраты, а в версии "Проф" также рабочий центр. Эти параметры могут быть изменены на произвольный период времени. Сведения о рабочих центрах, на которых выполнялись работы по нарядам, вводятся в модуле "АиТ:\Учет выполненных работ".

Рис. 3

Табельщик в случае необходимости может изменять параметры сотрудников на третьей закладке "Параметры нестрогие". В дальнейшем эти изменения учитываются при коррекции списков сотрудников в табельных листах и оформлении табельных листов, а также при автоматическом заполнении табельных листов с помощью Мастера.

Назначение кнопок для работы с текущим окном

Название кнопки | Кнопка | Назначение
Создать | TabAdded | Создание новой записи для выделенных сотрудников. Параметры новой записи вводятся в окне "Добавление записи" (рис. 4).
Открыть | SotrParam | Редактирование (рис. 4) и просмотр текущей записи на закладке "Параметры нестрогие".
Удалить | TabDel | Удаление карточки. В зависимости от типа активного окна удаляются табельные листы, типы времени и пр.
Закрыть окно | TabDoor | Закрыть текущее окно.

Добавление и редактирование записи

В случае необходимости параметры сотрудников на третьей закладке "Параметры нестрогие" можно изменять. В дальнейшем эти изменения учитываются при коррекции списков сотрудников в табельных листах и оформлении табельных листов, а также при автоматическом заполнении табельных листов с помощью Мастера.

Добавление новой записи позволяет сохранить историю изменений параметров конкретного сотрудника. В то время как, при редактировании записи сохраняются только последние изменения, а предыдущие затираются.

Чтобы откорректировать существующую запись или добавить новую, необходимо:

· выделить сотрудника (или группу сотрудников) на первой закладке окна;
· выбрать период, в котором будут изменяться параметры;
· перейти на закладку "Параметры нестрогие";
· выделить нужную запись;
· нажать на кнопку дополнительной панели инструментов "Открыть" SotrParam для изменения записи или "Создать" TabAdded для добавления новой записи;
· открывается соответственно окно "Добавление записи" или "Изменение записи" (рис. 4), в котором можно ввести новые данные или изменить даты действия параметров и сами нестрогие параметры сотрудников. Для того чтобы изменить график, категорию, код затрат или код рабочего центра, необходимо установить соответствующий флаг. В результате появляется поле для ввода соответствующего параметра. Ввод графика, категории, затрат или рабочего центра производится из выпадающих списков, которые для удобства ввода отсортированы соответственно по коду графика, категории, затрат и названию рабочего центра. График работы сотрудника выбирается из выпадающего списка, состоящего из двух колонок с кодом и названием всех плановых графиков.

При изменении дат выполняется проверка на правильность их ввода. В случае если дата начала строки меньше 1 числа текущего месяца или дата окончания меньше даты начала, выдается предупреждение.

· сохранить внесенные изменения по кнопке TabDoor .

Рис. 4.

Рассмотрим, как отражаются эти изменения в табельных листах.

Пример 1.

Табельные листы ведутся по подразделениям, а сотруднику изменен график. При этом сотрудник остается в том же табельном листе, но в своде по табельному листу на него будет две строки – по первому и по второму графику отдельно.

Пример 2.

Табельные листы ведутся по подразделению и графику, сотруднику изменен график. Тогда при коррекции списка сотрудник попадет в другой табельный лист. При оформлении листа плановые часы по старому графику попадут в первый табельный лист, по новому графику – во второй.


Поиск сотрудника

Режим "Поиск сотрудника" позволяет найти сотрудника в базе по фамилии или табельному номеру, просмотреть его параметры, а также перейти в любой табельный лист или журнал, содержащий данные об этом сотруднике.

Окно "Поиск сотрудника" открывается из пункта "Поиск" раздела "Режим" Главного меню, кнопкой "Поиск данных о сотруднике" Panel10 панели инструментов или горячими" клавишами Alt+F7. Окно "Поиск сотрудника" можно также открыть командой "Поиск" выпадающего меню практически из любого режима, где есть список сотрудников (например, из табельного листа, журналов и т.д.).

В открывшемся окне на закладке "Поиск" имеется только одно поле ввода "Найти (Фамилия или таб.№)". Если в это поле ввести первые буквы фамилии или табельный номер сотрудника, то ФИО и параметры найденного сотрудника появятся в соответствующих полях (рис. 3.18) на первой закладке окна.

Рис. 1

Для внутренних совместителей табельный номер, фамилия, имя и отчество подсвечиваются желтым цветом. Поиск внутреннего совместителя осуществляется по табельному номеру, по фамилии показываются сведения по основному месту работы.

На закладке "Данные" (рис. 2) в зависимости от положения переключателя "Табельные листы" или "Журналы" отображается список табельных листов или записей в журналах на данного сотрудника за текущий месяц. На этой закладке можно открыть выбранный табельный лист или журнал, если установить на него курсор и нажать на кнопку "Перейти".

Рис. 2


Настройки параметров модуля

Дополнительные настройки позволяют адаптировать модуль к особенностям табельного учета на конкретном предприятии. Часть настроек параметров и функциональных возможностей модуля устанавливается в модуле "АиТ:\Конфигурация", часть – непосредственно в самом модуле в окне "Настройка параметров программы" (рис. 1). Окно настроек параметров модуля открывается при выборе пункта "Настройки общие" пункта "Настройки" раздела "Режим" Главного меню.

Рис. 1

В окне "Настройка параметров программы" (рис. 1) можно выполнить следующие настройки.

Настройка ширины колонок в табельном листе

Поскольку рабочее время может учитываться с разной точностью (с минутами или в целых часах), для корректного отображения введенных данных требуется разная ширина колонок дней в табельном листе.

Поле "Ширина колонки дня в табельной карточке и шаблоне графика" позволяет пользователю изменять ширину этих колонок самостоятельно. Ширина всех колонок дней одинакова.

Следует помнить, что ширина колонки на экране не влияет на ширину колонки при печати отчетов, которая настраивается в файле шаблона, соответствующему отчету.

Проверка расстановки выходных дней

При установке флага "Проверять расстановку выходных в субботу и воскресенье при каждом открытии табельного листа" и при наличии в настройках табельного листа установленного флага "Субботы и воскресенья выходные" на каждом открытии табельного листа происходит проверка корректности расстановки выходных дней. Данная процедура занимает некоторое время и не является крайне необходимой.

При отключении флага "Проверять расстановку выходных в субботу и воскресенье на каждом открытии табельного листа" данная операция будет производиться только при смене текущего месяца или изменении списка сотрудников в табельном листе, что, возможно, увеличит быстродействие системы.

Автоматический перерасчет сводов по табельным листам

Когда флаг установлен, то расчет и добавление свода в список происходит автоматически при открытии окна "Своды по табельному листу".

Если существует необходимость открывать окно сводов только для просмотра, то флаг "Автоматически перерассчитывать своды по табельным листам" лучше снять. В этом случае расчет и добавление сводов происходит при нажатии кнопок "Создать свод в зарплату" SvodSalary, "Создать свод в кадры" SvodPerson дополнительной панели инструментов окна "Своды по табельному листу".

Уменьшение количества кнопок, отображаемых в панели инструментов.

При установке флага "Уменьшить количество кнопок, отображаемых в панели инструментов" количество кнопок на дополнительной панели инструментов минимизируется, т. е. в ней отображаются только кнопки, имеющие отношение к данному режиму (окну), все остальные кнопки скрываются. Эта возможность используется для облегчения ориентации начинающего работать с модулем пользователя.

Расчет итогов за ограниченный период месяца.

В модуле допускается расчет итогов по табельным листам за период, меньший месяца. Для этого необходимо установить флаг "Ограничить период расчета итогов по табельным листам" и в блоке "Рассчитывать итоги" указать дату начала и конца расчетного периода.

При этом в заголовке основного окна (рис. 2) после слова "Итоги" будет указан период, за который рассчитываются итоги.

Рис. 2


Настройка режимов

Модуль поставляется с набором настроенных типов времени, шаблонов графиков и плановых графиков, которые наиболее часто употребляются в табельном учете. Если этого набора достаточно для ведения табельного учета на предприятии, настройку указанных режимов желательно не менять.

Если возникла необходимость изменить исходные данные, то для их корректировки следует открыть доступ к соответствующим режимам. Настройка доступа к основным режимам производится в окне "Настройка режимов" (рис. 1), которое открывается из подпункта "Настройки режимов" пункта "Настройки" раздела "Режим" Главного меню.

Рис. 1

В этом окне в блоке "Доступ к основным режимам" нужно установить флаг для включения соответствующего режима. После выхода из окна настройки режимов по кнопке "Ок", и перезапуске модуля на панели инструментов появятся кнопки для вызова режимов и соответствующие им пункты в разделе "Режим".

В том же блоке существует возможность закрыть доступ к работе с табельными листами, с журналами, с режимом параметров сотрудников. Например, на рабочих местах можно разделить функции ведения табельных листов и внесения записей в журналы.

Блок "Работа с табельным листом" включает доступ к двум режимам. Установкой флага "Ввод отклонений аналитических признаков" открывается доступ к режиму "Отклонения аналитических признаков и графика в табельном листе". Флаг, разрешающий создание небазовых табельных листов, ставится в том случае, если на предприятии есть необходимость ведения двух и более табельных листов с разной аналитикой на одно подразделение, например, если сверхурочная работа учитывается в отдельном табельном листе.

Если открыт доступ к режиму "Параметры сотрудников", то в блоке "Изменение параметров сотрудников" можно задать, изменения каких именно параметров разрешены текущему пользователю. Когда в этом блоке не установлен ни один флаг, то режим "Параметры сотрудников" открыт только на просмотр.


Настройка аналитических признаков

Аналитические признаки, введенные в модуле "АиТ:\Зарплата", используются в модуле "АиТ:\Табельный учет" при совместном функционировании обоих модулей и соответствующей настройки признаков. Настройка использования признаков в модуле "АиТ:\Табельный учет" производится в окне "Настройка аналитических признаков" (рис. 1), которое вызывается из подпункта "Настройки аналитики" пункта "Настройки" раздела "Режим" Главного меню.

Внимание. Если модуль "АиТ:\Табельный учет" функционирует без модуля "АиТ:\Зарплата", то аналитические признаки в модуле не используются.

Рис. 1

В колонке "Аналитический признак" окна (рис. 1) сначала перечисляются три обязательных признака (Подразделение, Затраты, Категория), а потом – дополнительные признаки. Значения обязательных признаков описываются в отдельных справочниках подразделений, затрат и категорий в модуле "АиТ:\Зарплата", а название обязательного признака (название справочника) задается автоматически. Названия дополнительных аналитических признаков и их значения вводятся и настраиваются в справочнике аналитических признаков в модуле "АиТ:\Зарплата". В первой колонке перечислены только те дополнительные признаки, для которых установлен флаг в справочнике аналитических признаков в модуле "АиТ:\Зарплата".

Для каждого из указанных в первой колонке аналитических признаков во второй колонке можно указать, используется ли он в модуле, и если используется, то где устанавливается его значение – в табельных листах или в типах времени.

Те аналитические признаки, в настройке которых задан режим ввода "в табельных листах", отображаются на закладке "Аналитика" в окне "Настройка листа". Нужное значение выбирается мышью из выпадающего списка. Аналитические признаки, выбранные в этом окне, будут характеризовать все значения, учитываемые в данном табельном листе.

Те аналитические признаки, в настройке которых задан режим ввода "в типах времени" (т.е. все остальные из используемых), отображаются на закладке "Аналитика" в окне "Типы времени". Каждому типу времени можно поставить в соответствие определенные значения этих признаков. Аналитические признаки, установленные для данного типа времени, будут характеризовать все значения, имеющие этот тип.

При формировании сводов по табельному листу можно посмотреть значения всех аналитических признаков, которые передаются в модуль "АиТ:\Зарплата". В окне "Своды по табельному листу" на закладке "Данные по сотрудникам" при установке курсора на любую итоговую сумму в правой части окна показываются все аналитические признаки, характеризующие эту сумму. Существует возможность на определенный период изменить значения аналитических признаков данному сотруднику в конкретном табельном листе. Данная возможность описана в теме "Сложные случаи табельного учета".


Фильтр

Фильтр – это логическое выражение, записанное в виде одного или совокупности условий отбора данных, соединенных логическими "связками" (логическими операциями И, ИЛИ). Каждое условие (критерий) отбора описывается отдельной строкой и характеризуется названием параметра, по которому будет производиться отбор, и условием сравнения.

Фильтр позволяет установить различные критерии отбора данных, например, фильтр может использоваться для отбора группы плановых графиков, для отбора сотрудников предприятия при работе с журналами.

Установка фильтра, по которому выполняется отбор данных, производится в окне "Фильтр" (рис. 1). Вызов окна происходит из пункта "Фильтр" раздела "Вид" Главного меню или с помощью кнопки "Фильтр" Filtr основной панели инструментов.

В каждый момент работы модуля фильтр может находиться в двух состояниях: установлен или снят (отбор сотрудников отсутствует). Наличие установленного в данный момент фильтра можно определить по внешнему виду кнопки “Фильтр” панели инструментов. При установке фильтра кнопка изображается на желтом фоне Filtr , при снятии фильтра – на сером фоне Panel9 .

Рис. 1

Закладка "Для пользователя"

Первая закладка (рис. 1) позволяет установить или переустановить фильтр для списка сотрудников в табельном листе или отчетов, снять его, а также посмотреть установленный в текущий момент фильтр или список созданных фильтров.

В модуле предусмотрена возможность запоминать составленные фильтры под именами, определяемыми пользователем и вызывать их впоследствии. Список уже составленных фильтров отображается на левой панели "Наименование" закладки. Для идентификации фильтров целесообразно озаглавливать фильтры таким образом, чтобы в них отражалось смысловое действие фильтра. Число строк (фильтров) в списке не ограничено. Добавлять, удалять и копировать фильтр под другим именем можно с помощью соответствующих кнопок дополнительной панели инструментов. Установленный в момент открытия закладки фильтр окрашивается в соответствующей строке списка голубым цветом.

В правой части закладки (рис. 1) расположены колонки для непосредственного формирования выражения фильтра, имя которого выделено в левой части окна:

· Название – указывается имя переменной, по которой происходит отбор сотрудников. Выбор переменной осуществляется из выпадающего списка, который открывается щелчком мыши. Список переменных в списке ограничен и зафиксирован в самом модуле. В основном, в качестве переменных используются данные персональной карточки сотрудника.
· Условие – задается условие, которое может принимать одно из перечисленных значений: = (равно), <> (не равно), > (больше), >= (больше или равно), < (меньше), <= (меньше или равно), включает, пусто, не пусто, один из. Условие выбирается из выпадающего списка щелчком мыши. Условие "один из" позволяет выбрать несколько значений для отбора.
· Значение – в данное поле вводится значение переменной, по которому происходит отбор данных. Значение переменной можно вводить непосредственно с клавиатуры вручную (например, фамилия, подразделение и т.п.) или выбирать из списка значений (рис. 2), формируемого автоматически. Если для переменной (например, перечисления – Да/Нет), существует список фиксированных значений, то он открывается щелчком правой кнопки мыши.

Рис. 2

При выборе условия "включает" в поле "Значение" необходимо указать строку для поиска включения в следующем виде: %текст для поиска% или _текст для поиска_, где символ % заменяет несколько предшествующих / последующих символов, а символ _ (подчеркивание) – один символ.

· Расшифровка – поле недоступно для редактирования и заполняется автоматически одновременно с полем "Значение", когда значение в поле "Значение" заполняется из выпадающего списка, формируемого по данным справочника. В этом случае в поле "Значение" будет указан код по справочнику, а в поле "Расшифровка" – соответствующее ему наименование.
· Связка – поле заполняется, когда формируемый фильтр содержит одновременно несколько условий, которые должны быть объединены логическими операциями (связками). Связка “И” означает, что оба условия должны выполняться одновременно, например, ОКЛАД>1.000.000 И ПОДРАЗДЕЛЕНИЕ =“0001”. Связка “ИЛИ” означает, что должно выполняться хотя бы одно из заданных условий, например, ФАМИЛИЯ=“Петров” ИЛИ ФАМИЛИЯ = “Иванов”.

Внимание. Если между условиями не установлена связка, то выполняется только первое из них, а следующее условие за отсутствующей связкой будет проигнорировано.

Число условий (строк) фильтра не ограничено.

· две колонки для установки скобок – в этих колонках указываются скобки, когда необходимо определить логическую последовательность обработки условий фильтра.

Действие фильтра распространяется на все режимы работы, кроме формирования сводов (простых и аналитических).

Если установленный фильтр предназначен для формирования выходных документов, то в первую строку файла этого документа заносится выражение, описывающее условие установленного фильтра, например:

Выбрано по условию: Табельный номер = 0001 и Номер подразделения <> 9999

Установка выбранного в списке фильтра происходит по нажатию кнопки "Поставить фильтр" Filtr дополнительной панели инструментов. Снятие условия фильтра – по нажатию кнопки "Снять фильтр" Panel9 . Если в момент формирования фильтра создаваемому логическому условию не отвечает ни один из сотрудников предприятия или если под действие этого условие подпадают все сотрудники, выдается предупреждение и фильтр не устанавливается.

Информация для продвинутых пользователей

Список полей и таблиц, по которым может быть установлен фильтр, зафиксирован в базе данных. Поэтому для расширения этого списка достаточно выполнить соответствующий скрипт на базе данных с помощью модуля "АиТ:/Конфигурация" или любого внешнего средства исполнения sql-запросов. За подробностями обращайтесь в отдел консультаций компании "АиТ® Софт".

Закладка "Для администратора SQL"

Вторая закладка окна "Фильтр" (рис. 3) позволяет задавать условие отбора данных на основании sql-запросов.

Рис. 3

Эта возможность полезна системным администраторам, консультантам и опытным пользователям. Такого рода запросы позволяют делать выборки более сложного характера, для которых требуется знание языка SQL и структуры базы данных программного комплекса "АиТ:\Управление персоналом".

Условия отбора, введенные на второй закладке окна "Фильтр", по кнопке [image] могут быть сохранены в виде файлов SQL запросов *.sql в рабочей папке установки модуля \aitclient\tbu\Form. При необходимости сохранные в файле условия отбора могут быть вновь загружены с помощью кнопки "Загрузить" [image] дополнительной панели инструментов. При этом сначала открывается стандартное окно Windows для выбора имени файла с SQL запросом. После выбора файла на экране появляется дополнительное окно (рис. 4) для ввода названия фильтра. После его закрытия кнопкой [image] на закладке (рис. 3) в столбце "Наименование" добавляется новая строка с указанным именем, а в правой части закладки отображается условие отбора, записанное в выбранном файле.

Рис. 4

Закрытие окна "Фильтр" (рис. 1) с сохранением введенной информации происходит по кнопке "Выход" TabDoor , без сохранения - по кнопке "Закрыть" [image] , расположенной в правом верхнем углу окна.


Типы времени

Типом времени в модуле "АиТ:\Табельный учет" называется любой вид рабочего или нерабочего времени сотрудника, подлежащий учету.

Типы времени, которые используются в модуле, просматриваются, создаются и редактируются в справочнике типов времени. Модуль поставляется с набором наиболее часто используемых типов времени, чтобы облегчить процесс обучения работы с ним. Настройки типов времени ориентированы на общепринятые правила табельного учета.

Тип времени может исчисляться в днях и часах или только в днях. В днях и часах учитываются те типы времени, при оплате которых могут потребоваться данные по суммам часов за период (рабочее время, сверхурочное, ночное и т. д.).

В табельном листе рабочее время указывается в первой (основной) строке в формате ЧЧ:ММ, например, 8:15. Основная строка всегда присутствует в табельном листе. Для остальных типов времени, учитываемых в днях и часах, в табеле используются отдельные (дополнительные) строки, в них всегда указывается название типа времени.

Данные по типам времени, учитываемым только в днях (больничный, отпуск и пр.) отображаются в табеле на первой строке, соответствующей рабочему времени, в виде кратких обозначений, состоящих из одной или нескольких букв.

Кроме того, модуль позволяет вести суммированный учет рабочего времени. Для этого используется калькулируемый тип времени, который отражает разницу фактически отработанного и планового времени по определенному графику, например, пятидневке за учетный период (месяц, квартал, полугодие, год). Этот тип времени не отображается непосредственно в табельном листе. Отклонение от нормативного графика за учетный период показывается в итогах и сводах по табельному листу.


Создание нового типа времени

Свойства нового типа времени указываются в окне "Новый тип времени" (рис. 1). Для его открытия следует в окне справочника типов времени нажать на кнопку "Создать" TabAdded дополнительной панели инструментов.

Рис. 1

Для нового типа времени укажите следующие параметры:

· код – краткое условное обозначение типа времени, состоящее из одной или нескольких букв, обязателен для типов времени, учитываемых в днях;
· название типа времени – название, характеризующее тип времени;
· способ учета типа времени – выбор способа учета времени (поденный, почасовой, отклонение от нормативного графика) происходит из выпадающего списка.

После закрытия текущего окна кнопкой "Ok" новый тип времени попадает в список типов времени, перечисленных в справочнике типов времени.

Далее новый тип времени необходимо настроить в справочнике типов времени, установив настройки на каждой закладке отдельно.


Справочник типов времени

Настройка имеющихся в модуле типов времени выполняется в справочнике типов времени (рис. 1). Окно справочника открывается кнопкой "Типы времени" Panel4 основной панели инструментов, клавишами Alt+V или из пункта "Типы времени" раздела "Режим" Главного меню.

Внимание. Коррекция типов времени разрешена при установке флага "Настройка типов времени" в окне "Настройка режимов". В этом случае на панели инструментов появляется кнопка "Типы времени".

В левой части окна справочника располагается полный список всех используемых в модуле типов времени. Для типов времени, учитываемых только в днях, обязательно указывается краткое обозначение – код (от одной до пяти букв). В связи с тем, что разные виды больничных и отпусков оплачиваются по-разному, на каждый вид больничного и отпуска следует ввести свой тип времени.

Рис. 1

В каждый момент времени только один тип времени может быть текущим. Настройки в правой части окна показываются для текущего в списке типа времени. Для того чтобы сделать тип времени текущим следует щелкнуть на нем левой кнопкой мыши на поле "Код" или "Название" в строке с нужным типом времени. В результате для этого типа времени в первой колонке появится символ "стрелочка" Strelka , как показано на рис. 1.

В справочнике типов времени можно добавлять новые типы времени (кнопка "Создать" TabAdded), удалять (кнопка "Удалить строку" TabDel ) и перенастраивать любые необходимые типы времени, за исключением двух служебных: "Рабочее время" и "Выходной день". Для служебных типов времени изменение вида учета недопустимо. Для исправления кода или названия следует установить курсор на нужном поле, внести изменения и сохранить сделанные изменения кнопкой "Сохранить изменения" Save. Если изменился существующий код типа времени, то он будут изменен во всех табельных листах, где он используется.

Правая часть окна изменяется при переходе на новую закладку, в то время как левая часть окна не изменяется. В правой части отображаются настройки для текущего в списке типа времени. Правая часть окна справочника содержит закладки:

· Параметры – применяется для настройки для почасовых и поденных типов времени, а также для калькулируемых типов времени;
· Стыковки – определяет возможные варианты обмена данных между модулями программного комплекса "АиТ:/Управление персоналом";

Аналитика – позволяет текущему типу времени поставить в соответствие определенные значения признаков, указанных на этой закладке. Эти значения потом передаются в модули для расчета зарплаты и ведения бухгалтерского учета и могут использоваться как критерии группировки данных.

На закладке перечислены аналитические признаки, для которых в настройках аналитики задан режим ввода "в типах времени". Значение каждого признака вводится в поле, расположенное справа от его названия. Ввод признаков осуществляется из выпадающего списка. Аналитические признаки, установленные для данного типа времени, будут характеризовать все значения, имеющие этот тип;

· Perco – специальные настройки для режима стыковки с системой контроля и управления доступом "Perco-S-15000".

Внимание. Разработан функционал, позволяющий осуществить стыковку с электронной проходной для получения данных об отработанном сотрудниками времени и заполнения этими данными табельных листов в модуле "АиТ:\Табельный учет". В настоящее время реализована стыковка с проходными "Perco", однако возможна стыковка и с другими системами. По вопросам внедрения данного режима следует обращаться в отдел продаж компании "АиТ® Софт".


Настройка почасовых и поденных типов времени

Настройка почасовых и поденных типов времени выполняется на закладке "Параметры" окна "Типы времени". Набор графических элементов для почасовых и поденных типов времени отличается от калькулируемого типа времени. Настройки приводятся для текущего почасового и поденного типа времени, у которого в первой колонке присутствует символ "стрелочка" Strelka (см. рис. 1). Для того чтобы сделать тип времени текущим, следует щелкнуть на нем левой кнопкой мыши.

Рис. 1

Настройки, связанные с учетом по данному типу времени

1. Блок "Что учитывать по данному типу времени"

Тип времени в табеле может учитываться в днях или в днях и часах. Выбор вида учета в днях или в днях и часах для текущего типа времени устанавливается выбором переключателя:

· Дни и часы – тип времени учитывается в днях и часах, в табельном листе указывается на отдельной строке, соответствующей этому типу времени;
· Только дни – тип времени учитывается в целых днях и отображается на первой основной строке в виде одной или нескольких букв.

Те типы времени, для которых выбран переключатель "Дни и часы" попадут в список типов времени, показанный на закладке "Типы времени" в окне настроек параметров табельного листа.

Флаг "Считается неявкой на работу (для Т-13)"

Если данные по текущему типу времени должны учитываться в унифицированной форме Т-13 в качестве причины неявки, то для этого типа времени следует установить этот флаг.

Флаг "Суммировать к раб. времени (для Т-13)"

Установка флага свидетельствует о том, что данный тип времени будут добавлен к рабочему времени, например, при работе в ночное время.

2. Блок "При вводе значения данного типа времени все остальные типы времени в этом дне:"

· Не изменяются – все остальные типы времени за указанный день не изменяются;
· Обнуляются – автоматически обнуляются все остальные типы времени за указанный день. К данному типу времени относятся типы времени, которые по своей природе не допускают присутствия в этот день каких-либо других типов времени, например, в один день недопустимо указание типа времени "Отпуск" и любого другого типа времени.
· Обнуляются (только учитываемые в днях) – обнуляются все остальные типы времени, учитываемые только в днях, а типы времени, учитываемые в днях и часах, не изменяются.

3. Настройки по ведению журнала

Для любого типа времени допускается ведение журнала. Однако целесообразно вести журналы по тем типам времени, данные по которым можно получить из модулей "АиТ:\Зарплата" и "АиТ:\Кадровый учет". Более подробные сведения о работе с журналом описаны в теме "Работа с журналом". Подключения журнала ведется по текущему типу времени (рис. 1).

Флаг "Вести журнал по типу времени"

Для создания нового журнала следует установить флаг "Вести журнал по типу времени". Имя созданного журнала попадает в выпадающий список имен журналов окна "Настройка журналов".

Способы заполнения табельных листов

В том случае, когда по выбранному типу времени ведется журнал, следует указать способ заполнения табельного листа по записи в журнале. Метод заполнения табельных листов по записям в журнале определяется особенностями типа времени, по которому ведется журнал, и настраивается выбором нужного положения переключателя. При переносе записей из журналов в табельные листы заполнение может производиться разными способами (по рабочим или календарным дням, по плановому графику и т.д.).

Переключатели "Заполнять табельные листы":

· по календарным дням – переключатель выбирается для большинства отпусков;
· только по рабочим дням – как правило, для больничных листов указывается этот способ заполнения табеля;
· по плановому графику – если тип времени учитывается в днях и часах, то выбор положения переключателя "по плановому графику" означает, что заполнение табельных листов будет производиться в соответствии с личным плановым графиком каждого сотрудника. Это можно использовать, например, в случае учета больничных листов в часах при сменной работе.

Для типа времени, учитываемого в днях, при выборе положения переключателя "по плановому графику" в нижней части окна появляется выпадающий список для выбора планового графика, в соответствии с которым будут заполняться табельные листы по данному типу времени.

Внимание. Настройка недоступна для типа времени, учитываемого в днях и часах.

Флаг "Заполнять табельные листы внутр. совм."

При установке флага в табельном листе отражаются сведения по больничным листам также и для внутреннего совместителя. В этом случае при передаче данных по больничным листам из кадровой карточки модуля "АиТ:\Кадровый учет" в модуль "АиТ:\Зарплата" происходит также передача этих сведений в соответствующий журнал табельного учета как по основной должности, так и по всем должностям внутреннего совместительства.

4. Настройка цвета раскраски типа времени

Для облегчения восприятия больших табельных листов имеется возможность раскраски данных по различным типам времени разными цветами, которые устанавливаются при помощи выпадающих списков полей "Текст" и "Фон".

5. Флаг "Передается как рабочее время"

Флаг устанавливается, если текущий тип времени учитывается как рабочее время.


Настройка калькулируемого типа времени

Калькулируемый тип времени отражает разницу между фактически отработанным и плановым временем, рассчитанным по определенному нормативному графику за учетный период. Этот тип времени не отображается непосредственно в табельном листе. Отклонение от нормативного графика за учетный период показывается в итогах и сводах по табельному листу.

Закладка "Параметры" (рис. 1) окна "Типы времени" для калькулируемого типа времени отличается от почасовых и поденных типов времени и содержит следующие настройки.

Рис. 1

Нормативный график

При суммированном учете рабочего времени рассчитывается отклонение за учетный период фактически отработанного времени от планового, рассчитанного по нормативному графику. Плановый график, который будет использоваться в качестве нормативного для данного типа времени, выбирается из выпадающего списка.

Периодичность расчета

Для типа времени указывается желаемая периодичность расчета отклонения. Она выбирается из выпадающего списка (месяц, квартал, полугодие, год). Отклонение от нормативного графика показывается в итогах за выбранный период.

Обнуление отрицательных значений

Флаг "Допускаются отрицательные значения" устанавливается при необходимости отслеживать отрицательные отклонения от нормативного графика (недоработку).

Если для передачи в модуль "АиТ:\Зарплата" необходимо отслеживать только переработку, то для настраиваемого типа времени флаг снимается. При этом все рассчитанные отрицательные значения отклонений обнуляются.

Учет неявок

При неполном времени работы (отпуск, больничный и пр.) плановая норма времени должна быть уменьшена на количество рабочих часов, приходящихся на период отсутствия по уважительной причине. Для этого необходимо установить флаг "Неявки уменьшают плановую выработку" и в появившемся ниже поле с помощью кнопок "Добавить" TimeCalkTipAdd и "Удалить" TimeCalkTipDel заполнить перечень уважительных неявок.

Способ расчета количества дней

В зависимости от выбранного переключателя количество дней отклонения может рассчитываться как:

· Переработка по дням – разность между фактическими днями и днями по нормативному графику;
· Переработка в часах/8 – разность между фактическими часами и часами по нормативному графику, деленная на 8;
· Переработка в часах/среднюю смену – разность между фактическими часами и часами по нормативному графику, деленная на фактическую продолжительность смены (в часах) за период.

Полученное в результате расчета количество дней округляется до ближайшего большего целого числа.


Закладка "Стыковки"

Закладка "Стыковки" (рис. 1) содержит следующий набор графических элементов для настройки возможных вариантов обмена между программными модулями комплекса "АиТ:\Управление персоналом".

Рис. 1

Флаг "Передавать данные в зарплату"

При установке этого флага табельные данные по текущему типу времени попадают в своды и передаются в модуль "АиТ:\Зарплата". Если флаг установлен, для поденного типа времени появляется поле "Передавать в зарплату как:" для задания способа передачи данных: больничный, оплата по среднему или отпуск.

Флаг "Передавать данные в кадры"

Флаг активен (и передача данных возможна) только для тех типов времени, по которым не ведутся журналы. Флаг следует устанавливать для тех типов времени, по которым сотрудник получает отгулы, например, работа в выходные дни. При этом нужный тип времени должен быть текущим, т.е. в первой колонке присутствует символ "стрелочка" Strelka. После установки флага в поле "Передавать в кадры" из выпадающего списка следует ввести значение "отпуск в счет отгулов". После выполнения этих настроек можно сформировать своды по указанному типу времени и передать в модуль "АиТ:\Кадровый учет".

Флаг "Принимать данные из кадров"

Для типов времени, по которым ведутся журналы (в основном для различных отпусков), имеется возможность автоматического заполнения журналов данными из модуля "АиТ:\Кадровый учет". Для этого следует установить флаг "Принимать данные из кадров". Затем в открывшийся список "Вид отпуска" при помощи кнопок "Добавить" TimeCalkTipAdd и "Удалить" TimeCalkTipDel нужно добавить те виды отпуска из модуля "АиТ:\Кадровый учет", записи о которых должны попадать в журнал по настраиваемому типу времени.

Следует помнить, что в момент приема данных из модуля "АиТ:\Кадровый учет" все ранее введенные вручную записи в соответствующем журнале удаляются.

Кроме того, возможна запись данных из модуля "АиТ:\Кадровый учет" в журналы и при снятом флаге. Это происходит в случае, если в кадровом учете используется вид приказа "о рабочем времени", данные которого передаются в журналы (см. ниже). К таким приказам относятся приказ о направлении в командировку, об отзыве из командировки, о работе в выходные и праздничные дни, служебное задание.

Возможные варианты стыковок

Состояние флагов |  |  |  | Способ передачи данных в модуль "АиТ:\Зарплата" | Тип времени
Вести журнал | Передавать данные в зарплату | Передавать данные в кадры | Принимать данные из кадров
Нет | Да | Нет | – | Передается через свод по табельному листу. | Ночное
Нет | Нет | Да | – | Из программного модуля "АиТ:\Кадровый учет" как отпуск. | Работа в выходные дни
Да | Да | – | Нет | Передается через свод по журналу. В модуле "АиТ:\Зарплата" попадает в разные журналы в зависимости от настроенного метода передачи (больничный, отпуск, начисление по среднему). | Больничный
Да | Да | – | Нет* | Передается через свод по журналу. | Командировка
Да | Нет | – | Да | Из модуля "АиТ:\Кадровый учет". | Ежегодный отпуск
Калькулируемые типы времени
– | Да | Нет | – | Передается через свод по табельному листу. | Отклонение от пятидневки
– | Нет | Да | – | Из модуля "АиТ:\Кадровый учет" как отпуск. | Отпуск в счет отгулов

Знак "*" означает, что флаг не установлен, но табельный журнал заполняется кадровыми данными при проведении приказа с типом "о рабочем времени" (командировка, служебное задание, работа в выходные дни).

Знак "–" означает, что соответствующий флаг для данной комбинации настроек неактивен.


Назначение табельных листов

Табельным листом называется карточка, в которой ведется табельный учет группы сотрудников, например, работающих в одном подразделении. Все табельные листы, созданные в модуле, перечисляются в списке табельных листов, который открывается кнопкой Panel7 основной панели инструментов. При первом открытии модуля список пустой, т. е. не содержит ни одного табельного листа. Каждый табельный лист в списке характеризуется номером, названием и периодом действия. Все вышеперечисленные параметры устанавливаются в настройках табельного листа.

В табельном листе указывается фактическое рабочее время сотрудника, а также причины неявки (больничные, отпуска и т.д.). Табельный лист является источником данных для формирования сводов – итоговых документов, содержащих суммарное время за месяц или меньший период. Данные сводов передаются в модули "АиТ:\Зарплата" и "АиТ:\Кадровый учет" и используются для расчета зарплаты и формирования приказов.

Табельные листы по способу автоматизации табельных операций подразделяются на два типа:

· простые – создаваемые вручную, поэтому наименее автоматизированные;
· с автоведением – создаваемые автоматически Мастером ведения табельного учета, но допускается и ручной способ их формирования.

Наиболее удобным способом ведения табельного учета является использование табельных листов с автоведением, которые позволяют предельно сократить трудозатраты табельщиков за счет автоматизации типовых операций табельного учета.

Табельные листы создаются из окна со списком табельных листов. В модуле предусмотрено три способа создания новых табельных листов:

· автоматический способ создания новых табельных листов при помощи Мастера ведения табельного учета. Этот способ используется только для автоведомых табельных листов и позволяет автоматизировать все операции табельного учета. Автоматическое формирование списка сотрудников в табельном листе и заполнение его табельными данными на основании плановых графиков происходит, если при приеме на работу для каждого сотрудника в модуле "АиТ:\Кадры" или "АиТ:\Зарплата" указываются подразделение, должность, плановый график и некоторые другие параметры;
· ручной способ формирования автоведомых табельных листов;
· ручной способ формирования неавтоведомых табельных листов.

Ручной способ используется для создания только одного табельного листа в тех случаях, когда требуется сформировать список сотрудников в табельном листе не только с учетом подразделения, но и по графику работ, категории, рабочему центру или другим критериям. В этом случае табельные листы создаются с использованием кнопки "Создать" TabAdded дополнительной панели инструментов. Причем, таким способом можно создавать как автоведомые табельные листы, так и простые листы (без автоведения).

Внимание. Создавать новые табельные листы вручную могут пользователи, обладающие правами доступа к кнопке "Создать". В этом случае кнопка "Создать" отображается на дополнительной панели инструментов. Права доступа задаются функцией "Создание табельного листа", расположенной в разделе "Ведение табельных листов" окна "Редактирование списка ролей" модуля "АиТ:\ Конфигурация".

Кроме этого табельные листы могут быть базовыми (основными) и неосновными, что определяется пользователем в момент создания табельного листа. По умолчанию все создаваемые автоведомые табельные листы считаются базовыми (основными). Деление табельных листов на базовый и неосновной необходимо в сложных случаях табельного учета, когда данные, требующие ручной правки (например, данные о времени, отработанном сверхурочно), можно вести отдельно в неосновном табельном листе. Список сотрудников в обоих листах одинаков. При этом, естественно, количество неавтоматизированной работы несколько возрастает.


Список табельных листов

Окно со списком табельных листов вызывается кнопкой "Список табельных листов" Panel7 панели инструментов или из пункта "Табельные листы" раздела "Режим" Главного меню, а также клавишами Alt+T. Модуль позволяет создавать табельные листы несколькими способами как автоматически с помощью Мастера, так и вручную. С помощью Мастера можно сразу создавать несколько табельных листов. Каждый табельный лист содержит список сотрудников по одному подразделению.

В окне отражается список активных в текущем месяце табельных листов (рис. 1). Табельные листы, использующие автоведение, отмечены в списке табельных листов буквой "А".

Для каждого листа в списке показывается номер, название, количество сотрудников в списке и сводов, сформированных по этому листу, а также признак их автоматического ведения. Для текущего табельного листа эти сведения подчеркиваются. Кроме этого, текущий лист отмечается в списке символом "стрелочка" Strelka .

Рис. 1

Для того чтобы сделать табельный лист текущим, нужно нажать левую кнопку мыши. В списке может быть одновременно выделено несколько табельных листов, но только один лист является текущим. Выделить можно только текущий лист. Для этого нужно щелкнуть правой кнопкой мыши по строке с текущим листом, в результате строка выделяется синим цветом.

В одном табельном листе учет сотрудников может вестись в течение нескольких месяцев или лет. При этом список сотрудников и другие параметры сохраняются на весь период действия табельного листа.

Изменение списка сотрудников табельного листа в текущем месяце не влияет на состав сотрудников в этом табельном листе в прошлых месяцах.

Назначение кнопок панели инструментов

Кнопки | Клавиши | Назначение кнопки
TabAdded , TabDel | нет | Добавить новый табельный лист, удалить выделенный в списке табельный лист
TabSelect , TabSelectNo | нет | Выделить все табельные листы в списке, отменить выделение табельных листов в списке
TabParam | Ctrl+P | Настройка параметров табельного листа
TabSotr | Ctrl+L | Открытие списка сотрудников по текущему табельному листу
TabCopySotr | нет | Копирование списка сотрудников прошлого месяца для простых табельных листов при наличии полного доступа к этой функции
TabParamSotr | нет | Открытие окна для ввода отклонений графика и аналитики сотрудников в текущем табельном листе
TabDetal | Ctrl+T | Открытие табельного листа
TabItog | Ctrl+C | Открытие окна итогов по табельному листу. В режиме "Уменьшить количество отображаемых кнопок" операция недоступна
TabSvod | Ctrl+S | Открытие окна со списком сводов
TabDoor | нет | Закрытие текущего окна с сохранением данных
Print | F4 | Формирование отчетов и печать выделенных табельных листов. Если для пользователя, для которого установлены права на работу с модулем "Табельный учет", установлен фильтр в модуле "АиТ:\Конфигурация", то при печати отчетов по табельным листам (например, форма Т-13) из списка табельных листов (не из открытого табельного листа), печатаются данные только на тех сотрудников, которые отображаются в открытом табельном листе.


Табельный лист

Для учета рабочего времени применяется стандартный табельный лист с автоматическим или ручным заполнением данных. Табельный лист содержит список сотрудников и данные о фактическом отработанном и неотработанном времени за текущий месяц. Как правило, табельный лист относится к структурному подразделению.

Ввод, просмотр и коррекция ежедневных табельных данных (явок и неявок на работу сотрудников) осуществляется в окне "Табельный лист №" (рис. 1). Для работы с табельным листом используются кнопки на дополнительной панели инструментов. Табельный лист открывается из окна "Список табельных листов" одним из следующих способов:

· двойным щелчком мыши на строке нужного табельного листа;
· кнопкой "Детализация по дням" TabDetal дополнительной панели инструментов;
· выбором пункта "Детализация по дням" раздела "Вид" Главного меню;
· клавишами Ctrl+Т.

Кроме этого к табельным листам, содержащим конкретного сотрудника, можно перейти из режима "Поиск".

Рис. 1

Окно "Табельный лист" представляет собой классический табельный лист. В левой части окна расположен список сотрудников, учитываемых в данном табельном листе. Для каждого сотрудника по умолчанию указывается табельный номер и ФИО. В табельных листах предусмотрена сортировка сотрудников по фамилии, имени и отчеству, что удобно при наличии однофамильцев, работающих на предприятии.

Должность сотрудников в табельных листах (рис. 2) будет отображаться, если в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" в разделе "Табельные листы" установлена настройка "Показывать должность сотрудников". Для внутренних совместителей табельный номер подсвечивается желтым цветом (рис. 2).

Чтобы в табельный лист попадали все сотрудники, необходимо в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" для модуля "Табельный учет" в разделе "Табельные листы" для параметра "Учитывать сотрудников по договорам ГПХ" установить значение "Да". Если задать значение "Нет", то в табельный лист не попадают сотрудники, работающие по гражданско-правовому договору.

При смене фамилии обеспечивается сохранение вносимого в табель фактического времени по сотруднику, если в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" для модуля "Табельный учет" в разделе "Табельные листы" для настройки "Автоматически сохр. т.л. при переходе на строку" присвоено значение "Да". При установке этой настройки при переходе со строки на строку будет сохраняться весь табельный лист.

Рис. 2

В правой части окна располагается табельная сетка (рис. 1) на текущий месяц, где для каждого сотрудника указывается ежедневное табельное время для заданных типов времени. На первой, основной строке, которая всегда присутствует в табельном листе, указывается фактически отработанное за день рабочее время в формате ЧЧ:ММ, например, 8:15. На первой строке также указываются выходные дни в виде заглавной русской буквы "В" и коды типов времени, указываемые в днях (больничный, отпуск и пр.). Код (краткое условное обозначение) типа времени записывается в виде одной или нескольких букв так, как задано в справочнике типов времени.

Если сотрудники работают по графикам, предусматривающим учет других почасовых типов времени, кроме рабочего времени (сверхурочное, ночное и т. д.), то в табель необходимо добавить дополнительные строки. Слева для каждой такой строки указывается название типа времени. Количество таких строк в табеле и порядок их перечисления задается в настройках табельного листа на закладке "Типы времени".

При открытии табельных листов пустые строки не будут отображаться, если в модуле "АиТ:\Конфигурация" в окне "Настройки комплекса" в разделе "Табельные листы" для параметра "Автоматически скрывать пустые строки" будет задано значение "Нет". Для показа пустых строк нужно нажать на кнопку "Отобразить все строки" TabPluc дополнительной панели инструментов, для скрытия – на кнопку "Скрыть пустые строки" TabMinuc. Назначение остальных кнопок приведено в таблице (см. ниже).

В окне "Табельный лист" (рис. 1) возможны следующие действия с текущим табельным листом, которые выполняются с помощью кнопок, перечисленных в нижеприведенной таблице.

Кнопки | Клавиши | Назначение кнопки
Filtr | нет | Установить фильтр для табельного листа.
Panel9 | нет | Снять фильтр с табельного листа
TabWizardAdded | Ctrl+F | Мастер заполнения табельного листа
TabSotr | Ctrl+L | Показ списка сотрудников по текущему табельному листу
TabParamSotr | нет | Открытие окна для ввода отклонений графика и аналитики сотрудников в текущем табельном листе
TabItog | Ctrl+C | Отображение промежуточных итогов по табельному листу. В режиме "Уменьшить количество отображаемых кнопок" операция недоступна
TabSvod | Ctrl+S | Доступ к списку сводов
TabDoor | нет | Закрытие текущего окна с сохранением данных

Особенности печати табельных листов

Создание отчета и печать из списка табельных листов или по открытому в данный момент табельному листу выполняется кнопкой Print или клавишей F4. Строки с типами времени, в которых не введено ни одного значения, печататься не будут. При попытке напечатать табельный лист, в котором не отображается ни один сотрудник, будет выдано соответствующее сообщение, и табельный лист напечатан не будет.


Настройка параметров табельного листа

Настройка параметров табельных листов выполняется в окне "Настройка листа..." (рис. 1). При наличии прав доступа окно содержит 4 закладки. Права доступа к закладке "Общие" определяются в настройке "Доступ к закладке "Общие" параметров т.л." раздела "Ведение табельных листов" окна "Редактирование списка ролей" модуля "АиТ:\ Конфигурация". В этом же разделе имеются настройки для остальных закладок "Типы времени", "Автоведение" и "Аналитика". При отсутствии прав доступа к какой-либо закладке она не видна.

Рис. 1

Вызов окна (рис. 1) для коррекции параметров табельного листа осуществляется из окна со списком табельных листов кнопкой "Параметры" TabParam дополнительной панели инструментов, "горячими" клавишами Ctrl+P или из пункта "Параметры" раздела "Карточка" Главного меню. Напоминаем, что данное окно (рис. 1) открывается также кнопкой "Создать" TabAdded дополнительной панели инструментов при ручном создании табельного листа, но содержит только две закладки "Общие" и "Аналитика".

На первой закладке "Общие" расположены следующие поля и флаги:

· Номер табельного листа – следует ввести от одной до пяти цифр или букв в соответствии с принятой на предприятии системой документооборота.
· Описание (название) табельного листа – произвольное наименование (до 50 символов).
· Срок действия табельного листа (первый и последний месяц учета) – определяет период, в течение которого данный табельный лист остается видимым в списке табельных листов. При установке текущего месяца вне данного периода табельный лист не попадает в список.

Если подразделение расформировано и в карточке подразделения в модуле "Кадровый учет" указана дата его ликвидации, то в поле "Последний месяц учета" указывается месяц расформирования подразделения, а в следующем поле – год его расформирования.

· Фамилия табельщика – выбирается из выпадающего списка сотрудников.
· Субботы и воскресенья выходные – при установке флага все субботы и воскресенья в табельном листе автоматически становятся выходными днями для всех учитываемых в нем сотрудников.
· Автоматизированное ведение табельного листа – флаг определяет, будет ли для данного табельного листа использоваться режим автоведения. При установке этого флага в окне появляется дополнительная закладка – "Автоведение".

На второй закладке "Типы времени" перечислены почасовые и калькулируемые типы времени (рис. 2). В текущем табельном листе будут учитываться те типы времени, слева от названия которых установлен флаг, например, "ночное время".

Почасовые типы времени – это те типы времени, которые учитываются в днях и часах и для которых в окне "Типы времени" на закладке "Параметры" выбран переключатель "Дни и часы".

Эта закладка отсутствует в новом табельном листе. Настройка типов времени, учитываемых в листе, может быть выполнена только после заполнения списка сотрудников.

Рис. 2

Третья закладка "Автоведение" появляется, если на первой закладке "Общие" этого окна установить флаг "Автоматизированное ведение табельного листа".

На третьей закладке можно выбрать значения некоторых критериев (таких как подразделение, должность, категория, график работы и т.п.), по которым будет формироваться список сотрудников нового табельного листа.

На четвертой закладке "Аналитика" можно выбрать из выпадающего списка значения тех аналитических признаков, в настройке которых задан режим ввода "в табельных листах". Эти признаки будут характеризовать все суммы табельного времени, учтенные в данном табельном листе.

Чтобы сохранить введенные настройки, необходимо нажать на кнопку "Сохранить" TabSave дополнительной панели инструментов.


Порядок работы с простыми табельными листами

Табельные листы, создаваемые и заполняемые ручным способом, без использования режима автоведения называются простыми. Ручным способом можно создать только один табельный лист (простой или автоматизированный). Способ используется в тех случаях, когда список сотрудников в табельном листе требуется сформировать не только с учетом подразделения, но и по графику работ, категории, рабочему центру или другим критериям.

Учитывая, что ручной способ формирования простого табельного листа наименее автоматизирован, перечислим подробно действия пользователя для его создания и работы с ним.

1. Открыть окно со списком табельных листов, например, кнопкой Panel7 основной панели инструментов.

2. Добавить в список новый табельный лист, нажав на кнопку TabAdded дополнительной панели инструментов. В этом случае новый табельный лист попадает в список табельных листов с кодом <xx> и названием <Новый табельный лист>, и на экране автоматически открывается окно настройки его параметров" (рис. 1).

Внимание. Кнопка "Создать" TabAdded отображается на дополнительной панели инструментов, если пользователь обладает правом создавать новые табельные листы.

3. В момент формирования табельного листа окно (рис. 1) содержит только две закладки. На этом этапе можно указать только номер и название табельного листа для его идентификации.

Настройка типов времени, учитываемых в табельном листе, может быть выполнена в этом окне (рис. 1)только после заполнения списка сотрудников.

Рис. 1

4. Для сохранения сведений закрыть окно кнопкой TabSave или TabDoor.

5. Открывается окно для формирования списка сотрудников в табельном листе. После его закрытия на экране показывается новый табельный лист с уже заполненным списком сотрудников.

6. Если плановые графики сотрудников в табельном листе предусматривают учет других почасовых типов времени, кроме рабочего, то следует повторно открыть окно настройки параметров табельного листа кнопкой "Параметры" TabParam дополнительной панели инструментов. В этом случае окно "Настройка листа..." содержит 3 закладки, а не две, как показано на рис. 1. На закладке "Типы времени" следует отметить нужные типы времени, например, ночное время, сверхурочные другие необходимые типы времени.

7. Ввести табельные данные в сформированный лист вручную или при помощи Мастера заполнения, чтобы ускорить и облегчить операцию ввода ежедневных табельных данных.

8. После заполнения табельного листа по нему можно:

· сформировать свод, чтобы итоговые данные стали доступны в других модулях комплекса;
· сформировать отчет для анализа данных по табельному учету. Отчет формируется кнопкой "Печать отчета" Print дополнительной панели инструментов или клавишей F4 по открытому в данный момент табельному листу.


Список сотрудников в табельном листе

Список сотрудников, учитываемых в табельном листе, формируется непосредственно при создании нового табельного листа. В этом случае окно "Список сотрудников в табельном листе" (рис. 1) открывается автоматически после настройки параметров нового табельного листа.

Для корректировки списка сотрудников открыть окно (рис. 1) можно кнопкой "Список сотрудников в табельном листе" TabSotr панели инструментов, из одноименного пункта раздела "Вид" Главного меню или "горячими" клавишами Ctrl+L из окна "Список табельных листов". Доступ к окну со списком сотрудников возможен только при установке полных права доступа к функции "Копирование списка сотрудников", расположенной в разделе "Ведение табельных листов" окна "Редактирование списка ролей" модуля "АиТ:\ Конфигурация".

Рис. 1.

Левая часть окна предназначена для перечисления сотрудников предприятия, учитываемых в данном табельном листе. В правой части расположен список сотрудников для выбора, на основании которого формируется список сотрудников текущего табельного листа. При установке флага "Не попавшие в другие табельные листы" в правой части отражаются только сотрудники предприятия, не вошедшие ни в один табельный лист в текущем месяце. В нижней части окна расположены поля для поиска сотрудника по фамилии или табельному номеру, а также для установки фильтра по подразделению и категории.

Добавление сотрудников в текущий табельный лист

Для добавления или удаления выделенных сотрудников в текущий табельный лист используются кнопки TabLeft и TabWrite дополнительной панели инструментов, а также механизм "drag and drop" ("перетащить и отпустить"). Перед перемещением сотрудников из правой части окна в левую часть (добавление в табельный лист) или из левой части окна в правую часть (удаление из табельного листа) следует их выделить двойным щелчком мыши или соответствующей командой всплывающего меню.

Перечисленные в списке сотрудники автоматически попадают в табельный лист после нажатия на кнопку "Закрыть текущее окно" TabDoor. На экране показывается табельный лист со списком сотрудников, введенном в данном окне (рис. 1).


Ручной ввод данных в табельный лист

После того как все параметры табельного листа определены и сформирован список сотрудников, которые будут в нем учитываться, можно приступать к заполнению табельного листа. Ввод ежедневных табельных данных об использовании рабочего времени осуществляется в правой части окна "Табельный лист" (рис. 1). Для облегчения заполнения табельных данных вручную можно использовать команды всплывающего меню.

Рис. 1

В табельный лист можно вводить:

· фактически отработанное за день время почасового типа в формате ЧЧ:ММ (например, 8:15);
· обозначение выходного дня в виде заглавной русской буквы "В" вручную или с помощью команды "Код типа времени";
· краткое обозначение любого типа времени, учитываемого в днях (больничные, отпуска и пр.), Для этого используется команда "Код типа времени".

По умолчанию в табеле на каждого сотрудника всегда имеется основная строка с типом времени "Рабочее время". Условные обозначения для типов времени, учитываемых в днях, отображаются на основной строке.

Для того чтобы в табельном листе учитывались другие почасовые типы времени (например, ночное время, сверхурочные и др., см. рис. 2), кроме рабочего времени, необходимо добавить новые строки, нажав на кнопку "Параметры" TabParam панели инструментов. Далее в окне "Настройка листа" на закладке "Типы времени" в колонке "Отображать" установить флаг для типов времени (почасового и калькулируемого), данные по которым необходимо учитывать в данном табельном листе.

Рис. 2

После закрытия окна "Настройка листа" кнопкой "Закрыть текущее окно" TabDoor в табельном листе на каждого сотрудника появится столько дополнительных строк для ввода значений выбранных типов времени, сколько было установлено флагов в колонке "Отображать" на закладке "Типы времени".


Назначение команд всплывающего меню

Для облегчения заполнения табельных листов вручную можно использовать команды всплывающего меню (рис. 1).

Рис. 1

Меню открывается щелчком правой кнопкой мыши на любом дне в табельном листе и содержит следующие команды:

· Поиск – вызов окна "Поиск сотрудника" для текущего в списке сотрудника;
· Вырезать – вырезать и взять в буфер значение текущей ячейки;
· Копировать – скопировать в буфер значение текущей ячейки;
· Вставить – вставить в текущую ячейку значение из буфера;
· Код типа времени – при выборе этого пункта открывается дополнительное окно (рис. 2) с кодами и наименованиями поденных типов времени, отсутствие на работе по которым законодательно разрешено. Вставка кода нужного типа времени в текущую ячейку производится щелчком мыши на нем;

Рис. 2

· Заполнить строку – все выделенные в табельном листе строки заполняются значением текущей ячейки или значением из буфера обмена;
· Заполнить строку только по рабочим дням – рабочие дни всех выделенных в табельном листе строк заполняются значением текущей ячейки или значением из буфера обмена;
· Заполнить колонку – всем (или выбранным) сотрудникам в этот день проставляется одинаковое табельное время (текущее или значение из буфера обмена);
· Заполнить колонку по рабочим дням – всем (или выбранным) сотрудникам в этот день, если он не является выходным, заносится одинаковое табельное время (текущее или значение из буфера обмена);
· Значение из буфера обмена – если устанавливается этот флаг, то все операции заполнения с помощью выпадающего меню производятся значением из буфера обмена, в противном случае – текущим значением.


Мастер заполнения табельного листа

Для автоматического ввода табельных данных необходимо в табельном листе выделить сотрудников, для которых пользователь собирается заполнить табель, и нажать на кнопку "Мастер заполнения" TabWizardAdded, после чего откроется окно "Заполнение" (рис. 1).

Рис. 1

В поле "Дни месяца" указываются дни, в которые будет производиться запись данных для выделенных сотрудников. При перечислении дней следует использовать символы "тире" и "запятая".

При установке флага "Записывать данные только в рабочие дни" запись будет производиться только в те дни указанного диапазона, которые не отмечены как выходные (не содержат букву "В").

Табельный лист может быть заполнен:

· кратким обозначением типа времени, учитываемого в днях (больничный, отпуск, командировка и т. д.);
· числовым значением типа времени, учитываемого в днях и часах (рабочее время, ночное время и т. д.), в формате ЧЧ:ММ;
· совокупностью нескольких типов времени, заранее определенных в шаблоне графика;
· совокупностью нескольких типов времени, заранее определенных в плановом графике;
· совокупностью нескольких типов времени согласно плановому графику, определенному по умолчанию для каждого сотрудника.

Для заполнения табельного листа в блоке "Заполнить типом времени" нужно выбрать один из перечисленных переключателей, определяющих те данные, которые будут вноситься в табельный лист:

· 1. Учитываемым в днях – используется для ввода выходных, больничных, отпусков и проч. одному или нескольким сотрудникам за один или несколько дней. Для заполнения табеля в поле "Тип времени" из выпадающего списка следует выбрать необходимый тип времени.
· 2. Учитываемым в днях и часах – используется для ввода рабочего времени (ночного времени, сверхурочных и т. д.) за любой период месяца. После выбора этого переключателя в окне (рис. 1) становятся видимыми два поля Тип времени" и "Значение". Первое поле заполняется путем выбора необходимого типа времени из выпадающего списка. Во втором поле указывается время в формате ЧЧ:ММ, которое будет внесено в каждый из дней табеля, заданных в поле "Дни месяца".
· 3. Разложить шаблон графика – данный способ используется для заполнения табеля по графикам, заранее описанным в виде шаблона графика (сутки – трое, пятидневка и проч.). После выбора переключателя "Разложить шаблон графика" становится доступными два поля. В первом поле "Шаблон графика" из выпадающего списка следует выбрать необходимый для заполнения шаблон. Для шаблонов сменного и вахтового типов во втором поле нужно указать стартовый день рабочего цикла. Стартовый день определяет тот день шаблона, с которого начнется заполнение указанного в мастере периода дней. Стартовый день не может превышать количество дней в шаблоне.

Пример.

Разложить шаблон графика "Сутки – трое" на месяц так, чтобы 1-ое и 2-ое число месяца были выходными, 3-е – рабочим днем, 4, 5 и 6-ое снова выходными, 7-ое рабочим и т.д. Для такого разложения необходимо указать стартовый день "3".

Шаблон графика "Сутки – трое"

День шаблона | 1 | 2 | 3 | 4
Рабочее время, ч. | 16 | В | В | В
Ночное время, ч. | 8 |  |  |

Заполнение по шаблону "Сутки – трое" со стартовым днем "3"

День месяца | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | …
Рабочее время, ч. | В | В | 16 | В | В | В | 16 | В | …
Ночное время, ч. |  |  | 8 |  |  |  | 8 |  | …

Внимание. В случае наличия в шаблоне нескольких почасовых типов времени (ночное время, сверхурочные и т. д.) в табельный лист будут внесены только учитываемые в нем типы.

Если, к примеру, в настройках табельного листа отсутствует ночное время, то при заполнении этого табельного листа по шаблону, содержащему ночное время, данные по нему будут проигнорированы.

· 4. Разложить плановый график – данный способ предназначен для ввода табельных данных, заранее описанных в виде планового графика ("Сутки – Трое I", "Пятидневка (40ч)" и проч.). Для заполнения по плановому графику следует установить переключатель "Разложить плановый график" и заполнить поле "Плановый график" из выпадающего списка. При этом выбранный плановый график должен быть полностью заполнен за заданный месяц, иначе табельный лист для выбранных сотрудников заполнен не будет.
· 5. Разложить плановый график из личной карточки – данный способ используется для ввода табельного времени выделенным сотрудникам в соответствии с плановым графиком, закрепленным за каждым сотрудником по умолчанию. При заполнении плановый график для каждого из выделенных сотрудников выбирается индивидуально в соответствии с настройкой в окне "Отклонение аналитических признаков и графиков в табельном листе", которое открывается кнопкой "Параметры сотрудников табельного листа".

После выбора нужного переключателя и ввода нужных значений следует нажать кнопку "Заполнить". В результате для выделенных сотрудников в соответствии с установленными настройками будет заполнен табельный лист.


Копирование списка сотрудников

Для простых табельных листов, не автоматизированных и заполняемых вручную, разрешается копировать список сотрудников прошлого месяца. Копирование списка сотрудников осуществляется из окна со списком табельных листов.

Для проведения копирования требуется соблюсти следующие условия:

· задать полные права доступа к функции "Копирование списка сотрудников", расположенной в разделе "Ведение табельных листов" окна "Редактирование списка ролей" модуля "АиТ:\ Конфигурация". В этом случае на дополнительной панели инструментов отображается кнопка "Скопировать список сотрудников из прошлого месяца" SotrCopyLast;
· выбрать табельный лист, список сотрудников которого требуется копировать, в списке табельных листов (рис. 1). Причем, табельный лист должен быть простым, без автоведения. Если выбрать лист в автоведением, то кнопка будет не активной;
· нажать на кнопку SotrCopyLast. Если списки текущего и прошлого месяцев отличаются, то после окончания процесса копирования в табельный лист переносится точный список сотрудников из табеля предыдущего месяца.

Рис. 1

Внимание. Если в текущем месяце изменялись настройки дополнительных типов времени для табельного листа, то после копирования списка сотрудников в табельном листе сотрудники скопируются с теми типами времени, которые были в предыдущем месяце. Поэтому необходимо открыть окно "Настройка листа" на закладке "Типы времени" и проверить настройки дополнительных типов времени.


Автоматизированное ведение табельного учета

Наиболее удобным способом ведения табельного учета является использование табельных листов с автоведением, что позволяет:

· автоматически создавать новые табельные листы по подразделениям в соответствии с организационной структурой предприятия или по рабочим центрам;
· автоматически отслеживать кадровые перемещения (прием, увольнение, перевод);
· оформлять табельные листы в соответствии с плановыми графиками сотрудников, учитывая при этом временные (на период) изменения планового графика и аналитических признаков.

Использование табельных листов с автоведением помогает предельно сократить трудозатраты табельщиков за счет автоматизации типовых операций табельного учета.

Табельные листы с автоведением можно создавать двумя способами:

· автоматически – Мастером ведения табельного учета. Причем, таким способом создается группа табельных листов;
· вручную – создается один табельный лист с автоведением.

Для автоматического создания новых табельных листов нужно из окна со списком табельных листов вызвать "Мастер ведения табельного учета" кнопкой Panel2 основной панели инструментов или из пункта "Мастер табельного учета" раздела "Автоведение" Главного меню. В этом режиме Мастером:

· создаются новые табельные листы с автоведением по всем или заданным подразделениям и рабочим центрам;
· автоматически формируются списки сотрудников в новых табельных листах или корректируются в уже созданных табельных листах;
· оформляются табельные листы;
· рассчитываются своды по всем табельным листам.

После завершения работы Мастера в списке в соответствии с выбором пользователя появляются один или несколько новых табельных листов с автоведением. Каждый табельный лист с автоведением в списке табельных листов отмечается буквой "А". Для просмотра табельного листа следует дважды щелкнуть мышью на строке с табельным листом.

Если операции, выполняемые Мастером, следует проделать не со всем списком, а с произвольно выбранными в нем табельными листами, использующими автоведение, можно воспользоваться пунктами раздела "Автоведение" Главного меню, которые позволяют выполнить следующие операции:

· откорректировать списки сотрудников;
· оформить выделенные табельные листы;
· сформировать своды.


Мастер ведения табельного учета

Мастер ведения табельного учета позволяет не только создавать новые табельные листы с автоведением по всем или выделенным в списке подразделениям (рабочим центрам), но и автоматизировать все операции табельного учета (автоматически формировать списки сотрудников, оформлять табельные листы и рассчитывать своды по каждому из них).

Ежемесячная работа с Мастером

С помощью Мастера можно ежемесячно корректировать списки сотрудников уже созданных табельных листов, оформлять табельные листы и формировать по ним своды. Мастер позволяет сразу выполнить эти операции (все или в любом сочетании) со всеми табельными листами, использующими автоведение.

Первичное создание табельных листов

Режим "Мастер ведения табельного учета" вызывается из одноименного пункта раздела "Автоведение" Главного меню или нажатием одноименной кнопки Panel2 основной панели инструментов. Работа Мастера включает ряд последовательных этапов (шагов), каждый шаг выполняется в отдельном окне.

Шаг 1

В первом окне Мастера (рис. 1) требуется выбрать подразделения из списка, по которым будут создаваться табельные листы. В списке присутствуют все подразделения, на которые отсутствуют табельные листы в списке табельных листов.

Табельные листы могут создаваться Мастером по всем или выделенным в списке подразделениям либо по рабочим центрам (центрам затрат), что определяется выбором нужного переключателя. Выделение подразделения в списке производится двойным щелчком мыши по подразделению.

Рис. 1

В списке (рис. 1) представлены наименования:

· подразделений, которые рассчитываются в модуле "АиТ:\Зарплата" и по которым в текущем месяце отсутствуют табельные листы с автоведением;
· рабочих центров, которые в текущем месяце указаны для сотрудников в окне "Параметры сотрудников предприятия" и по которым в этом месяце отсутствуют табельные листы с автоведением.

Внимание. Возможность создания табельных листов по рабочим центрам существует только в профессиональной версии комплекса.

При первичном создании табельных листов нужно выбрать переключатель:

· Создавать табельные листы по всем – в этом случае выделять подразделения (рабочие центры) не нужно, т.к. табельные листы будут созданы по всем подразделениям (рабочим центрам), имеющимся в списке;
· Создавать табельные листы по выделенным – в этом случае нужно выделить подразделения (рабочие центры), по которым требуется создать новые табельные листы.

В тех случаях, когда требуются табельные листы не по всем сотрудникам подразделений, а дробное распределение (в рамках подразделения) сотрудников по табельным листам, то табельные листы лучше создавать вручную.

Внимание. Если создавать новые табельные листы (рабочие центры) не нужно, а требуется их корректировка, то следует выбрать переключатель "Не создавать новых табельных листов".

.Шаг 2.

На втором шаге (рис. 2) по желанию пользователя можно провести коррекцию табельных листов или отказаться от нее, установив соответствующий переключатель. Коррекция списка сотрудников заключается в добавлении в табельный лист сотрудников в соответствии с параметрами, настроенными на закладке "Автоведение" окна "Настройка листа" (подразделение, категория и пр.), с учетом кадровых перемещений. Мастер корректирует списки сотрудников во всех табельных листах, использующих автоведение (а не только в новых листах).

Рис. 2

При коррекции в каждый табельный лист, поддерживающий автоведение, будут добавлены сотрудники, которые должны в нем учитываться, и будут удалены сотрудники, которые должны учитываться в других табельных листах.

Параметры сотрудников (должность, подразделение, категория и прочие), по которым определяется принадлежность к табельному листу, отображается в окне "Параметры сотрудников предприятия".

Шаг 3.

На третьем шаге (рис. 3) выполняется операция оформления табельных листов. Операция предусматривает заполнение табеля всем сотрудникам в соответствии с их плановыми графиками с учетом изменений плановых графиков и переходов сотрудников между табельными листами, а также заполнение табельных листов типами времени, взятыми из журналов.

В табельных листах, созданных Мастером, автоматически вводится только рабочее время, и не учитываются другие почасовые типы времени, например, ночное, сверхурочные и т.п. В случае необходимости эти типы времени придется добавить позже в окне "Настройка листа" на закладке "Типы времени".

Перед оформлением табельных листов крайне желательно внести сведения о больничных, отпусках и т.д. в соответствующие журналы. В противном случае потребуется повторно запустить данный Мастер или воспользоваться Мастерами заполнения.

Рис. 3

Шаг 4.

На этом шаге (рис. 4) можно сформировать своды по табельным листам, если установить соответствующий переключатель. Под формированием сводов подразумевается создание первичных или корректирующих сводов по всем табельным листам, поддерживающим автоматическое ведение.

Свод – итоговый документ по табельному листу, содержащий суммы по типам табельного времени за месяц. Свод является финансовым документом и не подлежит изменению или удалению после поступления в расчет.

Рис. 4

Шаг 5.

Пятый шаг (рис. 5) завершает работу с Мастером. Если на этом шаге установить флаг "Перейти в окно Журналы", то после закрытия Мастера, открывается окно "Журналы", в котором можно сформировать своды по журналам.

Рис. 5


Создание автоведомого табельного листа ручным способом

В отличие от простых табельных листов, у автоведомых листов большинство операций табельного учета автоматизировано. Автоведомые табельные листы можно создавать вручную или с помощью Мастера ведения табельного учета, который позволяет автоматизировать большинство операций табельного учета.

Мастер позволяет создавать табельные листы со списком сотрудников конкретного подразделения. Ручной способ применяется в тех случаях, когда требуется сформировать список сотрудников в табельном листе не только для конкретного подразделения, но и с использованием одного или нескольких критериев отбора сотрудников, например, должности, графика или категории.

Для создания автоведомых табельных листов ручным способом пользователь должен выполнить перечисленные ниже действия.

1. Нажать на кнопку "Создать" TabAdded дополнительной панели инструментов в окне "Список табельных листов". При этом новый табельный лист добавляется в список, а на экране автоматически открывается окно "Настройка листа №" (рис. 1).

2. На первой закладке "Общие" этого окна нужно установить флаг "Автоматизированное ведение табельного листа". В этом случае табельный лист получает статус автоведомого и в окне настроек (рис. 1) появляется дополнительная закладка "Автоведение", и на ней автоматически устанавливается флаг "Автоматизированное оформление табельного листа". В этом случае табельный лист получает статус базового листа, и он заполняется автоматически после выбора пункта "Оформить табель" раздела "Автоведение" Главного меню. Для небазовых листов флаг "Автоматизированное оформление табельного листа" следует снять. Деление табельных листов на базовые (основные) и небазовые (неосновные) листы необходимо в сложных случаях ведения табельного учета.

Рис. 1

3. На закладке "Автоведение" приводится список критериев, по которым будет формироваться список сотрудников нового табельного листа. Выбор каждого критерия заключается в установке флага слева от его названия и задания его значения в соседнем поле. Значения критерия вводится из выпадающего списка. Если критерий отбора был задан, то пункты 4, 5 и 6 пропускаются.

4. Закрыть окно (рис. 1) с сохранением, нажав на кнопку TabDoor . Если пользователь на закладке "Автоведение" не задал ни одного критерия, на экран выдается сообщение (рис. 2).

Рис. 2

5. Если пользователь нажал на кнопку "Да", то открывается пустой табельный лист. Для создания списка сотрудников нажмите на кнопку TabPluc , в табельный лист попадут сотрудники из доступных пользователю подразделений.

Список доступных подразделений задается в модуле "АиТ:\Конфигурация" в окне "Редактирование списка пользователей" на закладке "Подразделения". Окно открывается кнопкой sotr основной панели инструментов или из пункта "Пользователи" раздела "Режим" Главного меню.

6. Если пользователь в окне (рис. 2) нажал на кнопку "Нет", то он не собирается создавать табельный лист со всеми сотрудниками предприятия. Поэтому сначала следует задать критерий для отбора сотрудников в табельном листе на закладке "Автоведение" в окне (рис. 1), которое открывается кнопкой TabParam. Затем откорректировать список сотрудников в этом листе в соответствии с заданным критерием. Для выполнения этой операция выберите пункт "Откорректировать списки сотрудников" раздела "Автоведение" Главного меню.

7. Если создается небазовый лист, и была нажата кнопка "Да", открывается новый табельный лист с уже заполненным списком сотрудников. После формирования новый автоведомый табельный лист в списке табельных листов отмечается буквой "А".

8. Если плановые графики сотрудников в табельном листе предусматривают учет других почасовых типов времени, кроме рабочего, то нужно повторно открыть окно настройки параметров табельного листа кнопкой "Параметры" TabParam дополнительной панели инструментов и на закладке "Типы времени" отметить нужные типы времени, например, ночное время, сверхурочные.

9. Далее нужно заполнить табельный лист вручную или воспользоваться Мастером заполнения, чтобы облегчить ручной ввод ежедневных табельных данных.


Корректировка списка сотрудников

Автоматическая корректировка списка сотрудников в табельных листах с автоведением, связанная с их кадровыми перемещениями, обычно проводится в конце месяца. Для проведения операции выберите пункт "Откорректировать списки сотрудников" раздела "Автоведение" Главного меню. Также как и другие функции, вызываемые из пункта меню "Автоведение", коррекция списка:

· может производиться только с табельными листами, использующими автоведение;
· может производиться как по текущему в списке табельному листу, так и по любой выделенной в списке выборке табельных листов.

Выделить табельный лист в списке можно клавишей Insert, выделить весь список – кнопкой "Выделить весь список" TabSelect панели инструментов.

При коррекции списка сотрудников в табельный лист попадут:

· все сотрудники, параметры которых в какие-либо дни текущего месяца удовлетворяют условиям, настроенным на закладке "Автоведение" окна "Настройка листа";
· сотрудники согласно датам приема и увольнения из журнала кадровой карточки модуля "АиТ:\Кадровый учет";
· сотрудник, у которого в журнале перемещений строки нет, но он в текущем месяце работает (в модуле "АиТ:\Кадровый учет" кадровой карточке указана дата приема или имеется запись в журнале кадровой карточки). Подразделение для определения автоведомого табельного листа при отсутствии строки в журнале перемещений будет браться из кадровой карточки сотрудника.

Корректировка списка сотрудников зависит от настройки параметра "При корректировке добавлять журн.типы времени" в разделе "Табельные листы" в окне "Настройка комплекса" модуля "АиТ:\Конфигурация". Если параметру присвоено значение "Да", то при корректировке списка сотрудников в табельные листы добавляются все типы времени, которые присутствуют хотя бы в 1 дне планового графика сотрудников. Также для всех табельных листов добавляются все типы времени, у которых на закладке "Параметры" окна "Типы времени" установлены флаги "Дни и часы", "Вести журнал по типу времени" и на закладке "Стыковки" установлен флаг "Передавать данные в зарплату". В этом случае для назначенных типов времени можно будет выполнить операцию разложить по журналам.

Коррекция списка при кадровых перемещениях

Коррекция списка при кадровых перемещениях выполняется в следующих случаях:

· если в текущем месяце сотрудник был принят на работу, то при коррекции списка он автоматически появится в табельном листе того подразделения, в которое был принят;
· если в текущем месяце сотрудник был переведен из одного подразделения в другое кадровым приказом, то при коррекции списка этот сотрудник автоматически появится в табельном листе того подразделения, в которое он переведен;
· если в текущем месяце сотрудник был уволен кадровым приказом, то при коррекции списка в следующем месяце он будет автоматически удален из табельного листа.


Оформление табельного листа

Функция оформления табельных листов вызывается из пункта "Оформить табель" раздела "Автоведение" Главного меню. Операция оформления табельных листов подразумевает занесение в табельные листы плановых графиков сотрудников и записей из журналов. Следовательно, перед проведением операции оформления табельных листов желательно:

· убедиться, что в табельном листе учитываются все почасовые типы времени, необходимые для правильного занесения плановых графиков сотрудников. Если ведутся журналы по типам времени, учитываемым в часах (например, почасовой больничный), то следует обратить внимание на наличие в табельном листе этих типов времени;
· внести в соответствующие журналы сведения о больничных, отпусках и т.д.

Оформление производится с учетом кадровых перемещений и изменений параметров сотрудника (например, графика) на некоторый период.

В зависимости от вида кадровых перемещений сотрудника в текущем месяце табельные листы заполняются следующим образом:

· сотрудник был принят на работу в текущем месяце – при оформлении табельного листа рабочее время этому сотруднику будет внесено от даты приема;
· сотрудник в текущем месяце был переведен из одного подразделения в другое – при оформлении табельных листов часть планового времени (до даты перевода) запишется в старый табельный лист, а плановое время от даты перевода до конца месяца будет записано в табельный лист того подразделения, в которое переведен сотрудник;
· сотрудник в текущем месяце был уволен кадровым приказом – при оформлении табельного листа рабочее время этому сотруднику будет внесено до даты увольнения.

Коррекция данных в табельном листе, использующем автоведение

Если после оформления табельного листа в течение месяца фактическое рабочее время сотрудника отличается от планового времени, может возникнуть необходимость ручной коррекции данных в табельном листе. Также можно откорректировать результаты переноса записи из журнала в табельный лист.

Внимание. Если в течение месяца данные в табельном листе корректировались, то при повторном оформлении листа, например, после внесения данных из журналов все изменения будут утрачены.

Ручная коррекция табельных данных производится с клавиатуры, с помощью команд выпадающего меню (открывается правой кнопкой мыши) или Мастера заполнения табельного листа.

Для повторного заполнения табельных листов по записям в журнале после ручной коррекции данных в листе следует воспользоваться кнопкой "Мастер заполнения" TabWizardAdded дополнительной панели инструментов окна "Журналы".


Учет совместителей в табельных листах

При приеме работающего сотрудника по внутреннему совместительству в модуле "АиТ:\Кадровый учет" на него создается новая кадровая карточка с теми же персональными данными, что и основная карточка, но с другим табельным номером и параметрами рабочего места. С целью обеспечения удобства просмотра списка сотрудников табельный номер внутреннего совместителя выделяется желтым цветом.

В модуле "АиТ:\Зарплата" у этого сотрудника будут также две персональные карточки, но одна карточка начислений, оперативного архива, налоговая карточка.

В программном комплексе "АиТ:\Управление персоналом" внутренние совместители могут работать как в подразделении по своему основному месту работы, так и в другом подразделении. В связи с этим, если сотрудник является внутренним совместителем, то его приходится учитывать в одном, двух (рис. 5.20) или более табельных листах. В табельных листах табельный номер внутренних совместителей, в отличие от основного места работы, подсвечивается желтым цветом (рис. 1).

Рис. 1

Табельный лист, в котором имеются внутренние совместители, формируется и заполняется так же, как и табельный лист, не имеющий внутренних совместителей. Для того чтобы сведения о полученном больничном листе попадали в табельный лист и для внутренних совместителей, т.е. отражались по всем должностям сотрудника, необходимо в окне "Типы времени" на закладке "Параметры" установить флаг "Заполнять табельные листы внутр. совм." для типа времени "Больничный". В этом случае при передаче данных по больничным листам из кадровой карточки модуля "АиТ:\Кадровый учет" в модуль "АиТ:\Зарплата" также происходит передача этих сведений в соответствующий журнал табельного учета как по основной должности, так и по всем должностям внутреннего совместительства, т.е. по всем табельным номерам.

Табельные листы заполняются с учетом графиков работы, которые указываются в карточках сотрудников на закладке "Работа" в модуле "АиТ:\Кадровый учет" и персональной карточке на закладке "Общее" в модуле "АиТ:\Зарплата", естественно, что график работы внутреннего совместителя отличается от графика работы по основному месту работы.

Работа с табельными листами, имеющими совместителей, выполняются тем же правилам, что и с табельными листами, не имеющими совместителей. Заполнение табельных листов проводится в зависимости от их вида (ручной или с автоведением). Данные из журналов переносятся в табельные листы на основании, имеющихся там записей по табельному номеру, т.е. не имеет значения, указан ли в журнале сотрудник по основному месту работы или по внутреннему совместительству.

После заполнения табельных листов целесообразно провести расчет итогов за месяц, а потом сформировать своды, которые используются для расчета зарплаты в модуле "АиТ:\Зарплата" и формирования приказов в модуле "АиТ:\Кадровый учет". Формирование сводов происходит по конкретному табельному листу, независимо, содержит ли он внутренних совместителей или нет.

Для того чтобы в карточку начислений правильно попадали начисления как по основной работе, так и по внутреннему совместительству, необходимо в модуле "АиТ:\Зарплата" в режиме "Начисление по табельным листам и нарядам" настроить коды начислений (столбец "Критерий").


Сложные случаи табельного учета

В некоторых случаях возникает необходимость ввода одного и того же типа времени в табельный лист по частям с разными аналитическими признаками. Например, один или два раза в месяц часть рабочего дня сотрудники подразделения занимаются профилактикой оборудования. Эта работа оплачивается так же, как основное рабочее время, но передается в модуль "АиТ:/Зарплата" с другой аналитикой.

В этом случае на одно и то же подразделение формируется два табельных листа с одинаковым списком сотрудников, использующих автоведение:

· базовый лист – заполняется автоматически на основании плановых графиков сотрудников и записей из журналов;
· неосновной лист – лист, имеющий те же параметры, что и базовый лист, но другую аналитику.

В модуле разрешается на какой-либо период изменять значения аналитических признаков сотрудника, не переводя его для этого в другой табельный лист.

Методика разбивки рабочего времени по аналитическим признакам удобна и по следующей причине. В основном табельном листе можно учитывать данные, не требующие ручной коррекции в течение месяца. Следовательно, работа табельщика в этом случае сводится к разовым операциям в конце месяца. А все данные, требующие ручной правки (например, данные о времени, отработанном сверхурочно), можно вести отдельно в неосновном табельном листе.

Статус базового (основного) или небазового (неосновного) табельный лист получает в момент своего создания. Все листы, которые создаются Мастером ведения табельного учета, по умолчанию считаются базовыми табельными листами. Если автоведомый лист создается вручную в версии "Проф", то по умолчанию он также считается базовым, т. е. в окне "Настройка листа №" на закладке "Автоведение" автоматически устанавливается флаг "Автоматизированное оформление табельного листа". Для того чтобы создаваемый табельный лист получил статус неосновного листа флаг "Автоматизированное ведение табельного листа" следует снять.

При создании новых табельных листов функция оформления может использоваться только для базовых табельных листов, для небазовых листов пункт "Оформить табель" раздела "Автоведение" Главного меню недоступен (выделен серым цветом).

В базовой версии для ведения сложного аналитического учета рабочего времени в окне "Настройка режимов" нужно установить флаг "Создание небазовых табельных листов", после чего в окне "Настройка листа №" станет доступным соответствующий флаг.


Отклонения аналитических признаков в табельном листе

В модуле предусмотрен механизм, разрешающий изменять значения аналитических признаков сотрудников на какой-либо период, не переводя его в другой табельный лист. Для того чтобы аналитика сотрудников была отлична от аналитики, настроенной в табельном листе в текущем периоде, нужно открыть окно "Отклонение аналитических признаков и графиков в табельном листе" (рис. 1) и изменить их аналитику. Для этого в окне "Список табельных листов" нужно выделить табельный лист и выбрать пункт "Отклонения параметров" раздела "Вид" Главного меню или кнопку "Параметры сотрудников табельного листа" TabParamSotr дополнительной панели инструментов.

Рис. 1

Окно (рис. 1) разделено на две части. В левой части приведен список сотрудников текущего табельного листа, а в правой части перечислены записи, введенные этом окне. Если это окно открывается в первый раз, то в правой части окна записи отсутствуют, т.к. никаких изменений значений аналитических признаков не производилось. В окне предусмотрена возможность сортировать список сотрудников по фамилии, имени и отчеству, что удобно при наличии однофамильцев, работающих на предприятии.

Ввод новой записи для текущего сотрудника выполняется в отдельном окне "Ввод изменений" (рис. 2), доступ к которому осуществляется кнопкой "Создать" TabAdded дополнительной панели инструментов. Изменения можно вносить на одного или сразу на нескольких выделенных в списке сотрудников, имеющих одинаковые значения аналитических признаков.

Рис. 2

В окне "Ввод изменений" нужно указать период, за который вносятся изменения, и признаки, по которым происходят изменения, установив соответствующий флаг. В этом случае под установленным флагом появляется дополнительное поле для ввода значения признака из выпадающего списка. В этом списке содержатся значения данного аналитического признака, которые перечислены в справочнике аналитических признаков в модуле "АиТ:\Зарплата". Например, можно изменить на произвольный период график сотруднику, по которому будет заполняться данный табельный лист. После окончания ввода и закрытия окна кнопкой "Ок" в правой части окна (рис. 1) появляется новая запись с введенными значениями.

Для редактирования уже существующей записи нужно сделать ее текущей и нажать на кнопку "Открыть" SotrParam. Открывается такое же, окно, как и при вводе записи (рис. 2), но уже с заполненными данными. В этом окне можно изменить аналитические признаки сотрудника в табельном листе, но запрещено изменить период, за который вносятся изменения.

На первой закладке окна (рис. 1) для каждой записи указывается табельный номер и ФИО сотрудника, а также период, за который вносятся изменения. Внизу на закладке для текущего сотрудника показываются измененные параметры. Если требуется просмотреть все изменения параметров на сотрудников, то нужно перейти на вторую закладку (рис. 3).

Рис. 3

Чтобы введенные изменения в окне (рис. 1) отразились в текущем табельном листе, нужно:

· в табельном листе выделить сотрудников, для которых выполнялись изменения;
· нажать на кнопку "Мастер заполнения" TabWizardAdded. Открывается окно "Заполнение";
· в окне "Заполнение" выбрать переключатель "5. Разложить плановый график из личной карточки";
· нажать на кнопку "Заполнить". Окно "Заполнение" закрывается, а текущий табельный лист заполняется с учетом внесенных изменений за указанный период в окне "Ввод изменений" (рис. 2).

В промежуточных итогах и в своде (рис. 4) по табельному листу на сотрудников, которым изменялись параметры, будет столько строк, сколько разных комбинаций аналитики было у него в текущем месяце.

Рис. 4


Промежуточные итоги по табельному листу

После заполнения табельного листа ежедневными табельными данными можно произвести расчет итогов за месяц. Это делается непосредственно из табельного листа или из списка табельных листов (при этом итоги будут рассчитаны для текущего в списке листа). Расчет происходит после нажатия на кнопку "Промежуточные итоги" TabItog панели инструментов.

В результате открывается окно "Итоги по табельному листу" (рис. 1) с рассчитанными промежуточными итогами. В окне итоговые данные представлены по всем типам времени, внесенным в табельный лист. Суммы часов представляются в десятичном формате (с долями часа).

Рис. 1

При изменении каких-либо данных в табельном листе, не закрывая окно итогов, можно пересчитать итоговые суммы, воспользовавшись кнопкой "Рассчитать результат" TabCalk дополнительной панели инструментов или пунктом меню "Расчет" раздела "Карточка".

Для подсчета итогов за период, меньший месяца, следует установить флаг "Ограничить период расчета итогов по табельным листам" в окне "Настройка параметров программы".

Таким образом, режим "Промежуточные итоги" удобно использовать для расчета и контроля итоговых сумм. Операции расчета итогов достаточно для формирования всех отчетов по табельным листам и отчетов по предприятию.

Настройка пересчета итоговых данных

При отсутствии необходимости ежедневного заполнения табеля модуль "АиТ:\Табельный учет" допускает ввод суммарных данных за период вне зависимости от данных, внесенных в табельный лист. Поскольку по умолчанию перерасчет итоговых данных производится автоматически при каждом открытии окна итогов (рис. 1), все введенные в режиме итогов данные могут быть утрачены. Для предотвращения этой ситуации следует выполнить соответствующую настройку в модуле "АиТ:\Конфигурация".

По умолчанию установлена настройка, обеспечивающая автоматический пересчет итогов. Для этого в разделе "Табельные листы" параметру "Автоматический перерасчет промежуточных итогов" присвоено значение "Да".

В том случае, когда в настройках установлено значение "Нет" пересчитать итоги по тем табельным листам, которые заполняются ежедневно, можно нажав на кнопку "Рассчитать результат" TabCalk дополнительной панели инструментов окна "Итоги по табельному листу" (рис. 1).


Формирование сводов по табельному листу

Для доступа к итоговым данным табельного листа в других модулях комплекса "АиТ:\Управление персоналом" необходимо сформировать своды. Пользователь может сформировать свод по любому заполненному табельному листу в окне "Своды по табельному листу" (рис. 1). Вызов окна со сводами осуществляется кнопкой "Своды по табельному листу" TabSvod дополнительной панели инструментов, клавишами Ctrl+S или из пункта "Своды по табельному листу" раздела "Вид" Главного меню:

· из списка табельных листов. При этом заданный табельный лист необходимо выделить;
· из открытого на экране табельного листа.

Рис. 1

Окно (рис. 1) содержит две закладки. На первой закладке приводится список сформированных сводов по текущему табельному листу. На второй закладке отображаются итоговые суммы в днях и часах за месяц или за выбранный период.

Внимание. При каждом открытии окна (рис. 1) происходит автоматический расчет и добавление свода в список, если в окне "Настройка параметров программы" установлен флаг "Автоматически перерассчитывать своды по табельным листам".

Если существует необходимость открывать окно сводов только для просмотра, флаг лучше снять. В этом случае расчет и добавление сводов происходит из соответствующих пунктов меню "Карточка" или при помощи кнопок "Создать свод в зарплату" SvodSalary и "Создать свод в кадры" SvodPerson дополнительной панели инструментов. В первом случае формируется свод, передаваемый в модуль "АиТ:\Зарплата", во втором случае формируется свод для передачи в модуль "АиТ:\Кадровый учет". При этом наименование нового свода появится в списке сводов (рис. 1). Чтобы увидеть содержимое нужного свода, необходимо выделить его двойным щелчком мыши и перейти на вторую закладку "Данные по сотрудникам" (рис. 2).

Рис. 2

В своде отражаются итоговые суммы за месяц (или за выбранный период) в днях и часах по всем почасовым типам времени, учитываемым в данном табельном листе. Суммы часов представлены в десятичном формате (с долями часа). При установке курсора на любую итоговую сумму в правой части окна показываются все аналитические признаки, характеризующие эту сумму.

Внимание. В свод по табельному листу для модуля "АиТ:\Зарплата" попадают все типы рабочего времени, передаваемые в модуль "АиТ:\Зарплата", по которым не ведутся журналы. Журналы в табеле ведутся по нерабочим типам времени.

При передаче сводов будут учитываться изменения оклада сотрудника, если в модуле "АиТ:\Конфигурация" установлена следующая настройка. Для этого в режиме "Настройки комплекса" для модуля "АиТ:\Табельный учет" в разделе "Своды в зарплату" для параметра "В своде учитывать смену оклада" нужно установить значение "Да". В этом случае при передаче свода в зарплату по сотруднику будет сформировано столько строк, сколько у этого сотрудника имеется периодов в журнале перемещений.

В модуль "АиТ:\Кадровый учет" из сформированного свода по табельному листу передаются только типы времени, за которые сотрудник получает отгулы, при условии, что выполнены соответствующие настройки на закладке "Стыковка" окна "Типы времени". Просмотреть переданные данные в модуле "АиТ:\Кадровый учет" можно в окне "Расчет отпуска" на закладке "Отгулы" только для тех сотрудников, в табельном листе которых имеются указанные типы времени. Окно "Расчет отпуска", которое открывается кнопкой PanelRep4 с закладки "Отпуска" кадровой карточки. На закладке "Отгулы" в правой таблице "Предоставлено" отражаются дополнительные выходные дни за время, отработанное сверх нормы, согласно данным, поступающим из модуля "АиТ:\Табельный учет". Эти данные используются для формирования приказа об отпуске в счет отгулов.

Итоговые суммы из сводов в зарплату по табельным листам автоматически попадают в модуль "АиТ:\Зарплата". Как только в модуль "АиТ:\Зарплата" производится начисление по сводам, изменить данные свода становится невозможным. Поэтому к формированию свода желательно приступать лишь после выверки итоговых сумм в режиме "Промежуточные итоги".

Если после начисления по сводам возникла необходимость внести какие-либо изменения в табельный лист, по нему можно сформировать корректирующий свод. Его формирование производится соответствующей кнопкой SvodSalary или SvodPerson дополнительной панели инструментов.

При этом в список сводов добавляется новая строка с наименованием "Свод №2". Корректирующий свод, в отличие от основного, содержит не итоговые суммы, а поправки к ним. В него попадают только те сотрудники, у которых после формирования первого свода изменялись табельные данные. Передача в модуль "АиТ:\Зарплата" корректирующего свода ничем не отличается от передачи основного.

Расчет сводов по табельным листам, использующим автоведение, выполняется из пункта "Рассчитать свод" раздела "Автоведение" Главного меню. Формирование сводов производится по любой выборке табельных листов, использующих автоведение.


Взаимодействие с модулем "АиТ:/Учет выполненных работ"

Если на сотрудника в текущем месяце создавались наряды, то информация об отработанном времени по нарядам может быть передана в модуль "АиТ:\Зарплата" как из табельных листов, так и из нарядов, что зависит от настройки. Настройка передачи данных устанавливается в модуле "АиТ:\Конфигурация" в окне "Настройки комплекса" в разделе "Табельные листы" и зависит от значения параметра "Вычитать из сводов оформленное по нарядам время":

· Нет – если табельное время по сотруднику подбирается в наряд, то в модуль "АиТ:/Зарплата" оно передается только из нарядов независимо от того, частично или полностью оно было подобрано.
· Да – табельное время в наряд подбирается из конкретного табельного листа, а оставшееся "неподобранным" время передается в модуль "АиТ:\Зарплата" через свод по табельному листу. Этот механизм взаимодействия модулей необходим, например, в случае, когда повременщик часть отчетного времени работает по наряду. Кроме установки этого значения необходимо выполнить некоторые дополнительные настройки в модуле "АиТ:\Учет выполненных работ".

Более подробные сведения, об особенностях настройки передачи данных в модуль "АиТ:\Зарплата", приводятся в Руководстве пользователя по модулю "АиТ:\Учет выполненных работ".


Несовпадение отчетного периода с календарным месяцем

В некоторых случаях расчет зарплаты проводится за период, не совпадающий с календарным месяцем (например, с 25 по 25 число), и требуется получить отдельные своды за 1-25 и 26-… число текущего месяца.

Для этого в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" для модуля "АиТ:\Табельный учет" в разделе "Табельные листы" параметру "Ручное удаление непринятых сводов" присвоить значение "Да".

Тогда при повторном формировании сводов по табельному листу после изменения данных старый (непринятый) свод остается без изменений, а повторный свод формируется как корректирующий к первому, т.е. содержит не общие суммы, а только поправки к ним. На дополнительной панели инструментов окна сводов появляется кнопка "Удалить строку" TabDel, позволяющая при необходимости удалить непринятый свод.

Рекомендуется следующая последовательность работы:

1. Сначала формируется свод за период с 1 по 25 число текущего месяца. Для этого в окне "Настройка параметров программы" следует установить флаг "Ограничить период расчета итогов по табельным листам" и указать дату начала и конца расчетного периода.
2. Затем это ограничение снимается и повторно формируется свод. В него войдут данные за период с 26 до конца месяца. В модуле "АиТ:\Зарплата" в расчетном периоде проводится свод за 1-25 число текущего месяца и свод, начиная с 26 числа прошлого месяца до конца месяца.


Назначение журналов

Журналы в модуле "АиТ:\Табельный учет" позволяют автоматизировать заполнение табельных листов. Модуль поставляется с несколькими настроенными журналами.

Журнал содержит набор однотипных записей о каком-либо одном типе времени (больничный, отпуск и т. д.) с указанием периода его действия. Добавление записей в журнал не зависит от текущего месяца. Обновление данных журналов происходит при загрузке модуля, нажатии кнопки "Перечитать данные", переходе на другой месяц.

Просмотр и редактирование журналов осуществляется в специальном окне "Журналы" (рис. 1), которое вызывается кнопкой "Журналы" Panel8 основной панели инструментов.

Внимание. Журналы целесообразно вести по тем типам времени, данные по которым можно получить из модулей "АиТ:\Зарплата" и "АиТ:\Кадровый учет". Таким образом, в журналах могут содержаться сведения об отсутствии сотрудника на рабочем месте, оформленные документами (больничный, очередной отпуск, учебный отпуск и т. д.), а также сведения о работе в ночное время, в выходные и праздничные дни и др. сведения.

Рис. 1

Работа с журналом включает следующие этапы:

· создание журнала по типу времени, для которого в режиме "Настройка типов времени" на закладке "Параметры" установлен флаг "Вести журнал по типу времени";
· настройка колонок журнала, которые будут заполняться в соответствующем журнале;
· внесение записей в журнал;
· заполнение табельных листов по записям в журнале;
· формирование сводов по журналам;
· формирование корректирующих сводов;
· формирование отчетов по журналам и печать отчетов.


Настройка журналов

Окно "Настройка журналов" (рис. 1) предназначено для настройки внешнего вида отображаемых полей выбранного журнала и открывается из подпункта "Настройки журналов" пункта "Настройки" раздела "Режим" Главного меню.

Рис. 1.

Каждый вид журнала настраивается отдельно. Выбор вида журнала осуществляется из выпадающего списка самого верхнего поля окна. В выпадающем списке перечислены те виды журналов, для которых в режиме "Настройка типов времени" на закладке "Параметры" установлен флаг "Вести журнал по типу времени".

В окне для каждого вида журнала имеется три колонки для внутреннего и пользовательского названий полей журнала и задания ширины колонки.

Внутренние названия полей изменению не подлежат. В качестве названий полей таблицы выводятся значения из колонки "Пользовательское название". Они так же, как и значения в поле "Ширина колонки", могут изменяться пользователем. Чтобы колонка с заданным пользовательским названием отображалась в окне "Журналы", в строке с ее названием должен быть установлен флаг.


Ведение журналов

Просмотр и редактирование журналов осуществляется в специальном окне "Журналы" (рис. 1), которое вызывается кнопкой "Журналы" Panel8 основной панели инструментов. Кроме этого доступ к окну ведения журналов выполняется из пункта "Журналы" раздела "Режим" Главного меню или клавишами Alt+J.

В каждый конкретный момент времени в окне "Журналы" можно получить сведения только по одному выбранному журналу, который указывается в верхнем поле "Вид журнала". Для смены вида журнала нужно нажать на кнопку list и из выпадающего списка выбрать нужный журнал, характеризующийся конкретным типом времени. В списке перечислены журналы по тем типам времени, для которых в режиме "Настройка типов времени" на закладке "Параметры" установлен флаг "Вести журнал по типу времени".

Окно "Журналы" в зависимости от типа времени, для которого создается текущий журнал, может содержать от двух до четырех закладок.

На первой закладке "Сотрудники" отображается весь список сотрудников предприятия, если фильтр не установлен (кнопка "Установка / снятие фильтра" на основной панели инструментов имеет вид Panel9). При установленном фильтре (кнопка имеет вид Filtr) на закладке "Сотрудники" отображается список сотрудников в соответствии с условием фильтра. Целесообразно фильтр устанавливать таким образом, чтобы в списке показывались сотрудники соответствующего табельного листа. На закладке предусмотрена возможность сортировать список сотрудников по фамилии, имени и отчеству, что удобно при наличии однофамильцев, работающих на предприятии. Для удобства пользователей табельные номера внутренних совместителей подсвечиваются желтым цветом. В нижней части окна имеются поля для поиска по фамилии или табельному номеру и подразделению.

На второй закладке "Журнал" (рис. 1) отображаются все записи выбранного журнала, имеющие отношение к выбранным на первой закладке сотрудникам. Выбор (выделение) сотрудников в списке осуществляется двойным щелчком мыши на нужной строке или командой всплывающего меню.

На закладке отображаются только те записи, период действия которых приходится на текущий месяц. Вид таблицы на закладке "Журналы" (наименования полей и ширина колонок) определяется пользователем в момент настройки журнала. В нижней части закладки приводятся информационные сведения об общем количестве отображаемых и выделенных на ней записей.

Рис. 1

Записи в журнале могут формироваться как автоматически на основании данных из модулей "АиТ:\Кадровый учет" и "АиТ:\Зарплата", так и добавляться вручную.

При передаче данных по больничным листам из кадровой карточки модуля "АиТ:\Кадровый учет" в модуль "АиТ:\Зарплата" они одновременно передаются в соответствующий журнал табельного учета как по основной должности, так и по всем должностям внутреннего совместительства, если установлен флаг "Заполнять табельные листы внутр. совм." на закладке "Параметры" окна "Типы времени". В этом случае дни временной нетрудоспособности сотрудника (больничный лист) корректно отразятся в табельном листе по всем должностям сотрудника, т.е. по всем табельным номерам.

Внимание. В журналах, предназначенных для отображения больничных листов, могут быть видны также больничные листы, добавленные в персональную карточку сотрудника, но еще не проведенные. Для этого в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" в разделе "Журналы" должна быть включена настройка "Отображать не проведенные больничные в журналах".

Третья закладка "Своды по журналу" появляется только в том случае, если данный тип времени, по которому формируется журнал, передается в модуль "АиТ:\Зарплата". Т. е. на закладке "Стыковки" окна "Типы времени" для данного типа установлен флаг "Передавать данные в модуль АиТ:\Зарплата".

Чтобы просмотреть все записи в журнале за текущий месяц, необходимо установить флаг "Все" в верхней части окна. Тогда независимо от того, какие сотрудники выделены на первой закладке, на второй будут отображаться все записи за месяц.

Установка флага "Суммы" в верхней части окна позволяет видеть на закладке "Своды по журналам" общие суммы дней и часов по тем записям, на которые сформировано несколько сводов. Такая ситуация может возникнуть, если после формирования основного свода запись изменялась и по ней был сформирован корректирующий свод.

Четвертая закладка "Не оплаченные" появляется только для типов времени, которые передаются в модуль "АиТ:\Зарплата" как больничный лист. При добавлении новой записи в журнал она автоматически дублируется на эту закладку. Для каждой записи отображается табельный номер и ФИО сотрудника, дата начала последнего интервала непрерывного стажа, продолжительность непрерывного стажа на дату начала больничного листа и процент оплаты больничного листа. Следует заметить, что на этой закладке отражаются также все больничные, введенные в журнал, в текущем месяце, даже если они относятся к другому периоду.

Назначение кнопок панели инструментов окна "Журналы"

Для работы с журналом используются кнопки дополнительной панели инструментов, перечисленные в ниже приведенной таблице.

Пункт | Кнопка | Исходные данные, действия и функции
Создать | TabAdded | Добавление записей в журнал вручную на выделенных сотрудников.
Удалить строку | TabDel | Удаление из списка текущей записи или всех выделенных записей. Данная кнопка становится неактивной, если у типа времени, соответствующего выбранному журналу, установлен флаг "Принимать данные из кадров". Если у типа времени флаг снят, то данная кнопка активна.
Мастер заполнения | TabWizardAdded | Вызов мастера заполнения табельных листов по всем записям, имеющимся в текущем журнале, если фильтр не установлен. Для выполнения операция заполнения табельных листов по всем журналам нужно выбрать пункт "Разложить все журналы" раздела "Режим" Главного меню.
Создать новый свод (своды) | JurSvod | Создание свода по текущей записи или по всем выделенным в списке записям.
Печать | Print | Формирование и печать отчетов по журналам.
Сохранить | Save | Сохранение данных в текущем окне


Ручное добавление записей в журнал

Ручное добавление новой записи в журнал (рис. 1) возможно только для типов времени, у которых в окне "Типы времени" на закладке "Стыковки" снят флаг "Принимать данные из кадров".

Рис. 1

Для ручного добавления записи в журнал нужно выполнить следующие действия:

· открыть журнал кнопкой "Журналы" Panel8 основной панели инструментов;
· выделить одного или нескольких нужных сотрудников на закладке "Сотрудники". Для выделения одного сотрудника дважды щелкните левой кнопкой мыши по соответствующей строке в списке сотрудников или воспользуйтесь командами всплывающего меню, которое открывается правой кнопкой мыши;
· добавить новую запись или записи в журнал. Для этого можно нажать на клавишу Insert или на кнопку "Создать" TabAdded дополнительной панели инструментов. Кнопка "Создать" неактивна, если журнал заполняется автоматически, в этом случае добавить вручную записи в журнал невозможно. Если в списке было выделено несколько сотрудников, на экране появляется окно (рис. 2);

Рис. 2

· задать даты начала и конца периода для добавляемых записей в окне "Добавление записей". Число добавляемых записей указывается в окне по умолчанию. Если добавляется тип времени, учитываемый в днях и часах, в окне отображается поле "Ежедневное время". В этом поле задается ежедневное время, т.е. количество часов в каждом дне периода, которые будут проставляться в табельном листе для заданного типа времени (журнала);
· нажать на кнопку "Ок" для сохранения введенных данных. Открывается окно "Журналы" (рис. 3) на закладке "Журнал" с заполненными данными и датами, введенными пользователем в окне "Добавление записей" (рис. 2).

Рис. 3

· если были введены даты, не попадающие в текущий месяц, то будет выдано соответствующее сообщение об ошибке (рис. 4), и требуется их исправить, иначе записи в журнал не будут добавлены;

Рис. 4

· если на закладке "Сотрудники" (рис. 1) была выделена одна запись, то окно "Добавление записи" не открывается, а сразу происходит переход на закладку "Журнал" (рис. 4), где запись, добавленная в журнал, подсвечивается красным цветом и отображается в формате 00.00.0000. Далее нужно отредактировать даты начала и конца периода в этой записи, после этого они будут показываться черным цветом (рис. 5), как и другие поля записи.

Рис. 5

В процессе редактирования дат осуществляется проверка на правильность ввода дат начала и конца периода. В том случае, если дата начала (конца) введена неправильно, выдается предупреждающее сообщение, после его закрытия происходит принудительное изменение даты конца (начала).

Если на одного сотрудника в журнале имеется более двух записей, то выполняется проверка на пересечение дат периодов. При обнаружении пересечения периодов в этих строках выдается соответствующее сообщение, и происходит автоматический возврат к предыдущим значениям дат, имеющимся до их редактирования.

Если все данные введены правильно, нажмите на кнопку TabDoor для сохранения сделанных изменений и закрытия окна "Журналы".


Автоматическое заполнение журнала

Автоматическое заполнение журнала данными из модуля "АиТ:\Кадровый учет" или "АиТ:\Зарплата" происходит для типов времени (отпуск, больничный, отзыв из отпуска), для которых в окне "Типы времени" на закладке "Стыковки" установлен флаг "Принимать данные из кадров". На закладке "Стыковки" нужно перечислить все виды больничных и отпусков, используемых на предприятии. Для автоматического заполнения журнала по больничным листам в модуле "АиТ:\Табельный учет" обязательно должна быть указана дата выдачи больничного листа в журнале "Больничные" модуля "АиТ:\Зарплата".

Внимание. Если журнал заполняется автоматически, кнопка "Создать" неактивна и добавление записей вручную невозможно!

Для добавления записей в журнал "Больничный (Б)" необходимо в модуле "АиТ:\Кадровый учет" в кадровой карточке на закладке "Больничные" в нижней части закладки установить переключатель "Переданные в З/П". Причем, в журнале будут отображаться только те больничные листы, у которых время болезни попадает в текущий месяц. Для просмотра больничных листов за другой месяц необходимо изменить текущий месяц.

Кроме того, возможна запись данных из модуля "АиТ:\Кадровый учет" в журналы и при снятом флаге "Принимать данные из кадров". Это происходит в случае, если в кадровом учете используется вид приказа "о рабочем времени", данные которого передаются в журналы.

Оформление отзыва из отпуска

Из кадровых приказов можно получать не только данные об отпусках, но и информацию об отзыве из отпуска. Для этого в модуле "АиТ:\Кадровый учет" в окне "Справочник видов приказов" для приказа об отзыве из отпуска следует установить флаг в колонке "В журн". Тогда в случае оформления отзыва из отпуска в журнале отпусков модуля "АиТ:\Табельный учет" вместо одной строки отпуска появятся две – за период до перерыва и после него, а старая строка удаляется.

Внимание. Для корректного заполнения табельного листа в случаях отзыва из отпуска и изменения дат больничного листа нужно заново оформить табельный лист, потому что, если просто разложить журналы, то старые дни отпуска или больничного не заменятся рабочим временем.


Перенос записей из журнала в табельные листы

Если сотрудник учитывается в табельном листе, использующем автоведение, то перенос записей из журнала в табельный лист происходит автоматически в момент оформления листа.

Заполнение простых табельных листов, не использующих автоведение, на основании записей в журналах производится из окна "Журналы" с использованием Мастера заполнения.

Для этого необходимо на закладке "Сотрудники" выделить в списке нужных сотрудников, перейти на закладку "Журнал" и нажать на кнопку "Мастер заполнения" TabWizardAdded дополнительной панели инструментов. При этом производится перенесение записей, отображенных на закладке "Журналы", в табельные листы.

Заполнение табельных листов ведется путем записи кода данного типа времени в каждый из дней, попавших в период.

Способ заполнения табельных листов (по рабочим, по календарным дням, по выбранному плановому графику и т. п.) определяется настройкой типа времени, по которому ведется данный журнал.

Если запись в журнале охватывает период больше месяца, то операцию заполнения табельных листов необходимо произвести отдельно для каждого месяца, входящего в период. Для этого следует изменить текущий месяц и повторить операцию заполнения табельного листа по той же записи в журнале.

Если сотрудник учитывается одновременно в двух и более равноценных табельных листах, то при попытке заполнить табельный лист по записи в журнале на экране появляется дополнительное окно с предложением выбрать (сделать его текущим) табельный лист из списка для внесения данных из журнала. Для того чтобы сделать табельный лист текущим следует щелкнуть на нем левой кнопкой мыши. В результате слева от названия листа появится символ "стрелочка" Strelka . После выбора листа нажмите на кнопку "Ок".

Если сотрудник учитывается одновременно в базовом и неосновном табельном листе (простом или автоведомом), то при заполнении табельных листов данные из журнала вносятся только в базовый лист, а в неосновном листе удаляются табельные данные за период, который охватывает запись.


Разложить все журналы

Операция "Разложить все журналы" в понятиях данного модуля означает операцию перенесение записей из всех журналов в табельные листы, что существенно автоматизирует процесс заполнения табельных листов. Для выполнения этой операции нужно выбрать пункт "Разложить все журналы" раздела "Режим" Главного меню. В том случае, если в модуле "АиТ:\Конфигурация" ограничен доступ (нет, чтение) к выполнению этой операции, то пункт "Разложить все журналы" в меню отсутствует, поэтому выполнить эту операцию невозможно.

Пункт присутствует в меню, когда в окне "Редактирование списка ролей" модуль "АиТ:\Конфигурация" в разделе "Доступ к режиму Ведение журналов" для функции "Раскладка всех журналов" установлен полный доступ.

При проведении операции можно указать, в каком порядке будут раскладываться журналы. Для этого в режиме "Типы времени" на закладке "Параметры" в поле "Сортировка" для требуемых типов времени нужно проставить порядковый номер (рис. 1). Поле "Сортировка" активно для журналируемых типов времени, т. е. для типов времени, по которым ведутся журналы. При проставленном в поле "Сортировка" значении журналы будут раскладываться согласно нумерации. Например, тип времени "Прогул" имеет порядок сортировки "1", а тип времени "Командировка" – "2". В этом случае, если в журналах "Прогул" и "Командировка" сотрудника имеются записи на одни и те же даты, то записи из журнала "Командировка" перезапишут записи из журнала "Прогул".

Рис. 1

Если поле "Сортировка" у нескольких журналируемых типов времени пустое, то сначала табельные листы заполняются из журналов с этими типами времени, а потом они будут перезаписаны типами времени с проставленным значением. Если значение одинаковое у нескольких типов времени, то при разложении они будут отсортированы между собой по краткому коду типа времени.

Операцию разложить по одному журналу можно выполнить из окна "Журналы", если на закладке "Журнал" нажать на кнопку TabWizardAdded.


Своды по журналу

Для того чтобы данные журнала стали доступны в модуле "АиТ:\Зарплата", по ним необходимо сформировать свод. Формирование свода по журналу осуществляется кнопкой "Создать новый свод" JurSvod панели инструментов из окна "Журналы". Кнопка "Создать новый свод" активна только для журналов, имеющих дополнительную закладку "Своды по журналу". Эта закладка появляется в окне "Журналы" в тех случаях. когда тип времени, по которому ведется журнал, обозначен в настройках типов времени на закладке "Стыковки" как передаваемый в модуль "АиТ:\Зарплата".

В своде по журналам суммы часов почасового типа времени отображаются в десятичном формате (с долями часа).

Обращаем внимание пользователей на тот факт, что формировать своды по журналу, который ведется по типу времени больничный лист, и передавать их в модуль" АиТ:\Зарплата" не целесообразно, т.к. при вводе больничного листа через модуль "АиТ:\Табельный учет" недостаточно данных для правильного расчета сумм больничного листа согласно Российскому законодательству.

Поэтому при передаче в модуль АиТ:\Зарплата сводов по журналу с записями по типу времени больничный лист, выдается предупреждающее сообщение (рис. 1).

Рис. 1

Пользователь, конечно, может нажать на кнопку "Да" и свод будет передан в модуль "АиТ:\Зарплата" в режим "Начисления по журналу" на закладку "Больничные", но лучше нажать на кнопку "Нет", чтобы не передавать свод в модуль "АиТ:\Зарплата".

Если данные по своду уже были переданы в модуль "АиТ:\Зарплата", то при изменении записей в журнале необходимо сформировать корректирующий свод. Для этого нужно заполнить табельный лист по измененной записи и повторить формирование свода. На закладке "Своды по журналу" появится второй свод на ту же запись. Чтобы видеть итоговую сумму по всем сводам для данной записи, в верхней части окна можно установить флаг "Суммы".

Внимание. Если по записи в журнале уже заполнен табельный лист, то при уменьшении периода записи и повторном заполнении по ней табельного листа автоматической коррекции (восстановления данных о рабочем времени) не происходит. Для корректного формирования сводов по такой записи необходимо вручную восстановить в табельном листе данные о рабочем времени в дни, исключенные из периода записи.

Если данные журнала по какой-либо причине не попали в табельный лист (например, табельный лист на сотрудника в этом месяце отсутствует), то при генерации свода по журналам выдается соответствующее предупреждение (рис. 2), и свод не формируется.

Рис. 2


Список шаблонов

Шаблоны графиков используются для заполнения плановых графиков и табельных листов. В поставку комплекса включен набор настроенных шаблонов для наиболее распространенных рабочих графиков. Если имеющихся шаблонов графиков достаточно для ведения табельного учета на предприятии, настройку шаблонов графиков желательно не менять.

Просмотр шаблонов, используемых в модуле, происходит в окне "Список шаблонов графиков" (рис. 1). Вызов окна осуществляется кнопкой "Шаблоны рабочих графиков" Panel5 основной панели инструментов, "горячими" клавишами Alt+D или из пункта "Шаблоны графиков" раздела "Режим" Главного меню.

Внимание. Кнопка "Шаблоны рабочих графиков" отображается на постоянной панели инструментов, если в окне "Настройка режимов" установлен флаг "Настройка шаблонов графиков".

В окне "Список шаблонов графиков" можно добавлять, удалять и настраивать различные шаблоны графиков, используя кнопки дополнительной панели инструментов. Если возникла необходимость добавить новый шаблон графика, воспользуйтесь кнопкой "Создать" TabAdded дополнительной панели инструментов.

Рис. 1

Окно "Список шаблонов графиков" содержит таблицу со списком используемых шаблонов. Каждый шаблон характеризуется кодом, названием, типом и продолжительностью смены. Для удобства работы название шаблона обычно совпадает с названием графика работы

Тип шаблона определяется при его создании и зависит графика работы, для формирования которого он предназначен. В модуле используется три типа шаблонов, характеризующих рабочий цикл графика работы:

· недельный – ориентирован на работу с недельными графиками. Пример: "Пятидневка (40ч)", "Пятидневка (36 ч)", "Шестидневка (40ч);
· сменный – облегчает работу со сменными графиками (с длиной цикла до 15 дней), характерными для охранных служб или производственных подразделений. Пример: "Сутки – трое", "Двое через двое по 12 часов";
· вахтовый – упрощает ввод данных по графикам, рабочий цикл которых превышает 15 дней.

Продолжительность смены, или количество часов рабочего времени в день, может быть:

· постоянная – для непрерывного производства продолжительность смены постоянна, следовательно, шаблоны графиков неизменны из года в год;
· рассчитываемая – рассчитывается каждый год, исходя из годовой нормы рабочего времени. В некоторых случаях (например, для вахт) возникает необходимость корректировать продолжительность смены согласно годовой норме рабочего времени. Для шаблонов таких графиков в колонке "Продолжительность смены" выбирается значение "Рассчитывается". При переходе на новый год такие шаблоны копируются, но данные в строке рабочего времени при этом обнуляются. Расчет продолжительности смены и автоматическое занесение ее в шаблон производится из режима плановых графиков.

В нижней части окна "Список шаблонов графиков" расположены поля поиска в списке нужного шаблона по коду и названию. Список шаблонов можно сортировать, дважды щелкнув мышью на заголовке колонки, выбранной в качестве критерия для сортировки.


Создание нового шаблона

Добавление нового шаблона планового графика в список шаблонов осуществляется кнопкой "Создать" TabAdded дополнительной панели инструментов из окна со списком шаблонов. Предварительно открывается дополнительное окно "Новый шаблон графика" (рис. 1).

Рис .1

В этом окне для создаваемого шаблона укажите его характеристики:

· код – код шаблона может содержать от одного до пяти символов в соответствии с принятой на предприятии системой документооборота;
· название – наименование, характеризующее назначение шаблона;
· тип шаблона – тип создаваемого шаблона задается путем выбора нужного переключателя "Недельный", "Сменный" или "Вахтовый".

Закрытие окна с сохранением всех введенных параметров нового шаблона выполняется кнопкой "Создать". При этом созданный шаблон добавляется в список шаблонов и становится текущим, т.е. слева от его названия находится символ "стрелочка" Strelka. Далее в колонке "Продолжительность смены" выберите нужное значение, соответствующее его типу и назначению. Каждый созданный пользователем шаблон необходимо настроить.


Настройка шаблона

Настройка созданных шаблонов выполняется в окне настройки шаблона графика (рис. 1). Вызов окна производится из списка шаблонов кнопкой "Открыть" SotrParam дополнительной панели инструментов или двойным щелчком левой кнопки мыши по нужному шаблону. Настройка выполняется для текущего в списке шаблона.

Внешний вид окна настройки зависит от типа выбранного шаблона, но в каждом окне отображается основной цикл графика в виде последовательности дней. Для недельного шаблона (рис. 1) количество дней цикла постоянно, для остальных типов – переменно (рис. 2) и (рис. 3) и определяется самим пользователем.

Рис. 1

В каждом дне цикла можно указать время работы в формате ЧЧ:ММ, краткое обозначение любого типа времени, учитываемого в днях (командировка и др.), или обозначить день как выходной, записав в него заглавную русскую букву "В".

Для добавления в шаблон типов времени, учитываемых в днях и часах (ночное время, сверхурочные и проч.), нажмите на кнопку "Установить параметры" TabParam дополнительной панели инструментов, в окне "Отображаемые типы времени" (рис. 2) для каждого добавляемого типа времени установите флаг в колонке "Отображать" и нажмите на кнопку "Ок". После этого в окне "Настройка шаблона" появятся новые строки с типами времени, их количества соответствует количеству установленных флагов.

Рис. 2

Удаление ненужных типов времени из шаблона, например, сменного (рис. 3) или вахтового типа (рис. 4) также осуществляется в окне "Отображаемые типы времени" (рис. 2) путем снятия флагов для ненужного типа времени. После нажатия на кнопку "Ок" строки с типами времени, у которых был снят флаг, удаляются из настроек шаблона. Для сохранения сделанных изменений нажмите на кнопку "Сохранить" Save.

Шаблон типа "Недельный"

Рабочим циклом шаблона является неделя. Окно позволяет указать время работы в каждый рабочий день недели в формате ЧЧ:ММ. В выходные дни следует записать заглавную русскую букву "В". Недельный шаблон приведен на рис. 1.

Шаблон типа "Сменный"

Для настройки шаблона типа "Сменный" (рис. 3) необходимо указать количество дней в цикле (например, 4), а в клетки дней внести рабочее время (в формате "ЧЧ:ММ") или букву, соответствующую типу времени, учитываемому в днях.

Рис. 3

Шаблон типа "Вахтовый"

Настройка шаблона начинается с задания количества групп дней в цикле шаблона (рис. 4) в поле ввода в верхней части окна. Число дней в группе указывается в таблице в правой части окна.

Рис. 4

В шаблоне типа "Вахтовый" (рис. 4) используется два типа времени "Рабочее время" и "Ночное время". Ночное время по ТК РФ продолжается с 22:00 часов вечера до 6:00 часов утра.

Ниже приведена таблица, в которую вводится описание рабочего времени для каждой группы дней. Например, если одна из клеток обозначена как "Выходной", то все дни в этой группе являются выходными.

На рис. 4 настроен шаблон для следующего графика:

День | Приход | Уход
1-5 | 8:00 | 20:00
6, 7 | Выходной
8-12 | 20:00 | 8:00
13, 14 | Выходной

Ночное время по ТК РФ продолжается с 22:00 до 6:00.


Плановые графики

Плановые графики содержат стандартные графики работ и служат для задания планового количества рабочих дней и часов по месяцам года. В плановых графиках определяется плановое количество табельного времени на каждую конкретную календарную дату.

Плановые графики вводятся и детализируются в модуле "АиТ:\Табельный учет", а затем используются в модуле "АиТ:\Зарплата" для расчета зарплаты.

В модуле можно использовать различные виды плановых графиков не только для сотрудников, работающих по сменным графикам, в том числе и графикам вахтового типа, но также и для сотрудников предприятий, работающих в режиме пятидневной, шестидневной рабочей недели или без выходных. Для каждого такого режима используется отдельный вид графика.

В поставку программного комплекса включены плановые графики "Пятидневка (40ч)", "Пятидневка (36ч)", "Шестидневка (40ч)", обеспечивающие заполнение табельных листов в соответствии с требованиями ТК РФ и автоматический перенос праздников, попадающих на выходные.

Каждому сотруднику можно поставить в соответствие определенный плановый график, отражаемый в окне "Параметры сотрудников предприятия". Тогда табельные листы можно заполнять сразу по всем сотрудникам. Для этого при заполнении табельного листа с помощью Мастера заполнения нужно в окне "Заполнение" выбрать переключатель "Разложить плановый график из личной карточки". Это дает экономию времени при заполнении табельных листов 15 – 20 %.

Режим плановых графиков позволяет автоматически учитывать праздничные дни, а также различные дополнительные изменения, например, санитарный день, профилактику и пр. Такие изменения вносятся единожды в плановый график и в табельные листы для всех сотрудников, работающих по этому графику.

Кроме того, режим позволяет рассчитать плановое количество табельного времени за любой интересующий период, кратный месяцу, а также привести годовую сумму планового времени любого графика к законодательно определенной норме.


Список плановых графиков

Список плановых графиков следует заполнить сразу же после установки программного комплекса. Для проведения этой операции следует ознакомиться с инструкцией по подключению плановых графиков.

Работа с плановыми графиками происходит в окне "Список плановых графиков" (рис. 1). Это окно вызывается кнопкой "Список плановых графиков" Panel6 основной панели инструментов или из пункта "Плановые графики" раздела "Режим" Главного меню, а также "горячими" клавишами Alt+P.

Для работы с плановыми графиками используются кнопки, расположенные на дополнительной панели инструментов, их назначение описано в отдельной теме.

Настройка доступа к списку плановых графиков

В версиях "Проф" и "Холдинг" доступ конкретного пользователя модуля к режиму "Список плановых графиков" зависит от настройки прав доступа к режиму. Права доступа (полный, чтение, нет) задает системный администратор в модуле "АиТ:\Конфигурация" в окне "Редактирование списка ролей" в разделе "Настройка плановых графиков" в строке "Доступ к режиму Настройка плановых графиков".

Для базовой версии доступ к режимам плановых графиков осуществляется в окне "Настройка режимов".

Закладка "Итоги"

В левой части окна после подключения приводится список всех плановых графиков, используемых в модуле. При установке курсора на любой плановый график в правой части окна на закладке "Итоги" показываются соответствующие суммарные данные по плановым дням и часам (в десятичном формате с долями часа) за каждый месяц текущего года. Текущий год и месяц устанавливается в модуле в окне "Текущий месяц". Эти данные используются в модуле "АиТ:\Зарплата" при расчетах.

Рис. 1

При необходимости можно изменить количество дней (часов) в выбранном месяце для текущего в списке планового графика. Эта операция выполняется в окне "Краткая раскладка планового графика", которое открывается двойным щелчком левой клавиши мыши на строке нужного месяца текущего графика.

Закладка "Поиск/Фильтр"

Видимость закладки "Поиск/Фильтр" определяется правами доступа, заданными в модуле "АиТ:\Конфигурация" для роли, под которой пользователь входит в модуль. Закладка не показывается в окне (рис. 1), если в модуле "АиТ:\Конфигурация" в режиме "Редактирование списка ролей" в разделе "Настройка плановых графиков" для функции "Расширенные параметры графиков" задать значение "Нет". Для остальных прав доступа (полный доступ или доступ на чтение) закладка "Поиск/Фильтр" отображается в окне (рис. 2).

Рис. 2.

Закладка "Поиск/Фильтр" позволяет:

· произвести поиск нужного графика по коду или названию;
· отобрать по определенным критериям часть графиков для просмотра, заполнения, балансировки, печати и других операций.

Для отбора группы графиков необходимо в блоке "Фильтр списка графиков" установить флаги слева от нужных условий и выбрать конкретные значения этих условий из выпадающих списков, после чего нажать на кнопку "Поставить фильтр" Filtr. Отменить действие фильтра можно кнопкой "Снять фильтр" Panel9.

Свойства графиков, которые служат основанием для отбора шаблона, стартовых дней, активных графиков, настраиваются в окне "Настройки графика", вызываемом кнопкой "Параметры" TabParam из этого окна.

Если флаг "Только активные графики" установлен, то в списке графиков показываются только активные графики, которые доступны и могут использоваться в модулях "АиТ:\Кадровый учет" и "АиТ:\Зарплата" в справочнике плановых графиков. При снятом флаге отображаются все графики, имеющиеся в базе данных программного комплекса.


Активные и неактивные плановые графики

Плановые графики могут находиться в двух состояниях: активном или деактивированном (неактивном). Активными называются графики, которые используются в программном комплексе "АиТ:\Управление персоналом", деактивированные (неактивные) графики в программном комплексе не используются и не отображаются в списке плановых графиков.

В процессе работы с модулем в списке плановых графиков могут находиться графики, не используемые в программном комплексе "АиТ:\Управление персоналом". При больших списках плановых графиков неиспользуемые графики целесообразно перевести в статус деактивированных, чтобы уменьшить размер списка и сделать его более обозримым.

Чтобы активный график стал деактивированным, следует выделить его в списке и нажать на кнопку "Деактивировать" GrafDeactiv и подтвердить свои действия в дополнительном окне, нажав на кнопку "ОК".

Внимание. Деактивированные графики будут недоступны в справочнике плановых графиков в модулях "АиТ:\Кадровый учет" и "АиТ:\Зарплата". Деактивированные графики также не отображаются в окне "Детализация графиков", которое открывается кнопкой TabDetal из списка плановых графиков.

Переход графика из деактивированного состояния в активное также осуществляется кнопкой "Деактивировать" GrafDeactiv. Перед нажатием на эту кнопку необходимо выполнить следующие действия, которые зависят от прав доступа к закладке "Поиск/Фильтр" в списке плановых графиков:

· доступ отсутствует – чтобы сделать видимым график, который был деактивирован, нужно закрыть окно со списком графиков. После этого опять открыть окно и график появится в списке. Далее выделить деактивированный график и нажать на кнопку "Деактивировать", график станет активным, и его снова можно будет использовать в модуле;
· разрешен доступ на чтение – поэтому закладка "Поиск/Фильтр" доступна в списке, следует перейти на эту закладку, снять флаг "Только активные графики", нажать на кнопку Filtr, чтобы в списке отображались все графики, в том числе и деактивированные графики. Можно также установить фильтр, например, по названию графика, как показано на рис. 1 и нажать на кнопку Filtr .

Рис. 1

В результате список станет намного меньше и в нем легко увидеть нужный не активный график, на рис. 2 – это график с названием "12ти ч. 4х дневный IV". Такие графики в списке отображаются цветом морской волны, а активные графики – черным цветом. Далее следует выделить нужный график (графики) и нажать на кнопку "Деактивировать". Появляется сообщение с вопросом (рис. 2).

Рис. 2

Если пользователь ответил положительно, нажав на кнопку "ОК", то неактивный график становится активным, и появляется в списке плановых графиков. Для того чтобы увидеть график в списке нужно закрыть окно (рис. 1), и снова открыть его, кнопкой Panel6 .

· полный доступ – выполняются те же действия, что и при доступе на чтение.


Кнопки для работы с плановыми графиками

Для работы с плановыми графиками используются кнопки, расположенные на дополнительной панели инструментов в окне "Список плановых графиков".

Кнопки "Поставить фильтр" и "Снять фильтр" отображаются на панели, если настроена видимость закладки "Поиск/Фильтр".

Название кнопки |  | Исходные данные, действия и функции
Копировать текущую запись | GrafCopy | Копировать текущий плановый график (со всеми параметрами и детализацией).
Поставить фильтр | Filtr | Фильтрация списка плановых графиков в соответствии с условиями, настроенными на закладке "Поиск/Фильтр"
Снять фильтр | Panel9 | Снятие установленного ранее фильтра на закладке "Поиск/Фильтр"
Перечень общегосударственных праздников | GrafHoliday | Список общегосударственных праздников, которые автоматически учитываются в поставляемых плановых графиках. Список может быть изменен и дополнен.
Балансировка планового графика | GrafBalans | Вызов окна балансировки планового графика
Деактивировать | GrafDeactiv | Кнопка позволяет перевести график из активного состояния в деактивированное состояние и наоборот. Действия этой кнопки зависит от прав доступа к закладке "Поиск/Фильтр". Более подробные сведения приведены в теме "Активные и неактивные графики".
Перерасчет плановых графиков на год | GrafRecalc | Автоматическое заполнение плановых графиков и расчет итогов по выделенным в списке плановым графикам на текущий год.
Установить параметры | TabParam | Вызов окна настройки параметров планового графика.
Детализация по дням | TabDetal | Вызов окна детализации всех плановых графиков по дням текущего месяца.
Промежуточные итоги | TabItog | Расчет итогов по всем плановым графикам за текущий месяц.
Печать отчета | Print | Формирование отчетов по плановым графикам.
Закрыть текущее окно | TabDoor | Закрыть текущее окно с сохранением данных


Общегосударственные праздники

Плановые графики заполняются с учетом отмечаемых ежегодных праздников, которые перечисляются в списке ежегодных праздников. В рамках настоящего программного комплекса к ежегодным повторяющимся праздникам (нерабочим дням) относятся как общегосударственные праздники, так и любые другие местные праздники, на усмотрение администрации предприятия.

Формирование единого для всех сотрудников предприятия списка ежегодных праздничных дней происходит в окне "Список ежегодных праздников" (рис. 1), который открывается из списка плановых графиков кнопкой GrafHoliday , клавишами Ctrl+H или из пункта "Праздники" раздела "Карточка" Главного меню.

Рис. 1

Информация по каждому празднику приводится на отдельной строке. Каждая строка содержит название, день и месяц праздника, которые можно редактировать.

Внимание. В случае корректировки списка праздников эти изменения отразятся в справочнике праздничных дней модуля "АиТ:\Зарплата".

Добавление нового праздника в список производится кнопкой "Добавить" TabAdded . Далее в новой строке нужно указать дату и название добавляемого праздника. Уникальность даты праздника в списке при этом проверяется автоматически.


Краткая раскладка планового графика

При необходимости в окне "Краткая раскладка планового графика" (рис. 1) можно изменить количество дней (часов) любого планового графика для выбранного пользователем месяца текущего года.

Рис. 1

Вызов окна (рис. 1) осуществляется из списка плановых графиков (рис. 2). Для этого в левой части окна следует выбрать нужный плановый график, а в правой части дважды щелкнуть левой клавишей мыши на названии месяца, в котором требуется внести изменения.

Рис. 2

В верхней части окна "Краткая раскладка планового графика" (рис. 1) приводится следующая информация:

· код и наименование графика;
· общее количество рабочих дней и часов, соответствующее заполненному календарю. Если календарь не заполнен, количество рабочих часов и дней равно нулю;
· месяц, за который рассчитываются плановые рабочие дни и часы. По умолчанию в поле "Месяц" указывается месяц, выбранный в момент открытия в левой части окна со списком плановых графиков. При необходимости месяц можно изменить, используя выпадающий список, который открывается кнопкой list .

В средней части окна расположен календарь выбранного месяца с перечислением всех дней этого месяца. Для каждого дня предусмотрено отдельное поле для ввода рабочего времени и выходных дней. Ввод часов рабочего времени производится в соответствующие поля вручную в формате ЧЧ:ММ (например, 8:15), а итоговая сумма рабочих часов за месяц рассчитывается в десятичном формате (с долями часа). При увеличении или уменьшении рабочих или выходных дней автоматически изменяются итоги за месяц.

Внимание. Если в колонку требуется ввести время в минутах, то сначала необходимо увеличить размер этой колонки. В итогах за месяц рабочее время указывается в целых днях и в часах в цифровом формате, т.е. указанные в календаре минуты преобразуются в часы в виде числа с десятичной дробью. Например, рабочее время 8 часов 30 минут будет показано как 8.5 часов.

Для отображения в календаре выходных и праздничных дней необходимо установить флаг "Выходные" и нажать на кнопку "Установить". В этом случае выходные и праздничные дни в календаре будут окрашены в красный цвет и помечены буквой "В".

Если требуется установить самостоятельно выходной день, введите с клавиатуры заглавную букву "В" и нажмите клавишу Tab. В результате курсор переместится на следующий день, а предыдущее поле окрасится в красный цвет.

Внимание. Праздники в календаре устанавливаются в соответствии с заполнением справочника праздничных дней.

Окно краткой раскладки открывается для текущего в списке месяца, но если требуется откорректировать данные за другой период, в верхней части окна можно установить нужный месяц.

Флаг "Выходные" в блоке "Субботы, воскресенья и праздники" устанавливается для каждого месяца отдельно. Чтобы расставить выходные в краткой раскладке, надо установить вышеназванный флаг, а затем нажать на кнопку "Установить".

Флаг "Выходные" можно использовать в том случае, если по каким-либо причинам возможности настройки параметров и автозаполнения плановых графиков не используются, т.е. пользователь заполняет плановые графики на каждый месяц вручную через краткую раскладку. Если используется набор корректно настроенных плановых графиков (автоматически заполняющихся в соответствии с настроенными шаблонами и при необходимости учитывающих праздничные дни), флаг устанавливать не нужно.


Добавление нового планового графика

Добавление нового планового графика в список

Добавление нового графика производится из окна список плановых графиков кнопкой "Создать" TabAdded дополнительной панели инструментов или из одноименного пункта раздела "Карточка" Главного меню. При этом на экране появляется окно (рис. 1) для ввода обязательного уникального кода, содержащего не более 31 символа, и названия нового графика. Название графика целесообразно задавать интуитивно понятным, чтобы в списке легко было идентифицировать плановые графики.

Рис. 1.

После корректного заполнения этих полей и нажатия на кнопку "Ок" наименование нового графика появляется в списке плановых графиков. При необходимости название графика можно изменить, дважды щелкнув мышью, чтобы сделать его доступным для редактирования.

Кроме того, добавить новый график можно, скопировав любой имеющийся в списке плановый график. Для этого следует установить курсор на имени графика, который надо скопировать, и нажать на кнопку "Копировать текущую запись" GrafCopy дополнительной панели инструментов или выбрать пункт "Копировать" раздела "Карточка" Главного меню. На экране появится окно для ввода кода и названия нового графика (рис. 1). После ввода наименования новый график появится в списке, причем все его параметры будут заполнены и идентичны параметрам графика-образца.

Заполнение планового графика на весь год

Каждый новый плановый график, который добавляется в список кнопкой "Создать", появляется в списке плановых графиков, но для него на правой панели "Итого" в колонках "Дни" и "Часы" указываются нулевые значения. Для заполнения планового графика по каждому месяцу текущего года необходимо выполнить следующие операции:

1. Создать шаблон для нового планового графика. Для этого открыть список шаблонов кнопкой Panel5 основной панели инструментов и нажать на кнопку TabAdded. Далее в окне "Новый шаблон графика" указать характеристики шаблона, который будет использоваться для настройки нового планового графика. После закрытия окна с сохранением созданный шаблон добавляется в список шаблонов и становится текущим, т.е. слева от его названия находится символ "стрелочка" Strelka. Далее в колонке "Продолжительность смены" выберите нужное значение, соответствующее его типу и назначению.

2. Настроить шаблон графика. В окне список шаблонов нажать на кнопку "Открыть" SotrParam дополнительной панели инструментов. Открывается окна "Настройка шаблона", настройка шаблона зависит от типа выбранного шаблона (недельный, сменный, вахтовый).

3. Настроить плановый график. Для настройки графика работы откройте окно "Настройки графика" кнопкой TabParam из списка плановых графиков и заполните параметры планового графика так, как рекомендуется в теме "Настройка параметров планового графика". Обязательно в поле "Шаблон" укажите имя нового шаблона (см. пункт 1), на основании которого заполняется данный график.

4. Заполнить новый плановый график на весь год. Для заполнения нового графика на весь календарный год его необходимо выделить в списке плановых графиков и нажать на кнопку GrafRecalc. Если все настройки были выполнены правильно, то для всех месяцев будут заполнены колонки "Дни" и "Часы" и подведены итоги. После этого плановый график может использоваться для заполнения табельных листов для тех сотрудников, у которых в карточке сотрудника в модуле "АиТ:\Кадровый учет" на закладке "Работа" в поле "График" будет указан этот плановый график работы.

Если новый график не заполнен, то следует проверить настройки шаблона (см. пункт 2) и планового графика (см. пункт 3).

Внимание. Заполнение планового графика на текущий месяц производится в окне "Детализация плановых графиков".


Настройка параметров планового графика

Настройки плановых графиков, перечисленных в списке плановых графиков, выполняются в окне "Настройки графика" (рис. 1). Окно вызывается из списка плановых графиков кнопкой "Параметры" TabParam дополнительной панели инструментов, из пункта "Параметры" раздела "Карточка" Главного меню или "горячими" клавишами Ctrl+P. Окно "Настройки графика" содержит три закладки (рис. 1), в заголовке окна отображается название графика, который был выделен в списке плановых графиков.

Рис. 1

Настройка параметров на закладке "Общие"

В блоке "Праздники" на закладке "Общие" в зависимости от выбранного переключателя при заполнении планового графика праздничные дни:

· Не учитываются – выбран первый переключатель, праздничные дни не учитываются.
· Считаются выходными – при выборе третьего переключателя в блоке "Праздники" дополнительно появляется флаг "Предпраздничные дни сокращаются" и поле "Праздники, попавшие на выходные" (рис. 1). При установке флага рабочее время в предпраздничные дни сокращается на 1 час. Дополнительное поле предназначено для настройки переноса праздников, попадающих на выходные дни. Ввод в поле производится из выпадающего списка (рис. 2). Если выбрано первое значение, праздники не переносятся. При выборе второго значения праздники будут переноситься только с воскресенья, например, для шестидневной рабочей недели. При выборе третьего значения будут переноситься с субботы и воскресенья, например, для пятидневной рабочей недели.

Рис. 2

· Учитываются особо – третий переключатель выбирается для сменных и вахтовых графиков, когда праздники не являются выходными, но работа в праздничные дни оплачивается дополнительно. В этом случае необходимо ввести специальный тип времени для учета работы в праздники и в настройках планового графика выбрать его из выпадающего списка.

В блоке "Автозаполнение" располагаются настройки, определяющие заполнение планового графика с использованием функции "Перерасчет плановых графиков". Если установлен флаг "Использовать шаблон по умолчанию", в рамке появляется поле с выпадающим списком всех шаблонов, имеющихся в модуле. Для шаблона сменного или вахтового типа необходимо указать стартовый день.

Окно (рис. 3) для указания стартового дня открывается кнопкой "Стартовые дни". Стартовым днем называется календарная дата, которой соответствует первый день выбранного шаблона графика. Каждый график может иметь бесконечное количество стартовых дней. Когда заполняемая календарная дата совпадает с очередным стартовым днем, раскладка шаблона графика начинается с первого дня цикла. Это можно использовать при наличии на предприятии майских и рождественских каникул или сложных многодневных вахтовых графиков.

Рис. 3

Чтобы добавить стартовый день, нужно нажать на кнопку "Создать" TabAdded панели инструментов. В окне появится новая строка, где можно установить нужную дату.

Для автоматического заполнения графика по шаблону необходимо установить флаг "Флаг несбалансированности графика". Если флаг снят, то данный график автоматически рассчитываться не будет.

В поле "Нормативный график" из выпадающего списка выбирается служебный график, годовая сумма часов которого должна использоваться в качестве нормы рабочего времени для данного графика. Если балансировка графика производиться не будет, в этом поле ничего указывать не нужно.

В поле "Коэффициент рабочего времени" указывается средняя продолжительность рабочего дня (число рабочих часов в неделе / число рабочих дней в неделе). Это значение используется для расчета средней численности неполностью занятых работников. Если для данного графика указан нормативный, то в это поле копируется коэффициент нормативного графика. Если нормативный график не указан, значение в поле вводится вручную.

При установке флага "Одинаковые параметры во всех месяцах" параметры настройки планового графика, введенные в текущем месяце, распространяются на все время использования графика. Установка этого флага эквивалентна действию функции "Распространить общие настройки", которая вызывается из одноименного пункта раздела "Карточка" Главного меню или по комбинации "горячих" клавиш Ctrl+F.

Флаг "Неполное рабочее время для среднесписочной" устанавливается для графиков сотрудников, оплата которых учитывается пропорционально отработанному времени, и лиц, работающих неполное рабочее время в соответствии с трудовым договором.

Флаг "Стандартный график" устанавливается в тех случаях, когда настройка параметров выполняется для графика с неполным рабочим днем.

Настройка параметров на закладке "Типы времени"

На второй закладке "Типы времени" окна "Настройки графика" в колонке "Отображать" следует установить флаги для типов времени, которые будут учитываться в плановом графике.

Внимание. При наличии в шаблоне, по которому заполняется плановый график, нескольких почасовых типов времени (ночное время, работа в праздничные дни и т. д.) в плановый график будут внесены только учитываемые в нем типы.

Настройка параметров на закладке "Дополнительные"

На закладке "Дополнительные" для данного планового графика можно установить флаг "График активен". Флаг нужен для того, чтобы отметить графики, которые используются в работе других модулей комплекса. Неактивные плановые графики хранятся в базе данных, но не видны в других модулях комплекса.

В поле "Свободный комментарий" можно вводить произвольный комментарий к данному графику длиной до 255 символов.

Видимость закладки "Дополнительные" для данной роли настраивается в режиме "Редактирование списка ролей" модуля "АиТ:\Конфигурация" (объект "Настройка плановых графиков \ Расширенные параметры графиков").

Введенные настройки планового графика будут автоматически сохраняться из месяца в месяц. В любом текущем месяце пользователь может изменить настройки по своему усмотрению, т. е. в принципе плановый график может иметь в каждом месяце свои настройки.


Детализация плановых графиков

Для заполнения ежедневного планового времени за текущий месяц используется окно "Детализация графиков" (рис. 1). В отличие от краткой раскладки, режим позволяет работать сразу со всем списком (или произвольной выборкой) плановых графиков и учитывать плановое время по дополнительным типам времени (например, ночное, работа в праздники и пр.). Кроме того, в окне детализации доступна функция Мастера заполнения плановых графиков.

Окно детализации вызывается кнопкой "Детализация по дням" TabDetal панели инструментов или выбором одноименного пункта раздела "Вид" Главного меню, а также "горячими" клавишами Ctrl+T. В окне приводится подробная раскладка всех имеющихся в неактивных плановых графиков по дням месяца, который установлен в модуле как текущий месяц. Для того чтобы увидеть детализацию плановых графиков за любой другой месяц, необходимо установить его как текущий месяц.

Рис. 1

Структура окна "Детализация графиков" подобна структуре табельного листа. В левой части окна расположен список всех плановых графиков, имеющихся в модуле. Дополнительные почасовые типы времени, которые учитываются в каждом плановом графике, выводятся отдельными строками. Справа для каждого графика приведены конкретные значения ежедневного табельного времени.

В строку, соответствующую рабочему времени, можно ввести:

· фактически отработанное за день время почасового типа в формате ЧЧ:ММ (например, 8:15);
· обозначение выходного дня в виде русской заглавной буквы "В";
· краткое обозначение любого типа времени, учитываемого в днях (профилактика, санитарный день и пр.).

Вводить значения в плановый график можно как вручную, так и с помощью Мастера заполнения.


Мастер заполнения плановых графиков

Заполнять плановые графики по всем дням текущего месяца можно вручную или автоматически с помощью Мастера заполнения из окна "Детализация графиков". В этом окне можно заполнить один (текущий), несколько или все выделенные плановые графики. Выделение всех графиков списка производится кнопкой TabSelect дополнительной панели инструментов, а одного графика – двойным щелчком левой клавиши мыши по наименованию графика в списке.

Вызов Мастера (рис. 1) происходит из окна "Детализация графика" одним из следующих способов:

· кнопкой "Мастер заполнения" TabWizardAdded дополнительной панели инструментов;
· "горячими" клавишами Ctrl+F;
· из пункта "Заполнить" раздела "Карточка" Главного меню.

Рис. 1

В поле "Дни месяца" указываются дни, в которые будет производиться запись данных для выделенных графиков. При перечислении дней следует пользоваться тире и запятой.

При установке флага "Записывать данные только в рабочие дни" запись будет производиться только в те дни указанного диапазона, которые не отмечены как выходные, т.е. не содержат букву "В".

Для заполнения планового графика в блоке "Заполнить типом времени" нужно выбрать один из перечисленных переключателей, определяющих те данные, которые будут вноситься в плановый график:

· Учитываемым в днях – используется для ввода краткого обозначения типа времени, учитываемого в днях и заданного в дополнительном поле "Тип времени". Ввод в поле производится из выпадающего списка;
· Учитываемым в днях и часах – используется для ввода типа времени (рабочее время) в формате ЧЧ:ММ. После выбора этого переключателя в окне (рис. 1) становятся видимыми два поля Тип времени" для выбора типа времени и "Значение" для ввода времени в формате ЧЧ:ММ, которое будет внесено в каждый из рабочих дней планового графика;
· Разложить шаблон графика, определенного по умолчанию – данный способ используется для заполнения планового графика по шаблону, заданному по умолчанию в окне "Настройки графика". Плановый график заполняется совокупностью нескольких типов времени, заданных в шаблоне.
· Разложить шаблон графика – данный способ предназначен для ввода типов времени, заданных в произвольном шаблоне, который указан в поле "Шаблон графика". Если выбранный шаблон не является недельным, то появляется поле "Стартовый день". В этом поле нужно указать номер дня цикла шаблона, с которого начинается раскладка шаблона графика.

После окончания настройки нужно нажать на кнопку "Заполнить" для выполнения процедуры заполнения графиков.


Автоматическое заполнение плановых графиков

Операция раскладки плановых графиков на весь год и расчета плановых сумм дней/часов за периоды производится в режиме "Список плановых графиков".

Рекомендуется следующая последовательность работы:

· выделить и заполнить все служебные графики, коды которых начинаются на "C";
· сбалансировать служебные графики, чтобы привести годовые суммы часов в соответствие с утвержденной нормой;
· выделить и заполнить остальные графики. Нужные графики в списке можно выделить по правой кнопке мыши или отобрать с помощью закладки "Поиск/Фильтр".

Для автоматического заполнения плановых графиков нажмите на кнопку "Перерасчет плановых графиков на год" GrafRecalc. При этом на экран выдается запрос (рис. 1) на подтверждение перерасчета плановых графиков.

Рис. 1

Перерасчет начинается после нажатия на кнопку "Да", на экран выдается процент выполнения расчета (рис. 2).

Рис. 2

После окончания операции перерасчета (100% выполнения) появляется сообщение (рис. 3) об успешном завершении перерасчета.

Рис. 3

Предупреждение о несбалансированности служебных графиков

Если служебные графики не были сбалансированы перед расчетом остальных плановых графиков, выдается список несбалансированных графиков (рис. 4) и предлагается продолжить перерасчет, нажав на кнопку "ОК", или остановить процесс.

Рис. 4

Кнопка "Отмена" позволяет прервать процесс перерасчета и сбалансировать все служебные графики согласно рекомендуемой технологии работы. Для продолжения перерасчета графиков нажмите на кнопку "ОК", причем несбалансированные служебные графики будут рассчитаны первыми. При этом следует помнить, что полученные при расчете годовые суммы часов служебных графиков могут отличаться от утвержденных по производственному календарю, поэтому производить расчет остальных графиков по несбалансированным служебным графикам нецелесообразно.

Внимание. Если до начала расчета в списке не выделен ни один график, сначала будут рассчитаны только служебные графики; если же они были сбалансированы ранее, то производится заполнение всех несбалансированных плановых графиков.

Проверка на наличие нормативного графика

Перед началом заполнения проверяются все графики с рассчитываемой продолжительностью смены на наличие нормативного графика. Если он не задан, выдается предупреждение, содержащее список таких графиков. По кнопке "Отмена" можно прервать процесс заполнения и указать нормативные графики, по кнопке "ОК" расчет продолжается, однако для перечисленных в сообщении графиков он выполняться не будет.

Алгоритм заполнения

Заполнение графиков с постоянной продолжительностью смены происходит по шаблону, который был скопирован на новый год в неизменном виде.

Для графиков с рассчитываемой сменой продолжительность смены в новом году неизвестна, строка рабочего времени в шаблонах обнулена, поэтому процесс заполнения таких графиков проходит следующие этапы:

· производится раскладка планового графика на новый год по шаблону прошлого года;
· рассчитывается годовое количество рабочих дней для этого графика;
· годовая сумма часов графика балансировки делится на годовое количество рабочих дней данного графика с округлением до 0,1. Это и есть новая продолжительность смены для данного графика;
· вычисленная продолжительность смены заносится в шаблон графика;
· по новому шаблону происходит окончательное заполнение планового графика на весь год и расчет сумм дней/часов. При этом годовая сумма часов планового графика может немного отличаться от нормативной за счет округления при расчете продолжительности смены.

Повторимся, весь процесс заполнения выделенных графиков проводится автоматически в режиме "Список плановых графиков" кнопкой "Перерасчет плановых графиков на год" GrafRecalc. После окончания заполнения плановых графиков можно переходить к их балансировке.


Итоги по плановым графикам

В окне "Список плановых графиков" для каждого настроенного графика можно видеть ежемесячные суммы дней и часов, но это данные только по рабочему времени.

Внимание. Заполнить ежемесячные данные по плановым дням и часам в окне "Список плановых графиков" для графика, не подлежащего автозаполнению, можно, только рассчитав итоги по плановым графикам.

Кроме того, в окне итогов можно увидеть ежемесячные итоговые суммы по всем типам времени.

Окно "Итоги по плановым графикам за месяц" (рис. 1) вызывается кнопкой "Промежуточные итоги" TabItog дополнительной панели инструментов или из одноименного пункта раздела "Вид" Главного меню, а также "горячими" клавишами Ctrl+C.

Рис. 1

В окне приводятся итоговые суммы за текущий месяц по всем имеющимся в модуле плановым графикам и всем типам времени, учитываемым в них. Эти данные приводятся в десятичном формате (с долями часа). Чтобы увидеть итоги за другой месяц, необходимо сменить текущий месяц.

Можно откорректировать данные планового графика, не закрывая окно итогов, и пересчитать итоговые суммы по кнопке "Рассчитать результат" TabCalk дополнительной панели инструментов.

Если модуль используется в режиме ручного ввода итоговых данных, т.е. в настройках модуля "АиТ:\Табельный учет" снят флаг "Автоматически перерассчитывать своды по табельным листам", то кнопка "Рассчитать результат" TabCalk при отключенном флаге служит также для пересчета итогов по тем плановым графикам, по которым ведется детализация.


Балансировка планового графика

Режим балансировки позволяет привести годовую или квартальную выработку по сменным графикам в соответствие с нормой выработки по графику 40-(36-ти, 24-х) часовой рабочей недели.

С точки зрения технологии балансировки плановые графики можно разделить на две группы:

· с неизменяемой продолжительностью смены (балансируемые по дням) – непрерывные производства;
· с рассчитываемой продолжительностью смены (балансируемые по часам).

Для первой группы графиков балансировка производится за счет изменения количества выходных дней, для второй группы – за счет изменения продолжительности рабочей смены.

Балансировка плановых графиков производится в окне "Балансировка планового графика" (рис. 1), вызываемом по одноименной кнопке GrafBalans дополнительной панели инструментов режима "Список плановых графиков", или из пункта "Балансировка графика" раздела "Вид" Главного меню, а также "горячими" клавишами Ctrl+B. Окно открывается для текущего в списке планового графика.

Рис. 1

В блоке "Нормативный график" отображается график балансировки, установленный в окне настроек планового графика.

В окне представлены суммы дней и часов для нормативного и балансируемого графика помесячно, поквартально, за полугодия и за год. Данные отображаются за установленный в модуле текущий год.

По этим данным автоматически рассчитываются следующие значения:

· Отклонение суммы часов балансируемого графика от базового графика за указанные выше периоды.
· Рекомендуемая средняя продолжительность смены за год; определяется делением суммарного количества часов нормативного графика на суммарное количество дней балансируемого графика за год.
· Рекомендуемое количество выходных (дополнительных рабочих) дней за год; определяется делением суммарной переработки за год на среднюю продолжительность смены.

Продолжительность смены берется из шаблона графика.

В блоке "Превышение балансируемым графиком часовой выработки нормативного графика" можно выбрать любой месяц установкой флага. При этом в нижней части окна отобразится детализация балансируемого планового графика по дням этого месяца.

В детализацию балансируемого графика за выбранный месяц можно вносить изменения (вручную и с помощью Мастера заполнения), при этом автоматически пересчитывается отклонение от нормативного графика за этот месяц и суммарные отклонения за периоды. Таким образом, годовую сумму часов текущего графика можно привести в соответствие с нормой; при этом в окне выдается запись "График сбалансирован".

Внесенные изменения можно сохранить по кнопке "Сохранить изменения" Save дополнительной панели инструментов. Если в этот момент годовая сумма часов балансируемого графика совпадает с нормативной, то для него автоматически снимается флаг "Флаг несбалансированности графика" и его наименование в списке плановых графиков становится серым.

Сбалансированные графики автоматически исключаются из списка выделенных при перерасчете плановых графиков на год.

Балансировка графиков с рассчитываемой сменой

После автоматического заполнения графика с рассчитываемой сменой его годовая сумма часов близка к нормативной. Отличие, полученное за счет округления при расчете продолжительности смены, можно убрать небольшой коррекцией рабочего времени в отдельные дни или назначением дополнительного рабочего (выходного) дня.

Балансировка плановых графиков непрерывного производства

Плановые графики непрерывного производства балансируются по дням, т.е. коррекция планового времени производится вводом дополнительных выходных или рабочих дней в детализацию выбранных месяцев.

При переработке, когда разница в часах между балансируемым и нормативным графиками положительна, в окне балансировки выдается запись "Рекомендуемое кол-во выходных дней: ..дн. ..ч." (см. рис. выше).

При ручном вводе вместо рабочего типа времени в выбранные дни буквы "В" (типа времени "Выходной день") автоматически уменьшается значение в ячейке "дн.", а при уменьшении продолжительности смены – в ячейке "ч.".

График считается сбалансированным, когда значения в обеих ячейках нулевые, при этом в окне балансировки выдается запись "График сбалансирован" (рис. 2).

Рис. 2

При недоработке, когда разница в часах между балансируемым и нормативным графиками отрицательна, в окне балансировки выдается запись "Рекомендуемое кол-во дополнительных раб. дней: ..дн. ..ч.".

В этом случае в выбранные месяцы вводятся дополнительные рабочие дни (вместо выходных) до тех пор, пока график не станет сбалансированным.

Предоставление отгулов за переработку

Если плановый график сотрудника несбалансирован, то информацию о времени, отработанном сверх годовой нормы, можно передать в кадровые службы для предоставления отгулов. Процесс передачи информации о переработке в модуль "АиТ:\Кадровый учет" можно автоматизировать, используя калькулируемые типы времени.

Рекомендуется следующая последовательность действий:

1. В окне "Типы времени" добавляется калькулируемый тип времени, передаваемый в модуль "АиТ:\Кадровый учет", и производится его настройка. Например, нормативный график – Пятидневка (40ч), периодичность расчета данных – раз в год, дни калькулируются как "Переработка в часах/среднюю смену", и т.д.

2. Если в табельном листе учитываются сотрудники, занятые на непрерывном производстве, рекомендуется в окне "Настройка листа" на закладке "Типы времени" настроить учет калькулируемого типа времени, передаваемого в модуль "АиТ:\Кадровый учет".

3. При расчете итогов по табельному листу за последний месяц года для каждого сотрудника рассчитается отклонение от нормативного графика (в днях и часах) за год.

4. Это отклонение можно передать в модуль "АиТ:\Кадровый учет", сформировав свод в кадры по табельному листу. Такой свод формируется в окне "Своды по табельному листу" по кнопке "Свод в кадры" SvodPerson дополнительной панели инструментов. В модуле "АиТ:\Кадровый учет" по данным свода формируется приказ на предоставление дополнительных дней отдыха.


Документы и отчеты

Модуль позволяет создавать разнообразные отчеты по ведению табельного учета. Отчеты применяются для всестороннего анализа рабочего времени и позволяют вести учет и контроль использования рабочего времени, получить сведения по плановым графикам, по типам времени, передаваемым в модуль "АиТ:\Зарплата", а также по тем типам, по которым ведутся журналы. С помощью отчетов можно получить структуру отработанного времени, явок и неявок на работу по подразделениям, всему предприятию или произвольным группам сотрудников с учетом нескольких уровней аналитики.

На основании сформированных отчетов можно в печатном виде получить унифицированные формы Т-13 и Т-12, а также другие типовые и произвольные документы.

В модуле "АиТ:\Табельный учет" отчеты можно создавать двумя способами с помощью Мастеров или шаблонов. Все сформированные отчеты хранятся в рабочей папке \aitclient\tbu\TXT.

Мастер – это средство графического интерфейса, которое автоматизирует процесс создания нового отчета по ведению табельного учета, а также позволяет облегчить и ускорить процесс его создания. Вызов Мастеров осуществляется из подпунктов пункта "Отчеты" раздела "Режим" Главного меню. С помощью Мастеров формируются следующие отчеты и документы:

· по списочной численности работников;
· по средней численности работников;
· по переработкам;
· по форме 38.

Процесс создания отчета выполняется в несколько этапов (шагов). На каждом шаге открывается модальное окно, поэтому во время работы Мастера остальные режимы работы модуля недоступны. Переход к следующему окну Мастера осуществляется кнопкой "Далее>>", а возврат к предыдущему окну – кнопкой "<<Назад". На любом шаге работу Мастера можно прервать, нажав на кнопку "Отмена". Все Мастера работают по одному принципу, поэтому работа Мастеров подробно описана на примере первого по порядку рассматриваемого Мастера создания отчетов по списочной численности.

Модуль также предоставляет возможность формировать отчеты, согласно их описаниям (шаблонам). К этому виду отчетов относятся следующие отчеты:

· по предприятию;
· по табельному листу;
· по группе табельных листов;
· по типам времени;
· по журналам;
· по плановым графикам;
· по хранимой процедуре.

Второй вид отчетов создается в модуле согласно их описаниям (шаблонам), которые хранятся в виде файлов с расширением *.rep (текстовые шаблоны) или *.dot (шаблоны для печати в Word) в рабочей папке установки модуля \aitclient\tbu\form. Пользователь может как корректировать имеющиеся текстовые и MS Word шаблоны, так и создавать новые. Для просмотра или редактирования шаблона его следует выделить в окне "Формирование отчета" и нажать на кнопку "Шаблон текстовый" PanelRep2 или на кнопку "Шаблон Word/Excel" PanelRep3 дополнительной панели инструментов.

Текстовые шаблоны представляют собой текстовые файлы предопределенной структуры, содержащие ключевые слова, на место которых вставляются значения полей из базы данных. Список ключевых слов, которые могут использоваться в шаблонах отчетов модуля "АиТ:\Табельный учет", приводится в книге "Ключевые слова в шаблонах" Справочной системы.

Данные о ежедневном табельном времени во всех отчетах представлены в формате ЧЧ:ММ, а итоговые суммы отработанного времени в часах за любой период – в десятичном формате с долями часа.


Разработка шаблонов

Шаблоны используются для автоматизации процесса формирования отчетов, что заметно облегчает работу с отчетами и типовыми документами в модуле. По существу, шаблон – это модель для создания конкретного типа документа, содержащая набор элементов, отражающих структуру документа, и механизм для ввода данных документа. Напоминаем, что на основании сформированного отчета можно получить печатную форму соответствующего типового документа.

Для каждого типа документов (отчетов) разрабатываются свои индивидуальные шаблоны. Модуль "АиТ:\Табельный учет" позволяет формировать отчеты в трех форматах: в текстовом формате (*.txt), в формате документа MS Word (*.dot) и MS Excel (*.xls). Для создания текстовых отчетов требуется разработать один шаблон в тестовом формате (rep), который определяет как содержание, так и внешний вид отчета. Для получения отчетов в формате документа MS Word и MS Excel требуется разработать два шаблона. Текстовый шаблон (*.rep) определяет содержание отчета, второй шаблон в формате *.doc или *.xls определяет форму представления отчета.

Скорость создания текстовых отчетов намного выше, чем у отчетов в формате MS Word, но печатный документ имеет недостаточно презентабельный вид по сравнению с документами в формате MS Word и MS Excel. Отчеты в формате MS Excel совмещают достоинства двух других типов отчетов, как высокую скорость построения отчета, так и оформление, и презентабельный вид документа.

Готовые шаблоны документов, в том числе и унифицированных форм (Т-13 и Т-12), утвержденных Госкомстатом РФ, поставляются в дистрибутиве программного комплекса и размещаются в рабочей папке установки модуля \aitclient\tbu\Form. Кроме этого, шаблоны пользовательских документов, учитывающих специфику конкретного предприятия, могут создаваться непосредственно самими пользователями. Чтобы создать новый шаблон документа, следует подготовить текстовый документ и сохранить его под заданным именем в формате *.rep или *.doc.

Разработка текстовых шаблонов

Текстовый шаблон конкретного типа документа хранится в файле с расширением *.rep. Файл шаблона строится в соответствии с заданной структурой и состоит из нескольких частей, перечисленных в строго определенном порядке. Шаблоны текстового формата *.rep можно создавать, просматривать или изменять с помощью любого текстового редактора Windows, например, Word. Редактируя шаблон, пользователь может изменять форму документа и состав включаемых в него данных. Для редактирования шаблона его следует выделить в окне "Формирование отчета" и нажать на кнопку "Шаблон текстовый" PanelRep2 или на кнопку "Шаблон Word/Excel" PanelRep3 дополнительной панели инструментов.

Каждый шаблон содержит уникальный набор ключевых слов, который зависит от типа документа. Ключевые слова – это зарезервированные служебные слова, имеющие уникальные имена и используемые при разработке шаблонов отчетов и документов.

В шаблоне используются ключевые слова двух видов, отличающиеся по виду и назначению. Ключевые слова первого вида начинается с символа # (решетка) и используется для задания начала и конца отдельных частей шаблона, например, #НАЧАЛО_ШАПКИ и #КОНЕЦ_ШАПКИ.

В готовом виде в шаблоне должны быть перечислены все элементы, отражающие структуру документа и являющиеся “общими” для всех документов данного типа. На основании одного шаблона создается множество документов данного типа (например, приказ о приеме сотрудника), отличающихся своим индивидуальным набором данных.

Второй вид ключевых слов используется для подстановки данных конкретного документа, их имена заключены в квадратные скобки "[ ]". При формировании отчета вместо этих ключевых слов автоматически вставляются соответствующие значения из базы данных. Причем, перед закрывающей квадратной скобкой можно добавить любое число символов "пробел" (оставить пустое место).

Внимание. Реальное значение, подставляемое вместо ключевого слова в выходной документ, будет занимать в документе столько же печатных позиций, сколько их занимает ключевое слово (вместе с обрамляющими его квадратными скобками и всеми пробелами) в тексте шаблона.

Шаблоны в формате *.doc или *.xls

Шаблоны в формате документа MS Word (*.dot) и (*.xls) предназначены для формирования внешнего вида документа и размещения ключевых слов. Создание нового документа по шаблону целесообразно начинать не “с чистого листа”, а с копии шаблона, созданного для похожего по внешнему виду документа.

Размещение ключевых слов в шаблоне в формате Word осуществляется через механизм закладок (bookmarks), имена которых берутся из списка ключевых слов. Закладка – это элемент документа в формате Word, которому присвоено уникальное имя. В шаблоне в формате MS Excel ключевые слова начинаются с символа "!" и размещаются в месте ввода нужного значения в документ.


Структура шаблона документа

Модуль позволяет создавать как типовые выходные документы, так и пользовательские документы, учитывающие специфику конкретного предприятия. Пользовательские документы могут создаваться непосредственно самими пользователями.

Выходные документы и отчеты формируются на основе текстовых файлов-шаблонов, которые можно создавать, редактировать или просматривать с помощью любого текстового редактора Windows, например, Word. Редактируя шаблон, пользователь может изменять форму документа и состав включаемых в него данных.

Файл шаблона состоит из нескольких частей, перечисленных в строго определенном порядке. Каждая часть содержит набор строк, характеризуется своим назначением и местоположением на шаблоне. Первая и последняя строки каждой части шаблона являются специальными, они характеризуют назначение этой части, начинаются с символа # и служат для разделения различных частей друг от друга.

В общем случае шаблон может включать следующие составные части, расположенные обязательно в указанном порядке:

· Область общих настроек – определяет особенности формирования тела отчета.

Область общих настроек обозначается в rep-файле словами: #НАЧАЛО_НАСТРОЕК и #КОНЕЦ_НАСТРОЕК. Например,

#НАЧАЛО_НАСТРОЕК

[ГРУППИРОВКА ПО ФИО]

#КОНЕЦ_НАСТРОЕК

Настройка [ГРУППИРОВКА ПО ФИО] располагает фамилии работников в табеле в алфавитном порядке.

· Титульная часть – текст, который должен печататься один раз в начале документа между строкой #НАЧАЛО_ТИТУЛ и строкой #КОНЕЦ_ТИТУЛ. В нем могут содержаться ключевые слова и ссылки на формулы.
· Шапка (заголовок страницы) – часть текста, которая должна повторяться на каждой новой странице выходного документа (в отличие от титула). Шапка может содержать ключевые слова. Она содержится в шаблоне между строкой #НАЧАЛО_ШАПКИ и строкой #КОНЕЦ_ШАПКИ.
· Цикл (тело документа) – описание повторяющейся части документа.

Тело документа в файле шаблона расположено между строкой #НАЧАЛО_ЦИКЛА и строкой #КОНЕЦ_ЦИКЛА. В выходном документе эта часть будет повторена столько раз, сколько сотрудников или подразделений (в случае сводной ведомости) будет перечислено в документе.

Все ключевые слова, являющиеся ссылками на формулы, в теле документа интерпретируются как обозначающие результат вычислений по конкретному сотруднику или подразделению.

· Подвал листа – нижняя часть листа, должна повторяться на каждой новой странице выходного документа.

Подвал листа документа может содержать ключевые слова, в том числе, ссылки на формулы. Он содержится в шаблоне между строкой #НАЧАЛО_ПОДВАЛА и строкой #КОНЕЦ_ПОДВАЛА.

· Подвал документа – завершающая (нижняя) часть, которая служит для формирования аналитической части документа и подписей на последней странице.

Нижняя часть печатается всегда на последней странице. Документ разбивается постранично таким образом, чтобы на последнем листе обязательно присутствовала "шапка" и хотя бы одна строка из повторяющейся части документа, а затем уже печатается нижняя часть документа.

В нижней части могут присутствовать ключевые слова, причем описываемые ими значения формул, интерпретируются как итоговые по ведомости.

Подвал документа расположен в шаблоне между строками #НАЧАЛО_ПОДВАЛА_ОТЧЕТА и #КОНЕЦ_ПОДВАЛА_ОТЧЕТА.

Шаблон может также содержать комментарии, т.е. поясняющий текст, содержащий одну или несколько строк, начинающихся со знаков "//". В выходной документ такие строки не переносятся. Комментарий может располагаться в любом месте файла-шаблона. Количество таких строк в шаблоне не ограничено.


Мастер расчета численности работников

Мастер создания отчета по списочной численности

Отчеты по списочной численности в модуле создаются непосредственно пользователями под управлением Мастера за несколько этапов (шагов), каждый из них выполняется в отдельном окне. Переход к следующему окну осуществляется кнопкой "Далее>>", а возврат к предыдущему окну – кнопкой "<<Назад". Для прекращения работы Мастера используется кнопка "Отмена". На каждом шаге работы Мастера открывается модальное окно, поэтому во время работы Мастера остальные режимы работы становятся недоступными.

Для вызова Мастера необходимо:

· открыть окно "Списочная численность работников" из подпункта "Списочная численность" пункта "Отчеты" раздела "Режим" Главного меню;
· нажать на кнопку "Мастер расчета численности" Panel2.

На первом шаге Мастера пользователю предлагается выбрать подразделения (одно, несколько или все), по которым требуется рассчитать списочную численность работников. По умолчанию отчет строится по всему предприятию, т.к. при открытии первого окна Мастера (рис. 1) установлен переключатель "По всему предприятию". В этом случае доступ к выбору подразделений запрещен, т.к. в структуре предприятия показаны только названия предприятия и филиалов самого верхнего (1 уровня), которые окрашены в серый цвет, поэтому показать список подразделений, входящих в состав этих филиалов невозможно.

Рис. 1

Если требуется построить отчет по подразделению или филиалу, то сначала необходимо включить переключатель "По подразделениям" (рис. 2), в этом случае названия филиалов окрашиваются в черный цвет, а потом в структуре предприятия выделить (левой кнопкой мыши) нужный филиал или подразделение. При выделении филиала списочная численность сотрудников рассчитывается по каждому подразделению, входящему в выделенный филиал.

Если отчет строится по подразделению, входящему в филиал, то необходимо щелкнуть мышью на знаке '+' слева от названия филиала, после чего знак '+' меняется на знак '-' и на экране отображаются подразделения, входящие в этот филиал. Если филиал имеет иерархическую структуру, то ее следует раскрывать указанным способом до тех пор, пока не покажется нужное подразделение, а затем выделить его. Существует и другой способ выделения нужного подразделения. Для этого достаточно в поле для поиска ввести номер подразделения (на рис. 2 это подразделение с номером 3) и нажать на кнопку "Поиск по подразделению". В результате автоматически раскрывается структура предприятия, нужное подразделение не только отображается в структуре, но и выделяется. Аналогичным способом можно выделить и другие подразделения.

Рис. 2

На втором шаге Мастера (рис. 3) выполняются настройки отчета:

· указывается название отчета;
· задается дата, на которую необходимо рассчитать списочную численность;
· устанавливается флаг "Сохранять отчет о списочной численности в списке". При снятом флаге информация об отчете не сохраняется в базе данных и название отчета не появляется в списке отчетов.

Рис. 3

На последнем третьем шаге (рис. 4) производится подтверждение выполненных настроек. Если приведенная итоговая информация не устраивает пользователя, можно вернуться на предыдущий шаг, нажав на кнопку "<<Назад", и изменить введенные данные. Если все данные введены правильно, то для проведения расчета списочной численности нажмите на кнопку "Готово". После окончания расчета Мастер закрывается, на экране открывается окно "Детализация отчета" с данными расчета. Созданный отчет пользователь может получить в печатном виде. Более подробные сведения приведены в теме "Отчеты по расчету списочной численности".

Рис. 4


Отчеты по расчету списочной численности

Списочную и среднюю численность сотрудников можно рассчитать по конкретному подразделению и предприятию в целом. Для корректного расчета численности необходимо произвести предварительные настройки в модуле "АиТ:\Кадровый учет". Особое внимание следует уделить сотрудникам, которые учитываются в расчете нетрадиционно (работающие неполное время, внешние совместители и пр.). Для сотрудников, работающих неполное время, обязательно следует указать коэффициент рабочего времени в настройках планового графика.

Для просмотра существующих отчетов по списочной численности работников, созданных пользователем под управлением Мастера, необходимо выполнить следующие действия:

· открыть окно (рис. 1) со списком отчетов по списочной численности работников из подпункта "Списочная численность" пункта "Отчеты" раздела "Режим" Главного меню;
· дважды щелкнуть мышью на нужной строке списка для открытия окна (рис. 2), содержащего информацию с результатами расчета списочной численности.

При первом открытии окна (рис. 1) список пустой, т. к. пользователь еще никаких отчетов не создавал. Отчеты создает сам пользователь с помощью Мастера, который открывается кнопкой "Мастер расчета численности" Panel2.

Рис. 1

Списочная численность работников приводится на определенную дату, например, на первое или последнее число месяца, которая задается пользователем при создании отчета. Эта дата приводится в столбце "Дата формирования" таблицы со списком отчетов (рис. 1). Каждый отчет также характеризуется названием, отражающим его назначение, и периодом расчета. В последнем столбце "Значение" первое число характеризует фактическое число сотрудников в подразделении (на предприятии) за указанный период, второе число – общее число сотрудников подразделения с учетом уволенных.

Неактуальные отчеты можно исключить из списка с помощью кнопки "Удалить" TabDel, предварительно выделив их нажатием правой кнопки мыши.

Для детального просмотра отчета (рис. 2) с показом всех сотрудников и коэффициент рабочего времени каждого из них дважды щелкните на строке списка нужного отчета в списке (рис. 1).

Рис. 2

Для сотрудников отдела, работающих на полной ставке коэффициент рабочего времени равен 1, для уволенных сотрудников он равен нулю.

Данные расчета, приведенные в окне (рис. 2), можно распечатать, нажав на кнопку "Печать отчета" Print или клавишу F4. Открывается окно (рис. 3), в нем по умолчанию предлагается имя файла, под которым отчет будет сохранен на диске.

Рис. 3

При необходимости имя файла можно изменить. Для формирования отчета следует нажать на кнопку "Продолжить". Начинается процесс построения отчета, процент выполнения отчета отражается в бегущей строке, а после построения отчет открывается на экране.

Отчет формируется по шаблону t7_payroll.dot, расположенному в рабочей папке \aitclient\tbu\Form.

В шаблоне отчета используются следующие ключевые слова:

Наименование | Значение
ПОДРАЗДЕЛЕНИЕ | Наименование подразделения
ПРЕДПРИЯТИЕ | Наименование предприятия
Date_begin | Дата расчета списочной численности
Emp_payrol | Значение списочной численности
Emp_whole | Общее количество сотрудников в подразделении


Отчеты по расчету средней численности

Расчет средней численности работников производится Мастером создания отчета по средней численности. В сформированных отчетах учитываются только те сотрудники, для которых за заданный период существует заполненный табельный лист. После проведения расчета сформированный отчет попадает в список отчетов окна "Средняя численность работников" (рис. 1).

Внимание. Расчет средней численности осуществляется в соответствии с Приказом от 12 ноября 2008 г. N 278 "ОБ УТВЕРЖДЕНИИ УКАЗАНИЙ ПО ЗАПОЛНЕНИЮ ФОРМ ФЕДЕРАЛЬНОГО СТАТИСТИЧЕСКОГО НАБЛЮДЕНИЯ: …" (часть, в которой описывается правила заполнения формы П-4).

Рис. 1

Вызов окна (рис. 1) осуществляется из подпункта "Средняя численность" подпункта "Отчеты" раздела "Режим" Главного меню.

В списке для каждого отчета указывается название отчета, начальная и конечная даты периода, за который рассчитывается среднюю численность, дата формирования отчета, значение средней численности для выбранных подразделений. Неактуальные отчеты можно исключить из списка с помощью кнопки "Удалить" TabDel, предварительно выделив их нажатием правой кнопки мыши. Удаление отчета происходит после подтверждения пользователя.

Отчеты в списке можно отобрать по типу отчета и по условию фильтру. Нужный тип отчета выбирается из выпадающего списка поля "Тип отчета", расположенного в нижней части окна. Тип отчета задается в момент его формирования Мастером. Установка и снятие фильтра производится соответственно кнопкой "Поставить фильтр" Filtr и "Снять фильтр" Panel9.

В окне (рис. 1) может быть представлено четыре типа отчетов:

· Средняя (общая) – рассчитывается средняя численность работников организации за произвольный период внутри месяца, которая определяется как сумма трех составляющих численности, указанных ниже;
· Среднесписочная – рассчитывается среднесписочная численность работников, в расчете учитываются работники, не вошедшие в следующие две группы;
· По внешним совместителям – рассчитывается средняя численность внешних совместителей, в расчете учитываются работники, у которых в журнале кадровой карточки модуля "АиТ:\Кадровый учет" присутствует запись о внешнем совместительстве на данный период;
· По договору гражданско-правового хар. – рассчитывается средняя численность работников, выполнявших работу по договорам гражданско-правового характера (ГПД), в расчете учитываются сотрудники, у которых в истории трудовых договоров на данный период времени присутствует запись с видом контракта "ГПД" и нет записи о трудовом договоре на этот же период.

Расчет средней численности в отчетах проводится в соответствии с порядком, описанным в теме "Расчет средней численности". Для правильного расчета средней численности нужно выполнить необходимые настройки для разных категорий сотрудников и провести корректное заполнение журналов. Расчет указанных типов отчетов в журналах должны проводится на основании в журналах записей о совместительстве, истории трудовых договоров, записей в журнале кадровых перемещений и журнале изменения графика.

Для просмотра отчета, приведенного в списке, дважды щелкните мышью на строке с названием отчета, открывается окно "Детализация отчета" (рис. 2), содержащее расчетную информацию.

Рис. 2

Данные расчета, приведенные в окне (рис. 2), можно распечатать кнопкой "Печать отчета" Print. Процесс получения печатного документа происходит так же, как и для отчетов по списочной численности работников. Отчет формируется по шаблону t7_apayroll.dot, расположенному в рабочей папке \aitclient\tbu\Form. Сформированный отчет содержит три колонки.

Ключевые слова, используемые в шаблоне

В шаблоне используются следующие ключевые слова:

Наименование | Значение
ПОДРАЗДЕЛЕНИЕ | Наименование подразделения
ПРЕДПРИЯТИЕ | Наименование предприятия
НАЗВАНИЕ | Тип отчета
Date_begin | Дата начала расчетного периода
Date_end | Дата окончания расчетного периода
Emp_payrol | Значение списочной численности
Emp_whole | Общее количество сотрудников в подразделении


Особенности учета средней численности

Учет сотрудников в средней численности

Сотрудник может учитываться в средней численности:

· целыми единицами за каждый календарный день – работники, работавшие по трудовому договору, работники, выполнявшие работу по ГПД, работники, которым в соответствии с законодательством РФ установлена сокращенная продолжительность рабочего времени и т.п.;
· пропорционально отработанному времени – лица, работавшие неполное рабочее время в соответствии с трудовым договором или переведенные с письменного согласия работника на неполное рабочее время – п.84.3;
· целыми единицами по дням явок на работу – (лица, не состоящие в списочном составе и привлеченные для работы по специальным договорам с государственными организациями на предоставление рабочей силы – военнослужащие и лица, отбывающие наказание в виде лишения свободы – п. 84.2):
· не учитываться в среднесписочной численности – адвокаты, собственники организации, не получающие заработную плату, находящиеся в отпусках по беременности и родам, в доп. отпуске без сохранения зарплаты и т.д. – п. 83).

Не учитываются в средней численности следующие периоды работы сотрудника:

· до даты поступления;
· после даты увольнения;
· периоды нахождения в отпусках, для которых в модуле "АиТ:\Кадровый учет" в справочнике "Виды отпусков" установлен флаг "Ср.числен.";
· периоды, явным образом исключенные из учета на закладке "Средняя численность" кадровой карточки (см. ниже п. 5).

Настройки для разных категорий сотрудников

Для каждой перечисленной категории работников указываются способы учета сотрудников в средней численности (целыми единицами, и т.п.).

1. Работники, работавшие по трудовому договору – включаются в среднесписочную численность целыми единицами за каждый календарный день. Численность за выходной или праздничный день принимается равной численности за рабочий день, предшествующий выходным или праздничным дням. Для этой категории работников не требуется дополнительных настроек, если сотрудник не имеет условий, описанных в пунктах 2-9, он автоматически учитывается в среднесписочной численности целыми единицами.

2. Лица, работавшие неполное рабочее время в соответствии с трудовым договором и другие категории сотрудников, которые учитываются пропорционально отработанному времени.

Включить сотрудника в данную группу можно 2 способами:

· указать для него график, для которого в окне настроек параметров плановых графиков на закладке "Общие" установлен флаг "Неполное рабочее время для среднесписочной";
· на закладке "Средняя численность" в кадровой карточке модуля "АиТ:\Кадровый учет" указать период, в течение которого сотрудника нужно учитывать пропорционально отработанному времени, а в колонке "Тип периода" задать значение "Неполное время" (см. рис. 1).

Рис. 1

Расчет средней численности для этой категории работников производится по отдельному алгоритму, описанному в пункте 2 темы "Расчет средней численности".

3. Работники, которым в соответствии с законодательством РФ установлена сокращенная продолжительность рабочего времени – они должны учитываться целыми единицами. Если такие сотрудники не имеют графиков, отмеченных как графики неполного времени (см. пункт 2), они будут учтены целыми единицами автоматически. Если они имеют график неполного времени, то только две категории льготников будут автоматически учтены целыми единицами:

· работники в возрасте до 18 лет (при условии заполнения даты рождения);
· инвалиды 1 и 2 группы (при условии заполнения данных по инвалидности).

Для остальных категорий льготников (работники, занятые на работах с вредными и опасными условиями труда, женщины, работающие в сельской местности и т.п.) необходимо на закладке "Средняя численность" в кадровой карточке модуля "АиТ:\Кадровый учет" указать период, в течение которого их нужно учитывать целыми единицами, а в колонке "Тип периода" задать значение "Обычная среднесписочная" (см. рис. 1).

4. Лица, не состоящие в списочном составе и привлеченные для работы по специальным договорам с государственными организациями на предоставление рабочей силы – к этой группе относятся военнослужащие и лица, отбывающие наказание в виде лишения свободы. Такие сотрудники учитываются целыми единицами по дням явок на работу. Для них необходимо на закладке "Средняя численность" в кадровой карточке модуля "АиТ:\Кадровый учет" указать период, в течение которого сотрудника нужно учитывать по дням явок на работу, а в колонке "Тип периода" задать значение "По дням посещаемости" (см. рис. 1).

5. Работники, которых необходимо исключить при расчете средней численности (адвокаты, члены кооператива, не заключившие трудовых договоров с организацией и т.п.) – если по таким работникам не ведутся табельные листы, они будут автоматически исключены из расчета средней численности. Если табельные листы ведутся, необходимо на закладке "Средняя численность" в кадровой карточке модуля "АиТ:\Кадровый учет" указать период, в течение которого их не нужно учитывать при расчете средней численности, а в колонке "Тип периода" задать значение "Исключить из средней численности" (см. рис. 1).

6. Женщины, находящиеся в отпусках по беременности и родам, работники, обучающиеся в образовательных учреждениях и находящиеся в дополнительном отпуске без сохранения зарплаты и т.п. – не учитываются при расчете средней численности. Такие работники будут автоматически исключены из расчета средней численности в течение указанного периода, если:

· у них в журнале отпусков есть запись о периоде нахождения в отпуске;
· для данного типа отпуска в справочнике "Виды отпусков" модуля "АиТ:\Кадровый учет" установлен флаг "Ср.числен." (рис. 2).

Рис. 2

7. Внешние совместители – учитываются в численности внешних совместителей, исключаются из среднесписочной численности. Для таких сотрудников при приеме на работу необходимо установить флаг "Внешнее совместительство" (рис. 3).

Рис. 3

Тогда журнал кадровой карточки (рис. 4) будет содержать запись о внешнем совместительстве, и сотрудник будет соответственно учитываться соответствующим способом.

Рис. 4

Средняя численность внешних совместителей исчисляется в соответствии с порядком определения средней численности лиц, работавших неполное рабочее время.

8. Работники, выполнявшие работу по ГПД – учитываются в численности по договорам гражданско-правового характера, исключаются из среднесписочной численности. Для таких сотрудников в истории трудовых договоров должна присутствовать запись о контракте с видом "ГПД" (рис. 5).

Рис. 5

Средняя численность работников, выполнявших работу по ГПД, исчисляется по методологии определения среднесписочной численности.

9. Работники, состоящие в списочном составе и заключившие договор ГПД с той же организацией, – работники, у которых в истории трудовых договоров присутствует не только запись о контракте ГПД, но и запись о трудовом договоре на соответствующий период (рис. 6). Такие работники автоматически учитываются только в среднесписочной численности, и не включаются в численность ГПД.

Рис. 6


Расчет средней численности

Расчет средней численности осуществляется в соответствии с Приказом от 12 ноября 2008 г. N 278 "ОБ УТВЕРЖДЕНИИ УКАЗАНИЙ ПО ЗАПОЛНЕНИЮ ФОРМ ФЕДЕРАЛЬНОГО СТАТИСТИЧЕСКОГО НАБЛЮДЕНИЯ: …" (часть, в которой описывается правила заполнения формы П-4).

1. Расчет среднесписочной численности работников

Среднесписочная численность за месяц исчисляется путем суммирования списочной численности за каждый календарный день и деления полученной суммы на число календарных дней месяца. Численность за выходной или праздничный день принимается равной численности за предшествующий рабочий день.

2. Расчет средней численности лиц, работавших неполное рабочее время

Для корректного расчета необходимо в модуле "АиТ:\Конфигурация" в режиме "Настройки комплекса" указать значение средней продолжительности рабочего дня, исходя из продолжительности рабочей недели – например, 8 часов. Настройка "Средняя продолжит. раб. дня для среднесписочной" находится в разделе "Табельные листы".

Работники учитываются за каждый день пропорционально отработанному времени, т.е. количество отработанных за день часов делится на указанную среднюю продолжительность рабочего дня, например, 4/8 = 0.5. Значения по всем отработанным дням складываются, и затем сумма делится на количество рабочих дней по графику сотрудника.

3. Расчет средней численности внешних совместителей

Средняя численность внешних совместителей исчисляется в соответствии с порядком определения средней численности лиц, работавших неполное рабочее время (см. пункт 2).

4. Расчет средней численности работников, выполнявших работу по ГПД

Исчисляется по методологии определения среднесписочной численности (см. пункт 1).


Мастер создания отчета по средней численности

Отчеты по средней численности сотрудников создаются непосредственно пользователем под управлением Мастера, который открывается кнопкой "Мастер расчета" Panel2 из окна "Средняя численность работников". Для создания отчета используется несколько последовательно открываемых окон, переход к следующему окну осуществляется кнопкой "Далее>>".

Работа Мастеров по созданию отчетов выполняется по одним и тем же принципам. Подробно работа Мастеров рассмотрена на примере создания отчета по списочной численности.

На первом шаге (рис. 1) открывается окно "Выбор подразделения". В этом окне пользователь за счет выбора соответствующего переключателя определяет состав отчета: по всему предприятию или по отдельному подразделению. Если отчет строится по филиалу или подразделению, то его необходимо выделить в структуре предприятия, представленного в виде дерева. Выделение филиала или подразделения производится щелчком левой кнопки мыши.

Рис. 1

На втором шаге (рис. 2) необходимо указать следующие параметры отчета:

· тип отчета – тип отчета выбирается из выпадающего списка верхнего поля, содержащего четыре типа отчетов: средняя (общий), среднесписочная, по внешним совместителям, по договору гражданско-правового характера;
· название отчета – используется для идентификации отчетов в списке;
· период отчета – начальная и конечная даты периода, за который необходимо рассчитать среднюю численность;
· количество итераций – этот параметр может принимать значения от 3 до 999, используется при расчете численности работавших неполное рабочее время и определяется возможной длительностью непрерывного периода неявок (например, длительностью ежегодного отпуска). Следует иметь в виду, что количество итераций определяет время расчета;
· установить флаг "Сохранять отчет о списочной численности в списке". Если он не установлен, информация об отчете не сохраняется в базе данных.

Рис. 2

На последнем третьем шаге производится подтверждение настроек и начинается расчет после нажатия на кнопку "Готово". После окончания расчета окно закрывается, а созданный отчет попадает в список отчетов по средней численности.


Предварительные операции перед формированием отчетов по предприятию

Перед формированием отчетов по предприятию необходимо выполнить следующие операции:

1. Создать шаблоны, по которым будут строиться отчеты по предприятию. Особенности разработки шаблонов описаны в теме "Создание шаблона отчета по предприятию". В дистрибутивной поставке в рабочей папке \aitclient\tbu\form имеется пример шаблона аналитического отчета totrep76.dot. Пользователи могут разрабатывать шаблоны в соответствии с потребностями текущего предприятия.

2. Настроить отчеты по предприятию. Каждому отчету пользователь назначает имя, под которым он отображается в списке отчетов по предприятию в окне "Формирование отчетов". Имя отчета вводится в окне "Настройка отчетов по предприятию". В этом же окне определяется содержание отчета (количество строк и столбцов, их назначение, задаются фильтры и др. параметры отчета).

3. Поскольку в отчет по предприятию попадают итоговые данные за период, то перед формированием отчета необходимо либо сделать расчет промежуточных итогов, либо сформировать своды по тем табельным листам, данные которых должны отразиться в отчете.


Создание шаблона отчета по предприятию

В качестве примера шаблона для создания аналитических отчетов по предприятию используется шаблон totrep76.dot в формате MS Word. Шаблон поставляется в дистрибутивном комплекте и размещается в рабочей папке \aitclient\tbu\form. В качестве шаблона промежуточного файла для формирования отчета используется текстовый шаблон totrep.rep. В нем прописано соответствие ключевых слов ПАРАМЕТР_(N), использующихся в аналитических отчетах, закладкам в MS Word.

Для каждого нового отчета необходимо создавать свой шаблон MS Word с соответствующими названиями колонок. Чтобы правильно озаглавить колонки, надо связать ключевые слова ПАРАМЕТР_(N) с типами времени, выдаваемыми в отчет. Эту информацию можно получить из таблицы на закладке "Колонки" окна "Настройка отчетов по предприятию". В колонке "Поля отчета" для каждого входящего в отчет типа времени указаны номера соответствующих ключевых слов (первое число – дни, второе – часы). Если в отчете нужно получить, например, значения рабочего времени в часах и больничного в днях, то в колонки шаблона в MS Word необходимо вставить следующие ключевые слова:

 | Рабочее время, часы | Больничный, дни
 | ПАРАМЕТР_(2) | ПАРАМЕТР_(5)
Итого | ПАРАМЕТР_ИТ_(2) | ПАРАМЕТР_ИТ_(5)

Внимание. При большом количестве колонок, выдаваемых в отчет (>6), в файл totrep.rep, указанный в качестве текстового шаблона отчета, необходимо добавить недостающие ключевые слова ПАРАМЕТР_(7) и т.д.


Настройка отчетов по предприятию

Окно "Настройка отчетов по предприятию" открывается при выборе подпункта "Настройки отчетов по предприятию" пункта "Настройки" раздела "Режим" Главного меню.

Новый отчет создается по кнопке "Создать" TabAdded дополнительной панели инструментов. Отчет можно также создать копированием любого из имеющихся в списке отчетов по кнопке "Копировать текущую запись" GrafCopy дополнительной панели инструментов. В левой части окна появляется новая строка, в которой указывается название (имя) создаваемого отчета. В правой части окна на трех закладках располагается информация, определяющая содержание отчета. Пользователь может настроить и сохранить произвольное количество отчетов.

Закладка "Строки"

На закладке "Строки" (рис. 1) формируются группы сотрудников, по которым будет строиться отчет. Он формируется по любой выборке сотрудников, которую можно реализовать, используя фильтр, причем в отчет может входить произвольное число строк по нескольким фильтрам.

Рис. 1.

Вставка новой строки производится кнопкой "Создать" TabAdded, при этом курсор должен располагаться в правой части окна. Номер строки проставляется автоматически, а название критерия отбора данных вводится пользователем вручную. Набор фильтров, по которым будет формироваться отчет, указывается в колонке "Используемый фильтр". Для каждой строки задается фильтр, выбранный из выпадающего списка поля "Используемый фильтр".

Если установлен флаг "Отображать все фильтры", то в выпадающий список колонки "Используемый фильтр" попадут фильтры, созданные всеми пользователями модуля. В противном случае в списке отображаются только фильтры, созданные текущим пользователем.

Закладка "Колонки"

Закладка "Колонки" (рис. 2) предназначена для настройки колонок отчета и разделена на две части. В левой части отображается список колонок, используемых в текущем отчете, в правой части – список колонок, которые могут использоваться в отчетах. Для перемещения колонок из списка в левой части в правую часть и наоборот воспользуйтесь методом перетащить и отпустить. В отчет могут быть включены данные из любых колонок, перечисленных в правой части.

В отчет могут входить суммы по всем типам времени, имеющимся в справочнике типов времени, в том числе и по калькулируемым типам (т.е. данные по отклонениям фактически отработанного времени от нормативного времени).

Внимание. Поскольку в отчет по предприятию попадают итоговые данные за период, то перед формированием отчета необходимо либо сделать расчет промежуточных итогов, либо сформировать своды по тем табельным листам, данные которых должны отразиться в отчете.

Рис. 2

Закладка "Параметры"

На закладке "Параметры" пользователь может настроить выдачу итоговых суммы по всему предприятию или подразделениям.

Чтобы данные по каждому фильтру, определенному на закладке "Строки", были разбиты по подразделениям, на закладке "Параметры" следует установить флаг "Детализировать отчет по подразделениям". Если флаг не установлен, в отчет будут выдаваться итоговые суммы по всему предприятию.


Отчеты по предприятию

Режим "Отчеты по предприятию" позволяет получать аналитические отчеты по использованию рабочего времени за произвольный период по любым выбранным группам сотрудников.

Непосредственно выбор отчета по предприятию и его формирование выполняется в окне "Выбор отчета по предприятию" (рис. 1), которое открывается из подпункта "Отчеты по предприятию" пункта "Отчеты" раздела "Режим" Главного меню.

Рис. 1.

После проведения предварительных операций можно приступить к непосредственному формированию отчета по предприятию. Для этого нужно:

· в окне (рис. 1) выбрать из списка нужный отчет;
· указать период, за который будут суммироваться данные в отчете (месяц, квартал или год);
· нажать на кнопку "Сформировать".

По окончании операции расчета на экран автоматически выводится окно "Формирование отчета" (рис. 2) для выбора шаблона, по которому будет сформирован итоговый документ.

Рис. 2

Если отчет формируется первый раз, то в окне (рис. 2) для данного отчета необходимо указать имя файла шаблона, по которому он формируется. Подробно операции включения файла в список описаны в теме "Добавление нового отчета в список формируемых отчетов". На рис. 2 отчет "Фонд рабочего времени" формируется в формате MS Word на основании шаблона totrep76.dot, предоставляемого компанией "АиТ® Софт".

Далее для создания отчета пользователь должен выбрать нужный шаблон, нажать на кнопку RepForm панели инструментов и выполнить действия, перечисленные в теме "Формирование отчетов". В результате сформированный отчет отображается на экране, а его данные записываются в файл, который хранится в рабочей папке \aitclient\tbu\TXT.


Формирование отчетов

Для получения различного вида отчетов (по предприятию, журналам, табельным листам) используется режим "Формирование отчетов". Для работы с режимом используются кнопки дополнительной панели инструментов. Назначение кнопок описано в конце этой темы.

Окно "Формирование отчетов" (рис. 1) открывается во время создания отчетов по предприятию, журналам, табельным листам, плановым графикам. Эти типы отчетов могут формироваться в текстовом формате, в формате документа MS Word и MS Excel.

Для каждого формата в окне используется отдельная закладка, на каждой из них приводится список шаблонов, соответствующих типу создаваемого отчета. В этом окне можно просмотреть или отредактировать нужный шаблон. Для его открытия воспользуйтесь кнопкой PanelRep2 дополнительной панели инструментов.

Если список на нужной закладке этого окна пуст, необходимо добавить в него отчет согласно инструкции, приведенной в теме "Добавление нового отчета в список формируемых отчетов".

Рис. 1

Для формирования требуемого отчета по выбранному шаблону следует:

· перейти на нужную закладку;
· выбрать шаблон, по которому создается отчет, т.е. выделить название отчета правой кнопкой мыши;
· нажать на кнопку RepForm панели инструментов. Появляется дополнительное окно (рис. 2), если в файле ait.ini в разделе [tabel] отсутствует настройка:

[tabel]

ask_tlist_report_name=N

Рис. 2

Внимание. При наличии указанной настройки окно "Имя файла" (рис. 2) не открывается, а имя файла, в котором будет храниться отчет, формируется автоматически. И сразу же начинается процесс формирования отчета.

· в окне (рис. 2) нужно указать имя файла, в котором будет сохранен документ. Имя файла предлагается по умолчанию;
· нажать на кнопку "Продолжить", начинается процесс формирования отчета. Процент выполнения отчета выводится на экран, как показано на рис. 3.

Рис. 3

После окончания операции сформированный отчет отображается на экране. Все сформированные отчеты хранятся в рабочей папке aitclient\tbu\TXT.

Назначение кнопок панели инструментов окна "Формирование отчетов".

Название кнопки | Кнопка | Исходные данные, действия и функции
Шаблон текстовый | PanelRep2 | Просмотр и редактирование текстового шаблона
Шаблон Word | PanelRep3 | Просмотр и редактирование Word шаблона
Пролистать | PanelRep4 | Открытие стандартного окна Windows для поиска файла шаблона
Прервать процесс | PanelRep5 | Прервать процесс формирования отчета


Добавление нового отчета в список формируемых отчетов

Отчеты по табельному учету могут формироваться в трех форматах (текстовом, Microsoft Word и Microsoft Excel) на основании шаблонов, разработанных программистами компании "АиТ® Софт". При желании пользователи сами могут создавать шаблоны для отчетов по предприятию, необходимых для табельного учета сотрудников текущего предприятия.

Формирование отчетов по табельному учету происходит в окне "Формирование отчета", содержащем три закладки. Каждый новый шаблон, по которому формируется отчет в заданном формате, должен быть включен в список отчетов, приведенный на соответствующей закладке окна "Формирование отчетов".

Рис. 1

Рассмотрим порядок добавления нового отчета в список формируемых отчетов на закладке "Отчеты в MS Excel" (рис. 1) на примере формы Т-13. Для вставки нового отчета по табельному листу в список необходимо выполнить перечисленные ниже действия.

1. Открыть окно "Формирование отчетов" кнопкой "Печать отчета" Print из окна с табельным листом. Это окно также открывается во время создания отчетов по предприятию, журналам, табельным листам, плановым графикам.
2. Перейти на закладку "Отчеты в MS Excel".
3. Нажать на кнопку "Создать" TabAdded дополнительной панели инструментов. При этом в списке отчетов появится новая строка.
4. Ввести название отчета в первое поле (рис. 1), например, Табель Т-13.
5. Дважды щелкнуть мышью в поле "Текстовый шаблон". На экране появляется стандартное окно "Найти шаблон" (рис. 2) для поиска файла с нужным шаблоном.

Рис. 2

6. В верхнем поле "Папка" окна (рис. 2) из выпадающего списка (рис. 3) выбрать папку "form". В результате в окне (рис. 2) отобразятся все файлы, хранящиеся в этой папке. Причем, если до этого осуществлялся выбор файла из рабочей папки "form", то окно сразу же открывается со списком файлов из этой папки.

Рис. 3

7. В списке файлов выбрать нужный файл (t-13xls.rep) с расширением rep, щелкнув на нем левой кнопкой мыши. Выбранный файл в списке выделяется синим цветов и одновременно отображается в поле "Имя файла" (рис. 2).
8. Нажать на кнопку "Открыть", окно (рис. 2) закрывается, а выбранный файл отображается в поле "Текстовый шаблон" (рис. 1).
9. Аналогичные действия выполняются пользователем и при вводе имен файлов в другие поля:
· "Текстовый шаблон" – на закладке "Текстовые отчеты";
· "Текстовый шаблон" и "Шаблон MS Word" – на закладке "Отчеты в MS Word".
10. В поле "Сортировка" выбрать способ сортировки данных в отчете. В данном отчете по табельному листу сортировка (порядок перечисления сотрудников) может осуществляться по фамилии или табельному номеру.
11. Сохранить новый отчет в списке, нажав на кнопку "Сохранить изменения" Save дополнительной панели инструментов.


Отчет по переработкам

Отчеты по переработкам строятся с помощью Мастера создания отчета по переработкам, который вызывается из подпункта "Отчеты по переработкам" пункта "Отчеты" раздела "Режим" Главного меню. С помощью этого Мастера отчеты также создаются за три шага.

Внимание. Отчет по переработкам (по калькулируемым типам времени) можно формировать только для табельных листов с автоведением.

На первом шаге открывается окно "Выбор подразделения" (рис. 1). Внешний вид окна и его назначение совпадает с одноименным окном Мастера создания отчета по списочной численности работников. Работа этого и последующих окон подробно описана в теме "Мастер создания отчета по списочной численности". Отчет можно построить по предприятию, филиалу или подразделениям.

Рис. 1

На втором шаге в окне "Настройка отчета" необходимо указать название отчета и период отчета (начальный и конечный месяц, за который строится отчет).

На третьем шаге требуется подтвердить сведения, приведенные в окне "Итоговая информация". В окне, в частности, указывается период, за который формируются данные отчета, и имя файла, в котором сохраняется отчет. Для формирования отчета нажмите на кнопку "Готово". Далее сформированный отчет открывается на экране (рис. 1).

Рис. 1


Настройки формы 38

Для формирования формы 38 требуется выполнить необходимые настройки в окне "Настройки формы 38" (рис. 1), которое открывается из подпункта "Настройки формы 38" пункта "Настройки" раздела "Режим" Главного меню. В окне приводится список элементов формы 38, т.е. показателей использования рабочего времени, которые отражаются в форме 38. Фрагмент формы приведен на рис. 2. Каждый показатель в форме имеет порядковый номер (рис. 2), который указывается в поле "Порядковый номер".

Рис. 1

При выделении какого-либо элемента с 1 по 8 открывается набор полей для ввода названия и префикса элемента, его порядкового номера, единицы измерения. В качестве единицы измерения в форме 38 используются следующие:

· час – для расчета продолжительности рабочего времени и числа отработанных человеко-часов;
· чел – для расчета среднесписочной численности;
· дн – для остальных показателей.

Поле "Формула" активно только для расчета явок и неявок, среднесписочной численности и продолжительности рабочего дня.

Рис. 2

Чтобы подсчитать количество дней, не входящих в расчет среднесписочной численности, нужно для каждой подгруппы 9 элемента указать тип времени, заполнив поле "Тип времени". Для ввода типа времени нужно нажать на кнопку "Добавить" TimeCalkTipAdd и в появившееся поле ввести значение из выпадающего списка. Например, для элемента 9.1 "Частично оплачиваемый отпуск по уходу за ребенком до 1.5 лет" нужно указать тип времени "Реб 1.5 Уход за ребенком до 1.5 лет". Этот тип должен быть указан на закладке "Параметры" окна "Типы времени". Для удаления не нужного типа времени, воспользуйтесь кнопкой "Удалить" TimeCalkTipDel .

В отчете приводятся данные для 4 категорий сотрудников: для руководителей, специалистов, служащих и рабочих. В отчете будут приведены данные для тех групп сотрудников, которые были выбраны из выпадающих списков этих полей, например, для категории "Руководители" выбрано значение "Руководство" (рис. 3).

Рис. 3


Отчеты по форме 38

Отчеты по форме 38 "Использование рабочего времени по структурному подразделению (филиалу, Обществу)'' формируются Мастером отчета в формате MS Excel и добавляются в окно "Список отчетов по форме 38" (рис. 1). Доступ к окну происходит из подпункта "Отчет по форме 38" пункта "Отчеты" раздела "Режим" Главного меню. Для получения уже созданного Мастером отчета в формате MS Excel нужно выделить его в списке и нажать на кнопку RepExcel дополнительной панели инструментов.

Рис. 1

Мастер создания формы 38

Отчеты по форме 38 не требуют создания шаблонов и формируются непосредственно самим пользователем под управлением Мастера создания формы 38, который открывается кнопкой "Мастер расчета" Panel2 из окна "Список отчетов по форме 38" (рис. 1). С помощью этого Мастера форма 38 создается за три шага.

На первом шаге открывается окно "Выбор подразделения" для определения состава отчета по всему предприятию или по отдельному подразделению. Внешний вид окна и его назначение совпадает с одноименным окном Мастера создания отчета по списочной численности работников. Работа этого и последующих окон подробно описана в теме "Мастер создания отчета по списочной численности".

На втором шаге в окне "Настройка отчета" (рис. 2) необходимо указать название отчета, имя файла, в котором будет храниться сформированная форма, месяц и год, за который строится отчет.

Рис. 2

На третьем шаге требуется подтвердить сведения, приведенные в окне "Итоговая информация". В окне, в частности, указывается период, за который формируются данные отчета, и имя файла, в котором сохраняется отчет. Для формирования отчета нажмите на кнопку "Готово". После формирования отчета по форме 38 его название попадает в список отчетов (рис. 1), а сам отчет открывается в окне программы Microsoft Excel.


Отчеты по типам времени

Режим "Отчет по типу времени" (рис. 1) позволяет создавать отчеты за выбранный период по типам времени, передаваемым в модуль "АиТ:\Зарплата". Режим открывается из подпункта "Отчет по типу времени" пункта "Отчеты" раздела "Режим" Главного меню.

Отчет может быть создан только для типов времени, у которых на закладке "Стыковки" установлен флаг "Передавать данные в зарплату". Помимо этого перед формированием отчета необходимо создать свод по соответствующему табельному листу и учесть его в модуле "АиТ:\Зарплата".

Рис. 1

Перед формированием отчета следует выполнить необходимые настройки: выделить сотрудников, по которым строится отчет, задать тип времени, период, за который строится отчет, задать шаблоны. Файл шаблона MS Excel rep_tv.xls и текстовый шаблон rep_tv.rep расположены в рабочей папке установки модуля \aitclient\tbu\Form.

После окончания настроек можно приступить к формированию отчета, нажав на кнопку RepForm дополнительной панели инструментов.


Отчеты по табельному листу

В модуле реализована возможность в окне "Формирование отчета" (рис.1) сформировать один отчет по форме Т-13 по одному или нескольким табельным листам.

Рис. 1.

Для того чтобы сформировать один отчет по одному или нескольким табельным листоам нужно:

1. Открыть окно со списком табельных листов кнопкой "Список табельных листов" Panel7 основной панели инструментов.

2. Выделить табельный лист, если отчет формируется по одному табельному листу, или несколько табельных листов.

Обращает внимание пользователей на тот факт, что табельные листы выделяются в списке поочередно. Сначала первый табельный лист следует сделать текущим, нажав левую кнопку мыши. При этом название текущего табельного листа в списке подчеркивается, слева от его номера появляется символ "стрелочка" Strelka. Затем щелкнуть правой кнопкой мыши по строке с текущим листом, в результате строка выделяется синим цветом. Аналогичные действия нужно выполнить для каждого табельного листа, по которым строится отчет.

3. Нажать на клавишу F4 или кнопку "Печать отчета" Print дополнительной панели инструментов.

4. В окне "Формирование отчета" (рис. 1) перейти на нужную закладку.

5. Выбрать шаблон, по которому будет формироваться отчет.

6. Установить флаг "Формировать один отчет для выделенных табельных листов", если отчет формируется по нескольким табельным листам. При снятом флаге формируется несколько отчетов по каждому табельному листу.

7. Нажать на кнопку RepForm панели инструментов для формирования отчета.

Список шаблонов в окне "Формирование отчетов" (рис. 1) можно редактировать. Недостающие шаблоны можно включить в список, руководствуясь инструкцией, приведенной в теме "Добавление нового отчета в список формируемых отчетов".

Внимание. По умолчанию созданные текстовые отчеты открываются в редакторе notepad. Чтобы изменить текстовый редактор, с которым работает модуль, нужно в файле ait.ini в секции [tabel] в строке editor=… указать полный путь к исполняемому файлу любого текстового редактора, например editor=C:\Program files\Windows NT\Accessories\wordpad.exe или C:\Program Files\Microsoft Office\Office WINWORD.EXE.

Шаблоны для отчетов

Для построения отчетов по табельному листу используется несколько шаблонов. Для получения унифицированной формы Т-13, утвержденной Госкомстатом РФ, в формате MS Word применяется тестовый шаблон t_13_full.rep и шаблон MS Word Т-13.dot.

Отчет по форме Т-13 можно сформировать в формате MS Excel. Для этого на закладку "Отчет MS Excel" нужно добавить шаблона t-13xls.xls в формате MS Excel и текстовый шаблон t-13xls.rep.

Можно получить отчет по упрощенной форме Т-13. Например, при использовании шаблона табельного листа daylist_xls.xls, daylist_xls.txe, daylist_xls.rep в отчете отсутствуют итоги за половину месяца и коды учета затрат при начислении зарплаты. Раздел неявок ограничен днями отпуска, больничного и командировок. Но учетные параметры шаблона соответствуют форме Т-13.

Отчет по унифицированной форме Т-12 "Табель учета рабочего времени" создается на основании шаблонов Т-12.xls и Т-12.rep (1 и 2 страницы – 1 раздел).

Отображение окладов в табельном листе

Для того чтобы отображать в отчетах поле "Оклад" из персональной карточки сотрудника, нужно в шаблоне проставить ключевое слово [ОКЛАД] и установить соответствующую настройку в модуле "АиТ:\Конфигурация" в окне "Настройки комплекса". Для этого в разделе "Табельные листы" для параметра "Подтягивать поле оклад" следует задать значение "Да". Если поставить значение "Нет", то в отчетах вместо оклада будут отображаться нули.


Печать нескольких табельных листов

Пользователь может одновременно распечатать как один отчет по одному или группе табельных листов, так и несколько отчетов по группе табельных листов, причем по каждому табельному листу формируется отдельный отчет.

Для печати нескольких отчетов по группе табельных листов нужно:

1. Открыть окно (рис. 1) со списком табельных листов кнопкой "Список табельных листов" Panel7 основной панели инструментов.

Рис. 1

2. Выделить в окне по отдельности каждый табельный лист, входящий в группу. Для этого сначала следует сделать табельный лист текущим, нажав левую кнопку мыши. При этом название текущего табельного листа в списке подчеркивается, слева от его номера появляется символ "стрелочка" Strelka . Затем щелкнуть правой кнопкой мыши по строке с текущим листом, в результате строка выделяется синим цветом. Аналогичные действия нужно выполнить для каждого листа из группы.

3. Нажать на кнопку "Печать отчета" Print дополнительной панели инструментов или клавишу F4.

4. В окне "Формирование отчета" (рис. 2) нужно выбрать шаблон, по которому формируется отчет, и нажать на кнопку RepForm панели инструментов.

Рис. 2.

5. Перед формированием отчета по каждому табельному листу будет запрашиваться имя отчета (рис. 3).

Рис. 3.

Окно "Имя файла" (рис. 3) не будет открываться, если в файле ait.ini в раздел [tabel] ввести опцию:

[tabel]

ask_tlist_report_name=N

В этом случае имя файла, где хранится отчет, формируется автоматически.

6. Начинается процесс формирования отчетов, процент выполнения каждого отчета выводится на экран.

7. После окончания операции сформированные отчеты отображаются на экране. Чтобы все отчеты одновременно не открывались, в файл ait.ini в раздел [tabel] нужно ввести опцию:

[tabel]

open_tlist_result_file=N

При наличии такой настройки файлы сформированных отчетов запишутся в рабочую папку aitclient\tbu\TXT.


Отчеты по плановым графикам

Формирование отчета по плановым графикам осуществляется из окна "Список плановых графиков", а также из окна "Детализация графиков" кнопкой "Печать отчета" Print дополнительной панели инструментов или клавишей F4. При этом открывается окно "Формирование отчета" (рис.1), содержащее шаблоны отчетов по плановым графикам.

Дальнейшая работа по формированию отчета подробно описана в теме "Формирование отчета". После выполнения всех действий, описанных в этой теме, на экране отображается построенный отчет (см. рис. 2).

Рис. 1.

Все отчеты могут быть сформированы по любой группе плановых графиков, отобранных с использованием закладки "Поиск/Фильтр" окна "Список плановых графиков".

Внимание. В окне (рис. 1) пользователь также может добавить недостающие шаблоны, по которым строятся отчеты по плановым графикам. Процесс включения отчета в список подробно описан в теме "Добавление нового отчета в список формируемых отчетов".

Данные, включаемые в отчет

Из окна "Список плановых графиков" по шаблону t7_brvr76.* выводятся в отчет данные о суммарном времени за периоды текущего года (месяц, квартал, год), а при использовании шаблонов plan_year.rep и plan_year76.dot – детализация плановых графиков по месяцам текущего года.

Из окна "Детализация графиков" по шаблону planlist76.* в отчет выдается детальная информация по дням текущего (установленного в модуле) месяца. На рис. 2 приведен фрагмент отчета с 1 по 16 число текущего месяца, остальные дни на рисунке не отображаются.

Рис. 2


Отчеты по журналам

Отчеты по журналам позволяют получить сведения о каком-либо типе времени (больничном, отпуске, командировке, работе в праздничные дни и т. д.). Отчет может быть построен по заданному виду журнала, т. е. каждый отчет по журналу содержит сведения по одному типу времени, для которого предназначен этот журнал.

Формирования отчетов по журналу предполагает выполнение действий, осуществленных в следующей последовательности.

1. Открытие журнала кнопкой "Журналы" Panel8 основной панели инструментов.

2. Выбор вида журнала, по которому формируется отчет. Вид журнала указывается в верхнем поле.

3. Нажатие на кнопку "Печать отчета" Print дополнительной панели инструментов или клавишей F4. При этом открывается окно "Формирование отчета" (рис.1), содержащее шаблоны отчетов по журналам.

Рис. 1.

Внимание. В окне (рис. 1) пользователь может добавить недостающие шаблоны, по которым строятся отчеты по журналам. Процесс включения отчета в список подробно описан в теме "Добавление нового отчета в список формируемых отчетов".

4. В окне (рис. 1) пользователь должен выбрать шаблон, по которому создается отчет, и нажать на кнопку RepForm панели инструментов, указать имя файла, в котором будет сохранен отчет. Более подробно работа с этим окном описана в теме "Формирование отчета".

5. После выполнения всех действий, описанных в этой теме, на экране отображается построенный отчет за текущий месяц.

На рис. 2 в качестве примера представлен отчет по журналу, учитывающему выдаваемые сотрудникам больничные листы.

Рис. 2

Отчет по неоплаченным больничным листам

Кроме того, в окне "Журналы" можно формировать отчет по неоплаченным больничным листам, поступившим в текущем месяце.

Для этого необходимо произвести предварительную настройку. В модуле "АиТ:\Конфигурация" (режим "Настройки комплекса") для модуля "АиТ:\Табельный учет" нужно установить флаг "Отображать неоплаченные больничные с процентом".

В этом случае в окне "Журналы" для типов времени, которые передаются в модуль "АиТ:\Зарплата" как больничный лист, появится дополнительная закладка – "Не оплаченные".

Добавленная в журнал новая запись автоматически дублируется на закладку "Не оплаченные". В строке с этой записью отобразится дата начала последнего интервала непрерывного стажа, продолжительность непрерывного стажа на дату начала больничного листа и процент оплаты больничного листа. Следует заметить, что на закладке "Не оплаченные" отражаются все больничные, поступившие (т.е. введенные в окно) в текущем месяце, даже если они относятся к другому периоду.

После того, как свод по журналу проведен в модуле "АиТ:\Зарплата", больничный лист считается оплаченным и запись со сведениями о нем с закладки "Не оплаченные" удаляется. Если в модуле "АиТ:\Зарплата" аннулировать проведение свода по журналу, то запись о больничном листе вновь появляется на закладке "Не оплаченные".

Отчет по неоплаченным больничным листам, поступившим в текущем месяце, формируется с закладки "Не оплаченные".


Отчеты по хранимым процедурам

Для получения отчета по хранимой процедуре пользователь должен создать шаблон с расширением rep, содержащий блок

[STORED_PROCEDURE]

с непустым именем процедуры, например,

procedure_name=usp_test_tabel_report

Кроме этого в шаблоне в блоке настроек отчета по хранимой процедуре можно задать настройки, перечисленные в конце этой темы.

Для формирования отчета по хранимой процедуре нужно:

1. Открыть окно со списком табельных листов кнопкой "Список табельных листов" Panel7 основной панели инструментов.

2. Нажать на кнопку "Печать отчета" Print дополнительной панели инструментов или клавишу F4.

3. В окне "Формирование отчета" нужно выбрать шаблон, по которому формируется отчет, и нажать на кнопку RepForm панели инструментов.

Внимание. Если в окне "Формирование отчета" в списке отсутствует нужный шаблон, его необходимо добавить.

4. Перед формированием отчета будет запрашиваться имя отчета.

5. После окончания процесс формирования отчета, он выводится на экран.

В блоке настроек отчета по хранимой процедуре можно задать следующие настройки:

[STORED_PROCEDURE]

– наименование процедуры

procedure_name=usp_test_tabel_report

– сигнатура процедуры для вызова должна быть

create PROCEDURE [dbo].[usp_test_tabel_report] @p_user_id int, @p_mm int,

@p_yy int

AS

begin

– наименование таблицы для цикла. Таблица будет обрабатываться

– в блоках НАЧАЛО_ЦИКЛА, КОНЕЦ_ЦИКЛА

tmp_table_name=test_tabel_report

– наименование таблицы для титула. В этой таблице должна быть только одна строка, она используется для заполнения титула

table_titul_name=test_tabel_report_header

– порядок сортировки для цикла. Поля, по которым будет сортироваться отчет, указываются через запятую

order_sort=order_number


Общие ключевые слова

В данной теме приведен перечень ключевых слов, которые можно использовать в титульной части, шапке и теле шаблона отчета.

Титульная часть

Ключевое слово | Описание
ПРЕДПРИЯТИЕ | Название предприятия, организации.
МЕСЯЦ | Русское название установленного в модуле текущего месяца.
ГОД | Установленный текущий год.
ШАБЛОН_WORD | Имя выбранного пользователем *.dot файла (необходимо для корректного формирования документа).
ИМЯ_WORD | Указанное пользователем имя файла документа *.doc (необходимо для корректного формирования документа).
СИСТЕМНЫЙ_ГОД | Текущий для данного компьютера (установленный в операционной системе) год.
СИСТЕМНЫЙ_МЕСЯЦ | Текущий для данного компьютера (установленный в операционной системе) месяц (цифровое обозначение).
СИСТЕМНЫЙ_ДЕНЬ | Текущий для данного компьютера (установленный в операционной системе) день.

Шапка отчета

Ключевое слово | Описание
Н | Порядковый номер строки.
ПОДРАЗДЕЛЕНИЕ | Название подразделения.
МЕСЯЦ | Русское название установленного в модуле текущего месяца.
ГОД | Установленный текущий год.
ШАБЛОН_WORD | Имя выбранного пользователем *.dot файла (необходимо для корректного формирования документа).
ИМЯ_WORD | Указанное пользователем имя файла документа *.doc (необходимо для корректного формирования документа).

Тело отчета

Ключевое слово | Описание
Н | Порядковый номер строки.
ФИО | Фамилия И.О. сотрудника.
ТН | Табельный номер сотрудника.
ДОЛЖНОСТЬ | Должность сотрудника.
КАТЕГОРИЯ | Категория сотрудника.
ШАБЛОН_WORD | Имя выбранного пользователем *.dot файла (необходимо для корректного формирования документа).
ПОДРАЗДЕЛЕНИЕ | Название подразделения.
КОД_ВРЕМЕНИ | Код типа времени
ВРЕМЯ | Полное русскоязычное название типа времени.
NEXT | Переход на следующую строку при формировании документа MS Word.


Ключевые слова для настройки отчетов

Общие настройки документа.

Общие настройки определяют особенности формирования тела отчета и располагаются в rep-файле между словами:

#НАЧАЛО_НАСТРОЕК

#КОНЕЦ_НАСТРОЕК

Ключевое слово | Описание
В СПИСКЕ ТОЛЬКО РАБОЧЕЕ ВРЕМЯ | При печати отчетов в основной цикл включаются только строки, содержащие рабочее время.
ТОЛЬКО ТЕКУЩИЙ МЕСЯЦ | При печати отчетов в основной цикл включаются данные по табельному времени только за текущий месяц.
ГРУППИРОВКА ПО ФИО | При наличии на одного сотрудника нескольких строк фамилия и табельный номер выводятся только в первой встреченной строке. В остальных строках проставляются пробелы.
ГРУППИРОВКА ПО ПОДРАЗДЕЛЕНИЮ | При наличии на одно подразделение нескольких строк название и номер подразделения выводятся только в первой встреченной строке. В остальных строках проставляются пробелы.
ГРУППИРОВКА ПО ГРАФИКУ | При наличии на один график нескольких строк название и номер графика выводятся только в первой встреченной строке. В остальных строках проставляются пробелы.
РАЗБИВКА ПО ПОДРАЗДЕЛЕНИЮ | Перед первой строкой каждого подразделения вставляется текст шапки отчета. Отсчет строк таблицы при этом начинается с 1. Настройка необходима для формирования в MS WORD отдельной таблицы по каждому подразделению.
РАЗБИВКА ПО ФИЛЬТРУ | Перед первой строкой каждого фильтра вставляется текст шапки отчета. Отсчет строк таблицы при этом начинается с 1. Настройка необходима для формирования в MS WORD отдельной таблицы по каждому фильтру.
РАЗБИВКА ПО ГРАФИКУ | Перед первой строкой каждого графика вставляется текст шапки отчета. Отсчет строк таблицы при этом начинается с 1. Настройка необходима для формирования в MS WORD отдельной таблицы по каждому графику.
РАЗБИВКА ПО МЕСЯЦУ | Перед первой строкой каждого месяца вставляется текст шапки отчета. Отсчет строк таблицы при этом начинается с 1. Настройка необходима для формирования в MS WORD отдельной таблицы по каждому месяцу.


Ключевые слова для табельных листов

В данной теме приведены ключевые слова, используемые в титульной части, шапке и теле шаблонов отчетов по табельным листам. Кроме перечисленных ключевых слов в этом шаблоне могут использоваться общие ключевые слова для всех шаблонов отчетов.

Титульная часть

Ключевое слово | Описание
КОД | Код табельного листа.
НАЗВАНИЕ | Название табельного листа.
ОТЧЕТНЫЙ_ ПЕРИОД_С | Дата начала отчетного периода
ОТЧЕТНЫЙ_ ПЕРИОД_ПО | Дата окончания отчетного периода

Шапка отчета

ФИО | Фамилия И.О. сотрудника.
ТН | Табельный номер сотрудника.
ПОДРАЗДЕЛЕНИЕ | Название подразделения.

Тело отчета

ДНИ_ИТ1/2 | Количество дней по типу времени за первую половину месяца (1-15 число).
ЧАСЫ_ИТ1/2 | Количество часов по типу времени за первую половину месяца (1-15 число).
ДНИ_ИТ2/2 | Количество дней по типу времени за вторую половину месяца (16-31 число).
ЧАСЫ_ИТ2/2 | Количество часов по типу времени за вторую половину месяца (16-31 число).
ДНИ_ИТ | Сумма дней по типу времени за месяц.
ЧАС_ИТ | Сумма часов по типу времени за месяц.
ДНИ_ПЛ | Плановая сумма рабочих дней за месяц.
ЧАС_ПЛ | Плановая сумма рабочих часов за месяц.
Д1….Д31 | Значения по типам времени за каждый день.
дни_(Z) | Сумма дней за месяц по типу времени, где "Z" – краткий пользовательский код этого типа времени.
ЧАСЫ_(Z) | Сумма часов за месяц по типу времени, где "Z" – краткий пользовательский код этого типа времени.
ДНИ_ИТ1/2_(Z) | Сумма дней по пользовательскому коду типа времени за первую половину месяца
ЧАСЫ_ИТ1/2_(Z) | Сумма часов по пользовательскому коду типа времени за первую половину месяца
ДНИ_ИТ2/2_(Z) | Сумма дней по пользовательскому коду типа времени за вторую половину месяца
ЧАСЫ_ИТ2/2_(Z) | Сумма часов по пользовательскому коду типа времени за вторую половину месяца


Ключевые слова для плановых графиков

В данной теме приведены ключевые слова, используемые в теле шаблонов отчетов по плановым графикам. Кроме перечисленных ключевых слов в этом шаблоне могут также использоваться общие ключевые слова для всех шаблонов отчетов.

Тело отчета

Ключевое слово | Описание
ГРАФИК | Код графика
ГРАФИК_НАЗВАНИЕ | Название графика
Д1….Д31 | Значения по типам времени за каждый день.
ДНИ_ИТ | Сумма дней по типу времени за месяц.
ЧАС_ИТ | Сумма часов по типу времени за месяц.
ПЛАНОВЫЕ_ДНИ/ ЧАСЫ _(<значение>) | Плановые дни/часы за месяц или квартал. <значение> может равняться: 1-12 – номер месяца, кв1-кв4 – номер квартала, кв5 – год.


Ключевые слова для журналов

В данной теме приведены ключевые слова, используемые в шапке и теле шаблонов отчетов по журналам. Кроме перечисленных ключевых слов в этом шаблоне могут также использоваться общие ключевые слова для всех шаблонов отчетов.

Шапка отчета

Ключевое слово | Описание
Н | Порядковый номер строки.
Н_СОТР | Количество сотрудников в подразделении.
Р_ЛИСТОВ | Количество записей в журналах, относящихся к сотруднику текущего подразделения.

Тело отчета

НАЧАЛО | Дата начала периода в соответствующей записи в журнале.
ОКОНЧАНИЕ | Дата окончания периода в соответствующей записи в журнале.
ДНИ_ЖУР | Количество рабочих дней, соответствующих данной записи.
ЧАСЫ_ЖУР | Количество часов, приходящихся на каждый рабочий день в периоде по записи в журнале.
ПАРАМЕТР_НОМЕР | Содержимое поля "Номер документа".
ПАРАМЕТР_ДАТА | Содержимое поля "Дата документа".
ПАРАМЕТР_ТЕКСТ | Содержимое поля "Комментарий документа".
ПАРАМЕТР_1 | Содержимое первого строкового параметра записи.
ПАРАМЕТР_2 | Содержимое второго строкового параметра записи.
ПАРАМЕТР_3 | Содержимое третьего строкового параметра записи.
ПАРАМЕТР_4 | Содержимое четвертого строкового параметра записи.
ПАРАМЕТР_5 | Содержимое пятого строкового параметра записи.
Н_СОТР | Количество сотрудников в подразделении.
Н_ЛИСТОВ | Количество записей в журналах, относящихся к сотруднику текущего подразделения.
ПРОЦЕНТ_БЛ | Процент больничного листа с учетом данных о непрерывном стаже.


Ключевые слова для отчетов по предприятию

В данной теме приведены ключевые слова, используемые в титульной части, шапке и теле шаблонов отчетов по журналам. Кроме перечисленных ключевых слов в этом шаблоне могут также использоваться общие ключевые слова для всех шаблонов отчетов.

Титульная часть

Ключевое слово | Описание
ПЕРИОД | Полное название периода, по которому производился расчет.

Шапка отчета

НАЗВАНИЕ_ФИЛЬТРА | Пользовательское название фильтра
КОД_ФИЛЬТРА | Пользовательский код фильтра

Тело отчета

ПАРАМЕТР_ИТ_(<xx>) | Итоги по отдельным параметрам, где <xx>- порядковый номер параметра
ПАРАМЕТР_(<xx>) | Значения отдельных параметров, где <xx>- порядковый номер параметра


Ключевые слова для формы Т-13

 Top Previous

В данной теме приведены ключевые слова, используемые в теле шаблонов по унифицированной форме Т-13. Кроме перечисленных ключевых слов в этом шаблоне могут также использоваться общие ключевые слова для всех шаблонов отчетов.

Тело отчета

Ключевое слово | Описание
ДБ1….ДБ31 | Код типа времени за каждый день
ДЦ1….ДЦ31 | Значения рабочего времени за каждый день
НЕЯВКА_КОД1, … , НЕЯВКА_КОД1 | Коды нерабочих типов времени, значения которых для данного сотрудника за данный месяц больше нуля.
НЕЯВКА_ДНИ1, … , НЕЯВКА_ДНИ8 | Дни нерабочих типов времени, значения которых для данного сотрудника за данный месяц больше нуля.
НЕЯВКА_ЧАСЫ1, … , НЕЯВКА_ЧАСЫ8 | Часы нерабочих типов времени, значения которых для данного сотрудника за данный месяц больше нуля.
НЕЯВКА_ДНИ_ЧАСЫ1, … ,НЕЯВКА_ДНИ_ЧАСЫ8 | Дни (часы) нерабочих типов времени, значения которых для данного сотрудника за данный месяц больше нуля.
ОПЛАТА_КОД1,…, ОПЛАТА_КОД4 | Код начисления из справочника начислений, соответствующий типу времени
ОПЛАТА_ЗАКАЗ1,…, ОПЛАТА_ЗАКАЗ4 | Код затрат, соответствующий типу времени
ОПЛАТА_ДНИ_ЧАСЫ1, …, ОПЛАТА_ДНИ_ЧАСЫ4 | Сумма дней (часов) для оплаты по данному типу времени
ОПЛАТа_ДНИ1, …, ОПЛАТА_ДНИ4 | Сумма дней для оплаты по данному типу времени
ОПЛАТа_ЧАСЫ1, …, ОПЛАТА_ЧАСЫ4 | Сумма часов для оплаты по данному типу времени
ДОБАВЛЯТЬ ИТОГИ | Суммарные итоговые данные по отработанному времени в днях/часах за полмесяца/месяц по всем сотрудникам табельного листа.
НАЧИСЛЕНИЯ И НЕЯВКИ ТОЛЬКО В Р.В. | "Данные для начисления заработной платы по видам и направлениям затрат" для каждого сотрудника нужно показать только в одной строке с типом времени "Рабочее время".


Пример использования настройки "Активно"

 Top

В текущем месяце сотрудник находится в очередном отпуске. Виды начисления "Повременно" и "Оплата питания", имеющие статус "Постоянно", перешли из прошлого месяца и имеют настройку "Активно" выбранной. Если сотруднику удалить эти виды начислений, то расчет за текущий месяц будет нулевой. Но в следующем месяце эти начисления надо будет вводить вновь. Если этим начислениям снять настройку "Активно", то расчет тоже будет нулевой. Но после закрытия месяца эти начисления перейдут в карточку начисления и их не надо будет вводить вновь. Этот же способ можно применить когда необходимо сделать пробный расчет в котором участвуют не все введенные начисления, а только часть из них.


Описание алгоритмов пересчета дней

 Top

Среднедневная сумма для расчета отпуска рассчитывается путем деления суммы зарплаты в расчетном периоде на число дней расчетного периода. Способ подсчета этого числа дней и определяется настройкой алгоритма отпускных. Выбор алгоритма из выпадающего списка осуществляется в окне "Настройка алгоритмов" (меню "Настройка", пункт "Алгоритмы", закладка "Отпуска") или в окне расчета отпуска (закладка "Алгоритмы").

Расчет по среднему числу дней/часов

Алгоритм расчета среднего заработка за день разработан согласно Постановлению Правительства РФ от 24 декабря 2007 г. N 922 "Об особенностях порядка исчисления средней заработной платы". В соответствии с алгоритмом средний дневной заработок для оплаты отпусков, предоставляемых в календарных днях, и выплаты компенсации за неиспользованные отпуска исчисляется путем деления суммы заработной платы, фактически начисленной за расчетный период, на 12 и на среднемесячное число календарных дней (29,4).

В случае если один или несколько месяцев расчетного периода отработаны не полностью или из него исключалось время в соответствии с пунктом 5 настоящего Положения, средний дневной заработок исчисляется путем деления суммы фактически начисленной заработной платы за расчетный период на сумму среднемесячного числа календарных дней (29,4), умноженного на количество полных календарных месяцев, и количества календарных дней в неполных календарных месяцах.

Количество календарных дней в неполном календарном месяце рассчитывается путем деления среднемесячного числа календарных дней (29,4) на количество календарных дней этого месяца и умножения на количество календарных дней, приходящихся на время, отработанное в данном месяце - в модуле они рассчитываются путем вычитания из календарных дней исключаемых дней и количества дней до дня приема, в случае, если в расчет отпуска попадает месяц приема сотрудника на работу не с начала месяца: [КЛ_Д] - [МИН_Д] - [ПРИЕМ_Д]

Для реализации данного алгоритма пересчета дней необходимо:

· В окне начисления отпуска на закладке "Алгоритмы" необходимо выбрать вид расчета - По среднему числу дней/часов и установить флажок пересчета дней по формуле - По формуле.
· На закладке "Отпуск-Вычисления" в столбце "Дни искл." помесячно показывается исключаемые дни из расчета отпуска.

Перечень ключевых слов, которые могут участвовать в формуле для дней пересчета:

[Ф_Д],[ПЛ_Д],[КЛ_Д],[МИН_Д],[НВК_Д],[ПРИЕМ_Д], [СУММА1],[СУММА2],[СУММА3],

где ПРИЕМ_Д – количество дней до дня приема, в случае, если в расчет отпуска попадает месяц приема сотрудника на работу не с начала месяца.

Дни пересчета могут быть рассчитаны по следующей формуле:

if([ПЛ_Д]>0 and [ПЛ_Д]=[Ф_Д], 29.4, if([Ф_Д]=0, 0, ([КЛ_Д]-[МИН_Д]-[ПРИЕМ_Д])*29.4/[КЛ_Д]))

Расчет отпуска по выбору клиента из расчета 12 или 3 месяцев указываются обычно по настройке в AIT.INI. Появилась возможность посмотреть за какой период расчета будет больше сумма отпускных, выбрав соответствующее количество месяцев для расчета средней не выходя из окна расчета отпуска.


Изменения в сборках

 Top

8 495 984 82 81

Сборка 18.1

1. Появилась возможность выдать свод из табельного листа по одному человеку. Для этого необходимо установить соответствующий фильтр.

t-13_A3.dot Форма Т-13 для печати

Шаблон табеля t-13.rep

#НАЧАЛО_НАСТРОЕК

//[В СПИСКЕ ТОЛЬКО РАБОЧЕЕ ВРЕМЯ]

[ГРУППИРОВКА ПО ФИО]

#КОНЕЦ_НАСТРОЕК

#НАЧАЛО_ТИТУЛ

[Header] // для Excel нет

[ШАБЛОН_WORD ] // для Excel нет

[Bookmarks] //закладки

!ГС:[СИСТЕМНЫЙ_ГОД]

!МС:[СИСТЕМНЫЙ_МЕСЯЦ]

!ДС:[СИСТЕМНЫЙ_ДЕНЬ]

!ПРЕДПРИЯТИЕ:[ПРЕДПРИЯТИЕ ]

!ТАБКАРТОЧКА:[НАЗВАНИЕ ]

!НОМЕР:[КОД]

!ГОД:[ГОД ]

!МЕСЯЦ:[МЕСЯЦ ]

!ОПС:[ОТЧЕТНЫЙ_ПЕРИОД_С]

!ОПП:[ОТЧЕТНЫЙ_ПЕРИОД_ПО]

!ДАТАС:[ОТЧЕТНЫЙ_ПЕРИОД_ПО]

[End]

[Cycle]

#КОНЕЦ_ТИТУЛ

#НАЧАЛО_ЦИКЛА

[ШАБЛОН_WORD ]

[Bookmarks]

!Н:[Н ]

!ФИО:[ФИО ]

!ТН:[ТН ]

!ДОЛЖНОСТЬ:[ДОЛЖНОСТЬ ]

!ДБ1:[ДБ1 ] ......

!ДБ31:[ДБ31 ]

!ДЦ1:[ДЦ1 ] .....

!ДЦ31:[ДЦ31 ]

!ДНИ_1П:[ДНИ_ИТ1/2 ]

!ЧАС_1П:[ЧАСЫ_ИТ1/2 ]

!ДНИ_2П:[ДНИ_ИТ2/2 ]

!ЧАС_2П:[ЧАСЫ_ИТ2/2 ]

!ДНИ_Ц:[ДНИ_ИТ]

!ЧАС_Ц:[ЧАС_ИТ]

!КО1:[ОПЛАТА_КОД1]....

!КО4:[ОПЛАТА_КОД4]

!ЗО1:[ОПЛАТА_ЗАКАЗ1] ......

!ЗО4:[ОПЛАТА_ЗАКАЗ4]

!ДЧО1:[ОПЛАТА_ДНИ_ЧАСЫ1]

!ДЧО2:[ОПЛАТА_ДНИ_ЧАСЫ2]

!ДЧО3:[ОПЛАТА_ДНИ_ЧАСЫ3]

!ДЧО4:[ОПЛАТА_ДНИ_ЧАСЫ4]

!КВ1:[НЕЯВКА_КОД1] .....

!КВ8:[НЕЯВКА_КОД8]

!ДЧВ1:[НЕЯВКА_ДНИ_ЧАСЫ1] ....

!ДЧВ8:[НЕЯВКА_ДНИ_ЧАСЫ8]

[Next]

#КОНЕЦ_ЦИКЛА

#НАЧАЛО_ПОДВАЛА_ОТЧЕТА

[End]

[Footer]

[ШАБЛОН_WORD ]

[Bookmarks]

!ПМЕСЯЦ1:[МЕСЯЦ ]

!ПГОД1:[ГОД ]

!ПМЕСЯЦ2:[МЕСЯЦ ]

!ПГОД2:[ГОД ]

!ГОДС:[СИСТЕМНЫЙ_ГОД]

!ГОДС1:[СИСТЕМНЫЙ_ГОД]

!МЕСЯЦС:[СИСТЕМНЫЙ_МЕСЯЦ]

!МЕСЯЦС1:[СИСТЕМНЫЙ_МЕСЯЦ]

!ДЕНЬС:[СИСТЕМНЫЙ_ДЕНЬ]

!ДЕНЬС1:[СИСТЕМНЫЙ_ДЕНЬ]

[End]

[SaveHuge]

[ИМЯ_WORD ]

#КОНЕЦ_ПОДВАЛА_ОТЧЕТА