Словарь терминов

 Top Next

A

Активное окно – открытое окно, в котором в текущий момент времени установлен курсор и разрешается редактировать данные. Заголовок активного окна окрашивается контрастным цветом.

Аналитические признаки (аналитика) – средство ведения аналитического учета. Аналитические признаки, используемые в программном комплексе "АиТ:\Управление персоналом", являются свойствами сотрудника или рабочего центра и объема работ, определенных в наряде на выполнение определенной работы. При передаче итогов для расчета заработной платы и себестоимости формируются начисления, содержащие аналитические признаки, заданные в наряде.

Архивные наряды – наряды, переданные в программу "АиТ:\Зарплата". Эти наряды редактировать запрещено, в списке нарядов они расположены на закладке "Архив".

Б

База данных – совокупность взаимосвязанных данных, размещаемая на сервере и используемая программными программами.

В

Выпадающие списки – используются для заполнения полей ввода значениями, установленными программой или пользователями при формировании справочников.

Вид рабочего центра – производственный объект (оборудование), например, станок, установка и др., на котором выполняются работы по производственным заданиям (нарядам). Является основной характеристикой рабочего центра, наряду с подразделением, на балансе которого он числится. Виды рабочих центров используются для группировки и возможности последующего анализа затрат, себестоимости продукции, изготовленной на объектах, имеющих одинаковые свойства.

Г

Главное меню – размещается в верхней строке основного окна под его заголовком и обеспечивает доступ к основным функциям и возможностям программы.

Генератор отчетов – программное средство для формирования выходных документов, создаваемых программой согласно их описаниям (шаблонам).

Д

Диалоги – окна, содержащие набор графических элементов, используемых для ввода данных и выбора параметров.

Дневной наряд – наряд, оформленный и рассчитанный на работу, выполненную в течение одного дня.

Дополнительная панель инструментов – панель инструментов, набор кнопок которой зависит от вида открытого окна и операций, выполняемых в нем.

Дополнительные суммы – доплаты к сумме за выполненную по наряду работу, например, за работу в ночное время, премии и т.д. Дополнительные суммы указываются в справочнике видов дополнительных сумм.

Дочернее окно – окно, размещающееся внутри основного окна.

Е

Единицы измерения – единицы измерения, используемые для определения объема выполненных работ.

З

Закладка — это элемент документа в формате Word, которому присвоено уникальное имя. Размещение ключевых слов в шаблоне осуществляется через механизм закладок (bookmarks), имена которых берутся из списка ключевых слов.

Закладка (окон) – название закладки (страницы) в многостраничном окне, а также особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку).

За период – тип наряда, выполняемый за указанный период, продолжительность которого не должна быть больше одного месяца.

И

Интерфейсные элементы – стандартные элементы графического интерфейса Windows (закладки, переключатели, флаги, выпадающие списки, поля ввода и др.).

К

Каталог– другое название папки, используется для хранения списка файлов и других вложенных папок (подкаталогов).

Команда – это последовательность действий, приводящих к определенному результату.

Ключевые слова – зарезервированные слова встроенного в программу языка программирования, используются при разработке шаблонов документов.

Л

Логин – системное имя пользователя, запрашиваемое при запуске программы.

М

Макет документа – это набор элементов (шапка, тело документа и подвал), содержащихся в шаблонах.

Мастер – средство графического интерфейса, которое представляет собой последовательно сменяющие друг друга диалоговые окна для выполнения задачи, которую можно разбить на этапы (шаги), например, Мастер приема сотрудника на работу.

Модальные окна – окна, функционирующие в монопольном режиме, когда они открыты, запрещен доступ к меню, кнопкам панелей инструментов и другим открытым окнам

Н

Новые наряды – наряды, которые разрешается редактировать, расположенные на закладке "Новые наряды" в списке нарядов.

Наряд – общее название документов, на основании которых происходит калькуляция объемов выполненных работ, их стоимости и распределения заработка по сотрудникам в соответствии с заданными критериями оплаты (коэффициента трудового участия, затраченного времени и др.). Каждый наряд содержит сведения о рабочем центре, т.е. о единице оборудования, на которой производились работы.

Наряд помесячный – наряд, оформленный и рассчитанный на работу, выполненную в течение календарного месяца.

Недочерние окна – окна, которые выходят за пределы основного окна, например, калькулятор, окна сообщений об ошибках.

Немодальные окна – позволяют осуществлять доступ к различным функциям программы без своего закрытия.

Норматив – расчетная норма времени на производство единицы продукции. Причем норматив является величиной, обратной скорости изготовления (размерность: время/штука).

О

Окно – это часть экрана, в которой выполняется вся работа с программой.

Основная панель инструментов – панель инструментов, содержащая постоянный набор кнопок, не зависящий от вида активного окна.

Основная сумма – сумма, предназначенная для оплаты по наряду и распределенная между членами бригады, выполняющими эту работу.

Основное окно – окно, открывающееся сразу же после запуска программы и содержащее меню, панель инструментов, открытые дочерние окна программы, а также значки свернутых дочерних окон.

Открытое окно – окно, которое размещается в основном окне программы или на рабочем столе компьютера, если окно является недочерним.

Отчет – аналитический документ, сформированный с учетом выбранных аналитических признаков на основе информации, содержащейся в карточках нарядов.

П

Панель инструментов – набор кнопок, обеспечивающий быстрый доступ ко многим режимам и функциям программы.

Папка (каталог) – элемент структуры файловой системы для упорядочения хранения программ и документов на диске и может вмещать как файлы, так и другие вложенные папки (подкаталоги). Папка на экране отображается с помощью значка, имеющего вид канцелярской папки.

Переключатель – одна из зависимых кнопок группы, предназначенная для выбора одного из взаимоисключающих условий.

Подразделение – элемент организационной структуры предприятия низшего уровня, в котором установлен производственный объект (станок, оборудование, установка и др.), на котором выполняется работа по нарядам.

Полосы прокрутки – используются для перемещения по тексту вверх/вниз (вертикальные полосы прокрутки) или влево/вправо (горизонтальные полосы прокрутки) в окнах, в полях списках или в таблицах.

Помесячный наряд – тип наряда, выполняемый за указанный месяц.

Р

Работы – перечень работ (изделий), выполняемых (производимых) на каждом рабочем центре с указанием единицы измерения, расценки, норматива и финансовых операций. Классификатор работ строится применительно к каждому рабочему центру и к подразделению через систему логинов – пользователей системы. Список работ, выполняемых на рабочем центре сотрудниками разных подразделений, отличается по составу для группировки и минимизации их (работ) количества. Такое построение классификатора связано с возможной специализацией подразделений.

Рабочий центр – понятие программы, которое характеризуется двумя взаимосвязанными атрибутами: производственным объектом (видом рабочего центра) и структурной единицей организационной структуры предприятия, на балансе которой он числится. Расходы по этим работам по нарядам могут быть отнесены на одну из статей затрат. При создании наряда рабочий центр однозначно определяет состав аналитических признаков наряда. Важным свойством рабочего центра является однозначная комбинация аналитических признаков.

Режим работы программы – совокупность функций и операций, доступных в текущем (активном) окне.

С

Свернутое (минимизированное) окно – открытое окно, которое отображается в виде значка в нижней части основного окна программы.

Свободные аналитические признаки – аналитические признаки, введенные пользователем. Их также называют дополнительными, в отличие от основных признаков (затрат, подразделений и категорий)

Скрипты – выполнимые файлы с расширением sql.

Список нарядов – экранная форма, в которой отражены все введенные пользователем наряды.

Справочник – это средство для просмотра и формирования справочной информации, которая хранится в таблицах базы данных и используется в программе.

Структура рабочих центров – указывается в справочнике и описывает отношения видов рабочих центров к производственным подразделениям. В структуре производится добавление и удаление рабочих центров, а также их соотнесение с аналитическими признаками.

Сумма наряда – общая сумма (основная и дополнительная), оплаченная за работу, выполненную по наряду, и предназначенная для распределения между членами бригады.

Т

Тип наряда – определяет календарный срок, в течение которого выполняется работа по наряду. Тип наряда (дневной, помесячный или за период) определяется в момент его создания.

Ф

Файл – поименованная целостная совокупность данных на диске, имеющая набор атрибутов (имя, расширение и др.).

Фильтр – инструмент программы, позволяющий отбирать определенную часть имеющейся информации по заданным условиям для просмотра на экране, выполнения расчетов или формирования отчетов.

Флаг – независимая кнопка, позволяющая выбрать одно из двух альтернативных условий.

Ц

Центр затрат – аналитический признак (подразделение), на которое отнесены затраты по данному виду оплаты.

Ш

Шаблон – текстовый файл определенной структуры с расширением (*.rep или *.dot). Используется для создания отчетов и выходных документов, содержит ключевые слова и набор элементов, отражающих содержание и внешний вид документа (отчета).


Принятые сокращения

 Top Previous Next

БД – база данных

ДПИ – дополнительная панель инструментов

КТУ – коэффициент трудового участия

ОПИ – основная панель инструментов

РФ – Российская федерация

СС – Справочная система

ТН – табельный номер

ФИО – фамилия, имя и отчество


Назначение программы и особенности функционирования

Программа "АиТ:\Учет выполненных работ" предназначена для учета индивидуальных и коллективных работ, выполненных в соответствии с производственными заданиями (нарядами) и обеспечивает расчет комплексных работ на основе системы расценок элементарных операций, нормативов времени и количества продукции. Программа позволяет накапливать данные о выполненных работах с учетом затраченного времени.

Гибкая настройка программы позволяет автоматизировать предприятия самого разного качества (в том числе, производственные, полиграфические, пищевые, энергетические, машиностроительные и другие), а также обеспечивает быстрый и корректный расчет начислений, связанных с отработанным временем и производственными заданиями.

В программе можно обрабатывать любые виды сдельной работы, выполняемые как индивидуально, так и бригадой с последующим распределением общего заработка. Программа позволяет производить обработку путевых листов с использованием различных надбавок за классность, экспедирование и др.

Распределение коллективного заработка производится с помощью гибкой системы алгоритмов, учитывающих индивидуальные коэффициенты и тарифные ставки, объем выполненной работы и отработанное время, различные константы и суммарные величины.

Программа функционирует в операционной среде Windows и входит в состав программного комплекса "АиТ:\Управление персоналом", включающего также программы "АиТ:\Кадровый учет", "АиТ:\Зарплата", "АиТ:\Табельный учет", "АиТ:\Персонифицированный пенсионный учет", "АиТ:\Управление обучением", "АиТ:\Конфигурация". Все программные модули для хранения данных используют общую базу данных. Программный комплекс поставляется вместе с инсталлятором – программой, которая автоматизирует большую часть работы, необходимой для его установки. Системное имя (логин) и пароль пользователя указываются в процессе установки серверной части комплекса.

Программа "АиТ:\Учет выполненных работ" не предусматривает автономной работы и может работать только совместно с программой "АиТ:\Табельный учет", т. к. в ней используются типы времени, созданные в программе "АиТ:\Табельный учет". Кроме этого данные об отработанном времени в рассматриваемую программу поступают из программы "АиТ:\Табельный учет", поэтому на момент получения данных в программе "АиТ:\Табельный учет" должны быть созданы табельные листы на сотрудников и рассчитаны предварительные итоги за тот период (месяц), за который оформляются наряды.

Для корректной обработки данных по нарядам в программе "АиТ:\Зарплата" необходимо создать начисления для оформления работ по нарядам и произвести настройку соответствия кодов начислений и данных нарядов. Кроме этого данные по сотрудникам о распределенных суммах и аналитике передаются в программу "АиТ:\Зарплата" для последующей их обработки и расчета заработной платы членам бригады, выполняющим работу по нарядам.

К основным функциональным возможностям программы относятся следующие:

▪ планирование и учет индивидуальных и коллективных нарядов;
▪ разработка структуры рабочих центров, ввод новых рабочих центров и их настройка;
▪ ведение и корректировка справочников работ, аналитики, видов рабочих центров, нарядов и дополнительных сумм, автоматизирующих оформление нарядов;
▪ накопление данных о выполненных работах;
▪ расчет стоимости комплексных работ на основе системы расценок элементарных операций;
▪ калькуляция объемов и фактических затрат при изготовлении продукции;
▪ формирование списка сотрудников (бригады), выполняющих работы по нарядам;
▪ импорт данных по работникам о фактически отработанном времени из табельных листов;
▪ возможность формирования собственных разнообразных формул расчета распределение общей суммы за выполненную работу между сотрудниками, учитывающих индивидуальные коэффициенты (КТУ), объемы выполненных работ и величину отработанного времени;
▪ расчет дополнительных сумм оплаты (надбавок) в качестве вознаграждения, например, за работу в вечернее и ночное время, за срочность, за качество работы (премиальные) и др.;
▪ ведение архива нарядов (производственных заданий);
▪ формирование аналитических и суммарных сводных отчетов (с учетом подробной аналитики по видам продукции, центрам затрат, заказам и др.). На основании построенных отчетов можно проводить анализ выполненных работ (по подразделениям, бригадам, сотрудникам, выполненным работам, виду продукции, рабочему центру, аналитическому признаку);
▪ передача результирующих итогов за учетный период в программу "АиТ:\Зарплата" в виде документа, являющегося основанием для начисления заработной платы.


Установка прав доступа к программе

Права на работу с программой "АиТ:\Учет выполненных работ" и с другими программами комплекса "АиТ:\Управление персоналом" устанавливаются в программе "АиТ:\Конфигурация" в режиме "Редактирование списка пользователей" на закладке "Общие" (рис. 1). В этом же окне необходимо назначить и роль пользователю, т.е. задать его полномочия и набор возможностей, которыми он будет обладать при работе с программой. Самыми большими правами на работу с программами обладает системный администратор.

Чтобы установить права на работу с программой требуется:

· в окне (рис. 1.1) сделать текущим пользователя, для которого будут установлены права на работу с программой, т.е. щелкнуть левой кнопкой мыши на логине, под которым текущий пользователь входит в программу "АиТ:\Учет выполненных работ". В этом случае слева от выбранного логина появится символ "стрелочка" [image] ;
· установить флаг "Права на работу с АиТ:\Учет выполненных работ".

Рис. 1

После установки прав на работу с программой, ее имя попадает в выпадающий список поля "Название модуля" на закладке "Роли" (рис. 2), что позволяет назначить роль пользователю, т.е.

Для назначения роли нужно:

· перейти на закладку "Роли";
· в поле "Название модуля" указать имя программы, для которой она назначается роль, обращаем внимание на тот факт, что никаких ролей не назначено;
· щелкнуть левой кнопкой мыши на левой панели под заголовком поля "Роль";
· нажать на кнопку "Создать" Added , под полем "Роль" появляется пустая строка;
· ввести имя роли пользователя в пустую строку из выпадающего списка (рис. 2).

Рис. 2

В том случае, когда пользователю не назначена роль, при запуске программы "АиТ:\Учет выполненных работ" выдается предупреждающее сообщение об ошибке (рис. 3), и программа закрывается.

Рис. 3


Настройка параметров запуска

Для работы с программой необходимо выполнить ряд настроек, а именно: установить права для работы с программой, создать базу данных, задать логин, пароль и путь к папке, в которую установлена программа. База данных создается во время установки серверной части программного комплекса.

Работа с программой возможна после ее успешного запуска. Первое окно программы, которое открывается после ее запуска, предназначено для регистрации пользователя. В нем запрашиваются системное имя (логин) и пароль на вход в программу, которые необходимо задать еще до запуска программы в файле настроек AIT_KP.INI, иначе вход в программу будет запрещен. Для функционирования программы в этом файле необходимо также указать ряд других сведений, в частности, имя сервера и базу (базы) данных, используемых программой.

Первоначально все перечисленные сведения формируются в файле AIT_KP.INI автоматически в момент установки программного комплекса "АиТ:\Управление персоналом", но эти данные доступны для редактирования. Следует заметить, что для каждого программного модуля в их рабочие папки установки добавляются два настроечных файла AIT_KP.INI и AIT.INI. Структура файла AIT_KP.INI одинакова для всех программных модулей. Рассмотрим подробно структуру файла AIT_KP.INI и назначение каждого его раздела.

Пример файла AIT_KP.INI

[Common]

DBMS=MSS (Msoft) SQL Server 6.0

ServerName=ServerProg

[DB]

Title_1=АиТ: Управление персоналом

DB_1=ait_hr

Prefix_1=A

text_path_1=d:\aitclient\works\TXT

Title_2=Base2

DB_2=Base2

Prefix_2=A

text_path_2=d:\aitclient\works\TXT

[Login]

LastUser=sa

LastDb=1

LastRole=

Назначение разделов файла AIT_KP.INI

Настроечный файл AIT_KP.INI включает три раздела, каждый из которых содержит набор директив. Имя каждого раздела указывается в квадратных скобках, например, [Common]. Каждая директива размещается на отдельной строке.

В первом разделе [Common] необходимо задать имя SQL сервера, на котором размещаются базы данных, с которыми будет работать программа (клиентское место). Имя севера, например, ServerProg указывается в директиве ServerName после знака "=".

Второй раздел [DB] предназначен для перечисления имен баз данных, доступных на текущем клиентском месте и размещенных на SQL сервере, имя которого приведено в первом разделе. Для каждой базы данных задается четыре директивы (строки). Первая база имеет порядковый номер 1, который ставится в каждой директиве после знака "_", например, Title_1, вторая база имеет порядковый номер 2 (Title_2) и так далее. В первой директиве указывается наименование базы данных, отображаемое в окне регистрации пользователя, Также директива может содержать и дополнительный поясняющий текст, например, название программы

Title_1=АиТ: Управление персоналом

Во второй директиве указывается имя базы данных, под которым она зарегистрирована на сервере. В третьей и четвертой директивах заданы пути доступа к папкам с текстовыми файлами.

В третьем разделе [Login] в директиве LastUser можно указать логин пользователя, заданный системным администратором. Если логин задан, то при открытии программы он отображается в поле "Имя", иначе поле будет пустое и должно заполняться пользователем вручную.

В директиве LastDb можно проставить номер базы данных в списке. В этом случае при открытии программы база данных с заданным номером будет выделена. Но разрешается выбрать из списка другую базу данных, которая будет использоваться при работе с программой в текущем сеансе связи. После окончания работы с программой в этой директиве будет задан номер базы данных, с которым работала программа.

Файл AIT.INI

Файл настроек AIT.ini размещается в рабочей папке установки программы и имеет такую же структуру, что и файл AIT_KP.INI, т.е. состоит из нескольких разделов, содержащих набор директив.

Для запуска программы необходимо в первой директиве StartDir первого раздела [Start] указать путь к папке, в которой размещаются файлы программы (модуля), например,

[Start]

StartDir=d:\aitclient\works\

Назначения остальных разделов и директив будет рассматриваться в дальнейших книгах по мере описания работы с программой.

Только после правильной настройки этого файла и при наличии логина и пароля можно начинать работу с программным модулем "АиТ:\Учет выполненных работ".


Запуск программы

Запуск программы производится только из операционной среды Windows. Для запуска необходимо дважды щелкнуть на ярлыке (иконке) программы [image] или запустить на выполнение исполняемый файл aitworks.exe, расположенный в рабочей папке программы \aitclient\Works\. Наиболее быстрым и удобным способом является запуск программы с использованием ярлыка.

Программа может поставляться в аппаратно защищенном от нелегального тиражирования виде. В момент запуска программы в LPT- порте компьютера должен стоять электронный ключ из комплекта поставки.

Чтобы исключить несанкционированный доступ к программе и базе данных, сразу же после запуска программы на экране открывается окно регистрации пользователя (рис. 1). Для идентификации пользователя в верхней части окна находятся два поля для ввода системного имени (логина и пароля). В целях конфиденциальности при вводе пароля вводимые символы заменяются звездочками.

Рис. 1

В центральной части окна приводится одна или список баз данных, заданных в настроечном файле AIT_KP.INI. База данных, с которой будет работать пользователь в данном сеансе работы программы, должна быть выделена в списке.

В случае успешной регистрации происходит вход в программу, и на экране появляется основное окно программы, содержащее панель инструментов и Главное меню. Внутри основного окна размещается дочернее окно “Список нарядов”.


Линия консультаций и поддержки

Зарегистрированным пользователям комплекса предоставляются бесплатные услуги линии консультаций по телефону (не более 15 минут).

Для пользователей, имеющих абонементный договор, предоставляются неограниченные по времени консультации по телефону, факсу, почте и E-mail.

Телефон / Факс: | 8 495 984 82 81
Адрес офиса: | Москва, Б. Почтовая, д. 55/59
E-mail: | ait@aitsoft.ru
Web страница: | HTTP://www.aitsoft.ru


Варианты поставки

Комплекс "АиТ:\Управление персоналом" (рис. 1) использует клиент - серверную архитектуру. Это означает, что он включает в себя два компонента: клиентскую часть (рабочее место) и серверную часть (базу данных и средства управления базой). Клиентские части и база данных могут быть расположены на одном компьютере или на различных компьютерах в локальной сети. Количество рабочих мест, одновременно работающих с базой данных, прописывается в ключе электронной защиты и определяется количеством лицензий на клиентские места, а также максимальным количеством клиентских мест, допустимых для базы данных.

Рис. 1

Для хранения базы данных могут использоваться MS SQL Server 7.0 (2000) и его "облегченный" вариант – MSDE (Microsoft Database Engine). Соответственно и программа может поставляться в нескольких вариантах:

· В поставку версии для MSDE входит сервер баз данных MSDE. Управление базами данных на MSDE и работа со списком пользователей осуществляется с помощью программы "АиТ:\Конфигурация", входящего в поставку. Версия для MSDE поставляется с локальным (на одного пользователя) или сетевым (до пяти пользователей) ключом электронной защиты. В первом случае клиентская часть и база данных устанавливаются на одном компьютере, во втором случае желательно установить базу данных на специально выделенном компьютере (сервере).
· Версию для MS SQL Server 7.0 рекомендуется использовать на средних и крупных предприятиях. Для работы комплекса необходимо наличие уже установленного сервера MS SQL Server 7.0. В этом случае число пользователей базы данных определяется условиями договора. Все операции с базами данных осуществляются стандартными средствами администрирования MS SQL Server 7.0.


Рекомендумый порядок работы с программой

Данная тема позволяет получить первоначальное представление о работе программы "АиТ:\Учет выполненных работ". Для получения полной картины работы программа необходимо полностью прочитать данную Справочную систему и поработать с программой. Для начала работы с программой необходимо прочитать книгу "Основные сведения о программе", а также ознакомиться с возможностями работы Справочной системы.

Внимание. При первом открытии окно Справочной системы всегда размещается в верхнем правом углу экрана и его размер задан по умолчанию. Пользователь может установить размер окна и его размещение на экране по своему усмотрению. При последующих открытиях окна настройки, сделанные пользователем сохраняются.

При работе с программой следует придерживаться изложенного здесь порядка работы с программой.

1. Предварительная настройка, выполняемая системным администратором

Для того чтобы начать работу с программным модулем "АиТ:\Учет выполненных работ", системным администратором комплекса каждому пользователю должны быть определены его системное имя (логин) и пароль на вход в программу, так как все наряды жестко связаны с системным именем пользователя.

Кроме того, каждому пользователю в программе "АиТ:\Конфигурация" системным администратором также должны быть установлены права доступа к отдельным режимам работы с программой и выполнена настройка функциональных возможностей режимов программного модуля "АиТ:\Учет выполненных работ".

2. Предварительные настройки в программе "АиТ:\Табельный учет"

Программа "АиТ:\Учет выполненных работ" может работать только совместно с программой "АиТ:\Табельный учет", т. к. в ней используются типы времени, заданные в программе "АиТ:\Табельный учет". Настройка типов времени в программе "АиТ:\Табельный учет" осуществляется в окне "Типы времени" и зависит от выбранного пользователем способа оформления работ по нарядам. Следует заметить, что в одном случае требуется создавать новые типы времени, при другом способе – достаточно только настроить требуемые типы времени. Подробные сведения об этих способах и особенностях взаимодействия текущей программы с программами "АиТ:\Табельный учет" и "АиТ:\Зарплата" можно получить в теме "Организация взаимодействия с программой АиТ:\Табельный учет".

3. Предварительные настройки в программе "АиТ:\Зарплата"

Для корректной обработки данных по нарядам в программе "АиТ:\Зарплата" необходимо осуществить предварительные настройки:

· в справочнике начислений создать начисление для оформления работ по нарядам;
· произвести настройку соответствия кодов начислений и данных нарядов.

Более подробные сведения приведены в теме "Обработка данных по нарядам в программе "АиТ:\Зарплата"".

4. Настройка и ввод справочных данных

После проведения настроек в других программах, пользователь этой программы "АиТ:\Учет выполненных работ" может приступить непосредственно к настройке в самой программе. Настройку следует проводить в следующей последовательности:

· выполнить общие настройки в окне "Настройка". Прежде всего, на первой закладке "Аналитика" следует определить, нужно ли редактировать справочник аналитических признаков в этой программе, и выбрать сам справочник.

Работа закладкой "Типы времени" должна осуществляться только после настройки типов времени в программе "АиТ:\Табельный учет". На этой закладке нужно задать типы времени, которые будут использоваться в нарядах по основной работе и работе по замещению другого работника на его рабочем месте;

· настроить справочники в строго определенной последовательности. Настройка каждого справочника описана в отдельной теме в книге "Справочники";
· откорректировать или разработать новые формулы для расчета распределения сумм и расчета надбавок между членами бригады, выполняющей работу по наряду.

Внимание. Указанные действия проводятся на начальном этапе работы. В дальнейшей работе настройки, справочники и алгоритмы расчета могут подвергаться необходимой корректировке.

После выполнения описанных выше операций можно приступать непосредственно к текущей работе, учету работ, выполненных по нарядам.

5. Текущая работа

Данные о составе и объеме выполненных бригадами работ представлены в виде карточек нарядов. Карточки можно просматривать, редактировать, отбирать по периоду и переносить в архив.

В процессе работы последовательно выполняются следующие действия:

· создание новой карточки наряда;
· заполнение данных в карточке наряда в соответствии с инструкцией, приведенной в теме "Порядок оформления работ по нарядам";
· настройка печати карточки нарядов и печать нарядов;
· настройка и печать отчетов;
· передача информации в программу "АиТ:\Зарплата";
· внесение изменений в случае необходимости в наряды, уже переданные в программу "АиТ:\Зарплата".


Справочная система (Помощь)

Справочная система (Справка, Помощь) содержит основные сведения и порядок работы с программой "АиТ:\Учет выполненных работ". В затруднительных ситуациях Справочная система (СС) позволяет получить оперативную контекстно-зависимую помощь и может быть открыта одним из трех способов:

· кнопкой Basehelp0 панели инструментов;
· “горячей” клавишей F1.

Обращение к Справочной системе происходит из любого режима (окна) программы. Для получения контекстно-зависимой справочной информации по работе с конкретным окном, открытым в настоящий момент, нажмите на клавиши Shift+F1.

Показ разделов Справочной системы происходит в специальном окне, разделенном на две панели. В верхней части окна расположены кнопки, назначение которых описано в конце этого раздела.

Внимание. При первом открытии окно Справочной системы всегда размещается в верхнем правом углу экрана и его размер задан по умолчанию. Пользователь может установить размер окна и его размещение на экране по своему усмотрению. При последующих открытиях окна настройки, сделанные пользователем сохраняются.

Назначение левой панели окна Справочной системы

На правой панели отображается собственно справочная информация по текущему разделу, открытому программой или выбранному пользователем. Информация, приведенная на левой панели, зависит от выбранной закладки. Если ширина левой панели недостаточна для отображения всех четырех закладок, то справа от набора закладок (рис. 1) появляются кнопки Basehelp2 для перемещения по закладкам.

Рис. 1

На закладке "Содержание" приводится иерархический список папок с включенными в них разделами Справочной системы и отдельных разделов. Папки помечены значком папки Basehelp4 (свернутая папка) или Basehelp5 (раскрытая папка), а разделы – значком документа Basehelp6 . Раскрыть или свернуть папку можно, щелкнув на значке "+" или "-", расположенном слева от названия папки. В раскрытой папке видны все разделы, входящие в нее, и вложенные папки. Щелчок левой кнопки мыши на заголовке выбранного раздела приводит к показу выбранного раздела в правой части окна.

Закладка "Указатель" позволяет перейти к нужной теме по выбранному из списка ключевому слову. В верхней части закладки находится поле для ввода ключевого слова. Причем, если поле ввода под закладками страниц не заполнено, то показывается список ключевых слов, начиная с первой буквы алфавита "А". Открытие раздела производится двойным щелчком левой кнопкой мыши на ключевом слове или в результате его выделения и нажатия на кнопку "Показать". Если ключевое слово относится к нескольким разделам, то предварительно открывается окно "Найденные разделы" со списком разделов.

Если ключевое находится за пределами его видимости, то можно воспользоваться вертикальной полосой прокрутки или ввести его в верхнее поле. Пользователь может ввести ключевое слово (полностью или только несколько первых букв) вручную. Ключевое слово, в котором имеются введенные символы, выделяется и перемещается в самый верх списка.

Закладка "Поиск" обеспечивает переход к нужному разделу по конкретным словам, фразам, имеющимся в тексте Справочной системы, а также по отдельным выражениям с использованием текста и логических операторов AND, OR, NEAR, NOT (рис. 2). Показ списка логических операторов происходит после нажатия на кнопку Basehelp7 .

Рис. 2

После ввода фрагмента текста нажмите на кнопку "Разделы", в результате в нижней части отобразится список разделов, удовлетворяющих заданному выражению. Выбранный в списке раздел показывается в правой части окна.

Закладка "Избранное" предназначена для быстрого показа наиболее часто просматриваемых пользователем разделов. Предварительно нужные разделы должны быть перечислены на этой закладке. Для этого сначала требуется открыть нужный раздел на другой закладке, а затем перейти на эту закладку. Заголовок открытого в данный момент раздела Справочной системы отображается в нижней части закладки в поле "Текущий раздел". После нажатия на кнопку "Добавить" выбранный раздел попадает в список разделов. Исключение ненужного раздела из списка выполняется кнопкой "Удалить".

Назначение правой панели окна Справочной системы

Правая панель служит для непосредственного представления на экране текста выбранного раздела (темы). Перемещаться по тексту раздела можно так же, как и в обычном окне редактирования, а также по словам (ссылкам), выделенным голубым цветом. В окне Справочной системы действуют команды текстового редактора, что позволяет выделить в нем текст, скопировать его или перенести в любой другой документ.

Быстрый переход к другому разделу выполняется по ссылкам внутри темы или по иерархическому списку разделов, ключевых слов, тексту для поиска, отображаемому в левой части окна. При остановке на ключевом слове указатель мыши меняет свой внешний вид со "стрелки" на изображение "руки". Щелчок на таком слове приводит к открытию на экране раздела, в котором содержится более подробная информация о подчеркнутом понятии (термине).

В верхней части окна Справочной системы расположены кнопки, обеспечивающие следующие действия:

· Показать / Скрыть – отображение или скрытие содержания Справочной системы. При показе содержания кнопка называется "Скрыть", при его отсутствии – "Показать". Нажатие на кнопку "Скрыть" делает содержание невидимым и изменяет название кнопки;
· Назад – переход к последнему просмотренному разделу;
· Вперед – перемещение вперед по списку ранее открытых разделов;
· Домой – переход к первой теме "Словарь терминов" Справочной системы. Перемещение к нужному термину в этом разделе осуществляется нажатием на кнопку с буквой алфавита, совпадающей с первой буквой этого термина. Возврат в начало темы происходит по кнопке "Назад";
· Печать – печать текущего раздела или всей книги, содержащей текущий раздел.
· Параметры – открытие контекстного меню с набором команд.


Основные понятия (рабочий центр, наряд и др.)

В программе учет выполненных работ ведется в соответствии с производственными заданиями (нарядами). Наряд – общее название документов, на основании которых происходит калькуляция объемов выполненных работ, их стоимости и распределения заработка по сотрудникам в соответствии с заданными критериями оплаты (коэффициента трудового участия, затраченного времени и др.).

Программа обеспечивает расчет комплексных работ на основе системы расценок элементарных операций, нормативов времени и количества продукции. Работы могут выполняться коллективом специалистов (бригадой) или индивидуальным работником. За выполненную работу выплачивается единая денежная сумма, которая прописывается в наряде и распределяется между коллективом специалистов (бригадой), выполняющих ее.

Основополагающим понятием в программе является рабочий центр. Каждый наряд содержит сведения о рабочем центре. Рабочие центры предназначены для определения конкретного рабочего места (структурного подразделения и оборудования, на котором производились работы) и конкретной учитываемой в наряде работы. Расходы по этим работам могут быть отнесены на одну из статей затрат. Важным свойством рабочего центра является однозначная комбинация аналитических признаков. При создании наряда рабочий центр однозначно определяет состав аналитических признаков наряда.

Под работой понимается перечень работ (изделий), выполняемых (производимых) на каждом рабочем центре с указанием единицы измерения, расценки, норматива и финансовых операций. Классификатор работ строится применительно к каждому рабочему центру и к подразделению через систему логинов – пользователей системы. Список работ, выполняемых на рабочем центре сотрудниками разных подразделений, отличается по составу для группировки и минимизации их (работ) количества. Такое построение классификатора связано с возможной специализацией подразделений.

Следует различать понятия рабочий центр и вид рабочего центра. В соответствии с терминологией программы рабочий центр определяется как комбинация вида рабочего центра и структурной единицы предприятия (цех, подразделение), в которой он установлен. Под видом рабочего центра понимается производственный объект (станок, оборудование, установка и др.), на котором выполнялась работа по производственным заданиям (нарядам). В каждом подразделении может быть один или несколько рабочих центров. Таким образом, рабочий центр характеризуется двумя взаимосвязанными атрибутами: производственным объектом и структурной единицей предприятия, на балансе которой он числится.

Рассмотрим понятие рабочий центр на примере полиграфического комбината с тремя печатными цехами, в каждом из которых установлен полиграфический станок одной и той же марки ХХХ. В рассматриваемом случае рабочим центром № 1 является станок марки ХХХ, установленный в первом печатном цехе, рабочим центром № 2 станок того же вида, но установленный во втором печатном цехе и т. д.


Интерфейс программы

Программа "АиТ:\Учет выполненных работ" оснащена стандартным пользовательским интерфейсом, который включает сервисные средства, обеспечивающие доступ к основным функциям и режимам программы. Учитывая особую значимость пользовательского интерфейса для работы с программой, его описание приведено в отдельной папке. К стандартному пользовательскому интерфейсу программы относятся:

· окна программы;
· Главное меню;
· основная и дополнительная панели инструментов;
· элементы графического интерфейса окон.

Следует заметить, что Главное меню и панели инструментов располагаются в основном окне программы. Только одно окно в программе является основным окном, и в нем размещаются все дочерние окна программы, в отличие от недочерних окон, которые выходят за границы основного окна.

Основная работа с программой "АиТ:\Учет выполненных работ" происходит в окнах программы. Они содержат набор стандартных графических элементов (объектов) Windows (полей, флагов, переключателей и других), имеющих стандартный внешний вид и выполняющих стандартные действия. Доступ ко всем видимым элементам графического интерфейса осуществляется с помощью клавиатуры или устройства координатного ввода типа "мышь".

Следует заметить, что работа с использованием мыши является более предпочтительной благодаря своей простоте и оперативности. Для выполнения различных операций с помощью клавиатуры применяются специально предназначенные для этого клавиши, называемые, горячими клавишами. Например, вызов Главного меню осуществляется клавишей горячей клавишей F10.


Основное окно программы

Основное окно программы – это часть экрана, в которой выполняется вся работа с программой "АиТ:\Учет выполненных работ". Сразу же после запуска программы и успешной регистрации пользователя открывается основное окно, имеющее заголовок "АиТ:\Учет выполненных работ" (рис. 1). Заголовок любого окна отображается в самой верхней строке слева, а справа располагаются три кнопки управления окном ("Свернуть", "Развернуть", "Закрыть").

В программе "АиТ:\Учет выполненных работ" только одно окно является основным, и в нем в качестве заголовка указывается название программы. Окна, размещающиеся внутри основного окна, называются дочерними. После открытия программы внутри основного окна размещается дочернее окно с заголовком "Список нарядов".

Рис. 1

Под строкой заголовка основного окна, в отличие от других дочерних окон, находится Главное меню и основная панель инструментов, а вдоль левой стороны окна – дополнительная панель инструментов.

В процессе работы в рабочей области основного окна могут размещаться и другие открытые дочерние окна программы, а также значки свернутых дочерних окон. Обратите внимание дочерние окна, в отличие от основного окна, не содержат меню и панели инструментов, но так же, как и основное окно имеют заголовки. Виды окон и способы управления ими рассмотрены в отдельной теме. Окна программы содержат набор стандартных графических элементов Windows (полей, флагов, переключателей и других).

Любая операция в окне, например, выбор пункта меню, настройка параметров в любых окнах, ввод данных и т.д. осуществляется с помощью мыши. Поэтому в самом начале работы следует познакомиться с основными действиями, выполняемыми мышью: "щелчок", "двойной щелчок", "нажать на кнопку", "перетащить и отпустить".

Щелчок

Для выполнения "щелчка" следует быстро нажать и отпустить левую кнопку мыши.

Двойной щелчок

Для осуществления "двойного щелчка" нужно дважды нажать на левую кнопку мыши с минимальным интервалом между нажатиями.

Нажать на кнопку

Операции "нажать на кнопку" в окне означает следующее:

· установить указатель мыши на кнопке;
· нажать левую кнопку мыши и отпустить ее.

В результате будут выполнены действия, для которых предназначена эта кнопка.

Перетащить и отпустить

Метод "перетащить и отпустить" означает следующую последовательность действий:

1. установить указатель мыши на нужный объект, например, на строку;
2. нажать левую кнопку мыши;
3. не отпуская копку, переместить указатель мыши на нужную позицию экрана, при этом одновременно с мышью перемещается и объект (строка);
4. отпустить кнопку мыши.


Окна программы и способы управления ими

Окно программы – это часть экрана, в которой выполняется вся работа с программой "АиТ:\Учет выполненных работ". Окна предназначены для отображения каких-либо сведений в электронном виде, для ввода данных, настройки параметров и поиска информации. Настройка параметров в любых окнах производится путем установки или снятия флагов, выбора переключателей, ввода данных или формирования различных списков. Пользователь может изменить настройки, задаваемые по умолчанию, или оставить их прежними.

Программа позволяет работать в многооконном режиме, когда одновременно может быть открыто несколько окон (рис. 1). Сразу же после запуска программы и успешной регистрации пользователя открывается основного окна. Все остальные открытые окна программы размещаются внутри основного окна и называются дочерними окнами. Дочерние окна, в отличие от основного окна, не содержат Главное меню и кнопки панели инструментов.

После открытия программы внутри основного окна размещается дочернее окно с заголовком "Список нарядов". Все окна (основное и дочерние) снабжены заголовком и кнопками управления окнами.

Рис. 1

Несмотря на то, что в каждый момент времени в программе может быть открыто несколько окон, работать можно только с одним окном, которое называется активным, или текущим окном. Активным считается окно, в котором находится курсор, в нем можно, просматривать, вводить или редактировать данные. Заголовок активного окна имеет более контрастный цвет по сравнению с другими окнами, на рис. 1 – это окно "Настройка печати карточки наряда".

Список открытых в данный момент окон показывается под пунктами раздела "Окно" Главного меню программы. Одно и то же окно не может быть открыто дважды. Для открытия окон в программе используются пункты Главного меню и кнопки основной и дополнительной панелей инструментов. Открытие нового окна приводит к переходу в новый режим работы, под которым подразумевается совокупность функций и операций, доступных в данном окне. Переключение между открытыми окнами выполняется мышью или “горячими” клавишами Ctrl+Tab.

Назначение кнопок управления окном

Заголовок любого окна отображается в его самой верхней строке с левой стороны. В той же строке с правой стороны размещаются кнопки управления окном "Свернуть" Winroll , "Развернуть" Winunfold и/или "Закрыть" WinClose (рис. 1). У основного окна активны все три кнопки.

Самая правая кнопка "Закрыть" предназначена для закрытия окна. Если окно имеет только одну эту кнопку, то его можно также перемещать по экрану, но нельзя изменять его размеры и сворачивать. Для сворачивания окон используется кнопка "Свернуть". Свернутое окно является неактивным и размещается в нижней части основного окна в виде значка (рис. 2), но в любой момент времени его можно сделать активным и показать на экране его содержимое, щелкнув мышью на первой левой кнопке Winrestore свернутого окна.

Рис. 2

Окна, у которых активна кнопка "Свернуть", можно также перемещать по экрану и изменять их размеры. Окна на экране могут быть представлены в полноэкранном виде, если у них активна кнопка "Развернуть". Щелчок на ней увеличивает размер окна до полного экрана (рис. 3).

Рис. 3

В этом случае заголовок полноэкранного окна отображается после заголовка основного окна в квадратных скобках, а кнопки управления этим окном в той же строке, что и Главное меню, с правой стороны. Вернуть окно к прежнему размеру можно при помощи кнопки "Свернуть в окно" Interfacewin4 , которая появляется только в полноэкранном окне вместо кнопки "Развернуть".

Окна, у которых активны все три кнопки, на экране могут быть представлены в полноэкранном (рис. 2) или в свернутом виде (рис. 3), их можно закрывать, перемещать и изменять их размеры.

Чтобы изменить размер окна по одному направлению, например, по его высоте (длине) следует установить указатель мыши на горизонтальную (вертикальную) сторону рамки окна, щелкнуть левой кнопкой мыши, и, не отпуская ее, переместить указатель мыши в нужную позицию экрана вверх/вниз (вправо/влево). Вместе с курсором по экрану перемещается и контур окна. Для фиксации размеров окна отпустите кнопку мыши. Для увеличения размеров окна одновременно по двум направлениям расположите указатель мыши на угол окна и выполните те же действия, что и при изменении размера в одном направлении.

Управление окнами производится с помощью пунктов раздела "Окно" Главного меню программы. Данная группа функций позволяет переключаться между открытыми в программе в данный момент окнами и выполнять над ними определенные действия.


Виды окон

Все окна программы могут быть классифицированы по различным критериям.

Открытое окно – окно, которое размещается в основном окне программы или на рабочем столе компьютера, если оно является недочерним. Все открытые окна программы вызываются только из основного окна и закрываются в момент окончания работы с программой. Только одно из открытых дочерних окон может быть активным.

Активное окно – открытое окно, в котором в текущий момент времени установлен курсор и разрешается редактировать данные. Заголовок активного окна окрашивается контрастным цветом.

Свернутое (минимизированное) окно – открытое окно, которое отображается в нижней части основного окна программы в виде значка (рис. 1). На рис. 1 показано три свернутых окна программы: "Справочник работ", "Структура рабочих центров" и "Карточка наряда".

Рис. 1

В программе все окна по их местоположению относительно основного окна классифицируются на следующие виды:

· дочерние окна – окна, размещающиеся внутри основного окна;
· недочерние окна – программные окна, которые выходят за пределы основного окна, например, калькулятор, окна сообщений об ошибках. Свернутые недочерние окна отображаются на панели задач в виде кнопки так же, как и запущенные программы, например, текущая программа (рис. 2). По умолчанию панель задач находится в нижней части экрана монитора. Чтобы закрыть текущую кнопку на панели задач, щелкните на ней правой кнопкой мыши и выберите команду "Закрыть" или нажмите на клавиши Alt+F4.

Рис. 2

В зависимости от возможности доступа к другим режимам окна подразделяются на два типа:

· модальные окна – работают в монопольном режиме, когда они открыты, запрещен доступ к меню, кнопкам панели инструментов и другим режимам работы (окнам). Типичным представителем модальных окон является окно Мастеров формирования стандартных отчетов;
· немодальные окна – позволяют осуществлять доступ к различным функциям программы без своего закрытия.

По количеству страниц (закладок) окна подразделяются на:

· одностраничные – окна, у которых отсутствуют закладки, например, окно "Новый наряд";
· многостраничные – окна, имеющие набор закладок, например, карточка наряда. Переход на нужную закладку выполняется щелчком мыши на одноименной кнопке (закладке), обычно расположенной в верхней части окна.

По содержанию отображаемых данных и внешнему виду окна делятся на следующие виды:

· карточки – электронные документы, используемые в программе и содержащие сведения о каком-либо субъекте или объекте (карточка наряда и др.) и имеющие произвольное расположение полей ввода и вывода информации;
· отчеты – окна, в которых приводятся результаты построения отчета. Обычно отчеты отображаются в других программах Word, Excel;
· документы – окна, в которых отображаются различного рода документы, используемые при учете работ, выполненных по производственным заданиям (нарядам);
· настроечные окна – окна, используемые для настроек, например, окна для общих настроек программы, настройки печати карточки наряда, настройки отчетов и другие окна. Настройка параметров в этих окнах производится путем установки или снятия флагов, выбора переключателей, ввода данных или формирования различных списков. Пользователь может изменить настройки, задаваемые по умолчанию, или оставить их прежними;
· окна-списки – окна, в которых информация представлена в виде списков в иерархическом или табличном виде. Иерархические списки можно отображать в свернутом (компактном виде) или развернутом виде с показом одной, нескольких или всех вложенных групп данных. Окна с иерархическими списками используются для отображения структуры предприятия.


Главное меню

Главное меню обеспечивает доступ к основным функциям и возможностям программы, имеет иерархическую структуру и включает три уровня меню. Верхний уровень Главного меню (рис. 1) включает несколько разделов (например, "Документы", "Сервис" и т.д.) и всегда показывается под заголовком основного окна программы "АиТ:\Учет выполненных работ".

Рис. 1

Каждый раздел содержит набор пунктов. Отдельные пункты Главного меню продублированы кнопками основной панели инструментов. В нижней части основного окна программы при выборе пункта меню выводится его назначение.

Для доступа к пунктам щелкните левой кнопкой мыши на требуемом разделе Главного меню. В результате на экране непосредственно под выбранным разделом отображается список всех пунктов этого раздела меню. Второй уровень меню, содержащий список пунктов раздела, по способу отображения называется также выпадающим меню. На рис. 1 показано выпадающее меню для раздела "Документы". Пункты меню, не содержащие подпунктов, называются командами. Под командой понимается последовательность действий, приводящих к определенному результату.

Выбор одного из пунктов раздела меню осуществляется щелчком левой кнопки мыши на нем и приводит к выполнению определенного действия, для которого он предназначен, например, команда "Каскад" раздела "Сервис" располагает открытые окон в виде стопки. Выполнение большинства команд приводит к открытию нового окна и соответственно переходу в новый режим работы, под которым подразумевается совокупность функций и операций, доступных в данном окне. Свернутое (минимизированное) окно отображается на основном окне программы в виде значка.

Главное меню содержит следующие разделы:

· Документы
· Справочники
· Сервис
· Окно
· Выход – раздел содержит только один пункт "Выход", предназначенный для закрытия всех открытых окон и завершение работы с программой. Аналогичное действие происходит при нажатии на клавиши Alt+F4 или на кнопку Panel13 .
· ?


Раздел "Документы"

Раздел "Документы" Главного меню включает набор пунктов, обеспечивающих операции с документами (нарядами) и формирования по ним отчетов.

Назначение пунктов меню раздела "Документы"

Открыть карточку Alt+F2 Open

Открытие текущей карточки наряда, на строке которой в списке нарядов установлен курсор.

Список panal2

Открытие списка всех введенных нарядов, созданных в пределах установленного периода времени.

Отчеты Alt+P Panal3

Формирование отчетов по нарядам, сформированных Мастером.

Генератор документов F4

Вызов генератора документов для формирования документов по нарядам на основе разработанных шаблонов.


Раздел "Справочники"

Раздел "Справочники" Главного меню открывает доступ к справочникам для их просмотра и редактирования. Если пользователь обладает правом доступа к какому-либо справочнику, то в разделе "Справочники" отсутствует пункт для его вызова.

Назначение пунктов меню раздела "Справочники"

Справочник работ Panal4

Справочник предназначен для формирования собственного набора работ для каждого рабочего центра, перечисленного в структуре рабочих центров.

Справочник видов рабочих центров Panal6

Открытие справочника для ввода видов рабочих центров (станка, установки и др. производственных объектов), используемых в программе.

Справочник единиц измерения

Заполнение справочника единиц измерения, используемого для формирования справочника работ и производственного задания в карточке наряда.

Справочник аналитики

Просмотр и заполнение значений аналитического признака, выбранного в настройках программы.

Виды нарядов

Ввод и редактирование видов нарядов, которые необходимо отдельно учитывать в программе "АиТ:\Учет выполненных работ" и отдельно обрабатывать в программе "АиТ:\Зарплата".

Виды дополнительных сумм

Вызов справочника с видами дополнительных сумм, используемых для поощрения сотрудников.


Раздел "Сервис"

Раздел "Сервис" Главного меню включает набор пунктов, обеспечивающих выполнение сервисных операций, необходимых для работы с программой.

Назначение пунктов меню раздела "Сервис"

Структура рабочих центров Panal5

Ввод и настройка справочника рабочих центров.

Формулы Panal7

Открытие окна для создания расчетных формул, используемых для распределения сумм по наряду среди членов бригады.

Фильтр Panal8

Вызов окна "Фильтр" для формирования условия отбора данных по заранее определенным параметрам.

Проверка сумм Panal9

Вызов режима для проверки карточек нарядов на соответствие сумм по нарядам суммам по работам и по сотрудникам, выполняющим работу по наряду.

Калькулятор Ctrl+F2 Panal10

Вызов калькулятора для расчета арифметических выражений любой сложности.

Настройка

Установка общих настроек программы на рабочем месте пользователя: выбор редактируемого аналитического признака и настройка соответствия типа времени в табеле и рабочего времени в нарядах.

Параметры печати карточки наряда

Открытия окна для выбора содержания отчета по карточке наряда и настройки параметров для печати карточки наряда.

Настройка редактора

Вызов окна для выбора текстового редактора.


Раздел "Окно"

Раздел "Окно" Главного меню управляет расположением на экране открытых окон и значков свернутых окон, а также позволяет запомнить положение окна.

Назначение пунктов раздела "Окно"

Каскад

Располагает окна в виде стопки, последовательно с частичным наложением друг на друга таким образом, чтобы на экране всегда был виден заголовок каждого окна и его левая вертикальная сторона. Активное в данный момент окно помещается в самый верх стопки.

Мозаика

Располагает в основном окне все открытые дочерние окна вертикально без перекрытия, чтобы был виден фрагмент каждого окна.

Горизонт

Располагает в основном окне все открытые дочерние окна горизонтально без перекрытия, чтобы был виден фрагмент каждого окна.

Упорядочить значки

Располагает все значки открытых, но свернутых окон упорядоченно в нижней строке основного окна, если до этого значки в области основного окна размещались в произвольном порядке.

Запомнить положение окна Ctrl+W

Запоминает положение и размеры активного в настоящий момент окна. При последующем открытии это окно появляется в том же месте экрана, в котором находилось в момент закрытия программы.

Список открытых окон

Одно и то же окно не может быть открыто дважды. Переключение между открытыми окнами производится мышью или клавишами Ctrl+Tab. Под пунктами раздела "Окно" Главного меню выводится список открытых в данный момент окон (рис. 1).

В каждый момент времени только одно окно может быть активным, в списке окон слева от его названия установлен флаг Flag . Щелчок мыши на заголовке окна в списке делает его активным, в списке окон флаг устанавливается слева от названия этого окна и снимается флаг с открытого окна, которое было до этого активным. На рис. 1 активным становится окно "Список нарядов".

Рис. 1


Раздел "?"

Раздел "?" Главного меню программы открывает доступ Справочной системе (Справке, Помощи), содержащей основные сведения и порядок работы с программой "АиТ:\Учет выполненных работ".

Назначение пунктов меню раздела "?"

Содержание Cправки F1

Показ оглавления Справочной системы программы.

Контекстная справка Shift+F1

Открывает тему Справочной системы, описывающую работу с текущим окном программы. Для получения контекстно-зависимой справочной информации можно также воспользоваться клавишами Shift+F1 или кнопкой Panel12 основной панели инструментов.

Поиск справки по .... Ctrl+F1

Поиск справочных сведений по ключевым словам. Справочная система открывается на закладке "Указатель" с перечнем ключевых слов.

О программе

Открывается окно со сведениями о программе и ее производителе – компании "АиТ Софт". В окне указывается номер и тип версии (Базовая, Проф, Холдинг), номер и дата сборки, имя базы данных. Для контактов с компанией сообщаются телефоны горячей линии, факс, почтовый и электронный адрес (e-mail), а также адрес официальной страницы (web-адрес) компании в сети Интернет.


Панель инструментов

Основная панель инструментов

Основная панель инструментов (рис. 1) расположена в верхней части основного окна программы под разделами Главного меню и содержит набор кнопок, посредством которых осуществляется быстрый доступ к основным режимам и функциям программы. Набор кнопок является постоянным и не зависит от вида открытого окна. Основная панель отображается на экране даже в том случае, когда закрыты все окна.

Действия кнопок основной панели аналогичны пунктам меню, но доступ к ним более оперативен. Однако не все пункты меню продублированы кнопками панели инструментов.

Рис. 1

Щелчок по кнопке панели инструментов приводит к открытию нового окна и соответственно переходу в новый режим, под которым подразумевается совокупность функций и операций, доступных в данном окне. Свернутое (минимизированное) окно отображается в основном окне программы в виде значка.

В нижней части активного окна программы при выборе кнопки панели инструментов выводится полное наименование выбранного режима. Если, не нажимая, установить указатель мыши на одну из кнопок панели инструментов, рядом с ней появится всплывающая подсказка, характеризующая краткое назначение режима.

Дополнительная панель инструментов

Дополнительная панель инструментов показывается в основном окне программы и содержит переменный набор кнопок, который зависит от конкретного активного окна. Состав кнопок дополнительной панели инструментов определяется автоматически программой и зависит от вида активного окна и действий, доступных в нем. Для некоторых активных окон дополнительная панель не отображается, например, для окна "Сводные отчеты по нарядам".

По умолчанию кнопки размещены на вертикальной панели с левой стороны основного окна (рис. 1). Как и кнопки основной панели инструментов, они имеют всплывающую подсказку, поясняющую назначение этой кнопки. При переводе курсора мыши на графическую кнопку возле нее появляется всплывающая подсказка на желтом фоне, дублирующая данные в статусной строке внизу окна.

Внимание. Если в текущий момент все окна закрыты, то кнопки дополнительной панели на экране не отображаются.


Графический интерфейс окна

В окнах программы могут отображаться стандартные элементы графического интерфейса Windows: кнопки, переключатели, флаги, списки, поля для ввода значений и другие, перечисленные в данной теме. Каждый из этих видимых экранных элементов выполняет определенную функцию или действие или используется для настройки параметров в окнах.

Кнопка – типовой элемент графического интерфейса, в окне изображается в виде прямоугольника с надписью, например, кнопка "Показать" на рис. 1. Нажатие на кнопку вызывает действие, указанное на этой кнопке (показать все данные за указанный период времени).

Рис. 1

Кнопки (закладки) – особый вид кнопок, расположенных под заголовком окна и позволяющих перейти на нужную страницу (закладку) в многостраничном окне. Например, на приведенном ниже рисунке (рис. 2) для списка нарядов показаны две кнопки (закладки): "Новые наряды" и "Архив". Переход с закладки на закладку осуществляется щелчком мыши на ее закладке (кнопке).

Рис. 2

Блок – набор графических элементов, объединенных по назначению и находящихся внутри рамки, прорисованной белым цветом. Например, на рис. 3 блок "Подразделения" включает два переключателя, таблицу со списком подразделений и полосы прокрутки.

Рис. 3

Переключатели – представляют собой группу зависимых кнопок (рис. 4), называемых также радио-кнопками, они предназначены для отбора данных в ряде отчетов. На рис. 4 показан блок "Вид нарядов", состоящий из трех переключателей, используемых для выбора вида нарядов в окне "Проверка соответствия сумм по наряду".

Выбор переключателя производится щелчком левой кнопки мыши. В группе переключателей может быть выбран (включен) только один переключатель, который имеет вид кружка с точкой [image]. Остальные переключатели (кнопки) находятся в выключенном состоянии и изображаются на экране кружком без точки [image] .

Рис. 4

Флаг – независимая кнопка, состояние флага не зависит от состояния других кнопок. Флаг позволяет выбрать одно из двух альтернативных условий, снабжен заголовком для выбора условия и может находиться в одном из двух состояний:

· включен (установлен) – если условие флага необходимо выполнить. На экране установленный флаг изображается в виде квадрата, внутри которого расположена "галочка" FlagYes . Если флаг используется в таблицах, то он изображается в виде перечеркнутого квадрата [image] ;
· выключен (снят) – если условие флага необходимо отменить. На экране снятый флаг отображается в виде пустого квадрата FlagNo .

Установка и снятие флага производится щелчком мыши или клавишей Пробел, если флаг активен, т.е. заголовок флага (единица измерения) обведен пунктирной рамкой (рис. 5). Флаг "норматив" не активен.

Рис. 5

Поля ввода – применяются для ввода в них значений как непосредственно с клавиатуры, так и с использованием кнопок list выпадающего списка (рис. 8) и [image] прокрутки (рис. 6). Щелчок на стрелке вверх увеличивает значение на единицу, на стрелке вниз – уменьшает на единицу. Если это поле предназначено для ввода даты (рис. 5), то можно выделить один из ее фрагментов (день, месяц, год) и с помощью стрелок изменить только его.

Рис. 6

Поля списки – поля, содержащие списки различного назначения для выбора необходимых элементов. При больших списках эти поля снабжаются полосой прокрутки. Примером таких полей могут служить списки переменных в справочнике расчетных формул (рис. 7) для выбора переменной.

Рис. 7

Выпадающие списки – списки возможных значений конкретного поля ввода, предназначенных для вставки выбранного значения в это поле. Списки формируются программой автоматически на основании данных справочников или других данных.

Выпадающий список располагается под полем ввода. Для его отображения необходимо щелкнуть мышью по кнопке list (рис. 8), расположенной справа от поля. Если такая кнопка отсутствует, для ее отображения нужно щелкнуть правой кнопкой мыши на поле. На рис. 8 показан выпадающий список, содержащий два значения. Выбор нужного значения осуществляется щелчком мыши на нем. Большие выпадающие списки снабжаются вертикальными полосами прокрутки.

Рис. 8

Таблицы – предназначены для визуального просмотра или редактирования списка данных. Каждая строка таблицы (рис. 9) называется записью и содержит информацию об одном элементе списка (объекте или документе). Столбцы таблицы имеют заголовок. Каждая запись (строка) содержит одинаковый набор поименованных полей (столбцов таблицы). Каждое поле в таблице характеризуется своим значением. Например, поле "Код работы" в первой строке содержит значение "010".

В таблице (табличном списке) можно выбрать одну или несколько строк. Выбранные строки по умолчанию окрашиваются синим цветом. Выбор строки в таблице выполняется двойным или одинарным щелчком мыши.

Рис. 9

Полосы прокрутки – позволяют перемещать вверх/вниз и влево/вправо текст, расположенный в окне, в полях списках (рис. 7) или в таблицах (рис. 9). Полосы расположены вдоль вертикальной и горизонтальной границы перечисленных выше графических элементов. Каждая полоса прокрутки содержит по краям стрелки прокрутки и внутри горизонтальный (вертикальный) бегунок для перемещения по тексту или списку. Стрелки прокрутки позволяют перемещаться только на строку вверх (вниз), или вправо (влево). Бегунок применяется для перемещения по тексту, когда он невидим и уходит за вертикальные границы окна, списка или таблицы. Для этого нужно щелкнуть мышью на бегунке и при нажатой правой клавиши мыши перемещать его в нужном направлении.


Настройка программы

Программа включает набор средств для настройки программы, обеспечивающие пользователю комфортный и удобный режим работы с программой, автоматизирующий большинство операций, выполняемых пользователем в процессе работы. Средства настройки реализуют гибкую настройку программы, определяющие логику работы программы для индивидуального пользователя. В программном комплексе предусмотрено три способа настройки работы программ:

1. Настройки прав доступа и функциональных возможностей режимов работы программы, задаваемые в программе "АиТ:\Конфигурация".

2. Настройки, задаваемые в настроечных файлах AIT.INI и AIT_KP.INI. Настройки, необходимы для запуска программы, были описаны в настройках параметров запуска, а настройки режимов работы программы описываются непосредственно в тех пунктах, где рассматриваются эти режимы работы.

3. Предварительные настройки, задаваемые в программах "АиТ:\Табельный учет" и "АиТ:\Зарплата" и необходимые для функционирования данной программы.

4. Настройки отдельных режимов работы программы, задаваемые в следующих окнах программы:

· "Настройка" – общие настройка программы;
· "Настройка редактора" – выбор редактора для просмотра и редактирования текстовых файлов;
· "Настройка печати карточки наряда" – определение формата и состава данных в печатной форме карточки;
· "Настройка печати" – настройка печати для получения печатного документа по содержимому справочников.


Настройка режимов работы

Пользователи, работающие с базовой версией программы, имеют полный доступ ко всем функциям программы, и от них не требуется настраивать доступ к работе отдельных режимов.

В версиях "Проф" и "Холдинг" настройка режимов работы программы "АиТ:\Учет выполненных работ" осуществляется системным администратором в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" (рис. 1). Вызов окна происходит из пункта меню "Настройки" раздела "Режим" Главного меню.

Рис. 1

Окно "Настройки комплекса" предназначено для общей настройки алгоритмов и функциональных возможностей режимов выбранного программного модуля. Для настройки текущего программного модуля "АиТ:\Учет выполненных работ" его имя следует указать в верхнем поле "Модуль". Ввод в поле происходит из выпадающего списка.

Под полем "Модуль" расположена таблица, содержащая два столбца "Параметр" и "Значение" для отображения списка параметров и их значений, установленных администратором сети. В каждый момент времени видимый фрагмент таблицы содержит имя выбранного программного модуля "АиТ:\Учет выполненных работ", которое отображается на сером фоне над заголовком раздела.

Все параметры в первом столбце сформированы программой автоматически, их редактировать нельзя. Параметры сгруппированы по разделам, каждый из разделов выделяется жирным синим цветом и может содержать от одного до нескольких параметров. Для перехода к нужному параметру или просмотру таблицы можно воспользоваться полосой прокрутки. Для автоматического перехода к нужному параметру необходимо ввести несколько начальных букв в поле "Поиск". В результате заданный параметр становится текущим, он подчеркивается и отмечается знаком Strelka ("стрелочка") слева от него.

Параметры (рис. 1) могут принимать как логические значения, так и числовые значения, которые указываются во втором столбце "Значение". Второй столбец является редактируемым, и значения в него вводятся в дополнительном окне "Изменение параметра" (рис. 2), которое открывается двойным щелчком левой кнопки мыши.

Рис. 2

Для ввода логических значений используется флаг "Значение" и открывается окно (рис. 2). Установка флага соответствует значению "Да", при снятом флаге значение равно "Нет". Для ввода числовых значений открывается то же окно "Изменение параметра" (рис. 3), но имеющее редактируемое поле "Значение". Ввод в это поле производится с клавиатуры.

Рис. 3


Настройка прав доступа

Пользователи, работающие с базовой версией программы, имеют полный доступ ко всем функциям программы, и от них не требуется настраивать права доступа.

В версии "Проф" перечень функциональных возможностей при работе с окнами (режимами работы) программы зависит от прав доступа конкретного пользователя программы к этим режимам.

Настройка прав доступа в этой версии осуществляется системным администратором в окне "Редактирование списка ролей" (рис. 1) программного модуля "АиТ:\Конфигурация". Вызов окна происходит с помощью пункта "Роли" раздела "Режим" Главного меню.

Прежде всего, в верхнем поле "Модуль" (рис. 1) необходимо указать программный модуль "АиТ:\Учет выполненных работ", для которого производится настройка прав доступа, и выбрать роль из списка, приведенного в левой части окна. Выбор роли осуществляется щелчком левой кнопки мыши на нужной роли, при этом слева от названия выбранной роли (sa) появляется символ "стрелочка" Strelka , как показано на рис. 1.

Рис. 1

В правой части окна для выбранной роли и программного модуля "АиТ:\Учет выполненных работ" отображается список общих настроек объектов, режимов и функций. Для каждого элемента списка системным администратором указываются права доступа.

Список настроек приводится в первом столбце "Объекты, режимы и функции", формируется автоматически и группируется по разделам, которые могут содержать одну или несколько настроек. Имя каждого раздела отображается с левой стороны первого столбца и указывается синим цветом. Второй столбец "Доступ" является редактируемым, значения в него вводится из выпадающего списка, содержащего следующие виды доступа, предоставляемые пользователю:

· полный – полный доступ предполагает возможность работы с выбранным режимом без ограничений, когда доступны все операции с данными. Пользователю разрешается не только просматривать данные, но и изменять их (вводить, удалять, править, печатать, импортировать или экспортировать);
· чтение – разрешен доступ на чтение, что дает возможность только просматривать информацию, но запрещает ее редактировать;
· нет – отсутствует доступ к режиму, т.е. невозможно даже открыть окно или воспользоваться данной функцией программы.


Общие настройки

Выполнение общих настроек программы на рабочем месте осуществляется в окне "Настройка", вызываемом из одноименного пункта раздела "Сервис" Главного меню программы. Окно "Настройка" содержит две закладки: "Аналитика" и "Типы времени".

Закладка "Аналитика"

В программе "АиТ:\Учет выполненных работ" разрешается редактировать только дополнительные аналитические признаки. На этой закладке отображены дополнительные (свободные) аналитические признаки и один основной признак "Затраты", который редактировать нельзя, поэтому переключатель "Затраты" всегда недоступен. Коды и наименования затрат перечисляются в справочнике затрат программы "АиТ:\Зарплата".

Дополнительные аналитические признаки создаются и настраиваются пользователем в справочнике аналитических признаков в программе "АиТ:\Зарплата". На закладке показаны те дополнительные аналитические признаки, для которых в справочнике аналитических признаков установлен флаг "Признак включен". Пользователь имеет возможность определить, какой из дополнительных аналитических признаков, перечисленных на закладке "Аналитика", можно будет редактировать в этой программе.

Для выбора аналитического признака, прежде всего, следует установить флаг "Разрешить вести справочник аналитических признаков в модуле Наряды". При снятом флаге выбрать признак нельзя, т.к. переключатели недоступны. В этом случае также недоступен пункт "Справочник аналитики" (выделен серым цветом), и открыть справочник аналитических признаков нельзя.

После установки флага пользователь может выбрать нужный свободный аналитический признак, установив соответствующий переключатель, расположенный слева от названия признака, например, "Заказ" (рис. 1).

Редактирование признака (добавление или удаление его значений) выполняется в справочнике аналитических признаков, вызываемом из пункта "Справочник аналитики" раздела "Справочники".

Рис. 1

Закладка "Типы времени"

Закладка "Типы времени" позволяет установить соответствие между типом времени в табеле и фактом рабочего времени в наряде.

Внимание. Работа с этой закладкой должна осуществляться после настройки типов времени в программе "АиТ:\Табельный учет".

Закладка состоит из двух частей. В левой части закладки приводится перечень типов времени, используемых в табельном учете. В правой части закладки необходимо указать, какой тип времени будет использован как рабочее время по наряду для импорта данных о фактически отработанном времени работника из табельных листов.

Для этого следует установить курсор на нужной строке слева, нажать левую кнопку мыши и переместить курсор в правую часть закладки (при этом изображение курсора в виде "стрелки" изменяется на символ "рука") и отпустить кнопку мыши. В результате выделенные строки переместятся из левой части окна в правую часть.

В левой части закладки:

· в поле "основная работа" – указываются типы времени, описывающие основную работу по наряду;
· в поле "работа по замещению" – указываются типы времени, описывающие работы по замещению другого работника на его рабочем месте.

Рис. 2.


Настройка редактора

В программе для редактирования документов разрешается использовать как встроенный, так и внешний редактор. Для работы с формируемыми программой текстовыми выходными документами (отчетами) пользователь может выбрать тип редактора в окне "Настройка редактора" (рис. 1). Вызов окна производится из пункта "Настройка редактора" раздела "Сервис" Главного меню программы.

Рис. 1

Настройка редактора в окне (рис. 1) производится за счет выбора нужного переключателя. Если выбран переключателя "Встроенный редактор", просмотр и редактирование текстовых файлов будет производиться с помощью встроенного редактора, разработанного программистами компании "АиТ Софт". По умолчанию встроенный в программу текстовый редактор aitpad.exe размещается в папке \aitclient\Works\.

Однако пользователь может использовать для работы внешний редактор (Word, wordpad, notepad и др.), установив переключатель "Внешний редактор". В этом случае необходимо указать полный путь доступа к внешнему редактору вручную или выбрать его с помощью стандартного диалога. Для этого следует нажать на кнопку "Пролистать" и в стандартном диалоге Windows выбрать папку и имя исполняемого файла, например notepad.exe. После выбора нужного редактора и закрытия стандартного диалога полный путь к выполнимому файлу отображается в поле ввода, например, C:\Program Files\Microsoft Office\Office\WINWORD.EXE. Для блокнота указывается только название программы notepad.exe (рис. 1).

Для сохранения сделанных в окне настроек следует нажать на кнопку "Ок".


Настройка печати карточки наряда

Отчет по карточке наряда может изменять свое содержание в зависимости от ее настройки, однако форма представления данных является стандартной.

Настройка документа для печати производится в окне "Настройка печати карточки наряда", которое вызывается из пункта "Параметры печати карточки наряда" раздела "Сервис" Главного меню программы.

Рис. 1.

В этом окне пользователь имеет возможность определять состав данных в печатной форме карточки наряда и выбирать те из необязательных параметров, которые ему необходимы.

Для получения карточки наряда в текстовом виде следует установить переключатель "Печать в текст". Карточка наряда открывается в том текстовом редакторе (Word, wordpad, notepad, aitpad), который был выбран в настройках редактора. Существует возможность добавить при печати текстового документа готовые "шапку" и "подвал" наряда из файла. Для этого в окне настройки печати в блоке "Оформление" нужно установить соответствующие флаги и указать путь к файлам, содержащим шапку и подвал.

Также есть возможность печатать карточки наряда из программы Excel по шаблонам помесячного и дневного нарядов, а также наряда за период. Для этого следует установить переключатель "Печать в Excel" и задать шаблоны для каждого вида нарядов. Выбор шаблона производится из стандартного окна выбора файлов, которое открывается кнопкой [image].

Для сохранения выполненных настроек нажмите на кнопку [image] . При печати нарядов производится в соответствии со сделанными настройками. После настройки можно выполнить печать нарядов, выделенных в списке нарядов, нажав на кнопку "Печать" Print дополнительной панели инструментов.


Сервисные средства

Программа включает разнообразные сервисные средства, предоставляющие разнообразные вспомогательные операции и функции, облегчающие пользователю работу с программой. Сервисные средства программы описаны в этой главе, а также и в других главах настоящего "Руководства пользователя".

Некоторые сервисные средства, знакомство с которыми необходимы для начала работы с программой, уже были описаны в предыдущих главах, например, Справочная система, графический интерфейс пользователя. В силу особой значимости графическому интерфейсу пользователя посвящена отдельная книга "Интерфейс программы". Сервисные средства для работы со справочниками, для формирования отчетов (документов) по нарядам – Генератор отчетов и Мастер создания сводных отчетов описываются в других книгах, которые посвящены работе этих средств.

В данной книге описываются следующие сервисные средства:

· фильтр;
· текстовый редактор;
· калькулятор;
· режим для создания формул.


Фильтр

Фильтр позволяет установить разнообразные критерии отбора различных данных, например, для отбора одного или группы сотрудников предприятия.

Фильтр – это логическое выражение, записанное в виде одного или совокупности условий отбора данных, соединенных логическими "связками" (логическими операциями И, ИЛИ). Каждое условие (критерий) отбора описывается отдельной строкой и характеризуется названием параметра, по которому будет производиться отбор, и условием сравнения.

Установка фильтра, по которому выполняется отбор сотрудников, производится в окне "Фильтр" (рис. 1). Вызов окна происходит из пункта "Фильтр" раздела "Сервис" Главного меню программы или с помощью кнопки "Фильтр" Panal8 основной панели инструментов.

В каждый момент работы программы фильтр может находиться в двух состояниях: установлен или снят (отбор сотрудников отсутствует). Наличие установленного в данный момент работы программы фильтра можно определить по внешнему виду кнопки “Фильтр” панели инструментов. При установке фильтра кнопка имеет вид Filtr, при этом фон рисунка кнопки становится желтым, при снятии фильтра – серым Panal8 .

Рис. 1

Закладка "Для пользователя"

Первая закладка (рис. 1) позволяет установить или переустановить фильтр для списка нарядов, отчетов, снять его, а также посмотреть установленный в текущий момент фильтр или список созданных фильтров.

Список уже составленных фильтров отображается на левой панели "Наименование" окна. Для идентификации фильтров целесообразно озаглавливать фильтры таким образом, чтобы в них отражалось смысловое действие фильтра. Число строк (наименований фильтров) в списке не ограничено. Добавлять, удалять и копировать фильтр под другим именем можно с помощью соответствующих кнопок дополнительной панели инструментов. Установленный в момент открытия окна фильтр окрашивается в соответствующей строке списка голубым цветом.

В правой части закладки (рис. 1) расположены колонки для непосредственного формирования выражения фильтра, имя которого выделено в левой части окна:

· Название – указывается имя переменной, по которой происходит отбор сотрудников. Выбор переменной осуществляется из выпадающего списка, открываемого щелчком мыши. Список переменных ограничен и зафиксирован в самой программе. В основном, в качестве переменных используются данные кадровой карточки сотрудника.
· Условие – задается условие, которое может принимать одно из перечисленных значений: = (равно), <> (не равно), > (больше), >= (больше или равно), < (меньше), <= (меньше или равно), включает, пусто, не пусто, один из. Условие выбирается из выпадающего списка щелчком мыши. Условие "один из" позволяет выбрать несколько значений для отбора.
· Значение – в данное поле вводится значение переменной, по которому происходит отбор данных. Значение переменной можно вводить непосредственно с клавиатуры вручную (например, фамилия, место рождения, размер оклада и т.п.) или выбирать из списка значений, сформированного на основании данных справочника. Если для переменной, существует список фиксированных значений, то он открывается щелчком правой кнопки мыши.

При выборе условия "включает" в поле "Значение" необходимо указать строку для поиска включения в следующем виде: %текст для поиска% или _текст для поиска_, где символ % заменяет несколько предшествующих / последующих символов, а символ _ (подчеркивание) – один символ.

· Расшифровка – поле недоступно для редактирования и заполняется автоматически одновременно с полем "Значение" в тех случаях, когда поле "Значение" заполняется из выпадающего списка, формируемого по данным справочника. В этом случае в поле "Значение" будет указан код по справочнику, а в поле "Расшифровка" – соответствующее ему наименование.
· Связка – поле заполняется, когда формируемый фильтр содержит одновременно несколько условий, которые должны быть объединены логическими операциями (связками). Связка “И” означает, что оба условия должны выполняться одновременно. Если между условиями не установлена связка, то выполняется только первое из них, а следующее условие за отсутствующей связкой будет проигнорировано.

Если установленный фильтр предназначен для формирования выходных документов, то в первую строку файла этого документа заносится выражение, описывающее условие установленного фильтра, например:

Выбрано по условию: Табельный номер = 0001 и Номер подразделения <> 9999

Установка выбранного в списке фильтра происходит по нажатию кнопки "Установить фильтр" Filtr дополнительной панели инструментов. Снятие условия фильтра – по нажатию кнопки "Снять фильтр" Panal8 . Если в момент установки фильтра создаваемому логическому условию не отвечает ни один из сотрудников предприятия или если под действие этого условие подпадают все сотрудники, выдается предупреждение и фильтр не устанавливается.

Информация для продвинутых пользователей программы

Список полей и таблиц, по которым может быть установлен фильтр, зафиксирован в базе данных. Поэтому для расширения этого списка достаточно выполнить соответствующий скрипт на базе данных с помощью программы "АиТ:/Конфигурация" или любого внешнего средства исполнения sql-запросов. За подробностями обращайтесь в отдел консультаций фирмы "АиТ Софт".

Закладка "Для администратора SQL"

Вторая закладка окна "Фильтр" (рис. 2) позволяет задавать условие отбора данных на основании sql-запросов.

Рис. 2

Эта возможность полезна системным администраторам, консультантам и опытным пользователям. Такого рода запросы позволяют делать выборки более сложного характера, для которых требуется знание языка SQL и структуры базы данных программного комплекса "АиТ:\Управление персоналом".

Текущее условие отбора на второй закладке можно сохранить в виде SQL запроса в файле с расширением sql в рабочей папке \aitclient\Works\TXT. Для этого нужно нажать на кнопку "экспорт в текст" ExportWorks и в стандартном окне Windows задать полное имя файла с указанием пути к нему.

Сохранные в файле условия отбора можно вновь загрузить с помощью кнопки "импорт данных" ImportWorks дополнительной панели инструментов. При этом открывается стандартное окно Windows для выбора файла с нужным условием (SQL запросом). После выбора файла на второй закладке отображается условие отбора, записанное в выбранном файле.

Закрытие окна "Фильтр" (рис. 1) происходит в момент установки фильтра кнопкой Filtr или в момент снятия фильтра кнопкой Panal8 дополнительной панели инструментов.


Текстовый редактор

Программа позволяет редактировать текстовые документы, используя выбранный пользователем редактор. Непосредственное открытие редактора происходит после формирования отчета генератором документов или просмотра шаблонов.

Все внешние редакторы, такие как notepad, Word и др. имеют подробную документацию, описывающую работу с ними, поэтому в данной теме описывается только работа со встроенным редактором, разработанным программистами компании "АиТ Софт".

Встроенный редактор позволяет осуществлять операции просмотра, редактирования, печати документов и шаблонов создаваемых документов, используя пункты разделов Главного меню или кнопки панели инструментов (рис. 1).

Рис. 1

Встроенный редактор предназначен для работы с текстовыми файлами формата ANSI, которые по умолчанию имеют расширение *.txt. Такие файлы могут содержать буквы, цифры и символы, но в них запрещается использовать форматирующие текст символы, кроме маркеров конца строки и конца страницы. При экспорте в приложения Windows (например, WinWord) формат ANSI именуется как “текст”, при просмотре из DOS - “текст Windows”.

Ниже описано назначение пунктов всех разделов Главного меню встроенного редактора.

Меню "Файл"

Пункт раздела | Кнопка | Действия и функции
Новый |  | Открывает новое окно для создания документа
Открыть |  | Открывает для редактирования файл документа
Закрыть |  | Закрывает активный документ
Сохранить |  | Сохраняет открытый документ на жестком диске (дискете) под тем же именем
Сохранить как |  | Сохраняет открытый документ на жестком диске (дискете) под другим именем
Удалить |  | Удаляет активный документ из оперативной памяти и с жесткого диска (дискеты)
Выбор принтера |  | Открывает стандартное окно Настройки принтеров Windows
Печать |  | Печатает активный документ на принтере, определенном “по умолчанию” в Настройке принтеров Windows. При отправке документа на печать открывается окно “Идет печать”, дающее возможность прервать этот процесс по кнопке “Отмена”
Выход |  | Закрывает встроенный редактор и все открытые документы

Меню "Редактирование"

Отмена | Отменяет последнюю операцию
Вырезать | Удаляет выделенный фрагмент из документа и записывает его в буфер обмена
Копировать | Копирует в буфер выделенный фрагмент
Вставить | Вставляет содержимое буфера обмена в точку ввода
Удалить | Удаляет выделенный фрагмент из документа
Выделить все | Выделяет все содержимое активного документа
Конец листа | Вставляет маркер конца страницы

Меню "Поиск"

Найти | Открывает дополнительное окно для поиска определенного сочетания символов в документе. Поиск может проходить как с учетом регистра букв, так и без учета. Поиск заканчивается на первом вхождении указанного сочетания символов в документ
Найти следующий | Продолжает поиск по указанному ранее сочетанию символов
Заменить текст | Заменяет одно указанное сочетание символов на другое столько раз, сколько оно встречается в документе
Перейти на строку | Устанавливает курсор на выбранную строку документа

Меню "Сервис"

Шрифт

Устанавливает выбранный рисунок (шрифт с Windows-кодировкой ANSI и DOS-кодировкой ASCII) и размер шрифта, используемого при выводе конкретного файла на экран и на печать.

Выбранный шрифт относится ко всему документу в целом и при записи файла на диск не сохраняется, а настройка размера шрифта сохраняется в самом редакторе.

Координаты курсора

Управляет отображением координаты курсора (строка: позиция) в правом нижнем углу окна

Табуляция

Настройка табуляции

Меню "Окно"

В процессе работы пользователь может открывать несколько файлов, каждый из которых размещается в своем окне.

Вертикальная мозаика | Располагает окна открытых документов в виде вертикальной мозаики
Горизонтальная мозаика | Располагает окна открытых документов в виде горизонтальной мозаики
Каскад | Располагает окна открытых документов в виде каскада с помещением активного документа наверх
Распахнуть | Максимизирует окно активного документа
Упорядочить значки | Упорядочивает в нижней части экрана значки открытых, но свернутых окон документов
Инструменты | Открывает дополнительное окно настройки размещения на экране панели инструментов редактора. Пользователь может перемещать ее по экрану, устанавливать или снимать микро-подсказки у кнопок, а также совсем спрятать панель

Меню "Листание"

Файлы большого размера (более 32 КБ, т.е. порядка 10 страниц текста) не могут быть загружены данным текстовым редактором целиком. Их загрузка и работа с ними происходит “порциями” по 32 КБ. Соответственно, если для редактирования выбран файл большего размера, сначала будут загружены только его первые 32 КБ.

Далее содержание файла можно последовательно “подгружать” с помощью кнопок панели инструментов "Вперед" и "На последний". Если файл не загружен целиком, а остался еще его фрагмент, который можно подгрузить, то кнопка "На последний" будет доступной (активной).

На первый | ServiceeditorList1 | Подгружает первые 32 КБ текста
Назад | ServiceeditorList2 | Подгружает предыдущие 32 КБ текста
Вперед | ServiceeditorList3 | Подгружает следующие 32 КБ текста
На последний | ServiceeditorList4 | Подгружает последние 32 КБ текста

Меню "Справка"

Содержание справки F1 | Basehelp0 | Показ оглавления разделов Справки по программе
Контекстная справка Shift+F1 |  | Вызывает описание работы встроенного редактора
Поиск справки по Ctrl+F1 |  | Вызывает систему поиска справки по контексту
АиТ:\Редактор |  | Вызывает окно с информацией о фирме-производителе программы


Калькулятор

Встроенный в программу калькулятор (рис. 1) позволяет вычислять произвольные выражения. Вызов калькулятора происходит кнопкой Panal10 основной панели инструментов, клавишами Ctrl+F2 или из пункта "Калькулятор" раздела "Сервис" Главного меню программы.

Рис. 1

Калькулятор позволяет:

· вести текст выражения для расчета в поле "Выражение" с помощью клавиатуры или мыши, используя кнопки калькулятора;
· просмотреть текст выражения на экране;
· задать точность расчетов (число знаков после запятой);
· рассчитать арифметическое выражение любой сложности;
· запомнить и восстановить из памяти текст выражения и результат.
· сохранить результат расчета в буфере обмена, нажав на кнопку "В буфер", клавиши Ctrl+S или Ctrl+Ins. Для вставки сохраненного значения в нужном месте программы, воспользуйтесь клавишами Ctrl+V или Shift+Ins.


Экспорт данных

Программа разрешает экспортировать данные различных документов, используемых в программе, в другие форматы, определяемые пользователем. Эта возможность применяется в окнах справочников, где имеется кнопка "экспорт в текст" ExportWorks .

Рис. 1

Для экспорта необходимо нажать на кнопку "экспорт в текст" ExportWorks дополнительной панели инструментов. При этом открывается окно (рис. 1). В появившемся на экране окне следует определить формат, в котором будет создаваться отчет, нажав на нужную кнопку:

· Для печати – открывается текстовый редактор, заданный в настройках, и экране отображается готовый для печати документ, отформатированный с помощью пробелов. Если в качестве редактора выбрана программа MS Word, то сначала открывается окно (рис. 2) и предлагается выбрать кодировку для загрузки файла. Следует выбрать кодировку "Текст" и нажать на кнопку "ОК". После этого на экране отображается готовый для печати документ. Для его печати выберите пункт "Печать" в разделе "Файл", задайте параметры печати и нажмите на кнопку "ОК".

Рис. 2

· На экспорт – создается промежуточный файл, разделенный по колонкам символом табуляции для выравнивания текста. После нажатия на эту кнопку открывается дополнительное окно с кнопками "С табул." и "Excel" для выбора программы, в которой создается отчет. При выборе кнопки "С табул." отчет строится с помощью того редактора, который задан в настройках редактора. При выборе кнопки "Excel" строится отчет в формате *.csv с помощью программы Excel.
· В htm – создается файл в формате html для просмотра с помощью Internet браузера.
· Для переноса – создается служебный файл с расширением *.txt для переноса данных в другую БД. Полный путь к папке указывается в дополнительном окне, которое открывается после нажатия на эту кнопку.

После выбора нужной кнопки формируется отчет и записывается на диске в рабочей папке \aitclient\works\TXT. Имя отчета определяется программой автоматически. Сформированный отчет открывается на экране и используется для просмотра, редактирования или получения по нему печатного документа.


Формулы распределения

Формулы позволяют автоматизировать процесс расчета распределения общей и дополнительной сумм между членами бригады за выполненную по наряду работу. Для ввода новой формулы, просмотра или редактирования ранее сформированных формул предназначено окно "Формулы распределения".

Вызов окна происходит из пункта "Формулы" раздела "Сервис" Главного меню программы или по кнопке "Формулы" Panal7 основной панели инструментов.

Окно (рис. 1) имеет две закладки: на первой закладке "Формула алгоритма" происходит настройка собственно формулы алгоритма, на второй закладке "Вычисляемые алгоритмы" – добавление и настройка формул вычисляемых переменных, которые могут использоваться в формуле.

Рис. 1

На закладке "Формула алгоритма" в ее верхней части расположено поле "Алгоритм" для ввода названия алгоритма, а под ним – поле для отображения собственно формулы, описывающей алгоритм расчета распределения суммы между членами бригады за работу, выполненную по наряду. Формула может содержать переменные, функции и действия, выполняемые над ними.

В нижней части закладки слева показан список доступных для использования в формуле переменных, а справа находится набор кнопок со знаками арифметических операций и скобок, под ними отображается список функций и поле для указания точности расчета.

Переменные

Переменные вставляются в расчетную формулу из фиксированного списка, создаваемого программой. Каждая переменная в списке и формуле записывается в квадратных скобках, например, [ИТОГО]. После имени переменной в списке указывается ее назначение. Переменные вводятся в формулу двойным щелчком мыши на строке с выбранной переменной. В качестве значений переменных используются данные стандартных полей персональной карточки сотрудника, табельных листов и полей ввода карточки наряда.

Переменная | Назначение переменной
[ИТОГО] | сумма для распределения
[ЧИСЛ_С] | количество (число) сотрудников в выборке
[ПРОЦЕНТ] | процент оплаты отдельного сотрудника
[СУМПР] | суммарный процент
[ДНИ] | число фактически отработанных дней отдельного сотрудника
[СУМДНИ] | суммарные плановые дни
[ЧАСЫ] | число фактически отработанных часов отдельного сотрудника
[СУМЧАС] | суммарные плановые часы
[КТУ1... 3] | коэффициенты трудового участия 1-3 для отдельного сотрудника
[СУМКТУ1... 3] | суммарные КТУ выборки (КТУ вводятся непосредственно на экране распределения)
[ОКЛАД] | оклад сотрудника
[СУМОКЛ] | суммарный оклад
[КОНСТ1... 8] | константы 1-8 из персональной карточки
[СУМКОН1].. [СУМКОН8] | суммарное значение констант
[ПЛ_Д] | плановые дни по графику сотрудника
[ПЛ_Ч] | плановые часы по графику сотрудника
[СУМПЛ_Д] | сумма плановых дней
[СУМПЛ_Ч] | сумма плановых часов
[ПРЦ_ВЫР] | процент выработки
[ДНИ_ТВ] | ‘ДНИ’ по определенному типу времени
[ЧАСЫ_ТВ] | ‘ЧАСЫ’ по определенному типу времени
[СУМДНИ_ТВ] | ‘СУМДНИ’ по определенному типу времени
[СУМЧАСЫ_ТВ] | ‘СУМЧАСЫ’ по определенному типу времени
[СУМ_НА_РУКИ] | сумма на руки

Функции

Поле "Функции", расположенное в правой нижней части закладки, позволяет вводить в расчетную формулу следующие встроенные функции:

· if (условие, истинно, ложно) – выбор из двух альтернатив по условию;
· int (число) – отбрасывание дробной части;
· round (число, дробная часть) – округление до выбранного числа разрядов.

Действия

В секции "Действия" расположены кнопки со знаками арифметических операций и скобок. Эти знаки вводятся в формулу щелчком мыши по соответствующим кнопкам.

Все элементы формул необходимо отделять друг от друга пробелами. Написанную формулу можно проверить с помощью специальной функции, вызываемой кнопкой "Проверить формулу" CheckFormul дополнительной панели инструментов.

В формулах могут также использоваться вычисляемые переменные (или весовые коэффициенты), добавляемые на второй закладке окна (рис. 2). Они представляют собой произведения нескольких числовых характеристик сотрудника. Одновременно может существовать до 5-х таких переменных.

Рис. 2

Весовые коэффициенты имеют типовое обозначение: F плюс порядковый номер (от 1 до 3) – для ссылки на значение по отдельному сотруднику, СУМ_F плюс порядковый номер – на суммарное значение по выборке. Например, F1 или СУМ_F2.

В формулах вычисляемых переменных, описываемых на второй закладке, могут использоваться стандартные аргументы из списка, приведенного выше. Новая вычисляемая переменная появляется в списке переменных основной формулы лишь после корректной её настройки. Подробнее см. тему "Пример создания формулы расчета".


Пример создания формулы расчета

Рекомендуется приступать к созданию новых расчетных алгоритмов (формул) после изучения алгоритмов, имеющих в дистрибутиве программы, так как создание нового алгоритма требует хорошего понимания принципов распределения сумм.

Создание новой формулы рассмотрим на примере распределения суммы наряда пропорционально тарифу и отработанному времени. Для этого берется общая сумма для распределения [ИТОГО] и распределяется в зависимости от планового тарифного фонда бригады ([ОКЛАД] * [ЧАСЫ]) пропорционально тарифу [ОКЛАД] и отработанному времени работника [ЧАСЫ].

Таким образом, формула для расчета имеет следующий вид:

[ИТОГО] / [СУМ_F1] * [ОКЛАД] * [ЧАСЫ], где [СУМ_F1] = [ОКЛАД] *[ЧАСЫ]

Создание нового алгоритма по шагам

1. Открыть окно "Формулы распределения" из пункта "Формулы" раздела "Сервис" Главного меню программы или с помощью кнопки "Формулы" Panal7 основной панели инструментов.

2. Перейти на закладку "Формула алгоритма" и нажать на кнопку "Добавить" Added дополнительной панели инструментов. В верхнем поле "Алгоритм" записать новое название алгоритма, например, "Пропорционально времени и тарифу" (см. рис. 1 в теме "Формулы распределения").

3. В поле "Переменные" двойным щелчком мыши выбрать переменную [ИТОГО]. После этого она появится в поле для отображения формулы.

4. Нажать на кнопку Divide из блока "Действия", в результате знак деления "/" появится в поле для отображения формулы после переменной [ИТОГО].

5. Перейти на закладку "Вычисляемые переменные", чтобы ввести формулу для расчета тарифного фонда каждого члена бригады [ОКЛАД]* [ЧАСЫ] (см. рис. 2 в теме "Формулы распределения"). Для этого:

· из выпадающего списка в поле "Переменная" выбрать имя вычисляемой переменной F1;
· в списке "Составляющие" дважды щелкнуть на переменную [ОКЛАД];
· нажать на кнопку Multiply из блока "Действия";
· в списке "Составляющие" дважды щелкнуть на переменную [ЧАСЫ].

6. Вернуться на закладку "Формула алгоритма". В списке "Переменные" появились две новые переменные – [F1] и [СУМ_F1]. Выбрать [СУМ_F1], так как нам необходимо рассчитать плановый тарифный фонд всей бригады.

7. Нажать на кнопку Multiply из блока "Действия".

8. Для распределения пропорционально тарифу в списке "Переменные" выбрать переменную [ОКЛАД].

9. Нажать на кнопку Multiply из блока "Действия".

10. Для распределения пропорционально отработанному времени в списке "Переменные" выбрать переменную [ЧАСЫ].

11.Проверить формулу на корректность, нажав на кнопку "Проверить формулу" CheckFormul дополнительной панели инструментов.

12.Сохранить формулу, воспользовавшись кнопкой "Сохранить данные" Save дополнительной панели инструментов.


Примеры расчетных алгоритмов

1. Распределение суммы поровну всем членам бригады

Формула:

[ИТОГО] / [ЧИСЛ_С]

Комментарии: Распределяем сумму по наряду поровну – сумма заработка напрямую зависит от общего фонда оплаты труда и количества работников в бригаде.

2. Распределение суммы пропорционально тарифу и отработанному времени

Формула: | [ИТОГО] / [СУМ_F1] * [ОКЛАД] * [ЧАСЫ],
 | где [СУМ_F1] = [ОКЛАД] * [ЧАСЫ]

Комментарии: Общий фонд оплаты труда [ИТОГО] распределяется ( / ) в зависимости от планового тарифного фонда бригады [СУМ_F1] = [ОКЛАД] * [ЧАСЫ] пропорционально ( * ) тарифу [ОКЛАД] и отработанному времени [ЧАСЫ].

3. Алгоритм с использованием КТУ

Формула:

[ИТОГО] / [СУМКТУ1] * [КТУ1]

Комментарии: Распределение суммы по наряду производится в зависимости от КТУ каждого сотрудника. КТУ вводится в карточку наряда.

4. Алгоритм с использованием персональных констант сотрудника

Формула:

[ИТОГО] / [СУМКОН1] * [КОНСТ1]

Комментарии: Распределение суммы по наряду производится пропорционально значению персональной константы сотрудника. Значение константы подбирается из персональной карточки сотрудника в программе "АиТ:\Зарплата" и помещается в карточку наряда в колонку Конст_1. Эта колонка в программе "АиТ:\Учет выполненных работ" не редактируется, изменения вносятся только в программе "АиТ:\Зарплата". В формуле может быть задействовано несколько констант (КОНСТ1-КОНСТ8). Такой алгоритм подходит и для определения размера надбавки (дополнительной суммы).


Общее понятие о справочниках

В программном комплексе “АиТ:\Управление персоналом” и, в частности, в программе "АиТ:\Учет выполненных работ" справочник – это средство для просмотра и формирования всевозможной справочной информации. Каждый справочник имеет собственное имя, по которому он распознается в программе. Содержимое справочника отображается в отдельном окне в виде таблицы и хранится в отдельной таблице базы данных программы.

Раздел "Справочники" Главного меню программы обеспечивает доступ к справочникам. Настройка справочников производится в следующей последовательности:

1. Справочник аналитических признаков.

2. Справочник видов рабочих центров.

3. Справочник структуры рабочих центров.

4. Справочник единиц измерения.

5. Справочник работ.

6. Справочник видов нарядов.

7. Виды дополнительных сумм.

После заполнения справочников можно откорректировать или разработать новые алгоритмы распределения сумм и расчета надбавок.

Операции со справочниками

Каждый из перечисленных выше справочников разрешается просматривать, корректировать (добавлять, удалять, редактировать строки), а также выполнять экспорт и импорт данных справочников. Работа со справочниками стандартизирована и осуществляется с помощью функциональных кнопок дополнительной панели инструментов.

Некоторые справочники можно распечатать, нажав на кнопку "Печать" Print дополнительной панели инструментов. Предварительно открывается окно "Настройка печати" (рис. 1) для настройки параметров печати справочника (задания шрифта и масштаба) и выбора ориентации содержимого справочника на странице. После настройки для получения печатного документа в этом окне следует нажать на кнопку "Печать".

Рис. 1

Назначение остальных кнопок, их название и вид указаны в нижеприведенной таблице. В ней перечислен наиболее полный набор кнопок для работы со всеми справочниками, однако каждый конкретный справочник имеет меньший набор кнопок.

Кнопка

Вид

Назначение кнопки

Добавить

Added

Добавляет в конец справочника, представленного в виде таблицы, новую пустую строку для ввода необходимых данных.

Удалить

Del

Удаляет из списка активную (выделенную курсором) строку.

Внимание. Удаление не производится, если имеется ссылка на эту строку в другом справочнике или в карточке.

Копировать (F5)

Copy

Добавление новой заполненной строки в конец списка. Наименование и параметры (реквизиты) добавленного элемента аналогичны тем, с которых происходило копирование, а его код (или уникальный номер) в каждом справочнике формируется особым образом, определяемым программой.

Выделить все строки (Alt+A)

Select

Выделить одновременно все строки.

Снять выделение всех строк (Alt+S)

SelectNo

Отменить выделение со всех выделенных строк.

Экспорт в текст

ExportWorks

После нажатия на данную кнопку открывается окно для выбора формата текстового файла, в который выгружается содержимое справочника.

Выгружает содержимое справочника в текстовый файл. Предварительно открывается окно с набором кнопок для выбора формата текстового файла.

Выход

DoorBlack

Выход из справочника без сохранения введенных данных.

Выход с сохранением

Выход из справочника с сохранением введенных в него изменений.

Отмена

Выход из справочника без сохранения введенных изменений.


Виды прав доступа к справочникам

Пользователи, работающие с базовой версией программы, имеют полный доступ ко всем функциям программы, и от них не требуется настраивать права доступа.

В версии "Проф" перечень функциональных возможностей при работе со справочниками зависит от прав доступа конкретного пользователя программы. Настройка прав доступа в этой версии осуществляется системным администратором в программе "АиТ:\Конфигурация" в режиме "Редактирование списка ролей" (рис. 1)). Доступ к режиму происходит из пункта "Роли" раздела "Режим" Главного меню.

Права доступа к справочникам задаются для выбранной роли (рис. 1), именно эта роль указывается в поле "Имя" при открытии программы.

Возможны следующие виды доступа:

· полный – полный доступ, который предполагает возможность работы с выбранным режимом без ограничений, т.е. пользователю доступны все операции с данными, ему разрешается не только просматривать данные, но и изменять их (вводить, удалять, править, печатать, импортировать или экспортировать);
· чтение – разрешен доступ на чтение, что дает возможность только просматривать информацию, но запрещает ее редактировать.
· нет – отсутствует доступ к режиму, т.е. невозможно даже открыть справочник.

Рис. 1


Справочник аналитических признаков

Доступ к справочнику

Справочник аналитических признаков вызывается из пункта "Справочник аналитики" раздела "Справочники" Главного меню программы. Редактирование справочника, в первую очередь, зависит от прав доступа к нему, заданных в программе "АиТ:\Конфигурация". Если доступ запрещен, то даже при установке флага "Разрешить вести справочник аналитических признаков в модуле Наряды" в настройках программы, справочник открыть нельзя.

Внимание. Если к справочнику разрешен полный доступ, а указанный выше флаг снят, то в разделе "Справочники" Главного меню программы пункт "Справочник аналитики" является неактивным (выделен серым цветом), поэтому открыть справочник нельзя.

Редактирование справочника

Следует заметить, что в программном комплексе "АиТ:\Управление персоналом" может быть задано достаточно количество аналитических признаков, большая их часть используется в программах "АиТ:\Зарплата", "АиТ:\Кадровый учет". Аналитические признаки формируются в программе "АиТ:\Зарплата". Обычно аналитика "принимается" из системы управления предприятием, из бухгалтерской системы. Но только один из свободных аналитических признаков можно редактировать в этой программе.

Содержание справочника (рис. 1) зависит от общих настроек программы. Редактировать в этом справочнике можно только один свободный аналитический признак, выбранный в настройках программы. Его краткое и полное название отображается на левой панели справочника. Краткое название используется в экранных формах, в частности на закладке II карточки наряда.

Рис. 1

Для каждого аналитического признака на правой панели приводятся значения, которые он может принимать. Для каждого значения указывается код и название. Для редактирования списка значений аналитического признака используются кнопки Added (добавить новое значение), Copy (скопировать выделенное значение) и Del (удалить выделенное значение из списка).

На рис. 1 показан аналитический справочник, используемый для ввода значений аналитического признака "Заказ". Именно название этого признака "Заказ" будет отображаться в справочнике структуры аналитических центров, а также будет использовано для названия последней колонки в карточке наряда на закладке "Производственное задание".


Справочник структуры рабочих центров

Рабочие центры предназначены для определения конкретного рабочего места и конкретной учитываемой в наряде работы. Каждый рабочий центр характеризуется подразделением, видом рабочего центра и аналитическими признаками (свойствами).

Ввод и настройка рабочих центров осуществляется в окне "Структура рабочих центров" (рис. 1). Это окно открывается из пункта "Структура рабочих центров" раздела "Сервис" Главного меню программы или по кнопке "Раб. центры" Panal5 основной панели инструментов.

Рис. 1

Чтобы добавить в подразделение рабочий центр, необходимо выполнить следующие действия:

· в блоке "Рабочий центр" добавить новую строку кнопкой "Добавить" Added и ввести название центра. Если в окне установлен флаг "Автоматически менять название центра", то название центра сформируется по умолчанию как сочетание наименования подразделения и вида рабочего центра;
· выбрать из выпадающего списка подразделение, куда добавляется рабочий центр;
· указать вид рабочего центра в соответствующем поле;
· задать аналитические признаки, характеризующие рабочий центр. Все аналитические признаки, указанные в настройках программы, перечислены в блоке "Аналитические свойства рабочего центра". Указанные аналитические признаки проставляются в карточке наряда по умолчанию при выборе рабочего центра. Те признаки, для которых в структуре рабочих центров установлен флаг FlagYes , не редактируются и будут недоступны для изменения непосредственно в карточке наряда на закладке II.

Свободный признак "Заказ", выбранный в настройках для редактирования в этой программе, показывается отдельно от других признаков. Имя признака "Заказ" будет использовано в качестве заголовка последнего столбца в карточке наряда на закладке "Производственное задание".


Справочник видов рабочих центров

Под видом рабочего центра понимается производственный объект (станок, установка и др.), на котором выполнялись работы. Расходы по этим работам могут быть отнесены на одну из статей затрат.

Для перечисления видов рабочих центров, используемых в программе, предназначен специальный справочник (рис. 1). Вызов справочника происходит из пункта "Справочник видов рабочих центров" раздела "Справочники" Главного меню программы или кнопкой "Виды раб. центров" Panal6 основной панели инструментов.

Рис. 1

Вид рабочего центра характеризуется кратким кодом и наименованием. Справочник предназначен для укрупненной группировки рабочих центров и возможности последующего анализа затрат, себестоимости продукции, изготовленной на объектах, имеющих одинаковые свойства.

Следует различать вид рабочего центра и непосредственно сам рабочий центр. Собственно рабочий центр определяется как комбинация вида рабочего центра и подразделения (структурной единицы предприятия). Например, в качестве вида рабочего центра выбран полиграфический станок марки ХХХ и имеется три печатных цеха. Тогда рабочим центром № 1 является станок марки ХХХ, установленный в первом печатном цехе, рабочим центром № 2 станок того же вида, но установленный во втором печатном цехе и т. д.

Данные этого справочника используются при формировании справочника структуры рабочих центров и справочника работ.


Справочник единиц измерения

Справочник единиц измерения вызывается из одноименного пункта раздела "Справочники" Главного меню программы. Данные справочника используются при заполнении справочника работ и при заполнении единицы измерения выполняемой работы в карточке наряда.

Справочник (рис. 1) содержит наименования единиц измерения, используемых для определения объема выполненных работ в нарядах.

Рис. 1

В справочнике предусмотрена возможность поиска нужной строки по коду или наименованию, что необходимо при большом количестве строк. Для этого в блоке "Поиск" достаточно указать код или несколько первых букв в наименовании и курсор сразу же позиционируют на нужную строчку, как показано на рис. 1, выделяя ее контрастным цветом (обычно, синим цветом).

Пользователь имеет возможность корректировать содержание справочника, добавлять новые единицы измерения, копировать и удалять существующие.


Справочник работ

Справочник работ вызывается из одноименного пункта раздела "Справочники" Главного меню программы или с помощью кнопки "Работы" Panal4 панели инструментов.

Рис. 1

В верхней части данного справочника (рис. 1) приводится список рабочих центров, перечисленных в справочнике структуры рабочих центров. Каждый рабочий центр имеет свой собственный набор работ. Поэтому при добавлении работы необходимо сначала выбрать из списка в верхней части окна рабочий центр (оборудование), на котором будет выполнена данная работа.

Для вновь созданной строки надо указать код и наименование работы, расценку, единицу измерения и норматив. Под нормативом понимается количество времени в часах, которое требуется для производства единицы продукции. Аналогичным образом вводятся работы и для других рабочих центров.

При необходимости можно добавить работы одного центра в список работ других центров. Для этого нужно:

· в верхней части окна двойным щелчком мыши отметить центры, в которые необходимо добавить работы;
· установить курсор напротив центра, работы которого добавляются;
· в нижней части окна двойным щелчком мыши выделить список этих работ;
· нажать на кнопку "Добавить работы в другие раб. центры" AddWorks дополнительной панели инструментов.


Справочник видов нарядов

Справочник видов нарядов (рис. 1) вызывается из пункта "Виды нарядов" раздела "Справочники" Главного меню программы и используется при заполнении поля "Вид наряда" в верхней части карточки наряда.

Рис. 1

В справочнике перечисляются те виды нарядов, которые необходимо отдельно учесть в программе "АиТ:\Учет выполненных работ" и отдельно обработать в программе "АиТ:\Зарплата".

В справочнике предусмотрена возможность поиска нужной строки по коду или наименованию, что необходимо при большом количестве строк. Для этого в блоке "Поиск" достаточно указать код или несколько первых букв в наименовании и курсор сразу же позиционируют на нужную строчку, как показано на рис. 1, выделяя ее контрастным цветом (обычно, синим цветом).


Виды дополнительных сумм

Справочник видов дополнительных сумм вызывается из пункта "Виды дополнительных сумм" раздела "Справочники" Главного меню программы и используется при вводе дополнительных сумм отдельным сотрудникам бригады в карточке наряда. В справочнике (рис. 1) перечисляются те виды дополнительных сумм нарядов, которые используются на предприятии.

Рис. 1

Ввод новой строки в справочник осуществляется стандартным способом кнопкой Added. Поля "Наименование" и "Комментарий" заполняются вручную, с клавиатуры, а поле "Тип времени по умолчанию" из выпадающего списка. Для того чтобы появился выпадающий список нужно щелкнуть левой кнопкой мыши по полю "Тип времени по умолчанию".

Использование данного справочника позволяет организовать начисление и расчет дополнительных сумм по разным, произвольно выбираемым типам времени.

Внимание! Если в программе справочник видов дополнительных сумм не доступен, следует выполнить описанный ниже скрипт Sfg_manyaddsum.sql

INSERT INTO cfg_reg_modes

( app_id, mode_id, code_f, name_f )

VALUES ( 11, 'MANYADDSUM', '', 'Распределение сумм' ) ;

INSERT INTO cfg_reg_params

( app_id, mode_id, param_id, name_f, type_f, sql_f, default_f )

VALUES ( 11, 'MANYADDSUM', 'is_viddopsum',

'Использовать разделение дополнительных сумм',

'ch', null, '0' ) ;

INSERT INTO cfg_reg_values

( app_id, mode_id, param_id, value_f )

VALUES ( 11, 'MANYADDSUM', 'is_viddopsum', '1' ) ;


Порядок оформления работ по нарядам

Процесс формирования производственных заданий и оплаты по нарядам требует определенной последовательности действий, перечисленных в данной теме.

1. Создание нового наряда. В момент создания наряда определяется его тип. Созданный наряд попадает в список нарядов.

2. Заполнение карточки наряда начинается с указания рабочего центра (оборудования), на котором выполнялись все работы (элементарные операции) по наряду, и формулы распределения сумм, т. е. с ввода значений в поля в верхней части карточки наряда на закладке I.

3. Ввод видов и объемов работ на закладке "Производственное задание".

4. Формирование состава бригады.

5. Ввод табельного времени (ручной или автоматический) в карточку наряда.

Внимание! При автоматическом заполнении отработанного времени табельные листы на всех членов бригады должны быть созданы и заполнены, промежуточные итоги рассчитаны. Корректировка табельных листов "задним числом" потребует перерасчета всех уже оформленных нарядов.

6. Автоматический ввод табельного времени при наличии нескольких табельных листов.

7. Распределение денежных сумм между членами бригады за выполненную работу, в том числе и расчет дополнительных сумм отдельным сотрудникам бригады по заданным алгоритмам.

8. Проверка соответствия сумм. Эту процедуру рекомендуется выполнять после того, как наряды за месяц заполнены и рассчитаны.

9. Передача данных в программу "АиТ:\Зарплата". Передача выполняется в случае правильного заполнения карточек нарядов (см. пункт 8).

Внимание! Для корректной обработки данных по нарядам в программе "АиТ:\Зарплата" необходимо осуществить предварительные настройки:

· в справочнике начислений создать начисление для оформления работ по нарядам;
· произвести настройку соответствия кодов начислений и данных нарядов.

10.В случае необходимости разрешается провести корректировку закрытых нарядов, уже переданных в программу "АиТ:\Зарплата".


Список нарядов

Все наряды, созданные на текущем предприятии, перечисляются в дочернем окне "Список нарядов" (рис. 1). Это окно открывается сразу же после запуска программы и показывается в основном окне. Кроме этого, окно “Список нарядов” вызывается кнопкой panal2 основной панели инструментов либо из пункта "Список" раздела "Документы" Главного меню программы.

Внимание. При первом открытии окна список пуст.

Список созданных в программе нарядов размещается на двух закладках. На первой закладке (рис. 1) показаны новые наряды, которые разрешено редактировать. На второй закладке "Архив" отображаются наряды, переданные в программу "АиТ:\Зарплата", и по ним проведено начисление заработной платы. В этом случае наряды переносятся с закладки "Новые наряды" на вторую закладку "Архив", они получают статус закрытого документа, их редактировать нельзя, но в случае острой необходимости можно выполнить откат начислений.

Новые наряды

На обеих закладках список нарядов представлен в виде таблиц, имеющих одинаковый состав столбцов. Каждая строка таблицы содержит сведения об одном наряде.

Для того чтобы просмотреть весь список созданных нарядов следует нажать на кнопку "Показать все". При этом изменяется название кнопки на "Показать" (рис. 1). Для показа не всех нарядов, а только их части, созданных за заданный промежуток времени нужно в нижней части закладки в блоке "Период времени" указать дату начала и конца периода и нажать на кнопку "Показать".

Рис. 1

Список нарядов можно упорядочить по любому столбцу таблицы, для этого следует дважды щелкнуть мышью на заголовке нужного столбца.

В списке нарядов на закладке "Новые наряды" можно выполнить следующие действия:

· добавить в список новый наряд, воспользовавшись кнопкой Added или клавишами Alt+Ins;
· удалить наряд из списка кнопкой Del или клавишами Alt+Del. Удаление выделенного наряда происходит после подтверждения;
· копировать наряд, нажав на кнопку Copy или клавишу F5;
· открыть карточку наряда кнопкой Open;
· распечатать выделенные наряды списком или один открытый наряд, нажав на кнопку "Печать" Print. Перед печатью нарядов необходимо настроить внешний вид распечатываемого документа.


Создание нового наряда

Создание наряда осуществляется в режиме "Новый наряд" (рис. 1). Для доступа к режиму откройте окно "Список нарядов", например, кнопкой panal2 основной панели инструментов и нажмите на кнопку "Добавить" Added дополнительной панели инструментов.

Рис. 1

При открытии окна автоматически формируется номер нового наряда (на единицу больший, чем предыдущий номер) и проставляется в поле "№". Нумерация нарядов единая для всего программного комплекса и определяется настройками, установленными в программе "АиТ:\Конфигурация" в разделе "Расширенный функционал управления" для параметра "Расширенная нумерация приказов" (0 – сквозная нумерация, 1 – сквозная нумерация в течение года, 2 – сквозная нумерация в течение месяца).

Следует заметить, что предыдущий номер может быть введен с любого рабочего места и не всегда виден в списке нарядов конкретного рабочего места. Поэтому номер наряда лучше не редактировать. Однако если параметры нового наряда будут отличаться от существующего наряда с тем же номером, то такой наряд будет сохранен в базе данных. Следует иметь в виду, что номер наряда передается вместе с нарядом в программу "АиТ:\Зарплата", и наличие нескольких нарядов с одинаковыми номерами может привести к путанице. Поэтому номер наряда лучше оставить без изменений.

Дата создания наряда (поле "от") по умолчанию устанавливается равной системной дате компьютера рабочего места, но при необходимости может быть отредактирована.

Тип наряда определяет календарный срок, в течение которого выполняется работа по наряду, он устанавливается в данном режиме и изменить его в дальнейшем невозможно. Для нового наряда тип устанавливается за счет выбора переключателя:

· дневной – наряд выполняется за один день;
· помесячный – наряд выполняется за месяц. Название месяца берется по месяцу создания наряда;
· за период – наряд выполняется за период, продолжительность которого не должна превышать одного месяца. Дата начала периода берется по дате создания нового наряда. В этом случае в карточке наряда вместо одного поля появляются два поля для задания дат начала и конца выполнения наряда.

Наряд будет создаваться по шаблону, если установлен флаг "Шаблон".

По нажатию кнопки "ОК" созданный наряд добавляется в список нарядов, а на экран выводится (рис. 2) практически незаполненная карточка наряда, в которой указываются только введенный номер и тип наряда (для дневного или помесячного наряда), а также текущий месяц и год (для наряда за период).

Рис. 2

Для заполнения полей наряда следует познакомиться с темой "Порядок оформления работ по нарядам".


Карточка наряда

Карточка наряда, приведенная в списке нарядов, открывается из пункта "Открыть карточку" раздела "Документы" Главного меню, с помощью клавиш Alt + F2 или кнопкой "Карточка наряда" Open основной панели инструментов. При этом открывается текущая карточка наряда, т. е. та, на строке которой в списке проставлен знак Strelka. Кроме этого новая карточка наряда открывается сразу же после ее создания из окна "Новый наряд" кнопкой "ОК".

Для правильного заполнения полей карточки наряда следует познакомиться с порядком ее заполнения.

Карточка содержит 4 закладки (рис. 1), по две закладки в верхней и нижней части окна.

На первой закладке "Производственное задание" осуществляется ввод видов и объемов работ. Заполнение карточки наряда всегда начинается с ввода видов и объемов работ, поэтому при ее открытии всегда отображается закладка "Производственное задание".

На второй закладке "Распределение сумм" карточки наряда производится ввод отработанных часов, корректировка отработанного времени и тарифных ставок.

Рис. 1

Назначение полей на закладке I

Перед вводом работ или выбором членов бригады обязательным условием является заполнение полей в верхней части карточки на закладке I (рис. 1):

· Название – произвольное название наряда. Оно не должно быть длинным. Акцент в названии желательно делать либо на работы, либо на бригаду;
· Рабочий центр – выбирается рабочий центр, на котором выполнялись работы сотрудником или бригадой. Ввод сведений в это и последующие поля производится из выпадающего списка, в котором список рабочих центров отсортирован по алфавиту;
· Алгоритм – задается формула распределения суммы заработка по наряду среди членов бригады;
· Вид наряда – вид наряда, который необходимо отдельно учесть в данной программе и отдельно обработать в программе "АиТ:\Зарплата". Ввод вида наряда проставляется в поле из выпадающего списка, сформированного по данным справочника видов нарядов. Для удобства ввода список видов нарядов отсортирован по коду;
· Бригадир – указывается сотрудник подразделения, являющийся назначенным или неформальным бригадиром;
· Сумма – основная сумма, оплаченная за работу, выполненную по наряду. Поле заполняется после заполнения видов и объемов работ на закладке "Производственное задание";
· Константа – поле используется для ввода дневной нормы выработки по конкретному наряду. Это значение может быть использовано в алгоритмах расчета наряда. Поле размещается под полем "Тип времени" (рис. 2), чтобы его увидеть нужно бегунок вертикальной полосы прокрутки переместить вниз до самого конца.

Рис. 2

Дополнительные поля

Набор дополнительных полей на этой закладке зависит от настроек в программе "АиТ:\Конфигурация".

Поле "Табельный лист" отображается в верхней части, если в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" в разделе "Взаимодействие с модулем АиТ:\Табельный учет" для параметра "Возможность подбора сотрудников из таб. листа" проставлено значение "Да". Если указано значение "Нет", то поле "Табельный лист" отсутствует, а на его месте располагается поле "Тип времени". Ввод данных в него осуществляется из выпадающего списка с типами времени, заданными в программе АиТ:\Табельный учет". Ввод данных в поле "Табельный лист" также осуществляется из выпадающего списка, в котором названия табельных листов отсортированного по алфавиту.

Внимание! Табельный лист является первичным по отношению к наряду. Перед началом работы с нарядами убедитесь, что табельные листы на всех членов бригады созданы и заполнены, промежуточные итоги рассчитаны. Корректировка табельных листов "задним числом" потребует перерасчета всех уже оформленных нарядов.

Для того чтобы на закладке отображалось поле "Тип времени" необходимо, в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" в разделе "Взаимодействие с модулем АиТ:\Табельный учет" выполнить следующие настройки:

· для параметра "Возможность подбора сотрудников из таб. листа" проставлено значение "Нет";
· для параметра "Наряд считается по определенному типу времени" проставлено значение "Да".

Поле "Тип времени" располагается в нижней части карточки наряда, для его показа следует воспользоваться вертикальной полосой прокрутки. Ввод в поле производится из выпадающего списка и позволяет выбрать тип времени, по которому в данный конкретный наряд выбирается отработанное время из табельных листов.

При включенной настройке конфигуратора в разделе "Взаимодействие с модулем АиТ:\Табельный учет" для параметра "Для работника из бригады указать Табельный лист" проставить значение "Да" на закладке "Распределение сумм" появится еще одно поле "Таб.лист" рядом с ФИО сотрудника. И если выбрать определенный табель, то по нему и идет обработка времени.

Назначение полей на закладке II

На этой закладке (рис. 4) перечислены все аналитические признаки, приведенные на закладке "Аналитика" окна "Настройка". При создании наряда рабочий центр однозначно определяет, значения каких признаков можно или нельзя редактировать на этой закладке. Те признаки, для которых в структуре рабочих центров установлен флаг FlagYes , нельзя редактировать, они также будут недоступны для изменения значений признаков на закладке II. Для этих признаков на закладке указываются значения, указанные при создании рабочего центра.

Значения аналитических признаков, которые разрешено редактировать, вводятся из выпадающих списков, открываемых щелчком левой кнопки мыши.

Рис. 4


Закладка "Производственное задание"

Заполнение карточки наряда начинается с ввода видов и объемов работ, поэтому при ее открытии всегда отображается закладка "Производственное задание".

При открытии карточки наряда всегда отображается первая закладка "Производственное задание". Этим предполагается, что сначала вводятся виды и объемы работы, а потом, на второй закладке – члены бригады и распределение оплаты между ними.

Закладка "Производственное задание" служит для ввода видов и объемов работ, выполняемых по данному наряду в конкретном рабочем центре, перечисленном в структуре рабочих центров.

Рис. 1

Заполнение полей таблицы

В таблице каждый вид работы указывается на отдельной строке. Для ввода новой строки предназначена кнопка "Добавить" Added дополнительной панели инструментов.

Заполнение полей каждой новой строки таблицы начинается с первого поля "Код работ". Ввод в поле "Код работ" происходит из выпадающего списка, который представляет собой список работ из справочника работ, соответствующих рабочему центру, указанному в поле "Раб. центр" карточки наряда.

Внимание. Для заполнения полей таблицы необходимо не только в верхнем поле "Раб. центр" на закладке I указать рабочий центр, но и для выбранного рабочего центра в справочнике работ, заполнить список работ, если список работ отсутствует, то выпадающий список поля "Код работ" не содержит ни одного значения.

При выборе нужного кода работы поля строки до поля "Кол-во работ" автоматически заполняются данными из справочника, при необходимости они могут быть изменены вручную для данного конкретного наряда.

В поле "Кол-во работ" вводится с клавиатуры выполненный объем, и программа автоматически рассчитывает значение в поле "Сумма зарплаты" как произведение расценки и количества работ. Чтобы рассчитанное значение появилось в поле "Сумма зарплаты" следует установить курсор в это поле, одновременно заполняется поле "Сумма" в верхней части карточки наряда.

Последний столбец в таблице для задания значений аналитических признаков и кнопка GarbAddSumAnalit на дополнительной панели инструментов появляется при наличии раздела [Наряды] в файле настроек AIT.ini:

[Наряды]

Is_factor=Y

Название этого столбца ("Заказ" на рис. 2) зависит от выбранного пользователем свободного аналитического признака в настройках программы. Добавление или удаление значений выбранного признака выполняется в справочнике аналитических признаков. В случае если поле пустое, то невозможно получить распределение денежных сумм по аналитике за выполненную по наряду работу.

Рис. 2

В нижней части окна (рис. 1) в итоговой строке слева указывается количество строк в таблице, справа подводятся итоги по последним двум колонкам, что особенно полезно, если видов работ несколько.

Итоговая сумма по колонке "Сумма зарплаты" также указывается в поле "Сумма" верхней части карточки наряда на закладке I. Для того чтобы она отразилась после заполнения второй и последующих строк необходимо перейти на вторую закладку, а затем снова вернуться на первую закладку.


Закладка "Распределение сумм"

Закладка "Распределение сумм" карточки наряда используется для ввода параметров, необходимых для распределения денежных сумм между членами бригады по заданному алгоритму.

Назначение полей таблицы

Первая колонка таблицы "ФИО" предназначена для указания табельных номеров и ФИО членов бригады, выполняющих работы по наряду, перечисленные в карточке наряда на закладке "Производственное задание. Заполнение этой колонки происходит после формирования списка бригады, выполняющей текущий наряд.

Состав остальных колонок таблицы (рис. 1) зависит от выбранного алгоритма распределения денежных сумм между членами бригады. Поля этих колонок предназначены для ввода необходимых параметров распределения денежных сумм, таких как: тарифные ставки работников, отработанное и плановое время, КТУ, различные персональные константы. Все поля редактируемы, кроме тех, в которые указываются вычисляемые переменные.

Рис. 1

Тарифные ставки, персональные константы, КТУ

Поле "Тариф" в карточке наряда появляется, если используется алгоритм "Распределение суммы пропорционально тарифу и отработанному времени". Поле по умолчанию заполняется значением, установленным в кадровой карточке сотрудника в программе "АиТ:\Кадровый учет" в поле "Оклад". Поле "Тариф" доступно для редактирования, так как сотрудник может выполнять работу другой квалификации (разряда), что требует временного изменения тарифной ставки.

Персональные константы передаются в карточку наряда из персональной карточки сотрудника (закладка "Блокнот"), заполняемой в программе "АиТ:\Зарплата".

Колонка "КТУ" появляется в таблице при использовании алгоритма "Распределение суммы с использованием КТУ". Коэффициент трудового участия проставляется вручную каждому сотруднику по результатам работы, оформленной конкретным нарядом.

Ввод отработанного времени вручную

Отработанное время для каждого члена бригады может быть введено вручную или автоматически из табельных листов. Автоматический ввод табельного времени можно осуществить как в момент переноса списка членов бригады (нажатия на кнопку "Выход с сохранением" [image]) в карточку наряда, так и впоследствии, кнопкой "Проверка резерва времени" CheckReservTime дополнительной панели инструментов.

Внимание! Табельный лист является первичным по отношению к наряду. Перед началом работы с нарядами следует убедиться, что табельные листы на всех членов бригады созданы и заполнены, промежуточные итоги рассчитаны. Корректировка табельных листов "задним числом" потребует перерасчета всех уже оформленных нарядов.

Колонка "Таб. лист" присутствует в таблице, если в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" в разделе "Взаимодействие с модулем АиТ:\Табельный учет" для параметра "Для работника из бригады указывается табельный лист" проставлено значение "Да". Параметр "Для работника из бригады указывается табельный лист" позволяет осуществить подбор времени для каждого сотрудника не по всем табельным листам, в которых он фигурирует, а по одному выбранному.

Подбор времени осуществляется по всем табельным листам сотрудника по тем типам времени, которые указаны в окне "Настройка" на закладке "Типы времени" для основной работы (если сотрудник выполнял основную работу) и работы по замещению (если сотрудник замещал другого работника). Подобранное время вставляется в колонки "Дни" и "Часы" карточки наряда. Автоматически заполненные дни-часы могут быть откорректированы. Эта возможность существует для того, чтобы на одну и ту же бригаду можно было вести несколько нарядов (по разным работам, разным рабочим центрам) как в течение одного рабочего дня, так и в течение месяца.

Особенности подбора табельного времени для нарядов

Процедура автоматического подбора табельного времени имеет некоторые особенности для дневных и помесячных нарядов.

1. При подборе времени в дневной наряд имеет значение дата оформления наряда – программа подбирает табельное время за конкретный день. Если на сотрудника оформлены другие дневные наряды на эту же дату, они учитываются при проверке резерва времени и в текущий наряд подбирается остаток времени за этот день. Время, подобранное в помесячные наряды, не учитывается.
2. При подборе времени в помесячный наряд и в наряд за период имеет значение месяц, за который оформлен этот наряд, – программа подбирает табельное время сотрудника за весь указанный месяц. При проверке резерва времени учитываются все оформленные за этот месяц наряды – дневные, помесячные и за период, и в текущий наряд подбирается разница между количеством дней-часов по табелю и суммой дней-часов во всех уже существующих нарядах.

Если лимит отработанного времени сотрудника исчерпан или разница отрицательная, то программа выводит предупреждающее сообщение (рис. 2).

Рис. 2

Это же сообщение появляется тогда, когда дата наряда является нерабочей датой по фактическому графику членов бригады.


Формирование состава бригады

После ввода видов и объемов работ, перечисленных на первой закладке "Производственное задание" карточки наряда, формируется состав бригады. Для этого необходимо перейти на вторую закладку "Распределение сумм". На этой закладке расположена таблица для ввода состава бригады (колонка "ФИО"), выполняющей этот наряд.

Кнопка "Выбор сотрудника" PersSotr дополнительной панели инструментов вызывает окно формирования состава бригады (рис. 1). Окно состоит из двух частей для отображения списка сотрудников, формируемого программой, и списка членов бригады, формируемого пользователем. В окне доступна функция поиска и установки фильтра по критерию (кнопка Filtr). Состав списка сотрудников зависит от условия фильтра. При снятом фильтре в левой части окна отображается полный список сотрудников предприятия. Список сотрудников упорядочен по подразделениям, а внутри каждого подразделения – по порядку табельных номеров. При установленном фильтре показывается частичный список, отвечающий условиям фильтра. Строка, на которой установлен курсор, выделяется подчеркиванием и символом StrelkaBlack слева от табельного номера сотрудника. В итоговой строке отображается общее количество сотрудников в списке и количество выделенных сотрудников.

На основании списка сотрудников пользователь в правой части окна формирует список членов бригады, используя метод "перетащить и отпустить". Для этого слева нужно выделить нужные строки с данными на сотрудников, нажать левую кнопку мыши (изображение курсора изменяется на символ "рука"), переместить курсор в правую часть окна и отпустить кнопку мыши. В результате выделенные строки переместятся из левой части окна в правую часть.

Закончив формирование состава бригады, можно выбрать ее бригадира. Для этого на правой панели в строке с ФИО бригадира следует установить курсор (при этом в первом поле отобразится символ StrelkaBlack ) и нажать на кнопку "Бригадир (Б)". В результате на строке с выбранной фамилией в поле "Б" устанавливается флаг FlagYes. Повторное нажатие на кнопку "Бригадир (Б)" снимает флаг. После закрытия окна с сохранением фамилия выбранного сотрудника появится в поле "Бригадир" в карточке наряда.

Рис. 1

Для того чтобы выбранный список членов бригады сохранился в базе данных и появился в колонке "ФИО" таблицы на второй закладке "Распределение сумм" карточки наряда, нажмите на кнопку "Выход с сохранением" [image] дополнительной панели инструментов. При этом окно "Состав бригады" закрывается и открывается окно "Автозаполнение" (рис. 2) для автоматического заполнения сведений об отработанном времени на основании данных табельного учета.

Рис. 2

В том случае, если к этому моменту пользователь не заполнил табельные листы на членов бригады, лучше воспользоваться кнопкой "Отмена". Кнопку "Ок" целесообразно нажимать в том случае, когда на членов бригады заполнен табельный лист за заданный период работы. Иначе при выборе кнопки "Ок" программа выдает предупреждающее сообщение (рис. 3) и поля "Дни" и "Часы" в таблице для ввода сведений об отработанном времени не заполняются. Однако их можно будет заполнить в дальнейшем, воспользовавшись кнопкой "Проверка резерва времени" CheckReservTime дополнительной панели инструментов закладки "Распределения сумм".

Рис. 3


Автоматическое заполнение сведений об отработанном времени

Сведения об отработанном времени, затраченном на выполнении работ, могут быть введены в поля "Дни" и "Часы" таблицы на закладке "Распределение сумм" карточки наряда на каждого члена бригады как вручную, так и автоматически.

Автоматический ввод отработанного по наряду времени в карточку наряда производится на основании заполненных табельных листов в модуле "АиТ:\Табельный учет". Поэтому перед проведением этой операции табельные листы на всех членов бригады должны быть созданы и заполнены, промежуточные итоги рассчитаны. Корректировка табельных листов "задним числом" потребует перерасчета всех уже оформленных нарядов.

Автоматический ввод табельного времени в карточку наряда осуществляется с помощью окна "Автозаполнение" (рис. 1), которое открывается кнопкой "Проверка резерва времени" CheckReservTime ДПИ закладки "Распределения сумм карточки наряда". Кроме этого, программа открывает это окно после окончания формирования списка членов бригады.

Рис. 1

Для автоматического ввода данных табельного времени в карточку наряда в окне "Автозаполнение" необходимо установить нужные флаги и нажать на кнопку "Ок". При установке флага "Часы" на закладке "Распределения сумм" в таблице заполняются поля "Дни" и "Часы". При установке флага "Табельные листы" заполняются поля столбца "Таб. лист" таблицы. Колонка присутствует в таблице при выполнении соответствующих настроек.

При наличии в нарядах нескольких дополнительных сумм с одинаковым типом времени на одно и тоже число и одного и того же работника, при проверке резерва времени часы для распределения сумм по ним будут вычитаться, кроме одной дополнительной суммы, если установлена настройка в программе "АиТ:\Конфигурация". Настройка считается установленной, если в окне "Настройка комплекса" в разделе "Взаимодействие с модулем АиТ:\Табельный учет" для параметра "Исключить при подборе доп.сумм с повт. типом времени" задать значение "Да".

Если лимит отработанного времени сотрудника исчерпан или разница отрицательная, то программа выводит сообщение.

Рис. 2

Это же сообщение появляется тогда, когда дата наряда является нерабочей датой по фактическому графику членов бригады.

Если пользователь нажал кнопку "Отмена" (рис. 1), то поля в таблице для ввода сведений об отработанном времени не заполняются.

Автоматическое заполнение колонок "Часы" и "Дни" в том случае, когда на членов бригады сформировано более одного табельного листа описан в отдельной теме.


Дополнительные возможности автоматического подбора времени из табеля

Подбор времени из табеля можно сделать более целенаправленным, если воспользоваться дополнительными настройками в программе "АиТ:\Конфигурация". Раздел "Взаимодействие с модулем "АиТ:\Табельный учет" содержит два настраиваемых параметра:

· Наряд считается по определенному типу времени;
· Для работника из бригады указывается табельный лист.

Параметр "Наряд считается по определенному типу времени" дает возможность поставить в соответствие каждому наряду отдельный тип времени. В базовой версии типы времени, учитываемые при подборе, указываются в окне "Настройка" и едины для всех нарядов. Если параметр принимает значение "Да", то в карточке наряда появляется дополнительное поле "Тип времени" (рис. 1),. В нем, пользуясь вертикальной полосой прокрутки, из выпадающего списка можно выбрать тот тип времени, по которому в данный конкретный наряд должно подбираться время из табельных листов.

Рис. 1

Параметр "Для работника из бригады указывается табельный лист" позволяет осуществить подбор времени для каждого сотрудника не по всем табельным листам, в которых он фигурирует, а по одному выбранному. Если параметр принимает значение "Да", то в карточке наряда на закладке "Распределение сумм" появляется дополнительная колонка "Табельный лист" (рис. 2), в которой из выпадающего списка можно выбрать необходимый табельный лист.

Рис. 2

Процесс автоматического заполнения отработанного времени по табельным данным в этом случае включает два этапа:

· задание табельных листов для каждого члена бригады в результате заполнения поля "Таб. лист" таблицы (рис. 2) на закладке "Распределения сумм" карточки наряда;
· подбор дней-часов из указанных табельных листов с помощью окна "Автозаполнение", вызываемого кнопкой "Проверка резерва времени" CheckReservTime дополнительной панели инструментов закладки "Распределения сумм". В этом окне (рис. 3) следует установить флаги "Табельные листы" и "Часы".

Рис. 3

Если работник учитывается в нескольких табельных листах, программа выдает предупреждающее сообщение (рис. 4).

Рис. 4

В этом случае необходимо убедиться, что для этих сотрудников подбор произведен правильно, из соответствующего табельного листа. При необходимости следует выбрать из выпадающего списка другой табельный лист и вновь запустить процедуру подбора, установив в окне "Автозаполнение" (рис. 3) только один флаг "Часы".


Расчет наряда (распределение) по выбранному алгоритму

После заполнения данных об отработанном времени можно переходить к расчету денежных сумм, за выполненную работу. Расчет сводится к распределению общей суммы наряда среди всех членов бригады по заранее определенному алгоритму, указанному в поле "Алгоритм" карточки наряда.

Для расчета оплаты за выполненные по наряду работы необходимо перейти на закладку "Распределение сумм" карточки наряда и нажать на кнопку "Расчет" Calculation ДПИ или на клавиши Alt+F3.

Если расчет не может быть выполнен в целых суммах (с копейками), то на экран выводится следующее сообщение:

Рис. 1

Пользователь может принять любое решение. При положительном ответе сумма распределения полностью совпадает с суммой по наряду.

Сумма на руки любого из членов бригады может быть отредактирована вручную, однако при повторном расчете такие изменения будут утеряны.

Использование дополнительного алгоритма в старой версии

Внимание. В новой версии дополнительный алгоритм указывается в поле "Алгоритм" в окне "Дополнительные суммы по наряду".

В программе предусмотрен механизм, позволяющий наряду с основной суммой, рассчитывать и распределять между членами бригады дополнительные суммы, т.е. доплаты, например, за работу в ночное время, за успешно выполненную по наряду работу. Все виды дополнительных сумм должны быть перечислены в справочнике. Для расчета дополнительных оплат за выполненную работу нужно разработать дополнительный алгоритм, для задания его имени предназначено поле "Алгоритм дополнит." (рис. 1). Следует заметить, дополнительные суммы рассчитываются по формуле на основании основной суммы, показываемой в поле "Сумма" карточки наряда, например:

[ИТОГО] * 0.1 / [ЧИСЛ_С]

Для расчета дополнительной суммы необходимо перейти на закладку "Распределения сумм" карточки наряда и выполнить следующие действия:

· в поле "Алгоритм дополнит." ввести алгоритм распределения дополнительной суммы между членами бригады, выбрав его из выпадающего списка;
· нажать на кнопку "Расчет" Calculation дополнительной панели инструментов, чтобы дополнительная сумма была рассчитана и распределена между сотрудниками в соответствии с выбранным алгоритмом;
· по расчета общая сумма надбавки для всей бригады будет показана в верхнем поле "Сумма дополнит." карточки наряда, а рассчитанная дополнительная сумма, положенная каждому члену бригады будет представлена в колонке "Доп.сумма" на закладке "Распределение сумм" (см. рис. 2).

Рис. 2

При экспорте данных в программу "АиТ:\Зарплата" основная и дополнительная суммы передаются и обрабатываются отдельно.


Режим временного замещения

Режим временного замещения одного сотрудника другим, из той же бригады, может использоваться только в помесячном наряде.

Временное замещение оформляется после ввода членов бригады и фактически отработанных часов за месяц. Для этого в карточке наряда на закладке "Распределение сумм" нужно установить курсор на строке работника, который временно замещал другого, и нажать на кнопку "Копировать" Copy дополнительной панели инструментов.

Программа выдаст запрос на дублирование сотрудника (рис. 1):

Рис. 1.

При положительном ответе в списке членов бригады появляется дополнительная строка с фамилией замещающего сотрудника, которая выделена ярко-синим цветом.

В колонку "Часы" нужно ввести время, отработанное по замещению, а в колонку "Тариф" ввести часовую тарифную ставку того сотрудника, за которого выполнялось работы (рис. 2).

Рис. 2.

Описанная последовательность действий повторяется столько раз, сколько сотрудников в данном наряде работает по замещению.


Использование дополнительных сумм

За выполненную по наряду работу дополнительно к основной сумме можно производить доплаты (дополнительные суммы), например, за успешно выполненную работу, за работу в ночное время и др.

Ввод и расчет дополнительных сумм по типам времени, указанных в справочнике, выполняется в специальном окне (рис. 1). Доступ к этому окну выполняется кнопкой CalcAddSum из карточки наряда.

Непосредственно в карточке наряда следует ввести тип времени, по которому рассчитывается основная сумма по наряду, указанная в поле "Сумма".

Рис. 1

Внимание. При первом открытии окно "Дополнительные суммы по наряду" не содержит никаких сведений.

Окно (рис. 1) разделено на две панели. Левая панель предназначена для задания видов используемых в наряде дополнительных сумм с указанием типов времени и алгоритмов, по которым рассчитываются дополнительные суммы. Каждая сумма указывается на отдельной строке. Текущей считается строка, на которой установлен курсор, т. е. слева от строки расположен символ StrelkaBlack . Для каждой текущей строки таблицы в нижней части панели приводится назначение дополнительной суммы и формула ее расчета.

В формулах расчета для типов времени должны использоваться специальные переменные:

[ДНИ_ТВ] – дни по определенному типу времени;

[ЧАСЫ_ТВ] – часы по определенному типу времени;

[СУМДНИ_ТВ] – сумма дней по определенному типу времени;

[СУМЧАС_ТВ] – сумма часов по определенному типу времени.

Правая панель используются для перечисления сотрудников, выполняющих наряд, с указанием дней, часов и выплачиваемых им денежных сумм. В нижней части правой панели появятся итоговые данные по общей дополнительной сумме, выданной членам бригады по всему наряду

Для ввода новой дополнительной суммы в окне (рис. 1) необходимо выполнить следующие действия:

1. Нажать на кнопку Added, на левой панели вставляется пустая строка, на правой панели появляется список сотрудников (рис. 1), перечисленных в текущей карточке наряде, из которой было открыто это окно;

2. Заполнить поля на левой панели. В поле "Вид" указывается вид дополнительной суммы, Поле заполняется из выпадающего списка, созданного по данным справочника видов дополнительных сумм. Ввод в поле "Тип времени" происходит из выпадающего списка, сформированного на основе типов времени, созданных в программе "АиТ:\Табельный учет". В поле "Алгоритм" указывается алгоритм расчета дополнительных сумм. Алгоритмы расчета формируются в окне "Формулы распределения".

3. Для автоматического ввода часов по заданному типу времени воспользуйтесь кнопкой "Проверка резерва времени" CheckReservTime;

4. Нажать на кнопку "Расчет" Calculation, после этого в правой части окна появятся суммы, распределенные по членам бригады.

Действия, описанные в п.п. 1-4, нужно повторить столько раз, сколько строк нужно вставить на левой панели окна. В нижней части правой панели появятся итоговые данные по общей дополнительной сумме, выданной членам бригады по всему наряду. Чтобы сохранить введенную информацию, нажмите на кнопку [image] .

При этом окно (рис. 1) закрывается, а текущим окном становится карточка наряда. Для того чтобы просмотреть все дополнительные суммы, выданные сотрудникам в карточке наряда нажмите на кнопку GarbAddSumAnalit дополнительной панели инструментов.


Распределение сумм по наряду по аналитике

Все суммы (основные и дополнительные) по конкретному наряду, распределенные по членам бригады, можно увидеть в отдельном окне программы (рис. 1). Доступ к этому окну осуществляется Доступ к этому окну осуществляется клавишами Shift+F3 или кнопкой "Распределение сумм по наряду по аналитике" GarbAddSumAnalit закладки "Распределение сумм" карточки наряда.

Внимание. Для того чтобы кнопка GarbAddSumAnalit появилась на дополнительной панели инструментов, необходимо в файле настроек AIT.ini, расположенном в рабочей папке программы \aitclient\Works, добавить раздел [Наряды] с одной директивой:

[Наряды]

Is_factor=Y

Рис. 1

Для отображения сведений по заработанным суммам нужно нажать на кнопку "Пересчитать". При этом распределение сумм показывается по значению свободного аналитического признака, указанного в последнем столбце таблицы на закладке "Производственное задание" (рис. 2).

Внимание. Если значение признака не введено (рис. 2), то сведения в окне (рис. 1) отсутствуют.

Название столбца соответствует тому свободному аналитическому признаку, который указан в справочнике аналитических признаков. Для ввода значений в последний столбец нужно переместить бегунок горизонтальный полосы прокрутки вправо до самого конца, и после этого ввести значение из выпадающего списка.

Рис. 2


Проверка соответствия сумм по наряду

Процедуру проверки соответствия сумм целесообразно проводить до передачи данных по нарядам в программу "АиТ:\Зарплата".

Окно "Проверка соответствия сумм по наряду" (рис. 1) вызывается из пункта "Проверка сумм" раздела "Сервис" Главного меню программы или по кнопке Panal9 панели инструментов.

Рис. 1

Режим позволяет установить расхождения между суммой по наряду, фигурирующей в списке нарядов, и суммами по работам на закладке "Производственное задание" карточки наряда и по сотрудникам на закладке "Распределение сумм" карточки наряда.

Настройка параметров проверки осуществляется в верхней части окна. Пользователь имеет возможность указать период, за который проверяются суммы, а также ограничить выборку по виду нарядов (дневные, помесячные) и состоянию (выделенные, новые, архивные). Переключатель "Выделенные" позволяет проверить произвольный набор карточек нарядов в окне "Список нарядов".

Проверка может быть осуществлена как по основной, так и по дополнительной сумме. Расчет производится с точностью до величины (например, 0.01), задаваемой в поле "Точность".

Настройка параметров проверки осуществляется в верхней части окна. Пользователь имеет возможность указать период, за который проверяются суммы, а также ограничить выборку по виду нарядов (дневные, помесячные) и состоянию (новые, архивные). Если в окне "Список нарядов" есть выделенные строки, становится доступным переключатель "Выделенные", позволяющий проверить произвольный набор карточек нарядов.

Проверка может быть осуществлена как по основной, так и по дополнительной сумме. Расчет производится с точностью до 0.001. Результат заносится в соответствующие колонки для каждой строки наряда. В нижней части окна подводятся итоги.

Для выполнения операции проверки соответствия сумм следует нажать на кнопку Refresh "Обновить" дополнительной панели инструментов. В том случае, если в соответствии с настройкой в списке нарядов имеются наряды, содержащие ошибки, то они появляются в таблице окна (рис. 1). При отсутствии ошибок таблица не содержит ни одной строки. В нижней части окна под таблицей подводятся итоги.


Корректировка наряда, откат начислений

Наряд, данные по которому переданы в программу "АиТ:\Зарплата", получает статус закрытого документа, и его редактировать запрещено. Переданные наряды удаляются с закладки "Новые наряды" и переносятся на вторую закладку "Архив" (рис. 1).

Рис. 1

В случае острой необходимости наряды, переданные в программу "АиТ:\Зарплата", можно вернуть из архива на закладку "Новые наряды". Для этого их следует выделить в списке на закладке "Архив" и нажать на кнопку "Аннулировать признак ‘’Передано в Зарплату’" Otkat дополнительной панели инструментов. После этого записи о выделенных нарядах будут перенесены с закладки "Архив" на закладку "Новые наряды", и эти наряды станут доступными для редактирования.

Кроме этого, для корректной работы программы "АиТ:\Зарплата" требуется выполнить ряд необходимых действий. Так как в программе "АиТ:\Зарплата" данные переданных нарядов автоматически не отзываются, необходимо проделать процедуру очистки вручную. Для этого в окне "Начисления по табелю и нарядам" для нарядов, которые еще не были проведены, удалить записи с закладки "К начислению", а для проведенных нарядов – удалить записи с закладки "Архив документов" и произведенные по этому наряду начисления из карточек сотрудников.

После корректировки этих нарядов в программе "АиТ:\Учет выполненных работ" их можно будет снова передать в программу "АиТ:\Зарплата" для последующей обработки.


Печать карточки наряда

Печать выделенных нарядов производится из списка нарядов кнопкой "Печать" Print дополнительной панели инструментов в соответствии с выполненными настройками. Если в списке нарядов отсутствуют выделенные наряды, то печатается текущий наряд, слева от номера которого, установлен символ Strelka.

В распечатываемом документе показываются текущий наряд или выделенные наряды, созданные за период, указанный в блоке "Период времени" окна "Список нарядов".

Сформированный документ для печати хранится на диске в текстовом файле \ТХТ\nar.txt, если в настройках выбран переключатель "Печать в текст", иначе – в файле \ТХТ\nar.xls. При печати новых нарядов в имени файла отображается № наряда, например, nar_17.xls, для архивных нарядов номер наряда не указывается в имени файла.

На рис. 1 приведена карточка наряда, сформированная в текстовом формате, на рис. 2 – в формате документа программы Excel.

Рис. 1

Рис. 2

В верхней части печатного документа указываются сведения, приведенные на закладках I и II (Аналитика). В поле "Примечание" указывается заголовок наряда. В таблице "Производственное задание" приводятся данные с закладки "Производственное задание". Там же в колонке "Сумма" показывается основная сумма, оплаченная за работу по наряду.

В таблице "Список сотрудников" показываются основные и дополнительные суммы, оплаченные за работу, выполненную по наряду. В столбце "Сумма" (сдельно) указываются основные суммы, заработанные членами бригады и приведенные на закладки "Распределение сумм". В последующих столбцах указываются дополнительные суммы, их данные берут из окна "Дополнительные суммы по наряду". В столбце "Итого" показывается общая сумма (основная и дополнительная), заработанная каждым членом бригады. В самой последней строке этого столбца указывается итоговая сумма, заработанная всеми работниками бригады.


Организация взаимодействия с программой "АиТ:\Табельный учет"

Программа "АиТ:\Учет выполненных работ" взаимодействует с программой "АиТ:\Табельный учет" на уровне получения данных об отработанном времени.

На момент получения данных об отработанном времени в программе "АиТ:\Табельный учет" должны быть созданы и настроены типы времени, по которым будет происходить обмен.

Осуществить настройку типов времени можно двумя способами, в зависимости от выбранной пользователем технологии оформления работ по нарядам:

· организовать один или несколько отдельных типов времени, обрабатываемых только программой "АиТ:\Учет выполненных работ";
· использовать типы времени, передаваемые в программу "АиТ:\Зарплата", в том числе рабочее время.

1. Организация отдельных типов времени

При использовании первого способа настройки, когда в модуле "АиТ:\Учет выполненных работ" будут введены типы времени только для данного модуля, необходимо выполнить следующие действия:

· в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" (рис. 1) в разделе "Взаимодействие с модулем "АиТ:\Табельный учет" проставить значением "Нет" для параметров "Наряд считается по определенному типу времени" и "Для работника из бригады указывается табельный лист";

Рис. 1

· в программе "АиТ:\Табельный учет" в окне "Типы времени" (рис. 2) создать отдельный тип времени "Рабочее время по нарядам", для которого на закладке "Стыковки" флаг "Передавать данные в зарплату" не устанавливать. Отработанное время по этому типу будет передаваться в программу "АиТ:\Зарплата" непосредственно из нарядов, минуя табельный свод;

Рис. 2

· в программе "АиТ:\Учет выполненных работ" в окне "Настройка" на закладке "Типы времени" указать для основной работы тип времени "Рабочее время по нарядам".

Выводы. Таким образом, будет организован отдельный тип времени, обрабатываемый в программе "АиТ:\Учет выполненных работ", но не попадающий в свод по табельному листу и через него в программу "АиТ:\Зарплата".

2. Использовать типы времени, передаваемые в программу "АиТ:\Зарплата"

Чтобы использовать типы времени, передаваемые в программу "АиТ:\Зарплата", в том числе рабочее время, необходимо:

· в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" (рис. 1) в разделе "Взаимодействие с модулем АиТ:\Табельный учет" проставить значение "Да" для параметров "Наряд считается по определенному типу времени" и "Для работника из бригады указывается табельный лист";
· в программе "АиТ:\Конфигурация" в окне "Настройки комплекса" для программы "АиТ:\Табельный учет" в разделе "Табельные листы" для параметра "Вычитать из сводов оформленное по нарядам время" проставить значение "Да";
· в программе "АиТ:\Табельный учет" в окне "Типы времени" создать и настроить типы времени, которые будут использоваться в нарядах. Для них установить флаг "Передавать данные в зарплату";

При заполнении карточки наряда указать тип времени, по которому должны подбираться данные, для каждого сотрудника установить номер табельного листа.

При такой организации взаимодействия отработанное время, использованное в наряде, однозначно определяется параметрами "сотрудник – тип времени – табельный лист", и может быть корректно учтено при формировании свода по табельному листу. Неиспользованная в нарядах часть времени будет передана в программу "АиТ:\Зарплата" через свод по табельному листу.

Настройки типов времени являются предварительными и осуществляются единовременно. Кроме того, на момент получения данных об отработанном времени в программе "АиТ:\Табельный учет" должны быть созданы табельные листы на сотрудников и рассчитаны предварительные итоги за тот период (месяц), за который оформляются наряды.


Обработка данных по нарядам в программе "АиТ:\Зарплата"

Для корректной обработки данных по нарядам в программе "АиТ:\Зарплата" необходимо осуществить предварительные настройки:

1. В справочнике начислений создать начисление для оформления работ по нарядам, например, "Оплата по нарядам" (рис. 1) и настроить его, установив необходимые флаги на закладках справочника.

Рис. 1

2. Произвести настройку соответствия кодов начислений и данных нарядов. Окно настройки кодов начислений (рис. 2) вызывается кнопкой "Настройка" [image] дополнительной панели инструментов окна "Начисление по табелю и нарядам".

Рис. 2

В этом окне в верхней таблице "Критерии настройки" (рис. 2) необходимо каждому сочетанию вида наряда (дневной, помесячный), суммы (основная, дополнительная) и работы (основная, по замещению) из колонки "Сумма по наряду/Тип времени" поставить в соответствие код начисления из колонки "Код в зарплате".

Если для данного сочетания оплата производится всегда одним и тем же кодом (для всех работников и любых параметрах наряда), то в колонке "Критерий" выбирается "Значение по умолчанию".

Если необходимо дифференцировать процесс начисления по одному критерию, то в колонке "Критерий" из выпадающего списка выбирается наименование критерия. В качестве критерия выступают параметры карточки наряда (вид наряда, тип времени, подразделение) и персональные данные работника (категория, должность, график работ и т.п.). В нижней таблице "Соответствие критерия и начисления" (рис. 3) устанавливается соответствие значения критерия и кода начисления.

Рис. 3

Если дифференцирования по одному критерию недостаточно, можно использовать сочетания разных критериев и их значений. Многокритериальная настройка используется только при совместной работе программ "АиТ:\Зарплата" и "АиТ:\Учет выполненных работ". Для этого из выпадающего списка поля "Критерий" (рис. 2) выбирается наименование критерия "Составной", а значения выбираются из выпадающего списка поля "Значение критерия" в нижней таблице "Соответствие критерия и начисления" (рис. 3). В этом случае выпадающий список формируется на основании предварительно заполненного справочника многокритериальной настройки в программе "АиТ:\Зарплата". Поле "Код в зарплате" заполняется из выпадающего списка, содержащего коды и наименования начислений из справочника начислений программы "АиТ:\Зарплата".


Передача нарядов в программу "АиТ:\Зарплата"

После того, как наряды за месяц заполнены и рассчитаны, рекомендуется провести процедуру проверки соответствия сумм, и только тогда передавать данные в программу "АиТ:\Зарплата".

Для передачи данных в списке нарядов необходимо выделить нужные строки и нажать на кнопку "Передача данных" ExchangeData дополнительной панели инструментов.

Программа выдает запрос (рис. 1) о способе передачи:

· при выборе кнопки "Детально" наряд передается с учетом аналитических признаков. Тогда при проведении наряда в программе "АиТ:\Зарплата" каждое формируемое начисление наследует аналитику из карточки наряда.
· при нажатии на кнопку "Итогом" аналитические признаки не передаются вместе с нарядом, они заполняются как "недостающие" по выбору пользователя (из персональной карточки, из справочника начислений или с экрана) при проведении наряда в программе "АиТ:\Зарплата".

Рис. 1

Наряд, данные по которому переданы в программу "АиТ:\Зарплата", получает статус "архивный", его редактировать запрещено. Архивные наряды переносятся с первой закладки "Новые наряды" окна "Список нарядов" на вторую закладку "Архив".

В программе "АиТ:\Зарплата" перенесенные наряды появятся в окне "Начисление по табелю и нарядам" (одноименный пункт меню в разделе "Начисления") на закладке "К начислению" (рис. 2). Наряд, не имеющий дополнительной суммы, будет представлен одной строкой. Наряд, в котором рассчитывалась дополнительная сумма, формируется из двух строк – отдельно по основной и дополнительной сумме.

В нижней части окна представлен список участников работ по наряду, на котором установлен курсор. На каждого работника формируется отдельная строка, работа по замещению оформляется еще одной дополнительной строкой.

Рис. 2

Начисление заработной платы по нарядам, переданным в программу "АиТ:\Зарплата", производится по кнопке "Мастер формирования начислений" [image] дополнительной панели инструментов. Наряды, по которым выполнено начисление, переносятся с закладки "К начислению" на закладку "Архив документов" окна "Начисление по табелю и нарядам".


Общее понятие о документах

Программа "АиТ:\Учет выполненных работ" позволяет формировать отчеты (выходные документы) на основе информации, содержащейся в карточках нарядов. Вызов документов происходит из пунктов раздела "Документы" Главного меню программы.

Документы в программе могут отличаться по содержанию, механизму настройки и формату данных. По способу формирования документы делятся на две группы:

· документы стандартного типа – формируются с помощью Мастера, могут изменять свое содержание в зависимости от их настройки перед формированием. В процессе настройки пользователь сам может определять, какие данные будут отображены в настраиваемом отчете, однако форма представления этих данных является стандартной, определяемой программой.
· документы, создаваемые генератором документов – формируются программой согласно их описаниям (шаблонам), редактируя которые пользователь изменяет форму документа и состав включаемых в него данных. Дистрибутивная поставка программы уже содержит готовые шаблоны. При этом пользователь может как корректировать их, так и создавать новые формы документов. Шаблоны хранятся на диске в текстовых файлах в рабочей папке Works\Form программы и имеют, как правило, расширение *.rep. Файлы с шаблонами можно просматривать и изменять с помощью встроенного текстового редактора программы или любого другого текстового редактора операционной системы Windows.


Документы стандартного вида

Режим формирования стандартных отчетов вызывается из пункта "Отчеты" раздела "Документы" Главного меню программы или кнопкой "Отчеты" Panal3 панели инструментов.

Режим организован в виде Мастера – графического средства, которое разделяет процесс создания отчета на отдельные этапы (шаги). На каждом шаге открывается модальное окно, поэтому во время работы Мастера остальные режимы работы программы являются недоступными. Переход к следующему окну осуществляется кнопкой "Далее>>", а возврат к предыдущему окну – кнопкой "<<Назад".

На первом шаге в окне "Настройка" (рис. 1) определяются параметры отчета. Пользователь имеет возможность указать период, за который формируется отчет, а также ограничить выборку по виду нарядов (дневные, помесячные) и состоянию (новые, архивные). В блоке "Отбор и группировка" выбирается вид создаваемого отчета.

Рис. 1

На втором шаге в окне "Отчет" выводится сформированный отчет. На рис. 2 приводится отчет по нарядам с дополнительной детализацией.

Рис. 2

Набор графических элементов в окне "Отчет" одинаков для всех видов создаваемых отчетов. В верхней части окна расположены графические элементы для настройки печати. Кнопка "Изменить" служит для определения параметров шрифта, а переключатели "вертикальная" и "горизонтальная" – для выбора ориентации отчета на листе бумаги. Кнопки DocStandart4 позволяют управлять размерами отчета (уменьшать или увеличивать) при просмотре и печати.

Кнопка "Печать отчета", расположенная в нижней части окна, формирует печатный выходной документ по сформированному отчету.

На рис. 3 и рис. 4 приведены соответственно сводная ведомость и итоговая ведомость по нарядам за указанный период.

Рис. 3

Рис. 4


Генератор документов

Генератор отчетов

Генератор отчетов – это программное средство, которое применяется для получения выходных печатных документов по нарядам. Генератор отчетов (рис. 1) вызывается из пункта "Генератор документов" раздела "Документы" Главного меню программы.

Рис. 1

В окне "Генератора отчетов" можно добавить новый документ в таблицу, произвести настройку данных, включаемых в сформированный документ, просмотреть или отредактировать шаблоны документов, а также сформировать отчет, нажав на кнопку "Сформировать отчет" Report.

В верхней части окна расположены настройки формирования документов:

1. Переключатели для выборки данных по подразделениям, расположенные в блоке "Подразделения".

Документы могут формироваться либо по всем подразделениям (выбран переключатель "Все"), либо по выбранным подразделениям. При установке переключателя "Выбранные" делается доступным для выбора список подразделений. Выбор (отмена выбора) происходит щелчком левой кнопки мыши на нужной строке списка.

2. Поля в блоке "Дата" для настройки периода, за который будет формироваться отчет.

Отбор документов будет производиться по дате наряда.

3. Флаг "Включая архивные наряды" в блоке "Дополнительно".

Дополнительная настройка, позволяющая при установленном флаге сформировать отчет, по всем нарядам в списке на закладке "Новые наряды" и на закладке "Архив". При снятом флаге отчет формируется по нарядам, приведенным в списке на закладке "Новые наряды".

В нижней части окна расположена таблица с перечнем документов, которые могут быть сформированы в текущий момент. В таблицу можно добавлять новые строки и удалять имеющиеся строки с помощью кнопок "Добавить" Added и "Удалить" дополнительной панели инструментов.

Документы создаются программой согласно их описаниям (шаблонам), корректируя которые, пользователь может изменять форму документа и состав включаемых в него данных. Дистрибутивная поставка программы уже содержит готовые шаблоны. При этом пользователь может как корректировать их, так и создавать новые формы документов.

Назначение столбцов таблицы

Таблица содержит следующие столбцы:

· Наименование – указывается название документа, отражающее его назначение.
· Шаблон – указывается имя используемого файла шаблона. Файл шаблона можно просмотреть на экране или отредактировать с помощью встроенного редактора, нажав на кнопку "Шаблон" [image] . Поиск нужного файла-шаблона в файловой системе производится двойным щелчком левой кнопкой мыши в соответствующей строке.
· Тип сортировки – пользователь имеет возможность выбрать порядок сортировки записей в отчете. Список выбора зависит от указанного типа группировки – для отчета с группировкой по сотрудникам, по нарядам и по работам записи не сортируются.
· Тип группировки – задается параметр, определяющий способ формирования документа – по каким записям организован цикл документа и по какому признаку будут сгруппированы записи. Для каждого типа группировки имеется свой набор ключевых слов.
· Строк в шаблоне – заполняется автоматически
· Строк на листе – указывается желаемое количество строк на листе.


Структура шаблона документа

Выходные документы формируются на основе файлов-шаблонов, которые представляют собой обычные текстовые файлы. Их можно просматривать или редактировать с помощью встроенного редактора программы.

Файл шаблона в общем случае может состоять из следующих частей, расположенных обязательно в указанном порядке и отделенных друг от друга специальными строками, начинающимися с символа #:

Расчетная часть – одна или несколько строк, содержащих описание формул.

Каждая формула описывается в отдельной строке расчетной части шаблона. Такая строка должна начинаться с латинской буквы "F"; затем две цифры (номер формулы) и знак "равно" (=). Справа от знака "равно" записывается собственно формула.

Например: F01=[СУММА]+[ДОПСУММА]

Расчетная часть содержится в шаблоне между строкой НАЧАЛО_ФОРМУЛ и строкой #КОНЕЦ_ФОРМУЛ.

Титульная часть – текст, который должен печататься один раз в начале документа.

В нем могут содержаться ключевые слова. Он содержится в шаблоне между строкой #НАЧАЛО_ТИТУЛ и строкой #КОНЕЦ_ТИТУЛ.

"Шапка" (заголовок) страницы – повторяемая часть текста.

Шапка должна повторяться на каждой новой странице выходного документа (в отличие от титула) и может содержать ключевые слова. Шапка располагается в шаблоне между строкой #НАЧАЛО_ШАПКИ и строкой #КОНЕЦ_ШАПКИ.

Секция – часть документа, содержащая ключевые слова, описывающие критерий группировки.

В секции могут быть также использованы формулы. По ключевому слову [S01] в секции сформируется сумма по всем записям цикла для данной единицы критерия группировки в соответствии с формулой, описанной для F01 в расчетной части. Секция содержится в шаблоне между строкой #НАЧАЛО_СЕКЦИИ и строкой #КОНЕЦ_СЕКЦИИ.

Цикл (тело) документа – описание повторяющейся части документа.

Тело документа в файле шаблона расположено между строкой #НАЧАЛО_ЦИКЛА и строкой #КОНЕЦ_ЦИКЛА. В выходном документе эта часть будет повторена столько раз, сколько нарядов или сотрудников будет перечислено в документе. В цикле документа могут использоваться ключевые слова и формулы.

Подвал листа – нижняя часть каждой страницы документа.

Подвал листа должен повторяться на каждой новой странице выходного документа. Подвал листа документа может содержать ключевые слова, в том числе, ссылки на формулы. Для формулы F01 ключевое слово в подвале листа должно быть описано как [S01]. Подвал листа содержится в шаблоне между строкой #НАЧАЛО_ПОДВАЛА и строкой #КОНЕЦ_ПОДВАЛА. Он может быть необходим, например, для того, чтобы формировать общие суммы по каждой странице документа.

Подвал документа – завершающая (нижняя) часть документа.

Подвал документа служит для формирования аналитической части документа и подписей на последней странице. Подвал документа может содержать ключевые слова, в том числе, ссылки на формулы. Для формулы F01 ключевое слово в подвале отчета должно быть описано как [S01]. Подвал документа расположен в шаблоне между строками #НАЧАЛО_ПОДВАЛА_ОТЧЕТА и #КОНЕЦ_ПОДВАЛА_ОТЧЕТА.

Комментарий – поясняющий текст в шаблоне.

Комментарий может занимать одну или несколько строк, начинающихся со знаков "//". В выходной документ такие строки не попадают.


Особенности работы с шаблонами в EXCEL

Особенности работы с шаблонами в формате xls касаются печати дополнительных часов и сумм.

В поставляемом шаблоне используются суммы, имеющиеся в текущем справочнике "Виды дополнительных сумм" и соответствующие к ним закладки.

Пример закладок по дополнительной сумме (вечерние)

!ДОПСУМ_ЧАСЫ_a2 – часы по дополнительной сумме (вечерние)

!ДОПСУМ_С_a2 – дополнительная сумма (вечерние)

!СУММА_ДОП_ЧАСОВ_a2 – итого часов (вечерние)

!СУММА_ДОП_СУММЫ_a2 – итого дополнительная сумма (вечерние)

Внимание! В названии закладки указывается уникальный код вида дополнительной суммы, который задается в столбце "Служебный код" справочника видов дополнительных сумм.

При добавлении новых видов дополнительных сумм в справочник необходимо в шаблоне с расширением xls заменить закладки неиспользуемых дополнительных сумм на новые или добавить новые столбцы в таблицу и проставить в них соответствующие закладки, используя уникальный код дополнительной суммы. Закладки можно просмотреть в промежуточном текстовом файле tmpxls.txt. При каких-либо изменениях в шаблоне c расширением xls необходимо удалить промежуточный файл naryad.txt. Он создастся заново при формировании документа.

В процессе формирования документа открывается окно, содержащее сообщение: "Переписать файл nar.xls" и кнопки "Да" и "Нет". Если нажать на кнопку "Нет", то в файл nar.xls будут добавлены новые листы и ранее сформированные наряды сохранятся, а если – "Да", то в файл попадет только текущий наряд.


Список ключевых слов, используемых в шаблоне

В данной теме описываются ключевые слова, используемые в разных частях шаблона, кроме цикла.

1. Ключевые слова, используемые в различных частях шаблона, кроме секции.

Ключевое слово | Значение, возвращаемое ключевым словом | Место использования ключевых слов
ДАТА | Текущая системная дата | В титульной части
ЛИСТ | Текущий лист | В шапке
ЛИСТОВ | Общее количество листов в документе | В шапке
ЗАПИСЕЙ | Количество записей на листе | В подвале листа
ЗАПИСЕЙ | Количество записей в отчете | В подвале отчета
БУХГАЛТЕР | ФИО главного бухгалтера | В подвале отчета

2. Ключевые слова, используемые в секции. Ключевые слова для секции описывают признак группировки, поэтому отличаются для каждого типа группировки.

Ключевое слово | Значение, возвращаемое ключевым словом | Тип группировки
РАБЦЕНТР | Название рабочего центра | По рабочим центрам
ПОДРАЗДЕЛЕНИЕ | Название подразделения | По подразделениям
КП | Код подразделения | По подразделениям
РАБОТА | Наименование работы | По работам
КР | Код работы | По работам
ЕИ | Единица измерения работы | По работам
ТФ | Расценка на работу | По работам
НМВ | Норматив выполнения работы | По работам
СОТРУДНИК | Фамилия, имя, отчество бригадира | По бригадам
ТАБ№ | Табельный номер бригадира | По бригадам
ДОЛЖНОСТЬ | Должность бригадира | По бригадам
КАТЕГОРИЯ | Категория бригадира | По бригадам
КД | Код должности бригадира | По бригадам
ФАМИЛИЯ | Фамилия сотрудника | По сотрудникам
ИМЯ | Имя сотрудника | По сотрудникам
ОТЧЕСТВО | Отчество сотрудника | По сотрудникам
ТАБ№ | Табельный номер сотрудника | По сотрудникам
ДОЛЖНОСТЬ | Должность сотрудника | По сотрудникам
КАТЕГОРИЯ | Категория сотрудника | По сотрудникам
КД | Код должности | По сотрудникам
СОТРУДНИК | Фамилия, имя, отчество сотрудника | По сотрудникам
ОКЛАД | Оклад сотрудника | По сотрудникам
ПОДРАЗДЕЛЕНИЕ | Название подразделения | По сотрудникам
КП | Код подразделения | По сотрудникам
НОМ | Номер наряда | По нарядам
ТЕКСТ | Название (заголовок) наряда | По нарядам
ДАТА_НАР | Дата наряда | По нарядам
СУММА | Сумма наряда | По нарядам
ТИП | Тип наряда (дневной, помесячный, за период) | По нарядам
ВЫР | процент выработки по наряду | По нарядам
ВИДНАР | Вид наряда | По нарядам
ВИДЗАТР | Вид затрат | По нарядам
ДОПСУММА | Дополнительная сумма по наряду | По нарядам
ЗА | Наряд за месяц/год | По нарядам
АЛГОРИТМ | Алгоритм расчета по наряду | По нарядам
СОТРУДНИК | Фамилия, имя, отчество бригадира | По нарядам
ТАБ№ | Табельный номер бригадира | По нарядам
ДОЛЖНОСТЬ | Должность бригадира | По нарядам
КАТЕГОРИЯ | Категория бригадира | По нарядам
КД | Код должности бригадира | По нарядам
РАБЦЕНТР | Название рабочего центра | По нарядам


Ключевые слова, используемые в цикле

 Top Previous

В данной теме приведены ключевые слова, используемые в цикле, для разных типов группировки.

1. Для типов группировки по рабочим центрам, по подразделениям, по работам, по бригадам, по сотрудникам и без группировки.

Отчеты с группировкой по бригадам, подразделениям, рабочим центрам, работам и сотрудникам представляют собой список нарядов, сгруппированных по выбранному признаку. Поэтому набор ключевых слов для цикла отчета у них одинаковый – эти ключевые слова являются характеристиками наряда – номер, сумма, шифр затрат и т.п. Отчет без группировки не имеет секции, а набор ключевых слов цикла для него аналогичен, описанному ниже.

Ключевое слово | Значение, возвращаемое ключевым словом
НОМ | Номер наряда
ТЕКСТ | Название (заголовок) наряда
ДАТА_НАР | Дата наряда
СУММА | Сумма наряда
ТИП | Тип наряда (дневной, помесячный, за период)
ВЫР | процент выработки по наряду
ВИДНАР | Вид наряда
ВИДЗАТР | Вид затрат
ДОПСУММА | Дополнительная сумма по наряду
ЗА | Наряд за месяц/год
АЛГОРИТМ | Алгоритм расчета по наряду
СОТРУДНИК | Фамилия И.О. бригадира (не используется в отчетах с группировкой по сотрудникам и по бригадам)
ТАБ№ | Табельный номер бригадира (не используется в отчетах с группировкой по сотрудникам и по бригадам)
ДОЛЖНОСТЬ | Должность бригадира (не используется в отчетах с группировкой по сотрудникам и по бригадам)
КАТЕГОРИЯ | Категория бригадира (не используется в отчетах с группировкой по сотрудникам и по бригадам)
КД | Код должности бригадира (не используется в отчетах с группировкой по сотрудникам и по бригадам)
РАБЦЕНТР | Название рабочего центра (не используется в отчетах с группировкой по рабочим центрам и по бригадам)

2. Для типа группировки по нарядам. Отчет с группировкой по нарядам состоит из записей по сотрудникам, сгруппированным по нарядам. Для этого вида отчета используется отдельный набор ключевых слов цикла.

ФАМИЛИЯ | Фамилия сотрудника
ИМЯ | Имя сотрудника
ОТЧЕСТВО | Отчество сотрудника
ТАБ№ | Табельный номер сотрудника
ДОЛЖНОСТЬ | Должность сотрудника
КАТЕГОРИЯ | Категория сотрудника
КД | Код должности
СОТРУДНИК | Фамилия, имя и отчество сотрудника
ОКЛАД | Оклад сотрудника
Д | Дни сотрудника
Ч | Часы сотрудника
ДСУМС | Дополнительная сумма по наряду для сотрудника
СУМС | Сумма по наряду для сотрудника
ПОДРАЗДЕЛЕНИЕ | Название подразделения
КП | Код подразделения